Jump to content

Dynamix - V6 Plugins

2889 posts in this topic Last Reply

Recommended Posts

Seeing negative/wrong MB/CPU temps on dashboard on unraid 6.7.0 / Dynamix System Temperature 2019.01.12a

Any idea what I'm doing wrong?

(See attached:)




Share this post

Link to post
On 5/19/2019 at 1:26 AM, poto2 said:

Just checking in to keep hope alive on update to AutoFan Speed plugin.  Ongoing issue with NVME drive temps not being ignored, even if checking in setup dialog.  Results in fan speeds (and noise levels) much higher than needed, and WAF being much lower than desired ;)


Details here:  



I realize that the plugins are supported in the free time of talented and generous community members, and they are very much appreciated.  In that same spirit of generosity, some communication regarding future direction of plugin would be helpful.


If this is the wrong channel to reach the right people, please redirect as needed.

same boat.

older versions didn't have nvme support, so i guess it would solve the problem.

any way to downgrade to the older version of the plug-in?

Share this post

Link to post

Seems like rolling back to version before nvme was supported could work, but I'm not sure how to do it.


Kind of sad after all the virtualization features added that a core NAS feature is degraded :(


i don't mind waiting, or participating in testing/troubleshooting, but the sound of crickets is a bit discouraging...

Share this post

Link to post
On 5/19/2019 at 12:39 PM, Ford Prefect said:

upgraded from 6.5.3 to 6.7.0, using S3_Sleep_Plugin  version


The server goes to sleep just fine, but will not respond to WOL requests anymore.

WOL flag is set to "g" only (realtek NIC)...actually can't remember if there was something different in it for unraid 6.5.3...it just used to work for "ages"...last downtime was 300+days ago ;-)


Edit: just checked and the NIC seems to be powered down completely upon sleep...no lights visible from the outside at the connector


Any hints Anyone? What are the correct flags in the NIC for making WOL work?...it did work perfectly for *years* with this board.


Edit: Nevermind, seems like I am not alone and the problem is discussed here: 


Edited by Ford Prefect

Share this post

Link to post

I work on these plugins when time and oppertunity arises, and I don't have much spare time lately.


The S3 sleep plugin is just a GUI wrapper, it won't solve the problem that people have with WoL.

Share this post

Link to post

basically I would agree, but all people affected had a working WOL setup before upgrading to unRAID 6.7.

The reason I did link in here was, that the S3-sleep plugin also appeared to have stopped working after the update.


The plugin allows for configuring a WOL parameter to be set, before putting the server to sleep.

Prior to unraid 6.7 this was enough to enable WOL, after the rig had been put to sleep.

After the upgrade to 6.7, this no longer works,.

However, manually configuring "ethtool -s eth0 wol g" into the "comand issued efore sleep" parameter, fixes it.


Conclusion: the S3-sleep plugin stopped working, because setting the wol parameter to g via the GUI stopped working


Edit: see 


Edited by Ford Prefect

Share this post

Link to post
but all people affected had a working WOL setup before upgrading to unRAID 6.7.

IIRC all the people affected are using the same Realtek NIC, so likely the change was NIC driver in the new kernel.



Share this post

Link to post

...but the direct command "ethtool -s eth0 wol g" is still working fine with the driver.
Config option in S3-sleep plugin to set wol parameter to "g" before going to sleep stopped working.
If the plugin is a wrapper to this command, it still should work, but it does not.

Gesendet von meinem SM-G930F mit Tapatalk

Share this post

Link to post

I will test, but I don't think the S3 plugin has a bug in executing pre and post sleep commands (this was always working).

Share this post

Link to post

Thank you for your support, this is very much appreciated.

When entering the post command directly, it works, but when using the parameter sets it looks like it is working, but does not (ethtool query on eth0 shows parameter "g" set, but nic goes off).
I can only guess that this is related to the moment in time, when the command is really issued...or related to a different ethtool version used in the script, compared to the system wide one.

Gesendet von meinem SM-G930F mit Tapatalk

Share this post

Link to post

Try to introduce some delay (e.g. sleep 10) after execution of the ethtool command.

The ethtool command is immediately followed by the command to put the system to sleep, perhaps this is too fast for the network card?


Share this post

Link to post

OK, I am now back in front of my rig.

Here's a screenshot showing things...


The parameter set - circled in red - used to work fine, prior to the upgrade to unraid v6.7

Now it stopped working and the script - circled in green - is now needed and is working fine.


I would have assumed, that the red parameter set is actually combined/wrapped into the same command as now used in the green set.

But the green script wasn't set/needed prior to v6.7



Share this post

Link to post

Will we see the icons for the below highlighted plugins be updated anytime soon? Weird that a number of Dynamix plugins have the updated icons, and some don't



Share this post

Link to post

I have a question to the system temp. plugin.

I am running version 6.7.0 on an ASUSTeK COMPUTER INC. ROG STRIX Z370-G Mainboard.

When I try to detect available drivers I only get "coretemp" which comes directly from the cpu if I am correct but I get nothing from the motherboard itself e.g. MB Temp, temperature of my drivecage or Fanspeeds etc.

Can anyone give me a hint or link to a ressource to solve this?

Share this post

Link to post

Hi. Trying to figure out how to control my fans from unraid.


My Asus Maximus Hero II dont detect any fans at all. I have tried different settings in bios regarding DC mode, PWM mode and also disable but it wont detect any fans at all. For temps it shows all of them, only fans that causes a problem.


Drivers in use are coretemp nct6775. Is there any other drivers I should test with?



Share this post

Link to post



I have detected all sensors running sensors-detect.


Running owmconfig I get this message


There are no pwm-capable sensor modules installed


I know the board has pwm for fans and that my fans support it.

Share this post

Link to post

I little update here if anyone else has the same issue.


I added acpi_enforce_resources=lax to the syslinux.cfg and now all fans show up in unraid.


So to next issue. My motherboard is from asus and all fans are controlled from bios based on MB temp. To control the fans from unraid and not from bios how do I configure them in bios?



For DC mode and PWM mode I got some additional options.





Ok, so I am getting somewhere. I set the q-control in BIOS to disabled and I can now control the drives from the plugin. 
My last issue is how do I get it to control more than one fan from my motherboard? 

Edited by ProphetSe7en

Share this post

Link to post

@bonienlThere a new cache-dirs plugin in my repo fork from 2018-12, that hasn't been merged into the main. We had a merge accident, so a merge came look like a conflict. I havn't merged main changes into my fork, because I didn't want to deal with that. Maybe its easiest to start over on a new cache-dirs-only branch? Or change the dynamix applications to expect my forked github repo, as the source.



Share this post

Link to post

Hi, I have some questions regarding auto fan control.

Can I control all the MB fans or just 1 ? 

Can I only select the different hdd´s temps to monitor the temps?

How can I look for all the fans of my MB (it actually shows only fan1 and fan2 (although it shows 3 sensors and my MB has 4/5 fans)?

Share this post

Link to post

Another user after updating to Unraid 6.7.0 seeing the Dynamix Auto Fan Control plugin behavior broken but in my case not all the way.


From a Status: Stopped state I can reset using the Default button and enable, detect and apply and it will run for some period of time, still not sure what length of time that is exactly but it seems to be longer than 12 hrs but shorter than 24 hrs.  


Diagnostics attached.


Edited by dabl

Share this post

Link to post

I got this working some time ago, but I infrequently get an edge case where the entire server crashes and shuts down if I don't have my VM in sleep. It's likely related to this command I set up to send after wake:


 virsh dompmwakeup "VM"


I usually have the VM active and sleeping, but not always. Does anyone know why it crashes and/or a possible solution to this problem? It's likely to be exacerbated if I set up more VMs (and not all will be on at the time)

Share this post

Link to post
On 4/30/2019 at 8:31 AM, poto2 said:

After upgrading my cache drive from 1.6tb Intel NVME to 3.8tb HGST NVME, fan auto control plugin is no longer ignoring NVME drive when calculating drive temp.


The new cache drive model is HGST N150 3800GB, and shows in Unraid dashboard as model UCSC-F-H38001.  Fans used to idle at 800rpm, now with min cache drive temp at 40C, a much louder 2000+rpm.


The new drive does run hot - 40C is after I switched pcie slots so open space next to drive heat sink, and also have 2000 rpm 12cm fan blowing directly down onto pcie slots.


I had a similar problem with plugin a couple of years ago, when NVME drives were newer, but something about this drive seems to be different, resulting in its temp not being ignored as configured.


Pics showing systemp temp/fan auto control settings, as well as drive status and log file.  Diagnostics attached.


Any help or suggestions appreciated, as this server used to be whisper-quiet except for parity checks!



drive status and log file.jpg

fan auto control.jpg

system temp.jpg

unraid-one-diagnostics-20190430-1146.zip 150.06 kB · 0 downloads

Bumping previous post in hopes of future attention.  Issue still remains where fan speed plugin does not ignore NVME drive when "checked"


Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.