Jump to content
jdubs

Paths?

5 posts in this topic Last Reply

Recommended Posts

Guys

 

I don't fully understand the way paths work in the context of the Docker and apps.  I want all the apps and their associated data to be stored on my cache drive which is where the docker.img file sits.  What do I change the "Host path" to?  The default looks like it puts stuff on the array?

 

I still need to access drives on the array, too.

 

Thanks guys.

 

Jim

 

 

Share this post


Link to post

There are two different paths that you have to set for each container

 

The container volume - This is the path that the container is going to see (it is local to the docker container, and bears no relationship to any path contained on your server)

 

The Host path - This is the path that the container path is mapped to. (These are the local paths that you see when browsing through your server)

 

So, for something like Sickbeard, the default container paths are /config, /downloads, and /tv.  When you're setting up sickbeard, you're going to see those paths in its webui

 

You'd probably use something like this:

 

/mnt/user/appdata/sickbeard  for  the /config

/mnt/user/appdata/downloads for the /downloads (or where ever your downloads wind up going)

/mnt/user/Television for the /TV

 

 

When you're setting up sickbeard, you're going to see folders called /config, /downloads, and /TV.    When you look in them, you'll see that the contents are identical to /mnt/user/appdata/sickbeard, /mnt/user/appdata/downloads, and /mnt/user/Television

 

Generally, you create a new share called "appdata" and change its settings to be "cache only" to force that directory to stay on the cache drive.

 

A bit confusing until you actually set one up and see how it works in practice

 

 

Share this post


Link to post

Awesome, thank you for this Squid.

 

I do have some more questions, though.  How do I force the appdata share to only use the cache drive?  seems like it also requires at least one data disk be selected? 

 

How do I direct finished / processed downloads to move to my array? 

 

Also, NZBGet is having trouble creating sub-directories within "/downloads"....the log shows that it cannot create the sub-directories. 

 

-Jim

 

 

There are two different paths that you have to set for each container

 

The container volume - This is the path that the container is going to see (it is local to the docker container, and bears no relationship to any path contained on your server)

 

The Host path - This is the path that the container path is mapped to. (These are the local paths that you see when browsing through your server)

 

So, for something like Sickbeard, the default container paths are /config, /downloads, and /tv.  When you're setting up sickbeard, you're going to see those paths in its webui

 

You'd probably use something like this:

 

/mnt/user/appdata/sickbeard  for  the /config

/mnt/user/appdata/downloads for the /downloads (or where ever your downloads wind up going)

/mnt/user/Television for the /TV

 

 

When you're setting up sickbeard, you're going to see folders called /config, /downloads, and /TV.    When you look in them, you'll see that the contents are identical to /mnt/user/appdata/sickbeard, /mnt/user/appdata/downloads, and /mnt/user/Television

 

Generally, you create a new share called "appdata" and change its settings to be "cache only" to force that directory to stay on the cache drive.

 

A bit confusing until you actually set one up and see how it works in practice

Share this post


Link to post

How do I force the appdata share to only use the cache drive?

Create (or modify) the appdata share, and under the use cache disk setting select "only"

How do I direct finished / processed downloads to move to my array? 

Using my example paths, you'd tell the docker to move processed downloads to the /TV directory (which means it will wind up on /mnt/user/Television)

Also, NZBGet is having trouble creating sub-directories within "/downloads"....the log shows that it cannot create the sub-directories. 

I don't use NZBGet, so I'm not sure about that.  Sounds like a permissions problem.  But, make sure that next to the host path for it that its read/write

Share this post


Link to post

Try changing the path on the host path to the top level of your download directory. Example /mnt/cache/appdata/nzbget/download

More than likely have a incomplete and completed.

I had an issue with sonarr and struggle until I read a post from someone using nzbget that had to point it to the top level folder. I did the same ans bam! It worked. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.