Deluge RSS Headache

Recommended Posts

I originally installed needos deluge docker which was working fine but then I wanted to add rss so I tried to install the yarss2 egg file, it showed up in preferences->plugins but when I select it and press apply and close it doesn't stay selected.


I've tried using the different python eggs (2.6 - 2.7) but still get the problem.


I've also tried changing to binhexs docker as I read someone had it working with his, but I've had no luck..


Any ideas are welcome :D

Link to comment

Hi Nas I've actually just done that but its still not working  :o


I'm running both 1.3.11 on unraid and my laptop, when I click apply it just deselects.


Are you using YaRSS2-1.3.3-py2.7.egg ?


I had to put a new user in the auth file so I could connect to my daemon

Link to comment

Now oyu mention it there was some gotcha I just cant remember what they were other than it wasn't a hard fix.


I suggest the best way to deal with this is to request RSS be made part of default as you areent the first or likely the last to request it.


Id otn have time


fyi YaRSS2-1.3.2-py2.7.egg but i have had it running for a long time now

Link to comment

Yeah spot on.


This is why there was a myth that deluge couldnt do RSS but its not that big a deal to set it up with gtk and then forget about it. Once setup it will just work by itself. It is not ideal but it is way better than having to maintain a separate tool


I think we should consider installing every single addon into the docker, by default they are off anyway.

Link to comment
  • 3 months later...

Can you point me to a good tutorial for setting up yarss in gtk (I don't even know what that means). I have a single rss feed I need to setup so I'd be happy with a set-it-and-forget-it approach.


For reference, I have ruTorrent docker up and running with my rss feed. It works great. Except is seeds for crap. The client says it is connectable. The tracker says I'm connectable. But I get crap uploads. My PC running uTorrent works great (I've fallen back to that for now). Transmission in my Xen/ArchVM worked great until it started crashing the virtual network (it is a Xen issue) and I went back to my PC. Now I've switched to Dockers but still can't get torrent duties back on my server. If I can't get a docker torrent with rss running I might just have to go back to a VM (in KVM) and see if I can make that work again.

Link to comment
  • 9 months later...

Can you point me to a good tutorial for setting up yarss in gtk (I don't even know what that means). I have a single rss feed I need to setup so I'd be happy with a set-it-and-forget-it approach.


Did you ever get this figured out? I'm in the exact same situation. Thanks!

Link to comment
  • 1 year later...
  • 6 months later...
On 8/2/2017 at 5:50 AM, francrouge said:

Me too if anyone got a tutorial it would be nice thnk

1. Download and install matching windows or Apple client from website for deluge

2. Under preferences and interface, uncheck classic interface which will allow you connection manager on next start

3. Modify your auth file with Notepad++ in your config directory for your deluge docker

4. Create a user as described here

5. Restart your docker or plugin

6. From windows client add a connection in connection manager.

7. Install plugin , I had to restart my docker once more after installing plugin before it worked.  I also tried 1.3.2 first then switched to 1.4.3


nicely described here 


Edited by Timbiotic
Link to comment
  • 1 year later...

So started weekend project to migrate from freenas to unraid, all looking good so far, apart from expected 1.6days for data transfer and 40days for parity build lmao


Anyway, moving from vm hosted yassr2 deluge.


So turns out you can just move your old configs and eggs from (windows) %appdata%\deluge and drop them into your config path, default being /mnt/user/appdata/deluge..


although my plugins path is super broken pointing to c:\..\appdata\ it still picks up plugins dir fine and installs them correctly and enables according to .conf


And since im such a nice guy, here's my mega links if you want something to go off of with no previous setup, my current is just looking at some nyaa rss, so adapt as you need, very easy to read and make changes.






after enabling in web (will reset to off and report in deluged-web.log it has no ui)

[INFO    ] 10:58:58 pluginmanager:108 'YaRSS2' plugin contains no WebUI code, ignoring WebUI enable call.
[INFO    ] 10:58:59 pluginmanager:145 Plugin has no web ui


but output from deluged.log


[INFO    ] 10:44:07 rpcserver:206 Deluge Client connection made from:
[INFO    ] 10:44:41 logger:37 YaRSS2.__init__:34: Appending to sys.path: '/config/plugins/YaRSS2-1.4.1-py2.7.egg/yarss2/include'
[INFO    ] 10:44:41 logger:37 YaRSS2.rssfeed_scheduler:42: Scheduled RSS Feed '1080p HorribleSubs Nyaa' with interval 5
[INFO    ] 10:44:41 logger:37 YaRSS2.rssfeed_scheduler:42: Scheduled RSS Feed '1080p BlueLobster Nyaa' with interval 5
[INFO    ] 10:44:41 logger:37 YaRSS2.core:40: Enabled YaRSS2 1.4.1
[INFO    ] 10:44:41 pluginmanagerbase:158 Plugin YaRSS2 enabled..




INFO    ] 11:03:59 logger:37 YaRSS2.rssfeed_handling:267: Update handler executed on RSS Feed '1080p BlueLobster Nyaa (' (Update interval 5 min)
[INFO    ] 11:03:59 logger:37 YaRSS2.rssfeed_handling:310: Fetching subscription '1080p BlueLobster Nyaa'.
[INFO    ] 11:03:59 logger:37 YaRSS2.rssfeed_handling:80: Fetching RSS Feed: '1080p BlueLobster Nyaa' with Cookie: '{}' and User-agent: 'Deluge v1.3.15 YaRSS2 v1.4.1 Linux/4.19.41-Unraid'.
[INFO    ] 11:04:00 logger:37 YaRSS2.rssfeed_handling:332: 70 items in feed, 70 matches the filter.
[INFO    ] 11:04:00 logger:37 YaRSS2.rssfeed_handling:344: Not adding because of old timestamp: '[BlueLobster] Meow Meow Japanese History (01-96) [1080p] (Batch) (Neko Neko Nihonshi)'



and proceed to use yarss2.conf file as configured.


added 2nd sub, just needs a "1" :{..} and another for feed, tested and works fine, make sure they're unique and match against right feeds


like so;





Edited by Mizerka
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.