Jump to content
jonp

unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)

833 posts in this topic Last Reply

Recommended Posts

6 hours ago, dmacias said:
On 5/23/2018 at 12:33 PM, airbillion said:
Would it be possible to upgrade pip from v9 to v10?
 
Thanks!

Ok. Done.

Super!! Thank a lot!

Share this post


Link to post
Posted (edited)

Can you please add libguestfs-tools?

 

Does anyone have a docker container for building all the nerdpack packages or is there a guide or post about creating your own build environment?  I searched around but didn't find anything.

 

 

Edited by brunnels

Share this post


Link to post
Can you please add libguestfs-tools?
 
Does anyone have a docker container for building all the nerdpack packages or is there a guide or post about creating your own build environment?  I searched around but didn't find anything.
 
 
That is probably out of the scope of this plugin. It would probably require a few more packages also.

There is another plugin called devpack that has a lot of the development packages. I just run a virtual machine of unRAID and compile on it.

Share this post


Link to post
Posted (edited)

SOLVED

 

Ever since I upgraded from 6.3.5 to 6.5.0 I have lost the use of unrar. I tried uninstalling/reinstalling the Nerd tools app, but haven't had any luck getting this function back. 

 

-bash: unrar: command not found

 

I apologize if this has been asked and answered, but I'm at my wits end on this. Any help would be great.

 

Regards.

 

 

Edit.... Damn It, I found a previous post about turning on the individual applications within NerdPack... never saw that before... 

 

Edited by TapRackPull

Share this post


Link to post
Posted (edited)

Can you please update borg backup to the latest version 1.1.5?

Edited by etsi

Share this post


Link to post
Can you please update borg backup to the latest version 1.1.5?
Yes I will ad soon as I can. Just been busy lately
  • Like 1

Share this post


Link to post

Please could you add ruby 2.5?

 

I'm having some difficulty getting a script working in Perl, as it requires a CPAN module to be installed. CPAN tells me it requires make, and I can't find a package with make in it…

 

Meanwhile, I know that ruby has the necessary module built in.

 

Alternatively, is there a package which provides make, so that I can install the CPAN module I need?

 

Thanks

Share this post


Link to post
1 hour ago, ElectricBadger said:

Alternatively, is there a package which provides make, so that I can install the CPAN module I need?

The DevPack plugin allows one to select from a wide range of development related tools.   If you install the plugin do not forget that no packages are actually installed until you go to Settings->Dev Pack and select them for install.

Share this post


Link to post
2 hours ago, itimpi said:

The DevPack plugin allows one to select from a wide range of development related tools.   If you install the plugin do not forget that no packages are actually installed until you go to Settings->Dev Pack and select them for install.

 

Sure, I have perl installed already through the plugin, but running 'perl -mCPAN shell' warns me after config that I need to install make or stuff will probably not work — and, indeed, entering 'install DateTime::Format::Strptime' doesn't seem to leave me with a usable strptime module — so I can only use modules that are part of the perl base install.

 

I can't see make or ruby in the list of DevPack plugins, though, so I'm not sure how to move on to fix this.

Share this post


Link to post

I can see ‘make’ as one of the Devpack pakages.    Whether that is enough to resolve your original problem I do not know.

Share this post


Link to post
37 minutes ago, itimpi said:

I can see ‘make’ as one of the Devpack pakages.    Whether that is enough to resolve your original problem I do not know.

 

Ah, there's a Devpack as well as a Nerdpack… that explains why I couldn't find it! Thanks for the pointer.

 

Would still like to have Ruby if it's at all possible, though.

Share this post


Link to post
Posted (edited)
On 2/26/2018 at 10:42 AM, dmacias said:
On 2/25/2018 at 4:04 AM, cassiusdrow said:

It's added

 

Hi,

 

I thought this package was working but after a reboot it was not reinstalling the package.  I checked /boot/config/plugins/NerdPack/packages/6.5 and the package file is not there.  NerdPack.cfg has a line ksh93-2012_08_01="yes" and the plugin page switch is "on" but the status is uninstalled and not downloaded. If I try to re-download and install using the plugin page, it says:

 

Downloading ksh93-2012_08_01-x86_64-2.txz package...

ksh93-2012_08_01-x86_64-2.txz package download sucessful!

Installing ksh93-2012.08.01 package...

 

But there is no package file and it is not installed.  I can install it manually for now, but I'd appreciate it if you could take a look.

 

Thanks

 

EDIT:  I just noticed that the download filename in the output above has underscores in the version date "2012_08_01" and the install package has dots "2012.08.01". Could that have something to do with it?

Edited by cassiusdrow

Share this post


Link to post
 
Hi,
 
I thought this package was working but after a reboot it was not reinstalling the package.  I checked /boot/config/plugins/NerdPack/packages/6.5 and the package file is not there.  NerdPack.cfg has a line ksh93-2012_08_01="yes" and the plugin page switch is "on" but the status is uninstalled and not downloaded. If I try to re-download and install using the plugin page, it says:
 
Downloading ksh93-2012_08_01-x86_64-2.txz package...

ksh93-2012_08_01-x86_64-2.txz package download sucessful!

Installing ksh93-2012.08.01 package...
 
But there is no package file and it is not installed.  I can install it manually for now, but I'd appreciate it if you could take a look.
 
Thanks
 
EDIT:  I just noticed that the download filename in the output above has underscores in the version date "2012_08_01" and the install package has dots "2012.08.01". Could that have something to do with it?
That may have been the problem. I changed the version to decimals instead of underscores.

Share this post


Link to post

Im new to nerd tools and installed the plugin.  

It says "Please wait, retrieving plugin information ..." and I have waited almost an hour. What could be the problem?

Share this post


Link to post
On 7/10/2018 at 8:33 PM, dmacias said:
On 7/10/2018 at 12:29 PM, cassiusdrow said:
 
Hi,
 
I thought this package was working but after a reboot it was not reinstalling the package.  I checked /boot/config/plugins/NerdPack/packages/6.5 and the package file is not there.  NerdPack.cfg has a line ksh93-2012_08_01="yes" and the plugin page switch is "on" but the status is uninstalled and not downloaded. If I try to re-download and install using the plugin page, it says:
 
Downloading ksh93-2012_08_01-x86_64-2.txz package...

ksh93-2012_08_01-x86_64-2.txz package download sucessful!

Installing ksh93-2012.08.01 package...
 
But there is no package file and it is not installed.  I can install it manually for now, but I'd appreciate it if you could take a look.
 
Thanks
 
EDIT:  I just noticed that the download filename in the output above has underscores in the version date "2012_08_01" and the install package has dots "2012.08.01". Could that have something to do with it?

That may have been the problem. I changed the version to decimals instead of underscores.

 

 

Looks like it's working now.  Thanks!

Share this post


Link to post
Im new to nerd tools and installed the plugin.  
It says "Please wait, retrieving plugin information ..." and I have waited almost an hour. What could be the problem?
No internet or github blocked for some reason. Maybe anti-virus

Share this post


Link to post

I dont use antivirus and the internet is also ok. I can download other apps and packages just fine.  ITs been like this for a while on my system I just now wanted to use it for borg backup so im in troubleshooting mode.   I have completely removed the packages from the flash and reinstalled.  It does download the packages but just hangs when it updates.

Share this post


Link to post

I have no idea... but now it just works.  Its been broken on my system for like 6 months.  I keep unraid fully updated but I have a feeling its because of my flash drive.  It died a couple days ago so maybe it was the culprit.

Thank you

Share this post


Link to post

Hello,

In order to use borg mount would it be possible to add  'llfuse' ?

When I try command I get this error :

# borg mount /mnt/user/backup /tmp/test
# borg mount not available: loading FUSE support failed [ImportError: No module named 'llfuse']
Best regards

Guillaume

Share this post


Link to post

I've tried to install pip

 

pip install --upgrade pip
pip install setuptools
pip install llfuse

 

I get an error :

 


Collecting llfuse
  Using cached https://files.pythonhosted.org/packages/fc/9f/074ba23d32b961cb4b43c22c70d49f2db2484f7b60777897a87726e2648f/llfuse-1.3.4.tar.bz2
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-Zn3zuR/llfuse/setup.py", line 283, in <module>
        main()
      File "/tmp/pip-install-Zn3zuR/llfuse/setup.py", line 76, in main
        compile_args = pkg_config('fuse', cflags=True, ldflags=False, min_ver='2.8.0')
      File "/tmp/pip-install-Zn3zuR/llfuse/setup.py", line 175, in pkg_config
        if subprocess.call(cmd) != 0:
      File "/usr/lib64/python2.7/subprocess.py", line 168, in call
        return Popen(*popenargs, **kwargs).wait()
      File "/usr/lib64/python2.7/subprocess.py", line 390, in __init__
        errread, errwrite)
      File "/usr/lib64/python2.7/subprocess.py", line 1025, in _execute_child
        raise child_exception
    OSError: [Errno 2] No such file or directory

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-Zn3zuR/llfuse/
 

Share this post


Link to post
Hello,
In order to use borg mount would it be possible to add  'llfuse' ?
When I try command I get this error :
# borg mount /mnt/user/backup /tmp/test
# borg mount not available: loading FUSE support failed [importError: No module named 'llfuse']
Best regards
Guillaume
Added llfuse. I'll try and update borg this week too

Share this post


Link to post

I might not be the first to ask but can you include rclone?

 

I know there's a docker and a plugin for it but the plugin needs to be installed every reboot and the container is more than I need.

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now