Jump to content
jonp

unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)

833 posts in this topic Last Reply

Recommended Posts

Just added Python 2.7.9 to the NerdPack.  iotop will work again after the update since it requires python.

Share this post


Link to post

Could we add SSHFS by any chance? Please.

No problem, just pushed an update that included SSHFS

Share this post


Link to post

Excellent plugin... But I think we need a WEBUI/php frontend to allow users to choose which plugins to install on boot - The number of packages is getting quite large.

 

I would volunteer to write it but I don't think my wife would approve  >:( after I spent too much time (nights) writing my ServerLayout plugin :P

Share this post


Link to post

Gotta be honest, if someone wants to submit a pull, by all means, we would consider implementing it. But if not, its probably not going to happen anytime soon.

Share this post


Link to post

Just tried to install the Nerdpack, but got "no space on device" error...  But there's 29GB free!

 

I used this link for the plugin - https://raw.githubusercontent.com/eschultz/unraid6-nerdpack/master/NerdPack.plg

 

This is the freespace on my flash drive...(assuming the plugin is trying to install there?).  Perhaps the problem is tmpfs?  Its at 100%?  Would the Plugin try to install there?

http://my.jetscreenshot.com/12412/20150628-dpoy-45kb.jpg

 

Thoughts?  Is there some parameter I need to provide the plugin installer?

 

plugin: installing: https://raw.githubusercontent.com/eschultz/unraid6-nerdpack/master/NerdPack.plg
plugin: downloading https://raw.githubusercontent.com/eschultz/unraid6-nerdpack/master/NerdPack.plg
plugin: downloading: https://raw.githubusercontent.com/eschultz/unraid6-nerdpack/master/NerdPack.plg ... done
plugin: downloading: https://raw.githubusercontent.com/eschultz/unraid6-nerdpack/master/packages/iftop-1.0pre2-x86_64-1.txz ... done

+==============================================================================
| Installing new package /boot/config/plugins/NerdPack/packages/iftop-1.0pre2-x86_64-1.txz
+==============================================================================

Verifying package iftop-1.0pre2-x86_64-1.txz.
expr: syntax error
/sbin/installpkg: line 432: [: -lt: unary operator expected
/sbin/installpkg: line 434: [: -lt: unary operator expected
expr: syntax error
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 469: echo: write error: No space left on device
cat: write error: No space left on device
Installing package iftop-1.0pre2-x86_64-1.txz:
PACKAGE DESCRIPTION:
/sbin/installpkg: line 537: echo: write error: No space left on device
/sbin/installpkg: line 538: echo: write error: No space left on device
/sbin/installpkg: line 539: echo: write error: No space left on device
/sbin/installpkg: line 540: echo: write error: No space left on device
/sbin/installpkg: line 545: echo: write error: No space left on device
/sbin/installpkg: line 550: echo: write error: No space left on device
WARNING: Package has not been created with 'makepkg'
/sbin/installpkg: line 559: echo: write error: No space left on device
Package iftop-1.0pre2-x86_64-1.txz installed.


plugin: downloading: https://raw.githubusercontent.com/eschultz/unraid6-nerdpack/master/packages/iotop-0.6-x86_64-1_fs.tgz ... done


**************************************************************************
*many* lines eliminated due to space requirements for forum, but they all say the same thing...
.
.
.
***************************************************************************

+==============================================================================
| Installing new package /boot/config/plugins/NerdPack/packages/sshfs-fuse-2.5-x86_64-1sl.txz
+==============================================================================

Verifying package sshfs-fuse-2.5-x86_64-1sl.txz.
expr: syntax error
/sbin/installpkg: line 432: [: -lt: unary operator expected
/sbin/installpkg: line 434: [: -lt: unary operator expected
expr: syntax error
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 466: echo: write error: No space left on device
/sbin/installpkg: line 469: echo: write error: No space left on device
cat: write error: No space left on device
Installing package sshfs-fuse-2.5-x86_64-1sl.txz:
PACKAGE DESCRIPTION:
/sbin/installpkg: line 537: echo: write error: No space left on device
/sbin/installpkg: line 538: echo: write error: No space left on device
/sbin/installpkg: line 539: echo: write error: No space left on device
/sbin/installpkg: line 540: echo: write error: No space left on device
/sbin/installpkg: line 545: echo: write error: No space left on device
/sbin/installpkg: line 550: echo: write error: No space left on device
WARNING: Package has not been created with 'makepkg'
/sbin/installpkg: line 559: echo: write error: No space left on device
Package sshfs-fuse-2.5-x86_64-1sl.txz installed.


plugin: installed

 

 

Share this post


Link to post

LOL, that would certainly be a PEBCAK!  But, I did, I hit enter and waited.  Nothing happens.  Its like its off busily doing something.  I let it run 10 or 15 min, then hit return just so see what happened.  Line feed.  Ctrl-C terminated it.

Share this post


Link to post

HAH!  It was a PEBCAK.  I looked at the command line and I had a strategic extra space...

 

mount -o remount, size=256m /var/log

 

should have been

mount -o remount,size=256m /var/log

 

It was patiently waiting for the rest of the command!

 

*duh*

Share this post


Link to post

Excellent plugin... But I think we need a WEBUI/php frontend to allow users to choose which plugins to install on boot - The number of packages is getting quite large.

 

I would volunteer to write it but I don't think my wife would approve  >:( after I spent too much time (nights) writing my ServerLayout plugin

Resurrect unmenu to install them? 

Share this post


Link to post

Could we add SSHFS by any chance? Please.

No problem, just pushed an update that included SSHFS

 

Much appreciated, thank you.

Share this post


Link to post

Any chance we could get htop and tmux added in?

already built-in to unRAID distro

Share this post


Link to post

Could consideration be given to Perl since it was dropped from unRAID proper this seems like the natural place for it now alongside python.

Share this post


Link to post

Could consideration be given to Perl since it was dropped from unRAID proper this seems like the natural place for it now alongside python.

I personally actually think perl and python which are large packages should probably not be in the nerd pack which should be kept slim.  Perhaps they should each be in a pack of their own?

Share this post


Link to post

Could consideration be given to Perl since it was dropped from unRAID proper this seems like the natural place for it now alongside python.

I personally actually think perl and python which are large packages should probably not be in the nerd pack which should be kept slim.  Perhaps they should each be in a pack of their own?

 

As I wrote before - I think there should be a frontend (UI) for the nerdpack where you could choose which tools to install/update.

 

I might have time after the summer  8)

Share this post


Link to post

Could consideration be given to Perl since it was dropped from unRAID proper this seems like the natural place for it now alongside python.

I personally actually think perl and python which are large packages should probably not be in the nerd pack which should be kept slim.  Perhaps they should each be in a pack of their own?

 

Perhaps one pack for new nerdy stuff thats never been native and another that adds back in stuff that used to be included.

 

TBH I am easy.

Share this post


Link to post

As I wrote before - I think there should be a frontend (UI) for the nerdpack where you could choose which tools to install/update.

+1

Share this post


Link to post

Love this plugin.

 

Question: Does it uninstall cleanly? I'm a little OCD about stray files on my systems... :-/

Share this post


Link to post

I know it's been requested before, but here's a +1 for adding lftp to this suite. Thanks!

 

Edit: aaaaand.. I'm blind

 

- Added lftp 4.6.1

 

Thanks!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now