unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)


jonp

Recommended Posts

I added libmediainfo, but then it came up with the same error for libssl.so.1. I had libssl.so.1.1 so I made a symlink to libssl.so.1, but then I just got the same error for libcrypto.so.1. I guess I can keep making symlinks??
 
Edit: So after symlinking libcrypto, it now errors for libzen.so.0, and I don't have any version of that to symlink to.
I'll have to compile it myself when I get time. I rolled back to the previous version
Link to comment
I added libmediainfo, but then it came up with the same error for libssl.so.1. I had libssl.so.1.1 so I made a symlink to libssl.so.1, but then I just got the same error for libcrypto.so.1. I guess I can keep making symlinks??
 
Edit: So after symlinking libcrypto, it now errors for libzen.so.0, and I don't have any version of that to symlink to.
Give it a try now. I compiled and added mediainfo, libmediainfo and libzen
Link to comment
13 minutes ago, dmacias said:
On 2/14/2020 at 12:23 PM, 3rdWheel said:
I added libmediainfo, but then it came up with the same error for libssl.so.1. I had libssl.so.1.1 so I made a symlink to libssl.so.1, but then I just got the same error for libcrypto.so.1. I guess I can keep making symlinks??
 
Edit: So after symlinking libcrypto, it now errors for libzen.so.0, and I don't have any version of that to symlink to.

Give it a try now. I compiled and added mediainfo, libmediainfo and libzen

Still no dice. Made sure all three packages were installed, and now get this error:

  • mediainfo: symbol lookup error: mediainfo: undefined symbol: _ZN12MediaInfoLib9MediaInfo13Option_StaticERKNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEEES8_
Link to comment
Still no dice. Made sure all three packages were installed, and now get this error:
  • mediainfo: symbol lookup error: mediainfo: undefined symbol: _ZN12MediaInfoLib9MediaInfo13Option_StaticERKNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEEES8_
If the Nerdpack packages are the same versions of packages you installed the plugin won't upgrade them. It's best if you removepkg them all then install them.
Link to comment
45 minutes ago, dmacias said:

If the Nerdpack packages are the same versions of packages you installed the plugin won't upgrade them. It's best if you removepkg them all then install them.

That did it. I'd already removed and then added them all in the web interface, and it still didn't work. But it did when using removepkg on the console. Oh well, working now, thanks.

Link to comment
On 2/17/2020 at 2:01 AM, leo_poldX said:
no, this is the AWS Admin CLI Tool, it must be installed on one of your devices to manage your AWS services
 
https://aws.amazon.com/cli/?nc1=h_ls

Added. You'll need python too.

 

Edit: removed for too many packages. However you can install as with any python packages that don't need to be compiled using pip. Install python, pip and setuptools then run pip install awscli

Edited by dmacias
Link to comment
4 hours ago, Marshalleq said:

I get a traceback when running aws-cli anyone else get it to work?

Too many other packages for this package. I removed it. I'm not sure if it will work but it did work on my unraid dev vm. I have a bunch of other packages installed though.  You need python, pip and setuptools. Then just run pip install awscli.

Edited by dmacias
  • Thanks 1
Link to comment

Since subversion seems to be non-functioning in this pack, you need to install the following as well:

mkdir -p /boot/config/plugins/NerdPack/packages/extra
cd /boot/config/plugins/NerdPack/packages/extra
wget http://slackware.cs.utah.edu/pub/slackware/slackware64-14.2/slackware64/l/apr-1.5.2-x86_64-1.txz
wget http://slackware.cs.utah.edu/pub/slackware/slackware64-14.2/slackware64/l/apr-util-1.5.4-x86_64-2.txz
wget http://slackware.cs.utah.edu/pub/slackware/slackware64-current/slackware64/n/openssl10-1.0.2u-x86_64-1.txz
wget http://slackware.cs.utah.edu/pub/slackware/slackware64-14.2/slackware64/l/serf-1.3.8-x86_64-1.txz
wget http://slackware.cs.utah.edu/pub/slackware/slackware64-14.2/slackware64/l/icu4c-56.1-x86_64-2.txz
wget https://www.ifconfig.com.ua/slackware/slackware64-current/slackware64/ap/mariadb-10.4.12-x86_64-2.txz
wget http://slackware.cs.utah.edu/pub/slackware/slackware64-current/slackware64/l/utf8proc-2.4.0-x86_64-1.txz

installpkg apr-1.5.2-x86_64-1.txz apr-util-1.5.4-x86_64-2.txz openssl10-1.0.2u-x86_64-1.txz serf-1.3.8-x86_64-1.txz icu4c-56.1-x86_64-2.txz mariadb-10.4.12-x86_64-2.txz utf8proc-2.4.0-x86_64-1.txz

Not sure if its documented in this thread, but that should save the googling for each dependency.  I think the issue is that the configure flags are for the server side subversion, meaning it needs apr, mariadb, etc.  Not sure if it can be switched to a statically linked or client only subversion package?

 

Probably should move my files to git at some point anyway :D

Edited by spamalam
better ctrl+c
Link to comment
I'm getting errors when I try to install the python module psutil.  On Google the same solution is listed - installing python-devel. 
 
https://github.com/giampaolo/psutil/issues/1143
 
Is it possible to add this to nerdpack please?
I don't believe there's a python dev package for slackware and in any case sounds like somethings need compiling. You might try DevPack instead of Nerdpack.
Link to comment

Hello, first of all thanks for your work, seriously!

 

I would like to ask for hints about my issue: after updating unraid from 6.6 to 6.8, ipmitool stopped working (I use it to control fan speed on a r710):

root@Tower:~# ipmitool 
ipmitool: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

Nerd Tools: 2019.12.31

IPMI Support: 2019.02.08

 

By the way it seems that the IPMI service is actually running since I can see details about sensors and wattage.

 

Any help will be more than appreciated, cheers!

Link to comment
On 3/6/2020 at 11:06 PM, iaga said:

Hello, first of all thanks for your work, seriously!

 

I would like to ask for hints about my issue: after updating unraid from 6.6 to 6.8, ipmitool stopped working (I use it to control fan speed on a r710):


root@Tower:~# ipmitool 
ipmitool: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

Nerd Tools: 2019.12.31

IPMI Support: 2019.02.08

 

By the way it seems that the IPMI service is actually running since I can see details about sensors and wattage.

 

Any help will be more than appreciated, cheers!

i recompiled ipmitool for 6.8. Should work now

Link to comment
10 hours ago, dmacias said:

i recompiled ipmitool for 6.8. Should work now

Thanks for your help, unfortunately after uninstalling, restarting and install the plugins again I get the same error:

Linux 4.19.107-Unraid.
Last login: Wed Mar 11 15:02:50 +0100 2020 on /dev/pts/3.
root@Tower:~# ipmitool 
ipmitool: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

Do I need other plugins to make it working?

 

Thanks again for your time!

Link to comment
Thanks for your help, unfortunately after uninstalling, restarting and install the plugins again I get the same error:
Linux 4.19.107-Unraid.Last login: Wed Mar 11 15:02:50 +0100 2020 on /dev/pts/3.root@Tower:~# ipmitool ipmitool: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

Do I need other plugins to make it working?
 
Thanks again for your time!

Not sure. It works fine on my server and my dev unraid vm. Make sure you don't have another ipmitool package loading or it might be something else you have installed.
Link to comment

Hi !

 

I installed 6.9 beta 1 and since then my NerdPack Plugin is endlessly trying to "retrieving plugin information ...". I tried to uninstall/install but it did not change anything.

So

1 - its normal as I'm on a 6.9 "beta", i just have to wait patiently for an update

2 - I did something wrong somewhere and I need to search how to properly remove and install the plugin again

Link to comment
Hi !
 
I installed 6.9 beta 1 and since then my NerdPack Plugin is endlessly trying to "retrieving plugin information ...". I tried to uninstall/install but it did not change anything.
So : 
1 - its normal as I'm on a 6.9 "beta", i just have to wait patiently for an update
2 - I did something wrong somewhere and I need to search how to properly remove and install the plugin again
I copied over the 6.8 repo to 6.9. Can't guarantee all packages will work. They should though for the most part.
  • Thanks 1
Link to comment
16 hours ago, dmacias said:

Not sure. It works fine on my server and my dev unraid vm. Make sure you don't have another ipmitool package loading or it might be something else you have installed.

Hi, I tried to uninstall everything but nerdpack without luck.

 

Digging in this thread i saw a year-old message from you about recompiling ipmitool from github for the 6.7, do you think it could be related?

 

Btw this is the ldd:

root@Tower:~# ldd /usr/bin/ipmitool
        linux-vdso.so.1 (0x00007ffece0e4000)
        libm.so.6 => /lib64/libm.so.6 (0x0000153a34160000)
        libncurses.so.5 => /lib64/libncurses.so.5 (0x0000153a33f09000)
        libcrypto.so.1 => not found
        libc.so.6 => /lib64/libc.so.6 (0x0000153a33d24000)
        /lib64/ld-linux-x86-64.so.2 (0x0000153a342bc000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000153a33d1f000)

Thanks again and sorry to bother you whit that (if I will not find a solution for the fan noise, I'll be in deep trouble with the wife 😅)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.