unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)


jonp

Recommended Posts

Hi,

 

with my Xeon W-1350 powerTOP isn't working properly. From what I read, It could be because Powertop 2.13 isn't up to date for my CPU (similar issues with Powertop in the past, were solved by newer Powertop Versions.)

 

There is a PowerTop 2.14 available on Github at www.01.org/powertop , but in nerdpack only 2.13 is the newest - cloud that be right? Could you update it?

Thx

Link to comment

Hello first of all very good work for this plugin tool I have a problem and I need node.js is there a possibility to insert this into the packet or another possibility to install it.
i'm from germany hope you understand me.

Link to comment
11 hours ago, ibroker said:

Hello first of all very good work for this plugin tool I have a problem and I need node.js is there a possibility to insert this into the packet or another possibility to install it.
i'm from germany hope you understand me.

Node v14.13.0 is built-in to Unraid 6.9.2. If you need a newer version, run it in a Docker container.

Link to comment

I'm unsure how dependencies work with NerdPack but I've been having an issue where Mosh quit working after a clean install of NerdPack.

libprotobuf.so.18: cannot open shared object file: No such file or directory 

 

After messing around way to long to try to figure out what I need to install I figured out I could install protobuf-3.7.1-x86_64-1cf.txz from NerdPack and now it works. I would expect when selecting Mosh in NerdPack it would know I need this and install it alongside Mosh.

Link to comment

So, with unRAID 6.10.0, in Settings, User Preferences, after the Nerd Pack link it adds to extra "spaces?" And when using the Dynamix "Grey" theme it puts two spaces in and makes it look like the following, if I switch it to White "Default theme" you can tell it's still there just not as noticable.
I removed Nerd Pack and the issue went away, put it back and the issue came back.ad1f36ba5e18b3f062d8b5f070d2399e.jpg9e1a1367ced6a42254338eab19f60a87.jpg

Sent from my SM-S908U using Tapatalk

Link to comment
Posted (edited)

Did yesterday the update from 6.9.2 to 6.10.0.

 

After the update I found out that my powertop --auto-tune from the "go" file was no more executed.

So I switched to the plugin page and clicked the NerdPack. A window poped up and mentioned that the configured packages (as perl and powertop) are no more installed and if I want to install them again. I did this and everything was again ok.

 

Just wanted to mention this here as I think this is an unexpected behaviour?

 

Greets,

Joerg

 

PS: According to another user this happened also for him when he updated from the latest stable 6.9.2 to 6.10.0, but not on his second system when he updated from the latest RC to 6.10.0.

Edited by MPC561
Link to comment

Sorry, I'm not sure if we're allowed to ask here - but could we get the bolt tools for thunderbolt added to this?  I think I have thunderbolt working in unraid by disabling the security, but I understand the bolt package will allow that to happen more elegantly.  

 

Many thanks.

 

Marshalleq.

Link to comment
Posted (edited)

UnRAID 6.10.2 appears to partially break iotop.

 

After updating, I reinstalled my packages (and had to install python2 to be able to open iotop again), but am now seeing the following warning;

 

CONFIG_TASK_DELAY_ACCT not enabled in kernel, cannot determine SWAPIN and IO %

 

Running;

echo 1 > /proc/sys/kernel/task_delayacct

appears to fix the issue, but it seems like a bit of a hacky workaround.

Edited by Dalarielus
Formatting
Link to comment
  • 2 weeks later...
On 5/12/2022 at 1:03 PM, majo23 said:

Hi,

 

with my Xeon W-1350 powerTOP isn't working properly. From what I read, It could be because Powertop 2.13 isn't up to date for my CPU (similar issues with Powertop in the past, were solved by newer Powertop Versions.)

 

There is a PowerTop 2.14 available on Github at www.01.org/powertop , but in nerdpack only 2.13 is the newest - cloud that be right? Could you update it?

Thx

Anyone from Nerdtools read this? :(

Link to comment

Hello All, 

 

I'm on a freshly installed UNRaid build, and tried installing IPMITool, and when I try to run a command from the console I get the following error, Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory

 

I ensured that I checked it to on and it shows that it is on but isn't there, anyone else run into this?

Link to comment
On 5/12/2022 at 1:03 PM, majo23 said:

Hi,

 

with my Xeon W-1350 powerTOP isn't working properly. From what I read, It could be because Powertop 2.13 isn't up to date for my CPU (similar issues with Powertop in the past, were solved by newer Powertop Versions.)

 

There is a PowerTop 2.14 available on Github at www.01.org/powertop , but in nerdpack only 2.13 is the newest - cloud that be right? Could you update it?

Thx

i have the same problem. Would be really cool if you could update Powertop. Many Thanks.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.