unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)


jonp

Recommended Posts

15 minutes ago, Kilrah said:

Nerdpack is deprecated in 6.11.

 

For the record, since it was unfortunately only posted in a thread in the German section instead of here where people would typically come for support (translated):

 

 

 

so is there any metod to get perl?

  • Upvote 1
Link to comment

See edited post above, as well as the previous discussion page or 2 where some of these things were covered already. The system temp plugin will likely get an update to integrate/not need perl, but 6.11 is currently in RC so not everything's ready for prime time yet.

Edited by Kilrah
Link to comment
29 minutes ago, Kilrah said:

See edited post above, as well as the previous discussion page or 2 where some of these things were covered already. The system temp plugin will likely get an update to integrate/not need perl, but 6.11 is currently in RC so not everything's ready for prime time yet.

so for system temp, still need to wait some time ?

Link to comment
2 hours ago, culilaren said:

so for system temp, still need to wait some time ?

There is some missinformation out there about Systemp.

Perl is only needed for the first installation and clicking the button Detect, after you set everything up you don‘t even need Perl and can uninstall it.

Link to comment
3 hours ago, Kilrah said:

For the record, since it was unfortunately only posted in a thread in the German section instead of here where people would typically come for support (translated):

Reason why it's not marked as being incompatible and it hasn't been said point blank that it's going to disappear is because the deadline for this to happen is when 6.11 stable is released.

 

App policies dictate in a situation like this to wait for stable to be released as there is no evidence that the plugin will not get updated.   Since I don't believe that it will actually get updated I initiated a conversation with limetech including @ich777 and a solution was formed to handle this eventuality mainly with regards to the trickle down effect it would cause for other popular plugins, notably System Temp.

 

My official announcement stating that this plugin is no longer available going forward will not come until stable is released and our assumption as to the status of the plugin is proven correct.

  • Like 4
  • Thanks 1
Link to comment

Does someone know where to get a Slackware package for rmlint : it's a great CLI tool to get a list of duplicates - and remove them.
It's one of the 3 programs I was using through NerdPack - along with iperf3 and iotop.

Link to comment

So this isn't working for me. I'm trying to use screen or tmux so that I don't have to migrate my data while keeping the terminal open. I downloaded Krusader and it's horrible, keeps failing telling me it can't write after about 100 gigs. All going to the same share. 

Link to comment
1 minute ago, dlandon said:

If Nerd Pack doesn't have screen, use tmux.  Nerd Pack doesn't include "everything".

You can ignore my noobness into Unraid and the settings. I found that I have to go to settings then nerdpack and can install the packages I need. I looked under plugins and clicked nerdpack and didn't see anything, so that was my bad. 

Link to comment

As of today, since 6.11.0 stable is imminent, and I don't believe that this plugin will get updated, I have marked this plugin as being incompatible with > 6.10.3

 

If you require any packages which you may have been installing via this, you will need to do your own package management.

 

Note that Perl is now included in the base OS once 6.11.0 is released.

  • Thanks 1
Link to comment
7 hours ago, Squid said:

As of today, since 6.11.0 stable is imminent, and I don't believe that this plugin will get updated, I have marked this plugin as being incompatible with > 6.10.3

 

If you require any packages which you may have been installing via this, you will need to do your own package management.

 

Note that Perl is now included in the base OS once 6.11.0 is released.

Will plugins that need manual package resolution be marked as incompatible ?

Link to comment
6 hours ago, tjb_altf4 said:

Will plugins that need manual package resolution be marked as incompatible ?

What other(s) am I missing?  VM WOL, Network Stats.  Anything that needs Perl isn't an issue as it's included in the OS

  • Upvote 1
Link to comment
On 8/15/2022 at 3:29 AM, Kilrah said:

Download the txz files for them, and put them on the flash drive in /extra (/boot/extra on a running system), that will cause them to auto-install on boot (create the folder if there isn't one)

 

Dumb question, but is there an alternate method of this to install these on a -running- system? Seems very short-sighted that the only documented method requires a full system reboot to install packages. I also hope that a proper package manager is on the short list of features to be added to Unraid since we're getting pushed in this direction.

Link to comment
8 minutes ago, cr08 said:

but is there an alternate method of this to install these on a -running- system?

From a post earlier in this thread:

 

To be able to use them without a reboot use unraid CLI to navigate where you put the packages and run installpkg <filename>

 

On my server running the 6.11.0 rc3, I have done this with a few of the packages previously loaded via Nerd pack.  No reboot required.

  • Thanks 1
  • Upvote 1
Link to comment
2 hours ago, cr08 said:

Dumb question, but is there an alternate method of this to install these on a -running- system? Seems very short-sighted that the only documented method requires a full system reboot to install packages

It's literally the next bullet point below what you quoted :)

  • Like 1
  • Thanks 1
Link to comment
On 8/15/2022 at 3:29 AM, Kilrah said:

To be able to use them without a reboot use unraid CLI to navigate where you put the packages and run installpkg <filename>

One last thing to note. Where you put the packages MUST be in /boot/extra or they won't be reinstalled on boot.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.