Jump to content
jonp

Plex: Guide to Moving Transcoding to RAM

205 posts in this topic Last Reply

Recommended Posts

I am curious if this happened to anyone else.  I just updated my server to 6.1.4 and plex quit "working".  The plex interface worked fine, and I could play music but video would not play over any device under any circumstances.  I spent about 10 hours trouble shooting and pouring over my logs, and it looks like transcoding to /tmp was the problem.  I moved the transcode directory to my ssd in docker and it started working again (it breaks if I try to move it back).  Just in case anyone else is experiencing the same issue, that seems to be a work around, but did we lose access to /tmp in 6.1.4? 

 

 

Plex 0.9.14.2 is broken. Roll back to an older version.

Share this post


Link to post

Happened to me as well. Upgraded to 6.1.4 today, and Plex stopped working. I see there's some issues being reported with Plex, but I'm positive I was on 0.9.14.2 yesterday and it was working fine with 6.1.3. I'm trying to revert Plex right now, but it seems to me like something in 6.1.4 stopped working with Plex.

Share this post


Link to post

Most likely what happened was your plex docker updated when it was started after the reboot, and it is plex that is broken. Probably would have happened even if you did not update unRAID and merely rebooted or restarted the docker. Nothing to do with 6.1.4.

Share this post


Link to post

This for some reason no longer works for me.

I had to move the directory back to the cache directory.

How can I or should I fix this back to the RAM?

 

Share this post


Link to post

Interesting read, i upgrade to v6 last night.  got plex up and running, played some movies and tv shows fine.  then set /transcode to /tmp, and changed the plex settings to /transcode

 

played a few HD tv shows, and worked great.  these are all around the 1gb size.  then tried some movies, coudln't get a single one to play!  very odd, they are all around the 8gb mark in size

 

removed the /transcode reference in plex settings, and then all tv and movies played fine. 

 

i have a system with 16gb ram (spread over 2 cpu) so i would have thought i have plenty!  not sure if the 'broken' plex has been fixed yet.

 

 

Share this post


Link to post

Plex has been updated and should work. Latest PlexPass version is 0.9.14.4. Regarding transcoding to RAM I haven’t enough experience to give any advice since I mostly can use Direct play.

Share this post


Link to post

I have the same issue. I am running dual 6 core processors and 48gb of ram. If I have my transcode set to the ram (/tmp) I can watch some tv shows, but none of my movies. I changed the transcode to my cache drive ( mnt/cache/) then my movies work fine.

 

I have to believe that something with the new update has changed. For now I have left my transcode set at the cache drive. I would prefer it set to ram, but right now it doesn't work for me.

Share this post


Link to post

I have the same issue. I am running dual 6 core processors and 48gb of ram. If I have my transcode set to the ram (/tmp) I can watch some tv shows, but none of my movies. I changed the transcode to my cache drive ( mnt/cache/) then my movies work fine.

 

I have to believe that something with the new update has changed. For now I have left my transcode set at the cache drive. I would prefer it set to ram, but right now it doesn't work for me.

 

its an open plex issue, has been for a few weeks now.

Share this post


Link to post

I have removed the mapping to /tmp and returned transcoding to default on the Plex server (cache drive is SSD so still speedy). Now running latest release 0.9.14.4 without any problems. I had 1 movie that would always fail to start no matter what version I ran (even known good older ones) ever since the version that initially broke transcoding in RAM. Now it plays fine.

 

They have borked sumthin' in there.

Share this post


Link to post

After reading a bit on the Plex forum I understand that Plex Media Server (from 0.9.14.x) now checks available space on the location where transcoding is done before it starts transcoding. It looks like that minimum required space is the size of the largest movie file plus 100 MB.

 

If I have understood this correctly, it would probably mean that transcoding needs to be set to the cache drive (unless you only have small files or a huge amount of memory).

 

When using “Optimized Versions” (making transcoded versions of media for different devices) the transcoding is already done to the cache drive since the location used is /Library/Application Support/Plex Media Server/Cache/Transcode/Sync/

 

Edit: There are several posts about this on the Plex forum but here is one of them:

http://forums.plex.tv/discussion/198012/pms-0-9-14-4-ignoring-transcoder-temporary-directory-setting#latest

Edit: Looks like the free space needed for transcoding now has changed to be the size of the actual movie plus 200 MB.

Share this post


Link to post

After reading a bit on the Plex forum I understand that Plex Media Server (from 0.9.14.x) now checks available space on the location where transcoding is done before it starts transcoding. It looks like that minimum required space is the size of the largest movie file plus 100 MB.

 

If I have understood this correctly, it would probably mean that transcoding needs to be set to the cache drive (unless you only have small files or a huge amount of memory).

 

When using “Optimized Versions” (making transcoded versions of media for different devices) the transcoding is already done to the cache drive since the location used is /Library/Application Support/Plex Media Server/Cache/Transcode/Sync/

Since you have linked back to this post from a few other threads, you should provide a link to the source of your information in this post.

Share this post


Link to post

After reading a bit on the Plex forum I understand that Plex Media Server (from 0.9.14.x) now checks available space on the location where transcoding is done before it starts transcoding. It looks like that minimum required space is the size of the largest movie file plus 100 MB.

 

If I have understood this correctly, it would probably mean that transcoding needs to be set to the cache drive (unless you only have small files or a huge amount of memory).

 

When using “Optimized Versions” (making transcoded versions of media for different devices) the transcoding is already done to the cache drive since the location used is /Library/Application Support/Plex Media Server/Cache/Transcode/Sync/

Since you have linked back to this post from a few other threads, you should provide a link to the source of your information in this post.

Link added to original post.

Share this post


Link to post

After reading a bit on the Plex forum I understand that Plex Media Server (from 0.9.14.x) now checks available space on the location where transcoding is done before it starts transcoding. It looks like that minimum required space is the size of the largest movie file plus 100 MB.

 

If I have understood this correctly, it would probably mean that transcoding needs to be set to the cache drive (unless you only have small files or a huge amount of memory).

 

When using “Optimized Versions” (making transcoded versions of media for different devices) the transcoding is already done to the cache drive since the location used is /Library/Application Support/Plex Media Server/Cache/Transcode/Sync/

Since you have linked back to this post from a few other threads, you should provide a link to the source of your information in this post.

 

Actually, that was me linking it, I recall it being mentioned as an issue so wanted to ensure people knew about this discovery.

Share this post


Link to post

Just wanted to add that I as well had issues transcoding to RAM (/tmp). My TV shows played fine but any of my remux movies would not play (~20-30GB per movie). I have a 6 core processor with 32GB RAM.

 

Until Plex fixes this, I think the Docker FAQ thread (http://lime-technology.com/forum/index.php?topic=40937.msg419495#msg419495) should be amended to NOT recommend transcoding to RAM. I just built my system so I followed those FAQs to the teeth. Would have saved me some frustrating hours.

 

I did similar to jumperalex.  I remapped /transcode in the Docker config from /tmp to /mnt/cache/apps/plex/Library/Application Support/Plex Media Server/Cache/Transcode.  I didn't change the path inside Plex itself as I mapped the full path to the transcode directory to /transcode in the Docker.

 

I followed these steps to transcode back to my SSD cache.

 

 

Share this post


Link to post

I have the same issue. I am running dual 6 core processors and 48gb of ram. If I have my transcode set to the ram (/tmp) I can watch some tv shows, but none of my movies. I changed the transcode to my cache drive ( mnt/cache/) then my movies work fine.

 

I have to believe that something with the new update has changed. For now I have left my transcode set at the cache drive. I would prefer it set to ram, but right now it doesn't work for me.

 

its an open plex issue, has been for a few weeks now.

 

Yeah, all this time i've been wondering why my bluray rips weren't playing.  Started a few weeks ago.  Anyway I hope they fix it....

Share this post


Link to post

Hi,

 

I'm newb and not as advanced as all of you. I faced an issue and I believe I solved it but not so sure.

 

I have unraid 6.1.7 and 32GB ram.

 

I've mapped the docker as suggested:

I've typed /transcode in Container volume box and /tmp in Host path box but when tested it and opened a movie, it didn't work.

Then I changed the Host path to /mnt/user/tmp and it worked

 

However, I kept that movie playing and I opened to the dashboard to see the load, CPU had about 50% load and the memory had just 4%

 

I'm not sure the transcoding is being performed by the RAM.

 

I have attached a snap shot of the mapping, what is wrong here?

 

Thanks,

 

Abdulla

Capture.JPG.fc67cfeab28d66438f3400833a209064.JPG

Share this post


Link to post

Hi,

 

I'm newb and not as advanced as all of you. I faced an issue and I believe I solved it but not so sure.

 

I have unraid 6.1.7 and 32GB ram.

 

I've mapped the docker as suggested:

I've typed /transcode in Container volume box and /tmp in Host path box but when tested it and opened a movie, it didn't work.

Then I changed the Host path to /mnt/user/tmp and it worked

 

However, I kept that movie playing and I opened to the dashboard to see the load, CPU had about 50% load and the memory had just 4%

 

I'm not sure the transcoding is being performed by the RAM.

 

I have attached a snap shot of the mapping, what is wrong here?

 

Thanks,

 

Abdulla

/mnt/user/tmp is not in RAM. When you specified that path you actually created a user share named tmp which will be stored on your disks using the default user share settings.

 

Your original mapping of /transcode:/tmp was the right one because /tmp is in RAM, but you also have to go into plex and tell it to use /transcode for transcoding.

 

Also, there have been reports that this doesn't work correctly with recent version of plex anyway. Not sure if that was ever resolved or not.

Share this post


Link to post

Hi,

 

I'm newb and not as advanced as all of you. I faced an issue and I believe I solved it but not so sure.

 

I have unraid 6.1.7 and 32GB ram.

 

I've mapped the docker as suggested:

I've typed /transcode in Container volume box and /tmp in Host path box but when tested it and opened a movie, it didn't work.

Then I changed the Host path to /mnt/user/tmp and it worked

 

However, I kept that movie playing and I opened to the dashboard to see the load, CPU had about 50% load and the memory had just 4%

 

I'm not sure the transcoding is being performed by the RAM.

 

I have attached a snap shot of the mapping, what is wrong here?

 

Thanks,

 

Abdulla

/mnt/user/tmp is not in RAM. When you specified that path you actually created a user share named tmp which will be stored on your disks using the default user share settings.

 

Your original mapping of /transcode:/tmp was the right one because /tmp is in RAM, but you also have to go into plex and tell it to use /transcode for transcoding.

 

Also, there have been reports that this doesn't work correctly with recent version of plex anyway. Not sure if that was ever resolved or not.

 

 

Thanks for the quick reply. I changed that in Plex transcoder page but the video is not working.

Share this post


Link to post

Thanks for the quick reply. I changed that in Plex transcoder page but the video is not working.

 

Transcoding in RAM stopped working around Plex 0.9.14.  See the other comments on this page.

 

For more info on moving the transcoding directory, see: https://lime-technology.com/forum/index.php?topic=40937.msg419495#msg419495

 

Thanks for this reply. Hopefully with the new update, we will be able to use RAM for transcoding

Share this post


Link to post

How can we install an old plex docker image that works with ram transcoding?

 

I do not care about new features. I would rather have an old working version for transcoding to ram.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.