Release: Folding@Home Docker


Recommended Posts

Just installed this docker and am getting the same thing - windows client is working just find on my 3 win 10 machines - they are getting out to the server

 

WUI is not loading as well

 

Ideas?

 

Myk

 

Change the number of CPUs assigned to your folding slot.  I found a mention of this issue on the folding forum https://foldingforum.org/viewtopic.php?f=18&t=28863

 

I haven't been able to access the web UI but I can connect through the os x controller app.  I feel like the default settings should work on my network but I still can't connect.

 

...This is my first post I think. I'm running 2xIntel Xeon E5-2670 @ 2.60GHz on an ASRock EP2C602-4L/D16.

 

This worked perfectly, thanks!

 

Was getting the error: Failed to get assignment from '171.67.108.45:8080': Empty work server assignment and it wasn't working, went through the document and added the following:

 

<cpus v="1"/>

 

Under the CPU Use section. I'm not sure why it matters when it already detects the number of cores but it works! :D

 

Fixed the problem for me to.

 

I simply pasted <cpus v="1"/> as a new line in my config.xml, restarted the docker, and it worked.

 

Thanks!

 

Link to comment

Just installed this docker and am getting the same thing - windows client is working just find on my 3 win 10 machines - they are getting out to the server

 

WUI is not loading as well

 

Ideas?

 

Myk

 

Change the number of CPUs assigned to your folding slot.  I found a mention of this issue on the folding forum https://foldingforum.org/viewtopic.php?f=18&t=28863

 

I haven't been able to access the web UI but I can connect through the os x controller app.  I feel like the default settings should work on my network but I still can't connect.

 

...This is my first post I think. I'm running 2xIntel Xeon E5-2670 @ 2.60GHz on an ASRock EP2C602-4L/D16.

 

This worked perfectly, thanks!

 

Was getting the error: Failed to get assignment from '171.67.108.45:8080': Empty work server assignment and it wasn't working, went through the document and added the following:

 

<cpus v="1"/>

 

Under the CPU Use section. I'm not sure why it matters when it already detects the number of cores but it works! :D

 

Fixed the problem for me to.

 

I simply pasted <cpus v="1"/> as a new line in my config.xml, restarted the docker, and it worked.

 

Thanks!

 

 

Now if I could just get the windows config program to connect to it - it sees it - but can never connect.

 

Have you been able to connect to it?

 

Myk

 

Link to comment
  • 5 months later...

How do I add more CPU cores? 

 

I've got 8 cores and want to use 4 of them, so tried typing: <cpus v='4'/>,  but also tried: <cpus v='0,3,4,7'/>, and set the folding power to full, but it never maxes all the cores chosen, only one core is at 100% at any time.

 

 

Skærmbillede 2017-05-21 kl. 10.07.51.png

Skærmbillede 2017-05-21 kl. 10.08.05.png

Link to comment
  • 5 months later...

I'm not sure why or what your changing in the config.xml?

"<cpus v='4'/>,  but also tried: <cpus v='0,3,4,7'/> " ? is this a config modification

I limit resources with Docker "Extra Parameters"

Here is mine. "--cpuset-cpus=1  --cpu-shares=2  --cpu-period=100000 --cpu-quota=30000  --cap-add=SYS_NICE  --memory="256m"  --memory-swap="384m"   --log-opt max-size=50m --log-opt max-file=1".

 

--cpuset-cpus=1  [ sets number of cpus ]

--cpu-shares=2  [ sets weighted priority of container ]

--cpu-period=100000 --cpu-quota=30000  [ limits cpu max usage. this is 30% ]

--memory="256m"  --memory-swap="384m"  [ limits memory usage ]

--log-opt max-size=50m --log-opt max-file=1"  [ controls log file size ]

 

Here is a good  reference. https://docs.docker.com/engine/reference/run/

I'm no expert but hopefully this helps some using this container.

 

Edited by spazmc
Link to comment
  • 2 months later...
  • 2 weeks later...

Not always.

The phone app connects every time though.

You can thy a different browser.

Just connected to mine.

Used firefox.  

I think my router or browser has something to do with this.

Used to connect to server @ 192.168.1.**:7396

Now changed to (server:7396)

Chrome based browsers block everything (Midori)

Sometimes I reboot this docker and then connect with firefox.

Hope that helps.

Edited by spazmc
added info
Link to comment
  • 7 months later...

I believe the client needs updating because it isn't able to process core_a7 work units:

01:24:13:WU00:FS00:Starting
01:24:13:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 19 -checkpoint 15 -np 16
01:24:13:WU00:FS00:Started FahCore on PID 54
01:24:13:WU00:FS00:Core PID:58
01:24:13:WU00:FS00:FahCore 0xa7 started
[93m01:24:14:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)[0m

while the older core_a4 WUs are getting fewer and further between but when they do arrive they work fine:

01:27:55:WU01:FS00:0xa4:Completed 2500 out of 250000 steps (1%)
01:28:23:WU01:FS00:0xa4:Completed 5000 out of 250000 steps (2%)
01:28:54:WU01:FS00:0xa4:Completed 7500 out of 250000 steps (3%)

 

Link to comment
  • 1 month later...
Quote

*********************** Log Started 2018-11-01T23:49:34Z ***********************
23:49:34:************************* Folding@home Client *************************
23:49:34:    Website: http://folding.stanford.edu/
23:49:34:  Copyright: (c) 2009-2014 Stanford University
23:49:34:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
23:49:34:       Args: --config /config/config.xml
23:49:34:     Config: /config/config.xml
23:49:34:******************************** Build ********************************
23:49:34:    Version: 7.4.4
23:49:34:       Date: Mar 4 2014
23:49:34:       Time: 12:02:38
23:49:34:    SVN Rev: 4130
23:49:34:     Branch: fah/trunk/client
23:49:34:   Compiler: GNU 4.4.7
23:49:34:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
23:49:34:             -fno-unsafe-math-optimizations -msse2
23:49:34:   Platform: linux2 3.2.0-1-amd64
23:49:34:       Bits: 64
23:49:34:       Mode: Release
23:49:34:******************************* System ********************************
23:49:34:        CPU: AMD Ryzen Threadripper 1950X 16-Core Processor
23:49:34:     CPU ID: AuthenticAMD Family 23 Model 1 Stepping 1
23:49:34:       CPUs: 32
23:49:34:     Memory: 31.28GiB
23:49:34:Free Memory: 322.00MiB
23:49:34:    Threads: POSIX_THREADS
23:49:34: OS Version: 4.18
23:49:34:Has Battery: false
23:49:34: On Battery: false
23:49:34: UTC Offset: -7
23:49:34:        PID: 23
23:49:34:        CWD: /config
23:49:34:         OS: Linux 4.18.10-unRAID x86_64
23:49:34:    OS Arch: AMD64
23:49:34:       GPUs: 2
23:49:34:      GPU 0: UNSUPPORTED: [FireMV 2250]
23:49:34:      GPU 1: UNSUPPORTED: [FireMV 2250] (Secondary)
23:49:34:       CUDA: Not detected
23:49:34:***********************************************************************
23:49:34:<config>
23:49:34:  <!-- Client Control -->
23:49:34:  <fold-anon v='true'/>
23:49:34:
23:49:34:  <!-- Folding Slot Configuration -->
23:49:34:  <gpu v='false'/>
23:49:34:
23:49:34:  <!-- HTTP Server -->
23:49:34:  <allow v='10.0.8.8/16'/>
23:49:34:
23:49:34:  <!-- Network -->
23:49:34:  <proxy v=':8080'/>
23:49:34:
23:49:34:  <!-- Remote Command Server -->
23:49:34:  <password v='********'/>
23:49:34:
23:49:34:  <!-- Slot Control -->
23:49:34:  <power v='full'/>
23:49:34:
23:49:34:  <!-- User Information -->
23:49:34:  <passkey v='********************************'/>
23:49:34:  <team v='223518'/>
23:49:34:  <user v='cturtle98'/>
23:49:34:
23:49:34:  <!-- Web Server -->
23:49:34:  <web-allow v='10.0.8.8/16'/>
23:49:34:
23:49:34:  <!-- Folding Slots -->
23:49:34:  <slot id='0' type='CPU'>
23:49:34:    <cpus v='4'/>
23:49:34:  </slot>
23:49:34:</config>
23:49:34:Trying to access database...
23:49:34:Successfully acquired database lock
23:49:34:Enabled folding slot 00: READY cpu:4
23:49:34:WU00:FS00:Starting
23:49:34:WARNING:WU00:FS00:Changed SMP threads from 32 to 4 this can cause some work units to fail
23:49:34:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 23 -checkpoint 15 -np 4
23:49:34:WU00:FS00:Started FahCore on PID 35
23:49:34:WU00:FS00:Core PID:39
23:49:34:WU00:FS00:FahCore 0xa7 started
23:49:35:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)
23:49:35:WARNING:WU00:FS00:Too many errors, failing
23:49:35:WU00:FS00:Sending unit results: id:00 state:SEND error:FAILED project:14101 run:16 clone:3 gen:10 core:0xa7 unit:0x000000110002894b5b7da3c972cdcc94
23:49:35:WU00:FS00:Connecting to 155.247.166.219:8080
23:49:35:WU01:FS00:Connecting to 65.254.110.245:8080
23:49:36:WU00:FS00:Server responded WORK_ACK (400)
23:49:36:WU00:FS00:Cleaning up
23:49:36:WU01:FS00:Assigned to work server 128.252.203.2
23:49:36:WU01:FS00:Requesting new work unit for slot 00: READY cpu:4 from 128.252.203.2
23:49:36:WU01:FS00:Connecting to 128.252.203.2:8080
23:49:37:WU01:FS00:Downloading 4.47MiB
23:49:38:WU01:FS00:Download complete
23:49:38:WU01:FS00:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:13811 run:0 clone:31 gen:335 core:0xa7 unit:0x0000019080fccb025a9818160aef9f17
23:49:38:WU01:FS00:Starting
23:49:38:WU01:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 01 -suffix 01 -version 704 -lifeline 23 -checkpoint 15 -np 4
23:49:38:WU01:FS00:Started FahCore on PID 40
23:49:38:WU01:FS00:Core PID:44
23:49:38:WU01:FS00:FahCore 0xa7 started
23:49:38:WARNING:WU01:FS00:FahCore returned: FAILED_2 (1 = 0x1)
23:49:39:WU01:FS00:Starting
23:49:39:WU01:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 01 -suffix 01 -version 704 -lifeline 23 -checkpoint 15 -np 4
23:49:39:WU01:FS00:Started FahCore on PID 46
23:49:39:WU01:FS00:Core PID:50
23:49:39:WU01:FS00:FahCore 0xa7 started
23:49:39:WARNING:WU01:FS00:FahCore returned: FAILED_2 (1 = 0x1)
 

my docker cpu usage is 0.3% and this is my log

 

any idea what im doing wrong?

Link to comment
On 9/1/2018 at 7:18 PM, John_M said:

I believe the client needs updating because it isn't able to process core_a7 work units:


01:24:13:WU00:FS00:Starting
01:24:13:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 19 -checkpoint 15 -np 16
01:24:13:WU00:FS00:Started FahCore on PID 54
01:24:13:WU00:FS00:Core PID:58
01:24:13:WU00:FS00:FahCore 0xa7 started
[93m01:24:14:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)[0m

while the older core_a4 WUs are getting fewer and further between but when they do arrive they work fine:


01:27:55:WU01:FS00:0xa4:Completed 2500 out of 250000 steps (1%)
01:28:23:WU01:FS00:0xa4:Completed 5000 out of 250000 steps (2%)
01:28:54:WU01:FS00:0xa4:Completed 7500 out of 250000 steps (3%)

 

https://foldingathome.org/support/faq/installation-guides/linux/manual-installation-advanced/

https://hub.docker.com/r/captinsano/foldingathome/~/dockerfile/

 

both version 7.4.4 so I think its up to date

Link to comment
25 minutes ago, cTurtle98 said:

I believe the client needs updating because it isn't able to process core_a7 work units:

That's a shame.  Probably best course of action though is to deprecate this application (it isn't even the 64 bit executable, so much slower than it should be) and hope to hell that @CHBMB et al feel generous one day and pop out a replacement over their morning coffee one day and help the world one day become a better place.

Edited by dockerPolice
Link to comment
  • 3 weeks later...

Anyone have ideas what could be causing this some days it will start but if I leave it going it crashes and goes into a state of the ui flickering

 

homenas-diagnostics-20181118-1113.zip

 

 

16:09:30:WU00:FS00:Starting
16:09:30:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 21 -checkpoint 15 -np 8
16:09:30:WU00:FS00:Started FahCore on PID 619
16:09:30:WU00:FS00:Core PID:623
16:09:30:WU00:FS00:FahCore 0xa7 started
[93m16:09:31:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)[0m

image.thumb.png.bdfad83da291ed1c05b905aa117470b7.png

 

Link to comment
2 minutes ago, mrbilky said:

16:09:30:WU00:FS00:FahCore 0xa7 started

 

On 11/1/2018 at 7:54 PM, cTurtle98 said:

I believe the client needs updating because it isn't able to process core_a7 work units:

 

On 11/1/2018 at 7:54 PM, cTurtle98 said:

while the older core_a4 WUs are getting fewer and further between but when they do arrive they work fine:

 

3 minutes ago, mrbilky said:

state of the ui flickering

Issue in the client.  If the WU isn't compatible, then the UI does the flicker thing.  The Windows version also does the exact same thing if the WU that it wants to run on your GPU isn't compatible.

Link to comment

I tried restricting the disease being researched, first to Alzheimer's then to Cancer, in the hope that one or other of them had a higher proportion of core_a4 WUs to offer but over a couple of weeks it didn't work any better than when Any disease was selected. If there isn't going to be an update I'll probably retire from the project - it just doesn't seem fair to request work units and then discard them.

Link to comment
  • 3 months later...

So with the recent release of this: 

 

https://forums.unraid.net/topic/77813-plugin-linuxserverio-unraid-nvidia/

 

I've gotten the unRaid Plex container to work with my K2200 for decoding without issue.  

 

So I decided to add the same container modifications to this folding container, modify my config file, add the GPU slot and check the logs.

image.thumb.png.f085bbf786c50c7bc686accf2cb96f8c.png

 

Everything seemed excellent at first.  After adding the GPU slot and starting up the client, the GPU count was detected and the name string of the card came back just fine.

 

*********************** Log Started 2019-02-25T07:07:05Z ***********************
07:07:05:************************* Folding@home Client *************************
07:07:05:    Website: http://folding.stanford.edu/
07:07:05:  Copyright: (c) 2009-2014 Stanford University
07:07:05:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
07:07:05:       Args: --config /config/config.xml
07:07:05:     Config: /config/config.xml
07:07:05:******************************** Build ********************************
07:07:05:    Version: 7.4.4
07:07:05:       Date: Mar 4 2014
07:07:05:       Time: 12:02:38
07:07:05:    SVN Rev: 4130
07:07:05:     Branch: fah/trunk/client
07:07:05:   Compiler: GNU 4.4.7
07:07:05:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
07:07:05:             -fno-unsafe-math-optimizations -msse2
07:07:05:   Platform: linux2 3.2.0-1-amd64
07:07:05:       Bits: 64
07:07:05:       Mode: Release
07:07:05:******************************* System ********************************
07:07:05:        CPU: Intel(R) Xeon(R) CPU E5-2448L v2 @ 1.80GHz
07:07:05:     CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
07:07:05:       CPUs: 20
07:07:05:     Memory: 31.43GiB
07:07:05:Free Memory: 379.02MiB
07:07:05:    Threads: POSIX_THREADS
07:07:05: OS Version: 4.18
07:07:05:Has Battery: false
07:07:05: On Battery: false
07:07:05: UTC Offset: -6
07:07:05:        PID: 21
07:07:05:        CWD: /config
07:07:05:         OS: Linux 4.18.20-unRAID x86_64
07:07:05:    OS Arch: AMD64
07:07:05:       GPUs: 1
07:07:05:      GPU 0: NVIDIA:4 GM107 [Quadro K2200]
07:07:05:       CUDA: 5.0
07:07:05:CUDA Driver: 10000
07:07:05:***********************************************************************
----removed config for space considerations----
07:07:05:  <!-- Folding Slots -->
07:07:05:  <slot id='0' type='CPU'>
07:07:05:    <paused v='true'/>
07:07:05:  </slot>
07:07:05:  <slot id='1' type='GPU'/>
07:07:05:</config>
07:07:05:Trying to access database...
07:07:05:Successfully acquired database lock
07:07:05:Enabled folding slot 00: PAUSED cpu:19 (by user)
07:07:05:Enabled folding slot 01: READY gpu:0:GM107 [Quadro K2200]
07:07:05:WU00:FS01:Starting
07:07:05:WU00:FS01:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 21 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
07:07:05:WU00:FS01:Started FahCore on PID 36
07:07:05:WU00:FS01:Core PID:40
07:07:05:WU00:FS01:FahCore 0x21 started
\x1b[93m07:07:06:WARNING:WU00:FS01:FahCore returned: UNKNOWN_ENUM (127 = 0x7f)\x1b[0m
07:07:06:WU00:FS01:Starting
07:07:06:WU00:FS01:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 21 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
07:07:06:WU00:FS01:Started FahCore on PID 41
07:07:06:WU00:FS01:Core PID:45
07:07:06:WU00:FS01:FahCore 0x21 started
\x1b[93m07:07:06:WARNING:WU00:FS01:FahCore returned: UNKNOWN_ENUM (127 = 0x7f)\x1b[0m

As you can see, I keep getting this "UNKNOWN_ENUM (127 = 0x7f) error when attempting to run the GPU folding slot.  Was wondering if anyone else here had tried this?  I was previously passing this same K2200 quadro through to windows VM and folding via the windows client on it.  While that worked, it was not 'ideal' and I would much rather pass the hardware to this container and fold without the overhead of a full windows VM.

Link to comment

Not sure if it helps or not, but I've recently spent some time looking for this error message and came across one other linux user who reported that running nvidia-xconfig had to be done in his ubuntu install when using repository drivers.

 

https://bbs.archlinux.org/viewtopic.php?id=170260

Quote

Solved

 

It's necessary execute "nvidia-xconfig". Without it, it's like "no driver" registred, and folding at home won't find way to work with gpu

thanks

So I've attempted to execute this string from the console within the container, and the command is not found.  No problem.  Backed out to the unraid server itself and executed this command and hit this gem:

 

root@Mediaserver:~# nvidia-xconfig

WARNING: Unable to locate/open X configuration file.


WARNING: Unable to parse X.Org version string.

sh: pkg-config: command not found
New X configuration file written to '/etc/X11/XF86Config'

root@Mediaserver:~#

So... no luck with that either. 

 

Link to comment
  • 3 weeks later...

always getting this error in the log:

22:58:58:WU00:FS00:Starting
22:58:58:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 21 -checkpoint 15 -np 4
22:58:58:WU00:FS00:Started FahCore on PID 110
22:58:58:WU00:FS00:Core PID:114
22:58:58:WU00:FS00:FahCore 0xa7 started
�[93m22:58:59:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)�[0m

seems like its the workunit problem. could an update of the docker fix this?

Link to comment

I'm fairly certain the work unit issues with captinsano's fah docker container is the result of an old phusion image base. I forked the project on github, updated the dockerfile to include a more recent phusion base, built it on dockerhub, and was able to handle a4's and a7's.

Edited by MobiusNine
Link to comment
2 hours ago, MobiusNine said:

I'm fairly certain the work unit issues with captinsano's fah docker container is the result of an old phusion image base. I forked the project on github, updated the dockerfile to include a more recent phusion base, built it on dockerhub, and was able to handle a4's and a7's.

feel free to publish it then here

Link to comment

Here's my repository. the updated FoldingAtHome is the only template in it. https://github.com/MobiusNine/docker-templates

 

 

It starts an a7 unit without issue.

 

07:15:49:WU00:FS00:Starting
07:15:49:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 28 -checkpoint 15 -np 16
07:15:49:WU00:FS00:Started FahCore on PID 37
07:15:49:WU00:FS00:Core PID:41
07:15:49:WU00:FS00:FahCore 0xa7 started
07:15:49:FS00:Unpaused
07:15:49:WU00:FS00:Starting
07:15:49:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/AVX/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 704 -lifeline 28 -checkpoint 15 -np 16
07:15:49:WU00:FS00:Started FahCore on PID 37
07:15:49:WU00:FS00:Core PID:41
07:15:49:WU00:FS00:FahCore 0xa7 started
07:15:49:WU00:FS00:0xa7:*********************** Log Started 2019-03-15T07:15:49Z ***********************
07:15:49:WU00:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
07:15:49:WU00:FS00:0xa7: Type: 0xa7
07:15:49:WU00:FS00:0xa7: Core: Gromacs
07:15:49:WU00:FS00:0xa7: Website: https://foldingathome.org/
07:15:49:WU00:FS00:0xa7: Copyright: (c) 2009-2018 foldingathome.org
07:15:49:WU00:FS00:0xa7: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
07:15:49:WU00:FS00:0xa7: Args: -dir 00 -suffix 01 -version 704 -lifeline 37 -checkpoint 15 -np 16
07:15:49:WU00:FS00:0xa7: Config: <none>
07:15:49:WU00:FS00:0xa7:************************************ Build *************************************
07:15:49:WU00:FS00:0xa7: Version: 0.0.17
07:15:49:WU00:FS00:0xa7: Date: Apr 27 2018
07:15:49:WU00:FS00:0xa7: Time: 19:09:21
07:15:49:WU00:FS00:0xa7: Repository: Git
07:15:49:WU00:FS00:0xa7: Revision: 21359963583d09ec2063ef946399441c4df4ccd7
07:15:49:WU00:FS00:0xa7: Branch: master
07:15:49:WU00:FS00:0xa7: Compiler: GNU 6.3.0 20170516
07:15:49:WU00:FS00:0xa7: Options: -std=gnu++98 -O3 -funroll-loops
07:15:49:WU00:FS00:0xa7: Platform: linux2 4.14.0-3-amd64
07:15:49:WU00:FS00:0xa7: Bits: 64
07:15:49:WU00:FS00:0xa7: Mode: Release
07:15:49:WU00:FS00:0xa7: SIMD: avx_256
07:15:49:WU00:FS00:0xa7:************************************ System ************************************
07:15:49:WU00:FS00:0xa7: CPU: Intel(R) Xeon(R) CPU E5-2667 v2 @ 3.30GHz
07:15:49:WU00:FS00:0xa7: CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
07:15:49:WU00:FS00:0xa7: CPUs: 32
07:15:49:WU00:FS00:0xa7: Memory: 62.94GiB
07:15:49:WU00:FS00:0xa7:Free Memory: 981.30MiB
07:15:49:WU00:FS00:0xa7: Threads: POSIX_THREADS
07:15:49:WU00:FS00:0xa7: OS Version: 4.19
07:15:49:WU00:FS00:0xa7:Has Battery: false
07:15:49:WU00:FS00:0xa7: On Battery: false
07:15:49:WU00:FS00:0xa7: UTC Offset: 0
07:15:49:WU00:FS00:0xa7: PID: 41
07:15:49:WU00:FS00:0xa7: CWD: /config/work
07:15:49:WU00:FS00:0xa7: OS: Linux 4.19.23-Unraid x86_64
07:15:49:WU00:FS00:0xa7: OS Arch: AMD64
07:15:49:WU00:FS00:0xa7:********************************************************************************
07:15:49:WU00:FS00:0xa7:Project: 13818 (Run 65, Clone 1, Gen 0)
07:15:49:WU00:FS00:0xa7:Unit: 0x0000000180fccb095c70623aa7181a41
07:15:49:WU00:FS00:0xa7:Digital signatures verified
07:15:49:WU00:FS00:0xa7:Calling: mdrun -s frame0.tpr -o frame0.trr -x frame0.xtc -cpi state.cpt -cpt 15 -nt 16
07:15:49:WU00:FS00:0xa7:Steps: first=0 total=250000
07:15:51:WU00:FS00:0xa7:Completed 2170 out of 250000 steps (0%)
07:15:51:WU00:FS00:0xa7:Completed 2170 out of 250000 steps (0%)
07:16:00:WU00:FS00:0xa7:Completed 2500 out of 250000 steps (1%)
07:16:00:WU00:FS00:0xa7:Completed 2500 out of 250000 steps (1%)
 

Edited by MobiusNine
I'm adding some of the log of the docker calculating a cpu work unit.
  • Like 1
Link to comment

I can't seem to get the gpu detected when passing it to the container, anyone have any ideas? I tried installing the nvidia driver 410 on the image, but all that did was increase the build time for the image and cause folding at home to not detect cuda, which is did beforehand at version 6.1

 

09:58:37:************************* Folding@home Client *************************
09:58:37: Website: http://folding.stanford.edu/
09:58:37: Copyright: (c) 2009-2014 Stanford University
09:58:37: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
09:58:37: Args: --config /config/config.xml
09:58:37: Config: /config/config.xml
09:58:37:******************************** Build ********************************
09:58:37: Version: 7.4.4
09:58:37: Date: Mar 4 2014
09:58:37: Time: 12:02:38
09:58:37: SVN Rev: 4130
09:58:37: Branch: fah/trunk/client
09:58:37: Compiler: GNU 4.4.7
09:58:37: Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
09:58:37: -fno-unsafe-math-optimizations -msse2
09:58:37: Platform: linux2 3.2.0-1-amd64
09:58:37: Bits: 64
09:58:37: Mode: Release
09:58:37:******************************* System ********************************
09:58:37: CPU: Intel(R) Xeon(R) CPU E5-2667 v2 @ 3.30GHz
09:58:37: CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
09:58:37: CPUs: 32
09:58:37: Memory: 62.94GiB
09:58:37:Free Memory: 1.49GiB
09:58:37: Threads: POSIX_THREADS
09:58:37: OS Version: 4.19
09:58:37:Has Battery: false
09:58:37: On Battery: false
09:58:37: UTC Offset: 0
09:58:37: PID: 28
09:58:37: CWD: /config
09:58:37: OS: Linux 4.19.23-Unraid x86_64
09:58:37: OS Arch: AMD64
09:58:37: GPUs: 0
09:58:37: CUDA: 6.1
09:58:37:CUDA Driver: 10000
09:58:37:***********************************************************************

Edited by MobiusNine
more detail
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.