Jump to content
Zeron

Open VM Tools for unRAID 6

225 posts in this topic Last Reply

Recommended Posts

Hi,

 

Can this be updated for 6.1?

 

Awesome plugin BTW...

 

Update from the plugin tab in unRaid - it supports the current 6.1 rc

Share this post


Link to post

root@unRAIDb:/boot/extra# cat /etc/unraid-version

version="6.1.0"

 

root@unRAIDb:/boot/extra# installpkg open_vm_tools-9.10.0.2476743_unRaid6.0rc3-x86_64-5Zeron.tgz

Verifying package open_vm_tools-9.10.0.2476743_unRaid6.0rc3-x86_64-5Zeron.tgz.

Installing package open_vm_tools-9.10.0.2476743_unRaid6.0rc3-x86_64-5Zeron.tgz:

PACKAGE DESCRIPTION:

Executing install script for open_vm_tools-9.10.0.2476743_unRaid6.0rc3-x86_64-5Zeron.tgz.

...

Plugin was built for Kernel 4.0.4 but you have 4.1.5

...

Package open_vm_tools-9.10.0.2476743_unRaid6.0rc3-x86_64-5Zeron.tgz installed.

 

Any updates to come?

Share this post


Link to post

Any updates to come?

 

Never mind. I grabbed the plg file and it seemed to install. Thank you for your hard work.

Share this post


Link to post

Any chance this will be updated for 6.1.3 since there was a kernel change to 4.1.7?

 

Done.

 

I didn't see that there was a 6.1.3 release until today.

Share this post


Link to post

Any chance this will be updated for 6.1.3 since there was a kernel change to 4.1.7?

 

Done.

 

I didn't see that there was a 6.1.3 release until today.

 

 

You're a class act oh mighty zeron!

Thanks!

Share this post


Link to post

Any chance this will be updated for 6.1.3 since there was a kernel change to 4.1.7?

 

Done.

 

I didn't see that there was a 6.1.3 release until today.

 

Zeron, you are the man!

Share this post


Link to post

This is fantastic! Thank you very much. My ultimate ESXi build is now complete.

Share this post


Link to post

Updated for 6.1.4

Zeron, you're single-handedly the only reason I'm still able to run unRAID under ESXi.  So thank you so much.

Share this post


Link to post

Updated for 6.1.4

Zeron, you're single-handedly the only reason I'm still able to run unRAID under ESXi.  So thank you so much.

 

Ditto!

Share this post


Link to post

Howdy,

 

Seems after the latest update to 6.1.7, my ESXi reports VM Tools as installed but not running, do we need a new version?

 

Thanks,

 

Mark

Share this post


Link to post

Howdy,

 

Seems after the latest update to 6.1.7, my ESXi reports VM Tools as installed but not running, do we need a new version?

 

Thanks,

 

Mark

 

A new version on VMtools is needed every time the kernel is updated in unRAID.  So, yes.

Share this post


Link to post

Howdy,

 

Seems after the latest update to 6.1.7, my ESXi reports VM Tools as installed but not running, do we need a new version?

 

Thanks,

 

Mark

 

A new version on VMtools is needed every time the kernel is updated in unRAID.  So, yes.

 

Currently building an updated version.  Should be uploaded in a few hours.

Share this post


Link to post

Howdy,

 

Seems after the latest update to 6.1.7, my ESXi reports VM Tools as installed but not running, do we need a new version?

 

Thanks,

 

Mark

 

A new version on VMtools is needed every time the kernel is updated in unRAID.  So, yes.

 

Currently building an updated version.  Should be uploaded in a few hours.

 

Wow, thanks for such a quick response... My no.1 plugin!

Share this post


Link to post

I'm getting this error when trying to update this plugin for v6.1.8.

openVMtools_error.png.95a0a9ecd88ed29769a03c853229031a.png

Share this post


Link to post

Thank you moose.

 

I was going to post up something similar as well about it wanting, at least it looks like, an older version of the program.

 

I cannot thank you enough for this plugin, I always wait until this is updated as well. It's a life saver for those of us running ESXi!

Share this post


Link to post

I'm also experiencing the error when trying to update on 6.1.8?

 

plugin: installing: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg

plugin: downloading http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg

plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg ... done

plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/open_vm_tools-9.10.0.2476743-K4.1.15_unRaid-x86_64-8Zeron.tgz ... failed (Invalid URL / Server error response)

plugin: wget: http://unraid.zeron.ca/plugins/open-vm-tools/open_vm_tools-9.10.0.2476743-K4.1.15_unRaid-x86_64-8Zeron.tgz download failure (Invalid URL / Server error response)

 

Share this post


Link to post

A new version is required any time the unRAID kernel is updated.  Zeron is usually pretty darn quick with compiling a new plugin and will update this thread when available.

 

Edit: Strange, I see an update for this plugin for the new kernel as of yesterday.  Is it not working for others?

 

Edit2: Ok, something funky is going on.  The plugin has been updated, and the new package is downloaded, but for some reason the package isn't properly installed.  Here's what it shows in the syslog after I updated the plugin and rebooted:

 

Feb 11 18:28:07 titan logger: plugin: installing: /boot/config/plugins/openVMTools.plg
Feb 11 18:28:07 titan logger: plugin: skipping: /boot/packages/open_vm_tools-9.10.0.2476743-K4.1.15_unRaid-x86_64-9Zeron.tgz already exists
Feb 11 18:28:07 titan logger: plugin: skipping: /boot/packages/open_vm_tools-9.10.0.2476743-K4.1.13_unRaid-x86_64-8Zeron.tgz already exists
Feb 11 18:28:07 titan logger: plugin: skipping: /boot/packages/open_vm_tools-9.10.0.2476743-K4.1.7_unRaid-x86_64-7Zeron.tgz already exists
Feb 11 18:28:07 titan logger: plugin: skipping: /boot/packages/open_vm_tools-9.10.0.2476743-K4.1.5_unRaid-x86_64-6Zeron.tgz already exists
Feb 11 18:28:07 titan logger: plugin: skipping: /boot/packages/open_vm_tools-9.10.0.2476743-K4.0.4_unRaid-x86_64-5Zeron.tgz already exists
Feb 11 18:28:07 titan logger: plugin: running: anonymous
Feb 11 18:28:07 titan logger: Open-VM-Tools is not available for Kernel 4.1.17 Please update the plugin. 
Feb 11 18:28:07 titan logger: plugin: installed

 

If you updated the plugin, it likely ended up being downloaded to your /boot/packages directory.  Just run a "installpkg open_vm_tools-9.10.0.2476743-K4.1.17_unRaid-x86_64-10Zeron.tgz" in that directory for a temporary fix. 

 

I think someone with better plugin experience will need to take a look at the file to figure out what went wonky.

 

Edit3: I went ahead and just deleted the old .plg (which was old) and redownloaded the updated one.  I think things are looking good now.  Thanks.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now