[support] Spants - NodeRed, MQTT, Dashing, couchDB


427 posts in this topic Last Reply

Recommended Posts

Yes - please use the official docker version and install nodes through the Palette menu option.

I can update my version if needed for some strange reason!

 

Note: If you want to pass through a device from the host to the official docker, you may need to change the user that runs node red to root. For example, to use a usb-serial adaptor, I had to use for the Extra Parameters :

 

--device=/dev/ttyACM0 --user=root

 

Tony

 

Link to post
  • 1 month later...
  • Replies 426
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ya....just go into the Node-Red Docker template and change the repository as I said above and hit apply.......That's all I had to do. Love it

This is where I will be hosting some dockers that I find useful, built on a Phusion or Linuxserver base. Add to your templates if you wish.   https://github.com/spants/unraidtemplates/

Does anyone here know how to update node.js version in the Node-Red Docker Container?   docker exec -it NodeRed-OfficialDocker /bin/bash node -V The command above shows I'm on v

Posted Images

Everything looks good spants, i'd love to get your node-red template up and running but adding https://github.com/spants/unraidtemplates/ to my templates doesnt show your templates up when I go to create a new docker.

 

Any tips? I had node red installed manually but i'd prefer the validity of a docker that can be updated.

I'm running 6.2.4 btw

Isn't it easier to use the app store plugin to install Docker's?

 

Link to post

Everything looks good spants, i'd love to get your node-red template up and running but adding https://github.com/spants/unraidtemplates/ to my templates doesnt show your templates up when I go to create a new docker.

 

Any tips? I had node red installed manually but i'd prefer the validity of a docker that can be updated.

I'm running 6.2.4 btw

Isn't it easier to use the app store plugin to install Docker's?

 

Absolutely - use the app store plugin please!

Link to post

Prevent creation of "mosquitto.conf.example"?

 

I can't figure out why the docker is creating the example file every time.  I've deleted the conf.d and config.d folders and am just using the config file in the root config folder.

 

I put that in there because I kept forgetting the settings :-)  It takes so little space so dont worry about it. It doesn't get used for anything.

Link to post
I put that in there because I kept forgetting the settings :-)  It takes so little space so dont worry about it. It doesn't get used for anything.

 

Gotcha.  Somehow it was ignoring a few of my commented out options in the config and I thought maybe the example was messing with something.  Turned out I just needed to delete them as it was ignoring the '#'.

 

Thanks for the docker!

Link to post
*** Make sure that you change unRaid's default port as this uses port 80

Is there a way to run the pi hole on a different IP address that way I can keep unpaid's UI on port 80?

 

I've tried changing the port to other numbers and get the same error:

[b]Removing container: pihole[/b]
Successfully removed container 'pihole'

[b]Command:
[/b]root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="America/Los_Angeles" -e HOST_OS="unRAID" -e "ServerIP"="192.168.1.26" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -p 53:53/tcp -p 53:53/udp -p [u][color=red]8111[/color][/u]:80/tcp -v "/mnt/user/appdata/pihole/pihole.log":"/var/log/pihole.log":rw -v "/mnt/user/appdata/pihole/blacklist.txt":"/etc/pihole/blacklist.txt":rw -v "/mnt/user/appdata/pihole/whitelist.txt":"/etc/pihole/whitelist.txt":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine
d4cea8212b5f7536bf61ecaa4b2cd218d8ebbdb121a7bd1546f490f21b5b1375
docker: Error response from daemon: failed to create endpoint pihole on network bridge: Error starting userland proxy: listen tcp 0.0.0.0:53: bind: address already in use.

[b]The command failed.[/b]

Unraid's IP is .25 and none of the other dockers are using port 8111.  For 53, I get this:

netstat -tulpn | grep --color :53                                                            
tcp        0      0 192.168.122.1:53        0.0.0.0:*               LISTEN      11799/dnsmasq       
udp        0      0 0.0.0.0:53657           0.0.0.0:*                           1681/rpc.statd      
udp        0      0 192.168.122.1:53        0.0.0.0:*                           11799/dnsmasq       
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           8064/avahi-daemon: 

 

Link to post

*** Make sure that you change unRaid's default port as this uses port 80

Is there a way to run the pi hole on a different IP address that way I can keep unpaid's UI on port 80?

 

I've tried changing the port to other numbers and get the same error:

[b]Removing container: pihole[/b]
Successfully removed container 'pihole'

[b]Command:
[/b]root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="America/Los_Angeles" -e HOST_OS="unRAID" -e "ServerIP"="192.168.1.26" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -p 53:53/tcp -p 53:53/udp -p [u][color=red]8111[/color][/u]:80/tcp -v "/mnt/user/appdata/pihole/pihole.log":"/var/log/pihole.log":rw -v "/mnt/user/appdata/pihole/blacklist.txt":"/etc/pihole/blacklist.txt":rw -v "/mnt/user/appdata/pihole/whitelist.txt":"/etc/pihole/whitelist.txt":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine
d4cea8212b5f7536bf61ecaa4b2cd218d8ebbdb121a7bd1546f490f21b5b1375
docker: Error response from daemon: failed to create endpoint pihole on network bridge: Error starting userland proxy: listen tcp 0.0.0.0:53: bind: address already in use.

[b]The command failed.[/b]

Unraid's IP is .25 and none of the other dockers are using port 8111.  For 53, I get this:

netstat -tulpn | grep --color :53                                                            
tcp        0      0 192.168.122.1:53        0.0.0.0:*               LISTEN      11799/dnsmasq       
udp        0      0 0.0.0.0:53657           0.0.0.0:*                           1681/rpc.statd      
udp        0      0 192.168.122.1:53        0.0.0.0:*                           11799/dnsmasq       
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           8064/avahi-daemon: 

 

The ip address and port 80 have to be on the docker server that responds to the dns requests. If you had two network cards in and by some fiddling I guess that it could work. If you dont want to change the unraid web port (its easy), you could run pihole on a separate Pi

Link to post

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="Asia/Jerusalem" -e HOST_OS="unRAID" -e "ServerIP"="10.0.0.3" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -p 53:53/tcp -p 53:53/udp -p 80:80/tcp -v "/mnt/user/appdata/pihole/pihole.log":"/var/log/pihole.log":rw -v "/mnt/user/appdata/pihole/blacklist.txt":"/etc/pihole/blacklist.txt":rw -v "/mnt/user/appdata/pihole/whitelist.txt":"/etc/pihole/whitelist.txt":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine
5195c3e5fb97c7514d1a3a864c11340a95f9db2bff28af3db11cda73e9fcc802
docker: Error response from daemon: failed to create endpoint pihole on network bridge: Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use.

The command failed.

 

whet is the problem?

Link to post

After I changed the server port from 80 to something else, I get another error

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="Asia/Jerusalem" -e HOST_OS="unRAID" -e "ServerIP"="10.0.0.3" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -p 53:53/tcp -p 53:53/udp -p 80:80/tcp -v "/mnt/user/appdata/pihole/pihole.log":"/var/log/pihole.log":rw -v "/mnt/user/appdata/pihole/blacklist.txt":"/etc/pihole/blacklist.txt":rw -v "/mnt/user/appdata/pihole/whitelist.txt":"/etc/pihole/whitelist.txt":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine
e6beca57440b5333bacb8ed5f01b030c7cc64f1ff4b493797487aeea619c7025
docker: Error response from daemon: Cannot start container e6beca57440b5333bacb8ed5f01b030c7cc64f1ff4b493797487aeea619c7025: [9] System error: not a directory.

The command failed.

Link to post

After I changed the server port from 80 to something else, I get another error

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="Asia/Jerusalem" -e HOST_OS="unRAID" -e "ServerIP"="10.0.0.3" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -p 53:53/tcp -p 53:53/udp -p 80:80/tcp -v "/mnt/user/appdata/pihole/pihole.log":"/var/log/pihole.log":rw -v "/mnt/user/appdata/pihole/blacklist.txt":"/etc/pihole/blacklist.txt":rw -v "/mnt/user/appdata/pihole/whitelist.txt":"/etc/pihole/whitelist.txt":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine
e6beca57440b5333bacb8ed5f01b030c7cc64f1ff4b493797487aeea619c7025
docker: Error response from daemon: Cannot start container e6beca57440b5333bacb8ed5f01b030c7cc64f1ff4b493797487aeea619c7025: [9] System error: not a directory.

The command failed.

Hi - the pihole support is here

https://lime-technology.com/forum/index.php?topic=50453.0

 

This is mine, working:

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="Europe/London" -e HOST_OS="unRAID" -e "ServerIP"="192.168.1.22" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -p 53:53/tcp -p 80:80/tcp -p 53:53/udp -v "/mnt/user/appdata/pihole/pihole.log":"/var/log/pihole.log":rw -v "/mnt/user/appdata/pihole/blacklist.txt":"/etc/pihole/blacklist.txt":rw -v "/mnt/user/appdata/pihole/whitelist.txt":"/etc/pihole/whitelist.txt":rw -v "/etc/localtime":"/etc/localtime":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine

e8948a0fe593ba75d65bf09d9be8ac6b044f89b0c821a65ec3bd5eb8cc79c17d

 

The command finished successfully!

 

 

Did you create the pihole folder and follow the instructions here: https://lime-technology.com/forum/index.php?topic=50453.0

 

Link to post

Hmm. I updated node-red docker to 0.16. Now I crashed after a few minutes minutes with a memory error. Can I easily revert back to 0.15.2 to test is if it was really the new version causing this?

 

Edit: Never mind, I think it's related to a node compatibility issue. I think it's a Samsung-tablet remote node. But I need to investigate more.

Link to post

0.16 seems really stable for me. One problem that I have is that serialport was removed and I use a usb/serial interface for some iot sensors.

If I add the node-red-node-serial port back in to the container, it doesnt work. If I rebuild the dockerfile and add it in at build time - it works fine :(

Link to post

Hmm. I updated node-red docker to 0.16. Now I crashed after a few minutes minutes with a memory error. Can I easily revert back to 0.15.2 to test is if it was really the new version causing this?

 

Edit: Never mind, I think it's related to a node compatibility issue. I think it's a Samsung-tablet remote node. But I need to investigate more.

 

Just to answer your question, you can force a version to be downloaded, rather than just the latest, by adding the version tag to the end of the Respository data as shown below.

 

(Check which versions available at: https://hub.docker.com/r/nodered/node-red-docker/tags/)

lime.png.0929eb3b1043fb8c2388eea489a324ce.png

Link to post
  • 3 weeks later...

Probably want couchdb to be more like this so that config persists....

 

/opt/couchdb/data  <->  /mnt/user/appdata/couchdb/data

/opt/couchdb/etc <->  /mnt/user/appdata/couchdb/config

 

Also, you only need port 5984 if you're not clustering.

 

Thanks! - I will make those changes now

edit: the config directory in the docker is /usr/local/etc/couchdb ....

 

 

Link to post
  • 1 month later...

@Zeron, sure - I will take a look.

 

edit: will have to do a number of changes to get 1.4.11 running. Will 1.4.10 solve any issues that you have? (and what are they?)

Edited by spants
Link to post
  • 4 weeks later...

With MQTT I've been getting intermittent disconnects the past few days with the below error. It's causing most of my home automation to fail since it's not getting my location updated. From Googling I see some references to this being related to version 1.4.8 but that's quite a bit out of my wheelhouse so I can't be sure.

1491447158: Socket error on client topic/myphone, disconnecting.

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.