PlexWatch Docker - failed to access plexWatch database


22 posts in this topic Last Reply

Recommended Posts

Just installed PlexWatch in a new docker from needo/plexwatch. I have tried everything. It is running in host mode. Plex however is still a plugin because it running the latest Plex Pass version and I can't find a docker with that version. I have literally tried EVERYTHING. Even permissions of the database its self.

Screen_Shot_2015-03-02_at_5_29.08_PM.png.88821d0fe3434df6093edb3ed6afc517.png

Link to post

Yes I have. This is the only thing in the log. It is repeated about 3 or 4 times.

 

*** Shutting down runit daemon (PID 11)...
*** Killing all processes...
*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/edge.sh...
Bleeding edge not requested
*** Running /etc/my_init.d/firstrun.sh...
Plex Media Server.log located in /logs directory
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 11
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message

Link to post

eroz, ruablack2, as an FYI, I implemented auto PlexPass version detection into Needo's plex docker a few versions ago.  If you want to always run the latest plexpass version you shouldn't need to specify the VERSION parameter any longer.  When a new version is released all you have to do is stop/start the plex container and it should update to the latest plexpass version.

 

As for plexWatch I ended up running Plex and plexWatch both in 'host' network mode, and then updated the plexWatch docker to use my own version: esvinson/plexwatch:latest  (template url: https://github.com/esvinson/docker-containers/tree/master) which defaults to port 8082 so it doesn't conflict with SABnzbd using port 8080.

 

My PlexWatch volume config:

/logs -  /mnt/user/appdata/plex/Library/Application Support/Plex Media Server/Logs/
/plexWatch - /mnt/user/appdata/plexWatch

 

Might check the permissions/ownership on the plexWatch.db file if it's having trouble accessing the database.  Mine appear to be: -rw-rw-rw- nobody users

 

Running this should list the contents of the path with the database/config in it:

docker exec plexWatch ls -al /plexWatch

 

-Eric/Heuristic

Link to post

eroz, ivez, I've tried that many times.

clowrym, I think I have seen a related problem to mind a couple months ago and that was the solution but I use Plex Home and don't really want to turn it off. I just don't see how Plex Home can effect whether or not it can access it's database.

Is anyone else using Plex Home with a working plexWatch?

Link to post

eroz, ivez, I've tried that many times.

clowrym, I think I have seen a related problem to mind a couple months ago and that was the solution but I use Plex Home and don't really want to turn it off. I just don't see how Plex Home can effect whether or not it can access it's database.

Is anyone else using Plex Home with a working plexWatch?

I'm using plex home.  That way I only share the G, PG, PG-13 movies with my kids.  I have not had an issue with plexWatch, other that when first installing it.

Link to post

Same here I use plex home with plexwatch and it works great. Like the previous poster plex home works great if you have kids. I've tagged all the my child friendly media with a 'kids' tag and then applied a filter to my sons plex account.

 

For reference I use the following dockers:

 

Needo/plex

Needo/plexwatch

 

If you need me to check anything let me know.

Link to post

Did you try these tips?

?Troubleshooting
To read the docker logs:

•From the unRAID docker manager, click on the status/log column
•Or from a shell type "docker logs plexWatch"
Common errors:

•If the log shows "Unable to locate the 'Plex Media Server.log' file":

?Check your paths as described in the "New Installation Instructions" section. Capitalization matters.
•If the log shows: "AH00558: apache2: Could not reliably determine the server's fully qualified domain name..."

?It is safe to ignore this message
•If plexWatchWeb loads, but gives a "Failed to access plexWatch database" error message:

?Login to Plex and go to Settings -> Server -> Connect. Verify that the account you are signed in as has a Plex Pass.
?Start watching a movie, wait a few minutes, then try accessing plexWatchWeb again.

•If plexWatchWeb loads, but gives a "Failed to access Plex Media Server" error message:

?Ensure the Plex docker is running(!) and is in host mode
?Review the "Host mode vs Bridge mode" section. It is likely that the wrong server ip or wrong username/pasword is specified in the config files. The same details need to be provided in both config.pl and config.php.

•Still having problems?

?Review the docker log as described above
?Review the debug.log file located in your plexWatch directory
?If you have edited config.pl or config.php, delete them and restart the docker to start fresh

 

Esp. this one. 

If plexWatchWeb loads, but gives a "Failed to access plexWatch database" error message:

 

?Login to Plex and go to Settings -> Server -> Connect. Verify that the account you are signed in as has a Plex Pass.

?Start watching a movie, wait a few minutes, then try accessing plexWatchWeb again.

Link to post
  • 4 months later...
  • 4 weeks later...

FWIW I was having this problem and was troubleshooting for a while. Then in the end, when I played a movie for a while it turned out that it was working fine. Not sure if I fixed anything at all in my troubleshooting or if it was fine all along. I'd try that first...

Link to post
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.