[REPO] dmaxwell351 repo - Air Video HD, splunk


110 posts in this topic Last Reply

Recommended Posts

  • 4 weeks later...
  • Replies 109
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I was having the same problem, and figured out a solution.   The codec needs to be updated inside the docker.  Here are the steps I took to accomplish this:   1. ssh into your Unra

Thank you for this! I've updated the dockerfile to include the h.265 codec.   Sadly, InMethod hasn't updated the linux version of Air Video HD past 2.2.3.  

I'm going to begin publishing some docker builds I've been doing for my unRAID setup...   Repo Address   https://github.com/dmaxwell351/docker-containers/tree/templates  

Posted Images

Hi again everybody :)

 

I have one question about Air Video HD: is it normal that it takes so long to build previews for a new folder with videos?

 

I have reinstalled the docker after 6.2 upgrade, and it had to rebuild screenshots for just one Modern Family season (.mkv, 720p), and it takes a lot of time. The CPU raises usage to round 30-40% for more than 10 minutes, just to index around 15 files. Status report from unRAID says about 50% of the RAM is free while Air Video is working (RAM on the server is 8GB).

Link to post
  • 1 month later...

I'm having the same issue with updating.

 

Error: layers from manifest don't match image configuration

 

Where is the docker FAQ?

In the docker engine sub board.  It's a sticky

 

Sent from my SM-T560NU using Tapatalk

 

 

Link to post
  • 1 month later...
  • 2 months later...
On 7/16/2016 at 8:16 PM, Lebowski said:

 

 

It says I'm missing the h.265 codec. So none play.

 

 

Sent from my iPhone using Tapatalk

 

I was having the same problem, and figured out a solution.

 

The codec needs to be updated inside the docker.  Here are the steps I took to accomplish this:

 

1. ssh into your Unraid server (I am on Windows and use Putty)

 

2. Run the following command to be able to make changes inside the Air Video HD container:

        docker exec -it <container_name> bash

   (<container_name> should match what you see in the Unraid GUI, my was "AirVideoHD" so my command was "docker exec -it AirVideoHD bash" without the quotes)

 

3. You should now be making changes inside the container - the h.265 codec plugin is not available from the Ubuntu repositories, so you will need to add a repository:

        sudo apt-add-repository ppa:strukturag/libde265

 

4. Update the packages from the newly added repository:

        sudo apt-get update

 

5. Install the h.265 codec plugin for VLC:

       sudo apt-get install vlc-plugin-libde265

 

6. Type "exit" to return to the Unraid command line (No longer making changes to the Air Video HD container)

 

7. Restart AirVideoHD docker container from Unraid GUI (may not be necessary, but I wanted to make sure the changes stuck after the container was restarted)

 

I was successfully able to stream and download videos using the h.265 codec and no longer received the "missing codec" error.  (Air Video Converted the files to download to iOS)

 

I am not sure if this container is still being maintained, as it has been over a year since the last update, but if it is, then hopefully this can be included in the next update.

 

Hope this helps anyone having problems playing h.265 video files!

Link to post
On 3/7/2017 at 10:49 AM, HocEman said:

 

I was having the same problem, and figured out a solution.

 

 

Thank you for this! I've updated the dockerfile to include the h.265 codec.

 

Sadly, InMethod hasn't updated the linux version of Air Video HD past 2.2.3.

 

Link to post
  • 3 weeks later...
On ‎1‎/‎3‎/‎2017 at 0:00 PM, scloutier said:

Greetings,

 

Was trying to get splunk running however I ran into the BTRFS issue.  The latest splunk version does have proper support for it.  Any chance you could update the docker ?

 

ref: http://docs.splunk.com/Documentation/Splunk/6.3.0/Installation/SystemRequirements#Supported_file_systems

 

thanks a lot !

 

Simon

 

+1

Link to post
On 4/3/2017 at 8:05 PM, dmaxwell351 said:

Got splunk updated to 6.5.3! I haven't tested if it fixes the BTRFS issue yet, but hopefully that will do it since they do say it is supported now...

 

Thanks for the update!

I gave the docker a try, but even though the docker is up and running, the WEBUI was not available (connection refused)

 

Looking at the logs, I still saw the dreaded " validating databases (splunkd validatedb) failed with code '1'. If you cannot resolve the issue(s) above after consulting documentation, please file a case online at http://www.splunk.com/page/submit_issue " error message , which is kind of strange, since I thought my data drives were formatted in XFS and not in BTRFS?

 

Anyway, Google recommended adding this :

 

 

Quote

You'll want to append the following configuration option to $SPLUNK_HOME/etc/splunk-launch.conf:

 

 

 

  1. OPTIMISTIC_ABOUT_FILE_LOCKING = 1

 

 

 

 

 

Once I did that, then restarted the splunk service and the webui came up.

is it possible to add this fix to the docker so I don't have to add it everytime the docker restarts?

Thanks

Edited by Elefantito
Link to post
7 hours ago, Elefantito said:

Once I did that, then restarted the splunk service and the webui came up.

is it possible to add this fix to the docker so I don't have to add it everytime the docker restarts?

Thanks

 

That looks like the fix! I just updated the Dockerfile to include it...

Link to post
7 hours ago, scloutier said:

on github I see this in the dockerfile: 

 

RUN echo "OPTIMISTIC_ABOUT_FILE_LOCKING = 1" >> $SPLUNK_HOME/etc/splunk-launch.conf

 

I think $SPLUNK_HOME isn't defined

 

------------

 

Since the $SPLUNK_HOME variable isn't defined (not sure why, but you can check by doing echo $SPLUNK_HOME) ,

RUN echo "OPTIMISTIC_ABOUT_FILE_LOCKING = 1" >> $SPLUNK_HOME/etc/splunk-launch.conf creates a file in the /root/etc directory which is not read by Splunk.

 

We either need to save that string in /opt/splunk/etc/splunk-conf or append a "SPLUNK_HOME=/opt/splunk" to the dockerfile before the echo string.

 

Edited by Elefantito
confirming
Link to post
Just now, dmaxwell351 said:

It's interesting because I have $SPLUNK_HOME defined after a vanilla install of splunk...

 

Either way, it's set in the Dockerfile now, so the command to append the optimistic file locking setting should work!

waiting for docker to finishing building and will give it a try.

Link to post

so the splunk home works.  But looking at the .conf file itself it might be missing a CR between the splunk_os_user and the optimistic flag.

 

# If SPLUNK_OS_USER is set, then Splunk service will only start
# if the 'splunk [re]start [splunkd]' command is invoked by a user who
# is, or can effectively become via setuid(2), $SPLUNK_OS_USER.
# (This setting can be specified as username or as UID.)
#
# SPLUNK_OS_USEROPTIMISTIC_ABOUT_FILE_LOCKING = 1
 

Link to post
7 hours ago, dmaxwell351 said:

It's interesting because I have $SPLUNK_HOME defined after a vanilla install of splunk...

 

Either way, it's set in the Dockerfile now, so the command to append the optimistic file locking setting should work!

 

I was thinking the same thing, the variable definition is part of the instalation so I'm not sure why it isnt showing up.

If you still have that vanilla install, can you check if $SPLUNK_DB is defined? 

Link to post

Hi everybody!

 

I have a question about Airvideo HD: Is it possible to set a static PIN for it? I ask because each time the docker is restarted or updated, the PIN is modified so I have to reconfigure all the devices I use to connect to the docker, and all the thumbnails also are missed and need to be created again as it's considered a brand new server from the app side, slowing down things. Do you guys have any other alternative to avoid this problem? Maybe just manually adding the server? I mostly use the app at home with all devices inside the same local network.

Link to post
  • 4 weeks later...

I would also like to know the above that almarma asked.  But also, looking at how this works it seems that the server is trying to output itself so that it's available outside my home network through my IP address.

 

I find this idea to be kind of startlingly scary and want to disable the external broadcasting.  Is there any way to do this? Am I being paranoid for no reason?

 

Also I'm still struggling to get my shares to appear, I can connect but the shares won't appear.  I believe I have the config file setup correctly but everyone's saying to have them the same in the Docker part of the GUI and I can't figure out this bit.  Should I be renaming "Host Path 2" and "Host Path 3", if someone like Kimovitz could share their docker screen that would be very helpful.

Edit - I set external access to false in the config file so that should have fixed that silly worry - should have looked at that file more carefully.

Edit2 - Thought it would make things easier if I showed how my systems were setup.  What am I doing wrong here? I feel like everything is set correctly now.
 

config.png

docker.png

Thought it might have been the ~ in my config file but deleted that and nothing changed.  Doh! Please help.

Edited by ColonialRaptor
Link to post
  • 2 weeks later...

Having a weird issue with Splunk.  I have a bunch of devices & servers on my network sending log data to UDP:514 on my Splunk container... events are showing up great in the dashboard and I can drill down to show hosts/sources/sourcetypes going into the thousands, so definitely getting data.  But when I click on any to search for the actual events, no matter the filter choice, I always get "No Results Found".  The data is there but source doesn't work.

Tried from the default admin user and a new user just in case it was a roles or permissions issue, but no dice.  

 

Any ideas?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.