Jump to content
Bungy

[support] Bungy's docker repository

425 posts in this topic Last Reply

Recommended Posts

I am very new to creating templates and dockers, but I am learning quickly. I've created a repository with my current work.

 

Repository link:

https://github.com/jshridha/templates

 

Templates:

  • Gitlab
    • Gitlab is a git code repository server. It can be hosted on your own private server so that you can collaborate with others and improve your projects and maintaining the flow of data.
    • Please read sameersbn's documentation for more information (https://github.com/sameersbn/docker-gitlab/blob/master/README.md). He is the docker maintainer and I am providing a template to make the Docker easily added into unraid.
    • Usage:
      • You need a redis and postgresql server running. You also need to fill out the environmental variables to point to these servers. I recommend creating a redis and postgresql docker provided by sameersbn using my templates.

      • Currently the docker links to the redis and postgresql servers to exchange connection information. This currently causes an issue with the unraid docker webgui. The webgui no longer displays the popup with controls after clicking on the docker icon.

       

    [*]Redis

    [*]Postgresql

    [*]Nzbgetvpn

    • This is a mashup of binhex's nzbget and delugevpn containers in order to use nzbget through an openvpn tunnel.

 

I will be editing this post with additional descriptions and more detailed usage information. Feel free to ask for support in this thread.

  • Upvote 1

Share this post


Link to post

Great work mate, downloaded and running good so far, just trying it out.  NZBGet & Deluge both on VPN, we're getting spoiled nowadays!

Share this post


Link to post

Bungy thank you! I am going to try out your NZBGet. Can you update in the container?

 

To be honest, I'm not completely sure. I based this docker primarily on binhex's work with delugevpn and nzbget. I would assume it can be updated to the newest version of nzbget. Currently it is on 14.2, which is the newest version. I'll plan to release I newer docker image with the newer version when one comes out, so you can stay updated through the webgui or use the newest container image.

Share this post


Link to post

I'm having some trouble with the openHAB docker from your repo. I can get it to install and it starts, and I even managed to get habmin installed, but it seems like none of the bindings are being downloaded/loaded. Even the demo sitemap displays no information (e.g. temperature being displayed as "-"). For what it's worth I'm running v6beta14b

Share this post


Link to post

I'm having some trouble with the openHAB docker from your repo. I can get it to install and it starts, and I even managed to get habmin installed, but it seems like none of the bindings are being downloaded/loaded. Even the demo sitemap displays no information (e.g. temperature being displayed as "-"). For what it's worth I'm running v6beta14b

 

Did you set up the binding configuration in the openhab.cfg file? For weather, this includes getting an api key from weather underground and setting your latitude/longitude. After I did that, I was able to get the weather in the demo to display correctly.

 

In order to check which bindings are installed you can do this:

 

docker exec -it openhab bash
ls -l /opt/openhab/addons

 

That will list all the bindings installed. You can also go to /opt/openhab/logs and look inside openhab.log to find some debugging information.

Share this post


Link to post

I tried adding a wunderground api  and restarting the docker with no luck. The command you suggested returned "Total 0"

Share this post


Link to post

It looks like the problem is your addons.cfg file if nothing shows up in that directory.

 

Try adding this to addons.cfg:

 

org.openhab.action.mail
org.openhab.action.squeezebox
org.openhab.action.xmpp
org.openhab.binding.exec
org.openhab.binding.http
org.openhab.binding.knx
org.openhab.binding.mqtt
org.openhab.binding.networkhealth
org.openhab.binding.serial
org.openhab.binding.squeezebox
org.openhab.io.squeezeserver
org.openhab.persistence.cosm
org.openhab.persistence.db4o
org.openhab.persistence.gcal
org.openhab.persistence.rrd4j
org.openhab.binding.ntp
org.openhab.binding.weather

Share this post


Link to post

I added those and I still get "Total 0", docker has been stopped and started and server rebooted (apparently trying to stop a docker while still connected to it via SSH locks up emhttp)

Share this post


Link to post

Hmm. It seems that the script that's supposed to read your addons.cfg file is not working correctly.

 

Can you check to see that your settings match the screenshot. Ignore the directory mapping and the docker link to mochad.

 

Your addons.cfg file should go into /mnt/cache/appdata/openhab/config. Mine currently has permissions 666, but any permissions should work fine since the docker has root access.

 

SOqhouZ.png

Share this post


Link to post

Remapped everything to a fresh directory (openhab2), stopped docker, dropped in addons.cfg. This is what I get in the log:

 

/usr/bin/docker logs --tail=350 -f openhab 2>&1

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

...

not found.

--------------------------------------------------------

NO openhab.cfg CONFIGURATION FOUND

 

= using demo files =

 

Consider running the Docker with a openhab configuration

 

--------------------------------------------------------

ln: failed to create symbolic link '/etc/openhab/openhab.cfg': File exists

2015-05-12 11:09:59,443 CRIT Supervisor running as root (no user in config file)

2015-05-12 11:09:59,443 WARN Included extra file "/etc/supervisor/conf.d/openhab.conf" during parsing

2015-05-12 11:09:59,465 INFO RPC interface 'supervisor' initialized

2015-05-12 11:09:59,465 CRIT Server 'inet_http_server' running without any HTTP authentication checking

2015-05-12 11:09:59,466 INFO RPC interface 'supervisor' initialized

2015-05-12 11:09:59,466 CRIT Server 'unix_http_server' running without any HTTP authentication checking

2015-05-12 11:09:59,466 INFO supervisord started with pid 1

2015-05-12 11:10:00,469 INFO spawned: 'openhab' with pid 13

2015-05-12 11:10:01,471 INFO success: openhab entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)

 

Aside from my docker residing at /mnt/cache/apps/dockerapps/openhab2 the mapping is the same as yours

Share this post


Link to post

All those "not founds" are it not being able to find the addons_available directory. Which version of my docker container are you using? The latest one?

 

I just tried with a fresh directory in which all i did was create the config directory and put the addons.cfg file in there and it worked without problems.

 

Try a chmod -Rv 777 on your openhab directory and then try this docker run command:

 

docker run -d --name=openhab --net=bridge -p 8080:8080 \
  -v /mnt/cache/appdata/openhab2/config:/etc/openhab \
  -v /etc/localtime:/etc/localtime:ro \
  jshridha/openhab:latest

 

If you're linking the addons-available directory to a directory on your unraid server, then you may be causing problems since that directory isn't supposed to be exposed to the host.

 

If I run the docker without linking any directories, I still get 5 of the bindings to show up, so my guess is you're having some issue with the directory mapping. Can you post a screenshot of your settings?

Share this post


Link to post

chmod didn't seem to have any effect. I wouldn't doubt that this is user error on my part somehow, but I've tried so many combinations of mapping and remapping over and over, I just can't figure out what is getting me messed up here

Screenshot_2015-05-12-12-07-54.png.1096928c52b42b81636ca90a2bd69d4d.png

Share this post


Link to post

I can't see the host side of the volume mapping for habmin. Can you make a post with that as plain text?

Share this post


Link to post

/opt/openhab/webapps/habmin  <-> /mnt/cache/apps/dockerapps/openhab2/webapps/habmin

/opt/openhab/addons-available/habmin <-> /mnt/cache/apps/dockerapps/openhab2/addons-available/habmin

Share this post


Link to post

I was finally able to reproduce your problem. I'm guessing you created the addons.cfg file in windows. Windows uses \r\n as the end of line identifier and unix uses \n. Convert your addons.cfg to unix style eol. You can do this in windows through the command line with (http://sourceforge.net/projects/dos2unix/) or if you're using notepad++ go to Edit->EOL Conversion->UNIX/OSX Format. That should fix your problems!

Share this post


Link to post

I had actually created the addons.cfg on my android phone, but I guess it saved in windows style EOL. Adjusting it did indeed get openhab running! Thank you so very much for your effort. I don't know if I'd ever have gotten around to checking that myself.

 

The only issue I'm having now is HABmin just shows openHAB as offline.

Share this post


Link to post

Interesting, I wouldn't have guessed that android defaulted to windows syte EOL.

 

I was having some trouble with habmin before too. I can't remember what I did to fix it, but I was having a similar issue. I turned out the binding wasn't actually activating. Have you checked to see that the binding shows up in the addons directory?

Share this post


Link to post

If I check the log, I see "Processing habmin/org.openhab.binding.zwave...

link created."  But I don't see a similar entry for habmin/org.openhab.io.habmin which is in my addons.cfg

Share this post


Link to post

Is the habmin binding the last one in your addons.cfg file? If so try to put an enter after the last line so that there is a blank line at the very end of the file.

Share this post


Link to post

That did the trick! Thanks again. As an aside, wouldn't it be nice if openhab could detect the EOL style and automatically convert if necessary?

Share this post


Link to post

Yeah that would be awesome. I'm not the original creator of the docker, but if I get a few minutes I'll try to push an update that parses the addons.cfg better.

Share this post


Link to post

I am going to start to play with the nzbgetvpn.  Is there a way to tell if it is actually connecting to PIA and using the service?

 

John

Share this post


Link to post

I am going to start to play with the nzbgetvpn.  Is there a way to tell if it is actually connecting to PIA and using the service?

 

John

Yeah, the easy way is to open a bash terminal into the docker and then check the ifconfig settings. If you see a connection to tun0, then you know you're connected to the VPN.

 

Another way is to run this command from within the docker and check to see if the ip address is the same or different as your ISP provided IP address.

 

curl ipecho.net/plain ; echo

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now