[support] Bungy's docker repository


Recommended Posts

  • 2 weeks later...
  • 3 weeks later...

WARNING TO ALL USING PIA

 

THE DEFAULT FOR THE CONTAINER IS NO LONGER CORRECT, IT IS "NL.PRIVATEINTERNETACCESS.COM"

 

YOU NEED TO CHANGE NL to WWW

 

Took me an hour and a half to troubleshoot and figure out by luck.  Hope this helps someone, and maybe we can get the template default changed as well ;-)

Link to comment
On 1/31/2016 at 11:56 PM, Skrot74 said:

I have tried uninstalling/reinstalling, different password variables, now trying a different network variable (host vs bridge).

 

Still having access denied errors. Could my volume mappings be an issue by any chance? I have all shares set to public, not sure what on earth I could be doing wrong.

I have the same problem, mysql start's up, and cannot be accessed. with its original pwd (mysql_password), or my given password. root cannot connect from local or other machine on the network. Access denied.
Even with the workbench installen on the server.

Its like after setup its lock it self down.

 

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
[email protected]:/# 

Edited by Starfire
Link to comment
  • 4 weeks later...
On 3/19/2022 at 12:04 PM, bobekdj said:

WARNING TO ALL USING PIA

 

THE DEFAULT FOR THE CONTAINER IS NO LONGER CORRECT, IT IS "NL.PRIVATEINTERNETACCESS.COM"

 

YOU NEED TO CHANGE NL to WWW

 

Took me an hour and a half to troubleshoot and figure out by luck.  Hope this helps someone, and maybe we can get the template default changed as well ;-)

 

How do you change this?

Link to comment
  • 3 weeks later...
On 5/9/2022 at 6:01 PM, blaine07 said:

I searched this thread first and no dice. In MySQL container trying to find a way to suppress "mbind: Operation not permitted."

 

It appears it's possible to suppress the message?  https://docs.docker.com/engine/security/seccomp/#run-without-the-default-seccomp-profile

 

Anyone have any insight/help?

Why yes!

 

I was just trying to fix this, and I think I found the answer.  The container is trying to use NUMA for resource allocation with the host, but is being gated by the default security profile.

 

To fix:  Edit the container, enable advanced view, and add:

 

--cap-add=sys_nice

--cap-add=sys_nice

 

to Extra Parameters.  Apply and profit.

 

The seccomp workaround is messy, it disables all the normal security for the container.  The call to mbind is now already gated by CAP_SYS_NICE, but if you want to use it you'll have to tune the security profile for the container.

 

Hope it helps!

 

-P

  • Like 1
Link to comment
Why yes!
 
I was just trying to fix this, and I think I found the answer.  The container is trying to use NUMA for resource allocation with the host, but is being gated by the default security profile.
 
To fix:  Edit the container, enable advanced view, and add:
 
--cap-add=sys_nice
--cap-add=sys_nice

 
to Extra Parameters.  Apply and profit.
 
The seccomp workaround is messy, it disables all the normal security for the container.  The call to mbind is now already gated by CAP_SYS_NICE, but if you want to use it you'll have to tune the security profile for the container.
 
Hope it helps!
 
-P


Will try this in a bit. I don’t think error actually hurts anything… other than me because I know it’s there LOL

Thank you!
Link to comment
Why yes!
 
I was just trying to fix this, and I think I found the answer.  The container is trying to use NUMA for resource allocation with the host, but is being gated by the default security profile.
 
To fix:  Edit the container, enable advanced view, and add:
 
--cap-add=sys_nice
--cap-add=sys_nice

 
to Extra Parameters.  Apply and profit.
 
The seccomp workaround is messy, it disables all the normal security for the container.  The call to mbind is now already gated by CAP_SYS_NICE, but if you want to use it you'll have to tune the security profile for the container.
 
Hope it helps!
 
-P


Worked. Thank you mate!
Link to comment
  • 2 months later...

Hi guys, my mysql docker is no longer starting since the most recent update. Log file attached. Something to do with "Upgrade is not supported after a crash or shutdown with innodb_fast_shutdown = 2. This redo log was created with MySQL 8.0.29, and it appears logically non empty. Please follow the instructions at http://dev.mysql.com/doc/refman/8.0/en/upgrading.html " I'm guessing.

 

The link given in the error seems irrelevant to the unraid docker.

mysql.log

Link to comment
On 8/15/2022 at 9:53 AM, dustyken said:

Having same issue as @SockDust.  Anyone know how to proceed?

 

I was able to solve this by starting another container with the version of mysql in the log file, then connecting to the container and shut down sql safely with the following command

 

mysqladmin shutdown -p

 

Then restart your other container with the latest tag or whatever

Edited by Sinopsis
  • Upvote 1
Link to comment
  • 5 weeks later...

I have had two big problems with mysql. I tried to move the database for my store and some of the files didn't transfer and I lost my whole store I worked months on. Then I build another store got halfway through adding products and I checked and sure enough there are no folders in the mysql folder. Where is the database located? There is nothing in Var/lib/mysql, after simply restarting the docker I could no longer load my new store and all 3 days is lost again. I don't know why it won't just install properly. Its not even installing, there should be files shouldn't there in the /mnt/user/appdata/mysql but nothing was ever there. I want to just give up and rent a server. Something with one click wordpress installation and be done with it. I am really frustrated with having to repeat my work installing this store so many times. Why did it work in the first place with no proper mysql?

 

Update, so I tested postgresql14 and also maria database and they both created  installation fliles, so I am sure that there is a problem with mysql repository, its empty and probably depreciated. They should remove it from the app store on unraid before anyone else loses precious time with it. I was able to reinstall my wordpress docker connecting to mariaDB and it sppears to have created the necessary files. With no files there is nothing to back up, and if u reboot the container all is lost. Serves me right for not checking it, I just assumed it installed properly but its been causing grief for me even with the last store. Please Remove it from the app store.

Edited by agkserver1
Link to comment
  • 1 month later...
  • 1 month later...

Hi, I'm hoping someone can help.

 

I have just restored my appdata folder using CA APPDATA BACKUP / RESTORE.

I have reinstalled my Docker containers via CA.

MySQL will not start.

Below is the error log.

 

2022-12-15T10:12:07.785325Z 0 [Warning] [MY-011068] [Server] The syntax '--skip-host-cache' is deprecated and will be removed in a future release. Please use SET GLOBAL host_cache_size=0 instead.
2022-12-15T10:12:07.788310Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.31) starting as process 1
2022-12-15T10:12:07.805531Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2022-12-15T10:12:08.727248Z 1 [ERROR] [MY-013882] [InnoDB] Missing redo log file ./#innodb_redo/#ib_redo1251 (with start_lsn = 13078623744).
2022-12-15T10:12:08.727313Z 1 [ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
2022-12-15T10:12:09.027791Z 1 [ERROR] [MY-010334] [Server] Failed to initialize DD Storage Engine
2022-12-15T10:12:09.028089Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2022-12-15T10:12:09.028127Z 0 [ERROR] [MY-010119] [Server] Aborting
2022-12-15T10:12:09.029174Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.31)  MySQL Community Server - GPL.
2022-12-15 21:12:06+11:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 8.0.31-1.el8 started.
2022-12-15 21:12:07+11:00 [Note] [Entrypoint]: Switching to dedicated user 'mysql'
2022-12-15 21:12:07+11:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 8.0.31-1.el8 started.
'/var/lib/mysql/mysql.sock' -> '/var/run/mysqld/mysqld.sock'

 

So far I have tried to:

- re-restore the backup.

- copy the folder using MC (Midnight Commander)

- change permissions

 

I can get the container to run if edit the template and change the AppData location ( eg. /appdataa/mysql2)

It creates a whole new folder structure and starts without any problem.

Obviously this isn't a solution since my databases are part of the backup.

(Unless I can import these back into the fresh install)

 

I would really appreciate any help that you can offer.

 

TIA.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.