[support] gfjardim's Docker Repository


343 posts in this topic Last Reply

Recommended Posts

Hello,

 

Is anyone using the CUPS plugin from gfjardim's Docker Repository?  The HP printer I am attempting to use is a LaserJet professional M1212nf.  Cups is telling me that I need a proprietary plugin.  I am assuming that this is HPLIP based upon my research.  My question though is, is this installed by default in the docker image?  and if not how do I go about installing it?

 

The current issue I am running into that is causing this line of thinking is that when I am attempting to print a test page from cups I get the following error message "Failed to connect to system bus".

 

Thanks

Link to post
  • Replies 342
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Updated DropBox and ownCloud, both with invaluable contribution of HurricaneHernandez!    

For those having issues getting Cloud Print to work in the CUPS docker... Here's how I got it all going: Add your printer in the WebUI ssh into your unRAID box run the following co

so after finding, sharing etc the USB printer (in CUPS), i can no longer find it on my windows 7 computer connected to the same router as the unraid NAS!   this is getting frustrating as it was w

Posted Images

Question on Dropbox behavior. When I make changes on my Dropbox folder from my phone or home computer they propagate fine to my unraid server Dropbox folder via the docker. However, when I make changes on my unraid Dropbox folder they don't appear to go out to my other devices. Does this docker only sync one way?

 

I have found that it just takes longer (sometimes significantly), but does eventually sync both ways. Have you tried just using very small text files to test?

 

The delay for up-sync means that I wouldn't do any siginificant changes on UNRAID - don't know if this is the docker, or dropbox client related.

Link to post

Has there been any success on getting this to work with CrashPlan PRO?

I noticed that The the Docker App was for regular CrashPlan.

Can uninstall regular CrashPlan and install PRO in the Docker App?

 

Cheers,

-A.S.

Link to post

Hey guys,

I don't get it. How to I install the cups docker? Actually I am using synology, but should work anyway. Can somebody tell me the docker run command? Or the standard user/password? I did manage to start it, but don't have any username and/or password.

 

Thanks,

Jaithn

Link to post

(SOLVED) Transmission docker and temp files. I get "Docker high image disk utilization" error.

 

UPDATE: solved here. My mistake :(: http://lime-technology.com/forum/index.php?topic=39227.msg415107#msg415107

 

Hi! I'm using Transmission docker, and each time I use it, unRAID sends me warnings about "Docker high image disk utilization", and when download is finished, I regain free space again, so I guess the temp files while downloading are stored inside the docker img file. What can I do to have them out of the docker? Is it an expected behavior? Today I can't even download, it seems it's stuck with the files inside the img and they can't be bring out to the Downloads folder :(

 

Thanks in advance!

Link to post

Transmission docker and temp files. I get "Docker high image disk utilization" error.

 

Hi! I'm using Transmission docker, and each time I use it, unRAID sends me warnings about "Docker high image disk utilization", and when download is finished, I regain free space again, so I guess the temp files while downloading are stored inside the docker img file. What can I do to have them out of the docker? Is it an expected behavior? Today I can't even download, it seems it's stuck with the files inside the img and they can't be bring out to the Downloads folder :(

 

Thanks in advance!

I don't use transmission, but there's probably a folder setting within it that specifies where the temporary download folder is stored.  Change it to be a mapped new mapped volume
Link to post

Transmission docker and temp files. I get "Docker high image disk utilization" error.

 

Hi! I'm using Transmission docker, and each time I use it, unRAID sends me warnings about "Docker high image disk utilization", and when download is finished, I regain free space again, so I guess the temp files while downloading are stored inside the docker img file. What can I do to have them out of the docker? Is it an expected behavior? Today I can't even download, it seems it's stuck with the files inside the img and they can't be bring out to the Downloads folder :(

 

Thanks in advance!

I don't use transmission, but there's probably a folder setting within it that specifies where the temporary download folder is stored.  Change it to be a mapped new mapped volume

 

Thank you Squid! I found the issue! It was a mistake with upper and lower case (the mapped folder was all upper case, and the shared folder was only the first). So I think that folder was created inside the img, or waiting in RAM, or something weird. I corrected it, and now the usage is back to 50% and the files are correctly being downloaded ;).

 

Thanks for your tips!

Link to post

Hi all,

is this the right place to ask for support on the LogitechMediaServer docker container?

I have it installed and running great on 2 separate Unraid 6.1.2 servers and they work great for local files, but on both servers I can't get the Spotify plugin to play ball. I'm using Triode's 3rd party spotify plugin, which has a helpful connection tester in the settings and I have it installed fine on both boxes, but neither will connect to spotify.

 

Both say the helper service is running, like so:

kTbiqXi.jpg

 

but when you test the connection, it switches to look like this

13TPbBu.jpg

 

I noted that the helper service mentions an additional port (as default it's 9005) so I went into the container settings and opened that port too (tcp and udp just to be sure)

RMCAIXh.jpg

But still no joy, so I changed it in the plugin settings and the container settings to be 9001 instead, just incase something else was using 9005, but still not connecting. 

 

Has anyone got this working or can anyone suggest something else to try?

Any suggestions gratefully received.

thanks,

James

 

 

Link to post

Hi, I just migrated to unRAID and am failing miserably to get my pyload fork running in docker.

 

I tried to fork and edit your pyload image but have no idea how to do the docker registry part.

 

Could you please tell me how to get my fork (https://github.com/rix1337/pyload) inside a docker file?

 

I have added path prefix support and a decent webinterface, so this would be lovely

Link to post

I wonder why suddenly my BTSync docker started to fill up my docker image file?

Today I started to get email notifications in tight intervals, warning that my docker image file was 70% full, 71% full, etc, up to 82% full in only 50 minutes or so.

 

The log got up to 25GB in size (my docker image file is 40GB), before I found it:

 

root@Tower:/var/lib/docker/containers/08a9c769f015b85dc4fc158e19c40818f2b1e8805fa4a21775feffa7a12e58d6# du -sh * | sort -h
4.0K    config.json
4.0K    hostconfig.json
4.0K    hostname
4.0K    hosts
4.0K    resolv.conf
4.0K    resolv.conf.hash
25G     08a9c769f015b85dc4fc158e19c40818f2b1e8805fa4a21775feffa7a12e58d6-json.log

 

I did an 'echo > 08a9c769f015b85dc4fc158e19c40818f2b1e8805fa4a21775feffa7a12e58d6-json.log' on it to empty the file, but I wonder why it did happen in the first place? The BTSync docker container had been runnig fine for a month without any problems.

 

Is it necessary to create a cron  job to truncate the log file, in case this happens again?

Link to post

I see this thread is linked as the official Crashplan GUI docker support thread so I'm reposting the issue here.

 

Several weeks ago several of us started getting the message "CrashPlan has been disconnected from the backup engine."  Someone figured out that Crashplan pushed out an update of the backup engine to 4.4.1.  The docker container for the backup engine did upgrade successfully but the push did not also upgrade the Crashplan GUI docker which is still at 4.3.0.  So because they are different versions, the GUI doesn't connect to the backup engine. 

 

There is a thread specific to this problem but no real resolution posted.  http://lime-technology.com/forum/index.php?topic=43271.msg414802#msg414802

 

Can someone post info on how to upgrade the Crashplan GUI container to 4.4.1?

 

thanks

Everend

Link to post

Hi, I am trying to set up printing from a Dell B1160w laser printer, which I understand is pretty much the same as a Samsung ML-2165.

I was able to detect the Dell B1160w and select the Samsung ML2160 series driver, and it seemed to have been added, but when I tried to print a test page, there was no response from the printer (although CUPS showed it as a completed job). After some fiddling, it asked me for a user/pass for the printer, which confused me at first. I uninstalled and reinstalled CUPS, then realized that I should be using my gmail login/pass to access the printer.

However now when I try to access the WebUI, I get a

"This webpage is not available

ERR_CONNECTION_REFUSED"

 

Uninstalling and reinstalling CUPS does not help.

 

Did I do something to break it? Anyone have any idea how I might get this printer working?

 

*Edit  I am also confused by the CrashPlan docker. I install it, can log in via the web UI, but I can't see any way to set folders on my unRaid array to be backed up.

 

Is there a faq someplace that explains all this stuff that I have somehow failed to find in my searches? I have read the Docker Guide and the unRAID6 manual, am still confused.

Link to post

Hi all,

is this the right place to ask for support on the LogitechMediaServer docker container?

I have it installed and running great on 2 separate Unraid 6.1.2 servers and they work great for local files, but on both servers I can't get the Spotify plugin to play ball. I'm using Triode's 3rd party spotify plugin, which has a helpful connection tester in the settings and I have it installed fine on both boxes, but neither will connect to spotify.

 

 

Not that it helps you, but im having the same problem. Please if you find an solution report back here or a pm.

Link to post

Thanks, welcome back!

 

I've been looking into how to upgrade the GUI container (Crashplan-Desktop).  I think I figured parts of this out, http://lime-technology.com/forum/index.php?topic=43271.0

 

The part I'm currently stuck on is how to modify the Crashplan install script to only install the GUI or if we use the standard install script, how to disable the new backup engine that's installed within the Crashplan-Desktop container. 

 

Once I figured that out, I still needed to figure out how the path's crashplan asks for in their install script relates to the docker container configuration.

 

thanks

Link to post
  • 2 weeks later...

Question on Dropbox behavior. When I make changes on my Dropbox folder from my phone or home computer they propagate fine to my unraid server Dropbox folder via the docker. However, when I make changes on my unraid Dropbox folder they don't appear to go out to my other devices. Does this docker only sync one way?

 

I have found that it just takes longer (sometimes significantly), but does eventually sync both ways. Have you tried just using very small text files to test?

 

The delay for up-sync means that I wouldn't do any siginificant changes on UNRAID - don't know if this is the docker, or dropbox client related.

Mine is doing this too. I have two machines (ignoring others but they should not make a difference), my Windows 7 laptop and my unRAID (and the Dropbox cloud I guess).

 

  • Anything I put on the Windows 7 machine syncs fine up to Dropbox and back down to the NAS. No problem there.
  • Anything I put on the unRAID machine, only syncs if it's at the top level or one down i.e. Dropbox/* or Dropbox/somefolder/* are OK but Dropbox/somefolder/anotherfolder/* does not sync.
  • If Dropbox restarts, the deeper files *might* sync from unRAID (it takes a long time to restart). I seem to get a lot of conflicts possibly from this running portable apps from my Dropbox

 

I have about 80000 files synced for about 25GB.  The docker container reports /proc/sys/fs/inotify/max_user_watches as 524288 which should be plenty.

 

I had similar issues back on unRAID v5 with a plugin. Does everyone else have Dropbox syncing up from unRAID within a few folders?

Link to post

Hi all,

is this the right place to ask for support on the LogitechMediaServer docker container?

I have it installed and running great on 2 separate Unraid 6.1.2 servers and they work great for local files, but on both servers I can't get the Spotify plugin to play ball. I'm using Triode's 3rd party spotify plugin, which has a helpful connection tester in the settings and I have it installed fine on both boxes, but neither will connect to spotify.

 

Both say the helper service is running, like so:

kTbiqXi.jpg

 

but when you test the connection, it switches to look like this

13TPbBu.jpg

 

I noted that the helper service mentions an additional port (as default it's 9005) so I went into the container settings and opened that port too (tcp and udp just to be sure)

RMCAIXh.jpg

But still no joy, so I changed it in the plugin settings and the container settings to be 9001 instead, just incase something else was using 9005, but still not connecting. 

 

Has anyone got this working or can anyone suggest something else to try?

Any suggestions gratefully received.

thanks,

James

 

Anyone any ideas on this?

Or should I be directing my questions at the guys on the slimdevices forums?

thanks,

James

Link to post

Hi James and any others that are having trouble with the Triode Spotify Plugin within the docker container,

 

I have been battling this issue for about a month now and finally spent the day trying to get to the root.

If you change the network mode of the docker container to 'host' you will notice that the spotify plugin works great.  This confirmed that it was definitely a networking issue.  I realized that the whole plugin test was actually streaming from the remote player, it dawned on me that the player needs to stream from the LMS, duh.  You can see from the Information tab of LMS that the internal IP is NOT the same as the unraid host.  So, with docker bridge mode, it is NAT'ing into the container, and the ports you indicated as forwarding are indeed required, however, the IP that the spotify plugin is "announcing" to the client player is the internal IP which it cannot resolve.

 

So that was the long answer.

 

There is currently no way to configure the 'external IP' of the docker container to the player.  The solution was to jump into the code and hard code the external IP.  I found an example of this issue at http://forums.slimdevices.com/showthread.php?79706-Announce-Spotify-Premium-Plugin-%28Beta%29/page140

 

There were two files that I modified.

/mnt/user/appdata/LogitechMediaServer/cache/InstalledPlugins/Plugins/Spotify/Spotifyd.pm

/mnt/user/appdata/LogitechMediaServer/cache/InstalledPlugins/Plugins/Spotify/ProtocolHandler.pm

 

I changed the following lines:

from:

my $host = Slim::Utils::Network::serverAddr();

to:

my $host = "x.x.x.x";

 

where x.x.x.x is my unraid server ip routable from the player.

 

Hope this helps!

Jeff

 

Edit: I forgot to mention that the default port for the plugin is 9005.  Within the docker configuration, I forwarded both TCP and UDP on port 9005.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.