(Support) Aptalca's docker templates


Recommended Posts

No I'm using port 2083. I have managed to get the old version of zoneminder running the other docker.

 

What is the difference between that one and 1.29?

 

I think it has something to do with the apache server:

 


The Apache error log may have more information.

*
* The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
Starting ZoneMinder: success
 

Edited by iTzturrtlex
Link to comment

Hi,

I use the docker container JDownloader2 he uses when unpacking the entire ram so my cache from the cache_dir plugin is broken.
I have read that with -m 1024 the container can limit. Does anyone have a tip as I must then install.
I have added it as a variable but does not work.

 

 

Link to comment
58 minutes ago, Eisi2005 said:

Hi,


I use the docker container JDownloader2 he uses when unpacking the entire ram so my cache from the cache_dir plugin is broken.
I have read that with -m 1024 the container can limit. Does anyone have a tip as I must then install.
I have added it as a variable but does not work.

 

 

Don't add it as a variable.  As it as an extra parameter (edit container, then hit advanced in top right)  

 

Link to comment

I just set up the RDP-Calibre docker, and was able to get a preexisting library mapped into it. When I open the WebUI, I see all my books and it's great. I'm not exactly sure how to make the library available outside the docker, though. I enabled the web server under preferences in Calibre and set the server port to 13579, added a username/password, and I've mapped docker port 8081 to 13579. When I go to saidin:13579, I get prompted for a username/password, and once I enter it, I end up at the normal web interface where you can view the library and download books. However, when I click on either "Newest" or "All Books", I get the error below. If I click on "Random Book" I get a 404 page saying this library has no books. How do I make my library available outside the docker?

 

Error: No books found

printStackTrace.implementation.prototype.createException@http://saidin:13579/static/stacktrace.js:81:13

printStackTrace.implementation.prototype.run@http://saidin:13579/static/stacktrace.js:66:20

printStackTrace@http://saidin:13579/static/stacktrace.js:57:60

render_error@http://saidin:13579/static/browse/browse.js:134:18

booklist@http://saidin:13579/static/browse/browse.js:271:29

@http://saidin:13579/browse/category/allbooks:34:17

.ready@http://saidin:13579/static/jquery.js:392:6

DOMContentLoaded@http://saidin:13579/static/jquery.js:745:3

 

Link to comment
I just set up the RDP-Calibre docker, and was able to get a preexisting library mapped into it. When I open the WebUI, I see all my books and it's great. I'm not exactly sure how to make the library available outside the docker, though. I enabled the web server under preferences in Calibre and set the server port to 13579, added a username/password, and I've mapped docker port 8081 to 13579. When I go to saidin:13579, I get prompted for a username/password, and once I enter it, I end up at the normal web interface where you can view the library and download books. However, when I click on either "Newest" or "All Books", I get the error below. If I click on "Random Book" I get a 404 page saying this library has no books. How do I make my library available outside the docker?
 
Error: No books foundprintStackTrace.implementation.prototype.createException@http://saidin:13579/static/stacktrace.js:81:13printStackTrace.implementation.prototype.run@http://saidin:13579/static/stacktrace.js:66:20printStackTrace@http://saidin:13579/static/stacktrace.js:57:60render_error@http://saidin:13579/static/browse/browse.js:134:18booklist@http://saidin:13579/static/browse/browse.js:271:29@http://saidin:13579/browse/category/allbooks:34:17.ready@http://saidin:13579/static/jquery.js:392:6DOMContentLoaded@http://saidin:13579/static/jquery.js:745:3

 



Don't enable the server in the gui. There is already a separate server instance running at the other port. You probably didn't set the library path variable in the container settings. It's described on the docker hub page.
Link to comment
10 hours ago, aptalca said:

 


Don't enable the server in the gui. There is already a separate server instance running at the other port. You probably didn't set the library path variable in the container settings. It's described on the docker hub page.

 

 

 

Is this what you're referring to? The "library" entry is the location of my preconfigured Calibre library, and LIBRARYINTERNALPATH is the variable I got from your post here.

 

 

Capture.JPG

Edited by master.h
Formatting
Link to comment
 
Ok with the 2 GB has worked so far that I can see it when I call "docker stats JDownloader 2" that the docker use "only" 2GB RAM.
I use cache_dirs and when I cache all my stuff on the server 3 GB occupied by 12 GB.
Once I use the JDownloader the cached ram increases higher than an additional 2GB. At least the live stats show.
When a file is unpacked, the cached RAM increases even more. It is released after unpacking something again,
but it should never be more than 5 GB be used. 3GB through my cached files and 2 GB by JDownloader.
Can I limit that still somewhere
Link to comment
5 hours ago, master.h said:

 

 

Is this what you're referring to? The "library" entry is the location of my preconfigured Calibre library, and LIBRARYINTERNALPATH is the variable I got from your post here.

 

 

Capture.JPG

 

 

I just deleted and recreated the docker twice, and had the same issue both times. The first time I added in a preconfigured library as in the screenshot above, the second time I created a new library. Both custom and new library give the same error pages as I described earlier.

Link to comment

Well I just fixed it... it really helps if you read the setup instructions completely. Ugh. I missed the line that said "set your library to config on first run." Once I did that, I was able to add the environment variable and map it to my existing library just fine. All my books are showing up in the docker and are being served out over 13579 just fine.

Link to comment
Well I just fixed it... it really helps if you read the setup instructions completely. Ugh. I missed the line that said "set your library to config on first run." Once I did that, I was able to add the environment variable and map it to my existing library just fine. All my books are showing up in the docker and are being served out over 13579 just fine.


Glad to hear it worked
Link to comment
 
Ok with the 2 GB has worked so far that I can see it when I call "docker stats JDownloader 2" that the docker use "only" 2GB RAM.I use cache_dirs and when I cache all my stuff on the server 3 GB occupied by 12 GB.Once I use the JDownloader the cached ram increases higher than an additional 2GB. At least the live stats show.When a file is unpacked, the cached RAM increases even more. It is released after unpacking something again,but it should never be more than 5 GB be used. 3GB through my cached files and 2 GB by JDownloader.Can I limit that still somewhere


Unused memory is wasted memory. Why are you trying to limit it? These days the OSes are smart enough to reallocate resources where necessary (except for VMs, they reserve their memory and not share)
Link to comment
45 minutes ago, dlandon said:

Any chance you could update the Zoneminder Docker to the latest version?

 

Each version of zoneminder requires a new separate image and likely a fresh install because of all the drastic structural changes they implement. It's too much work and I gave up.

 

 

@aptalca  I think I'm going to add a comment within CA about Zoneminder.  Basically stating that while functional, its going to be stuck at 1.29

Link to comment
  • 2 weeks later...
  • 4 weeks later...

A couple of issues I'm hoping to get some pointers on.  I had RDP-Calibre running fine, with no issues, but wanted to put an nginx proxy in front of it.  I tried to setup a proxy pass to:

  -http://Tower:2203/#/client/c/Calibre  (2203 is mapped host port)

AND

  -http://Tower:2203/calibre (short url in config)

However, neither of those worked.  I'd just get a 404.

 

From there, I tried to switch the base docker to "host" network type, to see if I could get it working that what, however, regardless of settings the ports to 2203 and 2204 and host network type, the docker always tries to bind to 8080/8081: 

ChannelFailures: IOError("Port 8081 not free on u'192.168.2.45'",)

My end goal is to setup the nginx reverse proxy to the RDP-Calibre docker, but can't seem to get there.  Any thoughts?

 

Link to comment
On 5/16/2017 at 11:56 AM, Xafloc said:

A couple of issues I'm hoping to get some pointers on.  I had RDP-Calibre running fine, with no issues, but wanted to put an nginx proxy in front of it.  I tried to setup a proxy pass to:

  -http://Tower:2203/#/client/c/Calibre  (2203 is mapped host port)

AND

  -http://Tower:2203/calibre (short url in config)

However, neither of those worked.  I'd just get a 404.

 

I've noticed that the docker is not passing the URLPREFIX anywhere in the startup command.  This is what it shows me after applying changes to the docker config:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="RDP-Calibre" --net="bridge" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "EDGE"="1" -e "WIDTH"="1280" -e "HEIGHT"="720" -p 2203:8080/tcp -p 2204:8081/tcp -v "/mnt/user/Media/Library/Calibre/":"/library":rw -v "/mnt/user/Temp/":"/temp":rw -v "/mnt/cache/appdata/RDP-Calibre":"/config":rw aptalca/docker-rdp-calibre

As you can see, no URLPREFIX.  However, I have defined it as a variable, per instructions.  Thoughts?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.