Jump to content
luksak

My array got a lot slower

23 posts in this topic Last Reply

Recommended Posts

My array is running unRAID 5.0.4 and it got a lot slower very recently. Any ideas how I could find the reason for this issue? Thanks for your help!

Share this post


Link to post

The first step would be to post a syslog to see if anyone can spot anything that needs looking at.

Share this post


Link to post

@luksak: can you describe what you mean by that? What operations were slower and how did you measure it? (Parity check, disk rebuild, file copy/move, etc)

Share this post


Link to post

I am sorry for the poor report. Attached you can find my syslog.

 

@ysss: I am accessing my array using AFP, which is slow in general. But very recently it got that much slower that the Mac OSX Finder crashes listing folder with a lot of files and VLC is unable to play any videos.

 

I just found out that the memory is full. I tried using top to find out what uses a lot of memory but without success. Any idea how to do this?

syslog.txt.zip

Share this post


Link to post

Probably unrelated, but your syslog has this:

May  9 13:23:05 Tower kernel: FAT-fs (sdg1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Put your flash in your PC and let it checkdisk. I think on apple it uses something called Disk Utility.

 

As for your speed, possibly your network connection has degraded to 100mb. From unRAID command line, what do you get with

ethtool eth0

?

 

What do you mean memory is full? Linux will normally use up any free memory for i/o buffers. It is not unusual for memory to be full. See Linux Ate My RAM

Share this post


Link to post

The syslog shows that there is definitely some sort of corruption/failure on the USB stick so follow the suggestions for fixing this.   

 

If it cannot be fixed then the other possibility is that the USB stick is failing and you will need to follow the procedure for getting a new USB stick and contacting LimeTech to get your license transferred to it.

Share this post


Link to post

@trurl: Here is the result of

ethtool eth0

:

 

Settings for eth0:

Supported ports: [ TP ]

Supported link modes:  10baseT/Half 10baseT/Full

                        100baseT/Half 100baseT/Full

                        1000baseT/Full

Supports auto-negotiation: Yes

Advertised link modes:  10baseT/Half 10baseT/Full

                        100baseT/Half 100baseT/Full

                        1000baseT/Full

Advertised pause frame use: Symmetric Receive-only

Advertised auto-negotiation: Yes

Speed: 100Mb/s

Duplex: Full

Port: Twisted Pair

PHYAD: 0

Transceiver: internal

Auto-negotiation: on

MDI-X: Unknown

Supports Wake-on: pumbg

Wake-on: g

Current message level: 0x00000033 (51)

Link detected: yes

 

omg, you were right about the ram. everything's fine.

 

I' ll try to repair the memory stick an get back to you. Thanks!

Share this post


Link to post

I am still getting this one ofter repair:

 

May 12 01:33:00 Tower kernel: FAT-fs (sdg1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

 

Is my USB drive broken?

 

How did my network connection get degarded to 100MB/s?

Share this post


Link to post

And maybe the more important question: Why is my Finder crashing?

Share this post


Link to post

I am still getting this one ofter repair:

 

May 12 01:33:00 Tower kernel: FAT-fs (sdg1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

 

Is my USB drive broken?

 

How did my network connection get degarded to 100MB/s?

Not sure about your USB drive. I have seen that in the log when there was nothing wrong. Your previous log did have a lot of other things in it about your USB drive. Maybe post a new log and we can see if it is still throwing errors.

 

GB ethernet can be very sensitive to cable and plug problems. The first thing I would try is unplugging and replugging the cable at both ends.

Share this post


Link to post

Now my network is back up at 1GB. I guess a cable was the problem:

 

Settings for eth0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes

 

But I am still facing the same problem. I am unable to play a 1080p mp4. I attached a new syslog.

syslog2.txt.zip

Share this post


Link to post

But I am still facing the same problem. I am unable to play a 1080p mp4. I attached a new syslog.

That syslog seems to be one taken just after a reboot - I assume it does not cover you trying to play a mp4?

 

When you say you cannot play a mp4 are you talking about a specific mp4 file, or any mp4 file?    If it is any mp4 file then I would think the problem was at the player end, not the unRAID one.

Share this post


Link to post

No, this syslog includes trying to view several mp4s.

 

I am trying to access my array from my Mac. I am used to very slow directory listings as a lot of people using AFP with unRAID. But since a few weeks the directory listing got so slow that Finder crashes and VLC is unable to play 1080p files. I doubt that the issue is with Finder or VLC...

Share this post


Link to post

Start in SAFE-mode. Try to recreate the problem. Attach a new syslog.

Share this post


Link to post

How do I enable safe mode? I couldn't find anything about it...

Share this post


Link to post

It  is a selection when booting. The boot options appear in the screen when booting.

Share this post


Link to post

How do I enable safe mode? I couldn't find anything about it...

SAFE mode is on the boot menu before unRAID starts.

Share this post


Link to post

How do I enable safe mode? I couldn't find anything about it...

It is one of the options on the unRAID boot menu.

 

If you have a monitor+keyboard on your unRAID system then you can select it when booting the system.

 

If you run your unRAID system headless, then you can edit the file syslinux/syslinux.cfg that controls the boot menu on the USB drive and move the 'default' entry to the section for Safe boot.  If you then reboot the server you will be in Safe mode.

Share this post


Link to post

Few things to try...

 

1. Have you tried copying said 1080p movie from one unraid disk to another? mc (midnight commander) can show the copy speed.

2. Have you tried a different protocol? Samba? Does it exhibit the same problems?

3. What kind of switch do you have? Tried switching ports? If it's manageable, check the log on the switch?

4. Do you have other computers to test with? Does the problem show up on all clients?

Share this post


Link to post

Sorry to reply that late... I didn't have time to look into this issue further.

 

Yes, I am running unRAID headless. I don't understand where I should move 'default'. Here is what my syslinux.cfg looks like:

 

default menu.c32
menu title Lime Technology LLC
prompt 0
timeout 50
label unRAID OS
  menu default
  kernel bzimage
  append initrd=bzroot
label Memtest86+
  kernel memtest

Share this post


Link to post

Sorry to reply that late... I didn't have time to look into this issue further.

 

Yes, I am running unRAID headless. I don't understand where I should move 'default'. Here is what my syslinux.cfg looks like:

 

default menu.c32
menu title Lime Technology LLC
prompt 0
timeout 50
label unRAID OS
  menu default
  kernel bzimage
  append initrd=bzroot
label Memtest86+
  kernel memtest

This is not a current or complete syslinux.cfg. Get the one from the latest download.

Share this post


Link to post

I guess I will wait for unRAID 6 to be released and see if the problems persist...

Share this post


Link to post

Well, upgrading to 6.0 solved the issue. Now even 4k mp4s play without any problems...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now