ISCSI Support


Recommended Posts

1 hour ago, ich777 said:

I think you mean me and not @CraziFuzzy? :D

Of course 😄

 

Just changed the Kernel with the one you posted (Unraid Custom iSCSI builtin v6.9.0 beta25), but can you give me a hint what the next step is? Do I need to install a software like "open-iscsi"?

 

Thanks :)

 

Edit:

 

Think I need this on the Server: "targetcli". Correct? Client will be a Windows 10 PC..

 

Edit2:

 

Damn, I should learn to read, its everything in the Thread you linked ;)

Edited by glockmane
  • Like 1
Link to comment
15 hours ago, glockmane said:

After installing Python3 and python-setuptools via NerdPack I get following error:

 

BRydx0G.png

You don't have to install anything.

The images have everything in it.

Have you put the images on your USB boot drive and rebooted the server?

 

If you installed python through the nerd pack please uninstall it.

 

EDIT: Ich schätze mal du sprichst deutsch (Windows aktivieren... :D ), kannst auch im Deutschen Unterforum einen Post machen. ;)

  • Like 1
Link to comment
13 hours ago, ich777 said:

[...] If you installed python through the nerd pack please uninstall it.[...]

 

Had to uninstall python2 from the Nerdpack, so you are right, everything is working out of the box, great work :)

 

Client is Windows 10, was also super simple to setup.. Can pool the drive with local disks using Stablebit DrivePool, great stuff..

  • Like 1
Link to comment
  • 3 weeks later...
On 8/28/2020 at 10:30 PM, Trembler said:

Awesome work. Any idea on the release of the plug-in?

If someone is experinced in webdesign and can help me out it will be soon... :D

 

Edit: I've written two manuals how to create a iSCSI target on Unraid for the time.

Shouldn't be that hard to do it that way fir the time.

Only a few commands.

Link to comment
  • 2 weeks later...
On 8/29/2020 at 11:32 AM, ich777 said:

If someone is experinced in webdesign and can help me out it will be soon... :D

 

Edit: I've written two manuals how to create a iSCSI target on Unraid for the time.

Shouldn't be that hard to do it that way fir the time.

Only a few commands.

Sorry if I missed it, can you share the manual? I want to try to setup unRAID as an ISCSI target for an ESXi cluster using multiple SSD pools/MPIO

 

Link to comment
5 hours ago, Trembler said:

Sorry if I missed it, can you share the manual? I want to try to setup unRAID as an ISCSI target for an ESXi cluster using multiple SSD pools/MPIO

 

In this thread you find the images required for iSCSI (or you can compile your own images, but please read the description carefully) and also the manual on how to setup iSCSI.

 

 

  • Thanks 1
Link to comment
  • 1 month later...
2 minutes ago, SimonF said:

I am building a plugin for iSCSI also still WIP.  But having to learn as i go. 

Looks really nice and is also a lot better coded than mine I think... (webcoding is not my favourite kind of thing).

 

Interested on a colab, eventually integrate that in the Unraid-Kernel-Helper?

  • Thanks 1
Link to comment
9 hours ago, ich777 said:

Looks really nice and is also a lot better coded than mine I think... (webcoding is not my favourite kind of thing).

 

Interested on a colab, eventually integrate that in the Unraid-Kernel-Helper?

Sure, I am putting the code behind the buttons at present. You can get initial one from here, but its still beta and most of the buttons dont work as yet.

 

https://github.com/SimonFair/unraid.iSCSI/raw/main/iSCSI.plg

 

I looked at your build script maybe we could put the targetcli install into the plugin?  Was going to look at using rtslib as phase 2 rather than targetcli.

Link to comment
41 minutes ago, SimonF said:

Sure, I am putting the code behind the buttons at present. You can get initial one from here, but its still beta and most of the buttons dont work as yet.

 

https://github.com/SimonFair/unraid.iSCSI/raw/main/iSCSI.plg

No problem.

Have you installed the Unraid-Kernel-Helper-Plugin?

 

45 minutes ago, SimonF said:

I looked at your build script maybe we could put the targetcli install into the plugin?  Was going to look at using rtslib as phase 2 rather than targetcli.

Please send me a PM and we can chat about that... :)

Link to comment
  • 2 weeks later...

Hello :)
I`m testing the iSCSI beta plugin and got it to work, but I have a question
:

On the 3--LUN page, when I choose the IQN + Volume and click "Create FileIO LUN" nothing shows on the page, is it suppose to show something here at all?
Its clearly the button works as I got the iSCSI volume up and running on my W10 PC.

Also both buttons says "Create FileIO LUN", I guess the bottom one should say "
Create Block LUN"

Keep up the good work :D
Looking forward to see how this evolves!

 

  • Like 1
Link to comment
1 hour ago, isvein said:

Hello :)
I`m testing the iSCSI beta plugin and got it to work, but I have a question
:

On the 3--LUN page, when I choose the IQN + Volume and click "Create FileIO LUN" nothing shows on the page, is it suppose to show something here at all?
Its clearly the button works as I got the iSCSI volume up and running on my W10 PC.

Also both buttons says "Create FileIO LUN", I guess the bottom one should say "
Create Block LUN"

Keep up the good work :D
Looking forward to see how this evolves!

 

Yes keep in mind that the configuration is may be lost if you reebot, since it's in beta now but I will update the plugin in the next few weeks with the help of @SimonF who is currently developing a complete new interface.

I recommend using the command line to save everything and make special configurations.

See the Unraid-Kernel-Helper thread for more information.

  • Like 1
Link to comment
14 minutes ago, isvein said:

Good to know :)
For now I don't use it with any important data.

Yes, there are maybe some bugs in the GUI but if you configure it from the command line it will work and is rock solid(I only marked it as beta because the GUI isn't finished and there may be bugs in it).

  • Like 1
Link to comment
5 hours ago, isvein said:

Looking forward to see how this evolves!

You should be able to install my plugin for the GUI in parallel with ich777's plugin.

 

https://github.com/SimonFair/unraid.iSCSI/raw/main/iSCSI.plg

 

@ich777

 

I have updated the package today, not all of the addition functions are working as yet so treat as beta.

 

There is an issue with create LUNS for second processing. Feel free to take a look a provide feedback via this support page.

 

 

  • Thanks 1
Link to comment
4 hours ago, SimonF said:

You should be able to install my plugin for the GUI in parallel with ich777's plugin.

 

https://github.com/SimonFair/unraid.iSCSI/raw/main/iSCSI.plg

 

@ich777

 

I have updated the package today, not all of the addition functions are working as yet so treat as beta.

 

There is an issue with create LUNS for second processing. Feel free to take a look a provide feedback via this support page.

 

 

Are they bundled together?
Because I installed only the "iSCSI Target" plugin and got the gui under "settings"

Edited by isvein
Link to comment
12 hours ago, isvein said:

Are they bundled together?
Because I installed only the "iSCSI Target" plugin and got the gui under "settings"

ich777 has a GUI in his plugin. I started developing my own GUI which we are looking to merge in the future. But currently it is standalone, so you will need to install both if you want to see my version. Again its beta and still WIP.

Below are some of the tabs in my vers.

 

image.thumb.png.8f6df1e336c359bcd6ede6820dcfd1c6.png

 

image.thumb.png.963c059c398d27a92af13f811b4b221b.png

image.thumb.png.f880066555bb644443a368ecf9c7f59f.png

image.png

Edited by SimonF
added Device tab image
  • Like 2
Link to comment
7 hours ago, isvein said:

So Im testing around both fileIO on array and on the cache but both gives me the same speed, around 5MB/sec
I cant seem to figure out why it is so slow.
Connected on a 2.5Gbit link directly to server

Unraid 6.9 Beta 35

Have you enabled WriteBack?

What hardware are you using? CPU, Cache drives, Array drives, Parity?

I'm getting around 100ish MB/s on a 1Gbit connection from a spinning hard drive.

Haven't tested FileIO over a wire, only tested it over WiFi and I get about 25MB/s.

Link to comment
2 hours ago, ich777 said:

Have you enabled WriteBack?

What hardware are you using? CPU, Cache drives, Array drives, Parity?

I'm getting around 100ish MB/s on a 1Gbit connection from a spinning hard drive.

Haven't tested FileIO over a wire, only tested it over WiFi and I get about 25MB/s.

WriteBack was default false so that is off, can I enable that without recreating the LUN?
CPU i7-4790, cache is an old WD green 2TB, parity is an WD red 10TB and the array is a mix where the newest ones are WD Red 10TB

 

 

Edit: Tried with an new LUN with writeback enabled, now it goes over 100MB/Sec for some time, then drops to 3-4MB/sec, then back to over 100MB and so on. Looks to me a cache is filling up, then waiting for the drive, then filling the cache and so on. This was tested on a FileIO on the cache drive.
Same happens with the LUN on the array.

Going to try on a BlockLUN when I can, but I only have old WD green 2TB drives laying around.

 

Read speeds was way better, 95% over 150MB/sec (from both WriteBack on and off LUNs), and read is more important for me than write so at least that is good :)

Edited by isvein
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.