Jump to content
theone

Server Layout Plugin for unRAID v6

293 posts in this topic Last Reply

Recommended Posts

9 minutes ago, Cessquill said:

 

 

Not an ideal workaround, but it's what other people are doing.  I have my parity and cache disks inside the case (the caches on PCI mounts).

 

Yes, although some 'fancy' icon for cache drives will be welcome

Share this post


Link to post
20 minutes ago, michael123 said:

 

Yes, although some 'fancy' icon for cache drives will be welcome

Of course, yes.  Although at the end of the day you know where your cache drive is without a picture ;-)

Share this post


Link to post

Any way to add support for Multiple chassis? My main chassis is horizontal and the second chassis is vertical... :x

Share this post


Link to post
On 12/29/2017 at 8:50 AM, trurl said:

You use an empty row or column to create space between different parts of the layout.

Tried this with mine but Server Layout deleted all my data when i applied the change to the number of drive slots. Is there any way to recover this data? CA Backup maybe?

Share this post


Link to post

I was just about to report that the 2018.01.25 update was not working for me, but I figured it out.

However its now working for.

 

So if, after installing the 2018.01.25 update you still get multiple errors:

Warning: array_key_exists() expects parameter 2 to be array, null given in /usr/local/emhttp/plugins/serverlayout/php/serverlayout_constants.php on line 126

 

Make sure you select and delete any Historical Devices, at the bottom of the Data Tab. I had a blank entry, and did not notice it. After removing it, it now works fine.

Share this post


Link to post
On 5/27/2015 at 5:45 PM, theone said:

Hello,

 

I am proud to present:

Server Layout plugin for unRAID v6

 

The Server Layout plugin enables you to view the devices (HDDs, CD/DVD ROMS) in a physical manner.

You can configure the server’s disk tray layout, assign each storage device to a drive tray and enter additional data manually (Purchase Date, etc…)

 

To install under unRAID v6:

1. In the unRAID Plugin Manager under "Install Plugin" tab enter link https://raw.githubusercontent.com/theone11/serverlayout_plugin/master/serverlayout.plg

2. Wait for installation to complete.

3. Go to plugin WEGUI and change initial settings

 

To update the plugin:

* For WEBUI and functionality updates - Use the unRAID Plugin Manager

 

Icon.gif.cecadcc55159e503dde910ff212ac6b1.gif

 

 

 

 

 

Hello @theone I was wondering if you can add a feature to remap the tray number....I have a supermicro 12 bay case and the layout is from bottom left to top right bays 0-11  putting the map as 1-12 as we read books doesnt work at all for me and presumably others. we should be able to edit the bay numbers to match our systems...if thats possible?

Share this post


Link to post

Like this plugin and would like to use it, but I'm having an issue with this plugin. It appears as though the DVD drive (sr0) and the usb drive (sda) are being detected as same device. Result is whenever the DVD rive is added to the layout, the plugin loses all drive data and the layout settings are scrambled. I am posting a screen shot.

 

Any help is appreciated.

 

image.thumb.png.0ed9d0ef9072dc11bf72434663629d3d.png

Share this post


Link to post

Great idea. Unfortunately, script is buggy. After losing all my notes for the third time* I am returning to notes in separate text file.

-------------------------------------------

* -- Each time under different circumstances, last time it was when I clicked "Exit Server layout" in "Data" tab without clicking "Save data" first -- I was hoping to cancel unwanted changes.

Share this post


Link to post

I found an issue with the new UNRAID 6.6.0 Dynamix Black Theme.

 

White text on the Server Layout plugin Data screen does not display properly against the screen areas with white or light backgrounds on this theme.

 

ServerLayoutData_UnRAID_6_6_0_Black.thumb.jpg.979f78fff13911416e2d0b8c16d6b810.jpg

 

Edited by lewcass

Share this post


Link to post

I am using a dell Poweredge T610 and can't seem to get the hard drives 'seen' by the plugin? Any help would be greatly appreciated.

Share this post


Link to post
29 minutes ago, RallyGallery said:

I am using a dell Poweredge T610 and can't seem to get the hard drives 'seen' by the plugin? Any help would be greatly appreciated.

Post your diagnostics so we can see how Unraid "sees" them.

Share this post


Link to post
On 9/20/2018 at 9:10 PM, lewcass said:

I found an issue with the new UNRAID 6.6.0 Dynamix Black Theme.

 

White text on the Server Layout plugin Data screen does not display properly against the screen areas with white or light backgrounds on this theme.

 

ServerLayoutData_UnRAID_6_6_0_Black.thumb.jpg.979f78fff13911416e2d0b8c16d6b810.jpg

 

About the readability - like lewcass mentioned - its still unreadable and we have the 18. Nov.

Please fix this because its not useable - thanks a lot

EDIT: The last update is from March 2018... i hope the dev didnt give up 😉

Edited by Zonediver

Share this post


Link to post
2 hours ago, Zonediver said:

About the readability - like lewcass mentioned - its still unreadable and we have the 18. Nov.

Please fix this because its not useable - thanks a lot

EDIT: The last update is from March 2018... i hope the dev didnt give up 😉

Honestly, @theone hasn't been active in updating this plugin, and while it would be awesome if he fixes the CSS for ServerLayout and the Black Theme (like many other plugins had to also), it may be best to not hold your breath.  The plugin however does appear to be completely fine on the other themes.

Share this post


Link to post

Love this plugin, thank for making it as it replaces my hand written scribble/excel spreadsheet, however, I was having an issue where a drive was showing as historical even though it's currently installed, live, active, and working in the array. When I go to the report tab it's not in there, so I went ahead and deleted it from the historical section thinking that may refresh something, but now it's just completely gone.

 

Any ideas? Not a big priority, just curious if I'm missing something obvious.

 

I'm running unraid 6.6.6 and am thinking I may have juggled this drive around into another slot at some point and maybe that's why it's confused.

Thanks,

 

Nate

Edited by nate1749

Share this post


Link to post

Ah, I think I figured it out. For some reason I can't seem to get any SMART data off of that drive. Even though the drive is spun up I can't run a short/extended test since it says it needs to be spun up. Refreshing, waiting, etc., don't seem to make a bit of difference and this works on other drives. My guess is the drive is 2tb and it's plugged into an old pci-x card (other drives plugged into the card are 1tb or less) and maybe that's causing issues (or maybe there is an issue with the drive). 

 

Anyways, this is probably due to my setup and not an issue with the plugin (unless someone has had this happen before). Thanks.

Share this post


Link to post

Thanks for this plugin! I shut down my array, identified things and realized my soon to be parity drives are occupying bay 1 and 4 instead of 1 and 2 lol. Just a suggestion, if you were to put this repo on github I wonder if others would collaborate or fork to make their own improvements on this great app then merge them back in for a better experience?

Share this post


Link to post

Is there anyway to edit/update the Historical Device notes?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now