Jump to content
Squid

[Plug-In] Community Applications

2936 posts in this topic Last Reply

Recommended Posts

1 hour ago, Squid said:

And have tried this on 6.6.7 with no issues either

Any suggestions for those of us who its not working for? Or perhaps access to the Feb update to see if that changes anything?

Share this post


Link to post
1 hour ago, Chunks said:

I grabbed my diagnostics and was about to send them but then I had a thought - I am using firefox which is having the problem. I switched to Edge (it's what I have) and the page loaded fine. 

 

Chrome just finished installing and that works fine too. It may just be Firefox that is choking?

Ill try that now...standby...

Share this post


Link to post
8 minutes ago, Embowe said:

Any suggestions for those of us who its not working for? Or perhaps access to the Feb update to see if that changes anything?

Uninstall and re-install hasnt fixed for me either. Happy to submit logs if i can get some instructions.

 

EDIT- Can confirm that it works in Chrome but not in FireFox. 

Edited by showstopper

Share this post


Link to post

Interesting.  FF was the one browser I didn't test with.  I usually only do Brave, Edge, and Chrome unless there's major changes.  

 

Now I have to figure out what change was made that FF hates, and of course there's no console errors showing in FF.  On the road, so may take a day

Share this post


Link to post
15 hours ago, Hammerfest said:

in the LinuxServer.io discord yes, forum thread no, seems like people there pointed to the discord or irc.

 

"with all info needed to set up diskover. Any unraid specific instructions for common things like adding from dockerhub and editing templates are not a part of our Readmes." is hugely contradictory for anyone not familiar with how linux, dockers, dependencies and unraid work and thus my statement on the advanced tag for it

 

Will continue on discord or in the other forum thread so as to not clutter CA any further.

 

I don't understand where you want to go with this. We are not developing unraid and we are not the unraid support team. So I don't see why we should educate people on basic things about setting up containers on unraid. There is also a docker faq with pretty much all info needed for understanding how to use docker in unraid. 

 

 

Share this post


Link to post
1 hour ago, Embowe said:

Confirmed.... it works with Google Chrome as well...Must be a Firefox issue...

Spent the last hour while at work  narrowing down where the problem lies with FF and I've got the section down that FF decides to puke on without giving any errors for some reason.  *Might* be able to get a release up tonight, but probably not til tomorrow when I'm back home.

Share this post


Link to post

Does anyone running safari have an issue?

Share this post


Link to post
5 hours ago, Squid said:

Spent the last hour while at work  narrowing down where the problem lies with FF and I've got the section down that FF decides to puke on without giving any errors for some reason.  *Might* be able to get a release up tonight, but probably not til tomorrow when I'm back home.

No worries, if you need a test for FF... let me know.

 

Share this post


Link to post
16 hours ago, Embowe said:

No worries, if you need a test for FF... let me know.

 

Thanks, but I've got it under control.  As an aside, the last release of CA (2019.02.21) also didn't work correctly with FF.  I know exactly where the problem is, and will be pumping out an update tonight.

 

You would think that javascript is javascript, but while Chrome, Edge, and Brave all think that 2+2=4, Firefox seems to believe that 2+2=5???

Share this post


Link to post
37 minutes ago, Squid said:

Firefox seems to believe that 2+2=5???

A classic. Javascript uses the '+' operator as well to concatenate strings, so 2+2 = 22 (if treated as string).

A simple way to ensure arithmetic is 2*1 + 2*1 = 4

Edited by bonienl

Share this post


Link to post

I want to install arangodb from dockerhub, but Apps plugin cannot find it... 😟

When I try searching, it cannot find arrangodb in the regular apps, so I use the Click Here To Get More Results From DockerHub. And then the search kinda hangs... the spinner is "vawing" away, and nothing...

 

Help, please.

Share this post


Link to post
9 minutes ago, bonienl said:

A classic. Javascript uses the '+' operator as well to concatenate strings, so 2+2 = 22 (if treated as string).

A simple way to ensure arithmetic is 2*1 + 2*1 = 4

LOL   it was just a simple explanation.  In this case, FF pukes at having an animation then a callback when the animation is completed followed by a post call and when that is returned another animation with a callback.  (Nested callbacks)  Safari had a similar issue with CA a couple years ago with nesting multiple post calls

Share this post


Link to post
9 minutes ago, shEiD said:

I want to install arangodb from dockerhub, but Apps plugin cannot find it... 😟

When I try searching, it cannot find arrangodb in the regular apps, so I use the Click Here To Get More Results From DockerHub. And then the search kinda hangs... the spinner is "vawing" away, and nothing...

 

Help, please.

Sweet.  This looks like it's actually a dockerHub issue.  It appears that the search API doesn't do anything when searching for "arangodb"  If you instead search for "aran" your app will appear (the official version is the 2nd result)

Share this post


Link to post
8 minutes ago, Squid said:

Sweet.  This looks like it's actually a dockerHub issue.  It appears that the search API doesn't do anything when searching for "arangodb"  If you instead search for "aran" your app will appear (the official version is the 2nd result)

HA, I actually tried "arango", when I got quite frustrated after trying arangodb for the nth time... it seems I still typed too much 😁

Thanks for a quick answer @Squid

Share this post


Link to post
14 minutes ago, shEiD said:

HA, I actually tried "arango", when I got quite frustrated after trying arangodb for the nth time... it seems I still typed too much 😁

Thanks for a quick answer @Squid

After the quick look, the more indepth look revealed that this is actually a CA issue  

 

Share this post


Link to post

Need some more help, please:

 

I have to provide these 2 environment variables (-e), when running the arangodb docker:

ARANGO_NO_AUTH=1
ARANGO_STORAGE_ENGINE=rocksdb

 

How do I do that in the template? How/where do I add these? First time adding docker from docker hub 😓

Share this post


Link to post
9 minutes ago, shEiD said:

How/where do I add these?

At the bottom of the Add Container page. Click on the "+Add another..."

Share this post


Link to post
1 hour ago, trurl said:

At the bottom of the Add Container page. Click on the "+Add another..."

@trurl Thanks, it worked 👍

Share this post


Link to post

Can some one try FF again?  I got home and everything is working fine for me.  I do see that a new release of FF was released on 3/27, and maybe it wound up getting installed at some point over the course of today.

Share this post


Link to post
18 hours ago, Squid said:

Can some one try FF again?  I got home and everything is working fine for me.  I do see that a new release of FF was released on 3/27, and maybe it wound up getting installed at some point over the course of today.

I tried today on Unraid 6.6.7, after re-installing Community Applications and using Firefox 66.0.2.  It didn't work for me, hanging on the "Updating Content" message.  Pressing Esc clears the message, and then the animated bars display indefinitely but the apps never appear.

 

Everything work fine on Brave 0.61.52 (Chromium 73.0) though.

Share this post


Link to post

Very strange.  But the update now available should fix it.

Share this post


Link to post
46 minutes ago, Squid said:

Very strange.  But the update now available should fix it.

Confirmed, new version works on Firefox.   Thanks for the speedy update!

Share this post


Link to post

I just ran it on FF on all my machines and it seems to be back up and running again. Kudos for the quick fix!!!

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.