[Plug-In] Community Applications


3429 posts in this topic Last Reply

Recommended Posts

5 minutes ago, Squid said:

Probably.  No real reason to use piHole as the DNS for the server as there are no ads within the server.

 

Shutting array down to change to static public DNS addresses.

 

One question: will changing this make all docker containers on the server now use these for DNS and bypass my piholes? I know this isn't necessarily the right section to ask this question...

Link to post
  • Replies 3.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Community Applications (aka CA)     This thread is rather long, and it is NOT necessary to read it in order to utilize Community Applications (CA)  Just install the plugin, go to

My co-workers wondered why I was taking off my shirt.  They are still baffled why I have to show my belly button to a squid.  😁   

I've been going through withdrawal waiting for 6.6 to be released - When was the last time between CA releases ~6 weeks?   2018.09.01 Adjust CSS if unRaid is 6.6+ Many code opt

Posted Images

3 minutes ago, Squid said:

Think so.

Static, non pi-hole DNS lookup on main network settings seems to have cleared it up. I'll look through the pihole logs to see if I can see what is being blocked to add to a whitelist.

 

Thanks for the help @Squid, all you do is appreciated.

Link to post

latest update behave the same as preview one regarding pinned application.

basically applications or not all application are pinned, even if they do show as pinned under installed, not all show in pinned apps

Link to post
20 hours ago, Danuel said:

latest update behave the same as preview one regarding pinned application.

basically applications or not all application are pinned, even if they do show as pinned under installed, not all show in pinned apps

Shouldn't be any issue with CA and this, barring something up with the flash drive. 

 

Try deleting /config/plugins/community.applications/pinned_appsV2.json from the flash drive and try again.

Link to post

Maybe I'm confused.  There's a difference between pinned apps and favourite repository.

 

You can have as many apps as you want pinned to appear in the pinned apps section.

 

Favourite repo there is only 1, and whatever you have selected as the favourite shows up first in any category / searches etc.

Link to post
6 minutes ago, Squid said:

Maybe I'm confused.  There's a difference between pinned apps and favourite repository.

 

You can have as many apps as you want pinned to appear in the pinned apps section.

 

Favourite repo there is only 1, and whatever you have selected as the favourite shows up first in any category / searches etc.

that is what i try to say, i have 19 pinned apps and only 9 show in the pinned tab, i have no favourite repository added, have a look at the pinned_appsV2.json i added (they are in the file) but they do not show in the tab 

Edited by Danuel
Link to post

ok.  I see what the problem is.  I'll work on a solution.  The issue is your previously pinned binhex apps are stored in the file slightly differently than how they're now supposed to be, due to the "branding" removals.

 

Your easiest solution is to delete the file and repin the apps.

Link to post
6 minutes ago, Squid said:

You didn't delete the file and then re-pin the various apps.  But, I see what the problem is, and will work on a solution.

 

In the meantime, what you want to do is edit that file (if you don't want to re-create it) and where it says (as an example)



binhex/arch-deluge&binhex-deluge

change it to



binhex/arch-deluge&binhex deluge

 

ie: change the dashes in the left hand side to instead be a space.

 

This is related to the "branding" removal introduced a couple of revisions ago.

i did delete the file, that why i made the replay and did not work.

 

|

 

and i can confirm editing the file as suggested  is working, thank you ..:D

 

 

Edited by Danuel
Link to post
39 minutes ago, Danuel said:

i did delete the file, that why i made the replay and did not work.

 

Trying to understand why deleting the file didn't work.  Did you delete, then re-pin, and then update CA?

Link to post
1 minute ago, Squid said:

Trying to understand why deleting the file didn't work.  Did you delete, then re-pin, and then update CA?

 

i only delete the file and re-pin, i did not done any update since was to the latest version ...but i can try doing that.

to delete community application from drive and reinstall ..

Link to post
42 minutes ago, Squid said:

Trying to understand why deleting the file didn't work.  Did you delete, then re-pin, and then update CA?

 

so deleting Community Applications also delete from flash drive config/plugins/

when pinn the application i am back to step 1 where only few show up , at the moment single work around is to manually edit pinned_appsV2.json this is working.

 

i saw something interesting, the pinned apps that i edit in the pinned tab do not show as pinned, but they appear in the pinned tab, but if i pin that app from pinned tab, will create a duplicate and when removed, apps still visible in the pinned tab, but in the pinned_appsV2.json will show as false. i though you want want to know this

 

 

pinned.JPG

pinned2.JPG

pinned_appsV2.json

Edited by Danuel
Link to post

I got this when looking at the previous applications page of community apps

<br /> <b>Warning</b>: usort() expects parameter 1 to be array, null given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>655</b><br /> {"status":"ok"}

Link to post
On 2/14/2021 at 7:30 PM, ceyo14 said:

Is there a reason why this isn't already integrated with unraid? I think it should at least be offered, with any disclaimer it may need.

My own personal theory is that no one can properly pronounce my name when it gets added to the Credits.  :) 

Link to post

Hmm. Fixed by reinstalling it appears.

 

But I wonder why it disappeared.

 

Symptoms: no 'Apps' Tab. Clicking the plugin on the Plugins page comes up to blank page.

 

plugin: removing: community.applications.plg
No such package: community.applications-2021.02.19a-x86_64-1. Can't remove.
plugin: removed

 

After these messages:

Feb 22 02:48:00 BlackTower nginx: 2021/02/22 02:48:00 [error] 3088#3088: *225282 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:48:55 BlackTower nginx: 2021/02/22 02:48:55 [error] 3088#3088: *224960 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:49:11 BlackTower nginx: 2021/02/22 02:49:11 [error] 3088#3088: *224956 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:49:27 BlackTower nginx: 2021/02/22 02:49:27 [error] 3088#3088: *224764 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:49:43 BlackTower nginx: 2021/02/22 02:49:43 [error] 3088#3088: *224146 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:49:59 BlackTower nginx: 2021/02/22 02:49:59 [error] 3088#3088: *225281 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:50:15 BlackTower nginx: 2021/02/22 02:50:15 [error] 3088#3088: *225282 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 02:55:01 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1
Feb 22 03:37:06 BlackTower nginx: 2021/02/22 03:37:06 [error] 3088#3088: *238887 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/Notify.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:37:13 BlackTower nginx: 2021/02/22 03:37:13 [error] 3088#3088: *239426 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:37:28 BlackTower nginx: 2021/02/22 03:37:28 [error] 3088#3088: *239168 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:37:44 BlackTower nginx: 2021/02/22 03:37:44 [error] 3088#3088: *239711 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:38:00 BlackTower nginx: 2021/02/22 03:38:00 [error] 3088#3088: *239754 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:38:16 BlackTower nginx: 2021/02/22 03:38:16 [error] 3088#3088: *239809 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:39:22 BlackTower nginx: 2021/02/22 03:39:22 [error] 3088#3088: *239426 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:39:37 BlackTower nginx: 2021/02/22 03:39:37 [error] 3088#3088: *238887 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:39:53 BlackTower nginx: 2021/02/22 03:39:53 [error] 3088#3088: *239711 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:40:09 BlackTower nginx: 2021/02/22 03:40:09 [error] 3088#3088: *239754 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:40:25 BlackTower nginx: 2021/02/22 03:40:25 [error] 3088#3088: *239168 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:40:41 BlackTower nginx: 2021/02/22 03:40:41 [error] 3088#3088: *239809 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:41:37 BlackTower nginx: 2021/02/22 03:41:37 [error] 3088#3088: *239426 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:41:53 BlackTower nginx: 2021/02/22 03:41:53 [error] 3088#3088: *239711 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:42:09 BlackTower nginx: 2021/02/22 03:42:09 [error] 3088#3088: *238887 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:42:25 BlackTower nginx: 2021/02/22 03:42:25 [error] 3088#3088: *239168 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:42:41 BlackTower nginx: 2021/02/22 03:42:41 [error] 3088#3088: *239809 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:42:57 BlackTower nginx: 2021/02/22 03:42:57 [error] 3088#3088: *239754 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:43:53 BlackTower nginx: 2021/02/22 03:43:53 [error] 3088#3088: *239711 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:44:09 BlackTower nginx: 2021/02/22 03:44:09 [error] 3088#3088: *239426 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:44:25 BlackTower nginx: 2021/02/22 03:44:25 [error] 3088#3088: *238887 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:44:41 BlackTower nginx: 2021/02/22 03:44:41 [error] 3088#3088: *239168 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.69, server: , request: "POST /webGui/include/DashUpdate.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "blacktower.local", referrer: "http://blacktower.local/Dashboard"
Feb 22 03:55:01 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1
Feb 22 04:55:01 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1
Feb 22 05:55:01 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1
Feb 22 06:55:02 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1
Feb 22 07:55:01 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1
Feb 22 08:55:01 BlackTower crond[1770]: exit status 1 from user root php /usr/local/emhttp/plugins/community.applications/scripts/notices.php > /dev/null 2>&1

 

Reinstallied via https://raw.githubusercontent.com/Squidly271/community.applications/master/plugins/community.applications.plg

 

Flash drive isn't that old. Made a Backup before and after.

 

 

 

 

 

Link to post

I'm having a problem with CA that's new to me, but I'm not clear if it started with version 2021.02.27, or earlier.

 

The problem is that when I do a DockerHub search, the chain-looking "link" icons don't do anything when clicked.

 

And when I hover, the popups all read "Go to DockerHub page ca_href"

 

I'm happy to gather more information, if useful.

Edited by bland328
Link to post

Thanks for the latest update - from the change log it looks like there was a lot of work on that one.  I don't use this plug-in that often, but when I do it's great to have a tool such as this that "just works".  Much appreciated.  Thank you.

Link to post

When trying to install Hastebin I get the following.

 

Something really wrong went on during createXML
Post the ENTIRE contents of this message in the Community Applications Support Thread

<br /> <b>Warning</b>: explode() expects parameter 2 to be string, array given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>1582</b><br /> <br /> <b>Warning</b>: array_filter() expects parameter 1 to be array, null given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>1582</b><br /> <br /> <b>Warning</b>: array_values() expects parameter 1 to be array, null given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>1582</b><br /> {"status":"ok","cache":null}

 

Edited by CorneliousJD
Link to post
8 hours ago, CorneliousJD said:

When trying to install Hastebin I get the following.

 


Something really wrong went on during createXML
Post the ENTIRE contents of this message in the Community Applications Support Thread

<br /> <b>Warning</b>: explode() expects parameter 2 to be string, array given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>1582</b><br /> <br /> <b>Warning</b>: array_filter() expects parameter 1 to be array, null given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>1582</b><br /> <br /> <b>Warning</b>: array_values() expects parameter 1 to be array, null given in <b>/usr/local/emhttp/plugins/community.applications/include/exec.php</b> on line <b>1582</b><br /> {"status":"ok","cache":null}

 

 

Don't know how you're installing it though...  It won't show up for me because of this...

 

    {
        "TemplatePath": "/tmp/appFeed/templates/FlippinTurtsRepository/hastebin.xml",
        "errors": [
            "Opening and ending tag mismatch: Container line 2 and Overview",
            "Extra content at the end of the document",
            "Opening and ending tag mismatch: Registry line 5 and Container",
            "EndTag: '            "Opening and ending tag mismatch: Registry line 5 and Container",
            "EndTag: '            "Opening and ending tag mismatch: Container line 2 and support",
            "Extra content at the end of the document",
            "Opening and ending tag mismatch: Container line 2 and support",
            "Extra content at the end of the document"
        ],

 

Link to post

But, even with the error causing that fixed, it's not a valid template (and causing the error you're seeing) because of @FlippinTurt manually editing the template to add in extra path mappings, but doing it incorrectly.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.