[Plug-In] Community Applications


Recommended Posts

Community Applications Changelog for version 2021.10.24:

  • Windows 11 temporary compatibility fix
  • Fixed: Repository descriptions weren't showing up on cards if descriptions were allowed in Settings

2021.10.21

  • Changed / Fixed: Rendering speed at startup, page transitions etc
  • Fixed: Uninstalling from a category wouldn't highlight Installed Apps after finish.
  • Fixed: Uninstalling from either the docker or plugin subsection of installed apps would highlight Installed Apps after uninstall
  • Various CSS tweaks

2021.10.19

  • Changed: Drop limit of displayed apps on home page from 25 to 7 / 10 depending upon settings
  • Added: Ability to display descriptions by default on the cards. (Go to CA's Settings page)
  • Changed: Easier access to debugging information in certain cases

2021.10.17a

  • Fixed: Certain apps would have the Installed flag showing when in Installed Apps
  • Fixed: Pinned Apps were not honoring the sort order when initially going into that section
  • Fixed: Going from Home / SHOW MORE to Installed / Previously Installed the sort order would be incorrect

2021.10.17

  • Complete overhaul of GUI
  • Fixed: Disable categories after performing a dockerHub search
  • Removed: Compatibility with OS versions prior to 6.9.0
  • Fixed: Attempting to sort a repository display would return errors if only a single repository was present
  • Added: When installing a second instance, automatically change the app name
  • Changed: Priority of support options is now Project, Discord, Support Forum
  • Removed: Help text (unnecessary with replacement GUI)
  • Fixed: Setting a favourite repository would change all of CA's settings back to defaults
  • Added: Support ReadMe files on templates
  • Fixed: Multiple instances of apps installed using the same tag would only appear once within installed apps
  • Removed: dockerHub searches (See release post)
  • Fixed: All steamcmd apps would show as being installed if any of them were.
  • Changed: Dim background on any sweet alerts (eg: choose branch)
  • Fixed: Display aberrations if app's name didn't fit within designated area
  • Fixed: Entering a search term (but not searching for it) followed by selecting a category would return errors
  • Added: Languages show up within Installed Apps (plugins subsection)
  • Added: Identification of apps which are currently installed
  • Fixed: Second instance would show up within Previous Apps (and give installed options) if original instance was installed, then second instance was not installed and both used the same tag
  • Added: Fatal error if docker image / folder is either completely full or mounted read-only
  • Fixed: Hover area / click area of left menus extended into blank area to the right
  • Fixed: Deleting the entire private repository storage location (/boot/config/plugins/community.applications/private) would result in the private applications still appearing until the next appfeed update
  • Fixed: Various issues related to installing 2nd instances
  • Rediscovered: A profound appreciation of the phrase 'Nothing takes 5 minutes'
Link to comment
21 hours ago, jakeortman said:

force install back to a version that works on 6.8.3?

Uninstall the plugin, and then install via this URL

 

https://raw.githubusercontent.com/Squidly271/community.applications/d075fda8b8337c4c6bbd0b6d1d66b80a8870d9ba/plugins/community.applications.plg

 

Link to comment

I've been having a weird issue with unpinning apps. I believe the issue was introduced with the GUI overhaul in 2021.10.17 or one of the following patches. This occurs if I install an app that was pinned before the update. The "pin" changes from green to black when the app is installed, but still shows up in my list of pinned apps. Pinning and unpinning an app without installing it works as expected. The same goes for unpinning apps that were pinned before the GUI overhaul, but has not been installed. Unpinning an app that was pinned before the overhaul but installed after works as intended. Unpinning an app that was pinned and installed after the overhaul works as intended.

 

Is it just me?

Link to comment

On 6.9.0

 

Beta worked perfectly for me. Updated to latest CA. Initial load works fine and I can browse apps but if I try to use the CA search bar...when the search executes I get the loading icon for a second before it freezes, along with the entire page. Network tab (devtools) shows no console errors, Notify.php and exec.php returning 200s.

 

Also tried 2021.10.20-x86_64-1.txz with no change in behavior.

Link to comment
16 hours ago, dockeith said:

I've been having a weird issue with unpinning apps. I believe the issue was introduced with the GUI overhaul in 2021.10.17 or one of the following patches. This occurs if I install an app that was pinned before the update. The "pin" changes from green to black when the app is installed, but still shows up in my list of pinned apps. Pinning and unpinning an app without installing it works as expected. The same goes for unpinning apps that were pinned before the GUI overhaul, but has not been installed. Unpinning an app that was pinned before the overhaul but installed after works as intended. Unpinning an app that was pinned and installed after the overhaul works as intended.

 

Is it just me?

I can't replicate.  Which apps in particular

Link to comment
21 hours ago, BradleyDS2 said:

Mealie has a known bug that causes an endlessly large backup file.

The dev has stated that he will not address the issue unless someone else provides a PR, as they will not take on the additional burden to support Unraid.

Link to said issue.

And it's also in that same thread the fix

Link to comment

Install the latest community applications. Just restart unraid and click apps to prompt an error,How to solve it(This problem did not occur before this plug-in was updated)

Thanks

 

Fatal Docker Image Error

Your docker image or folder is either read-only or completely full. Issues will result because of this. You should create a new post in the Unraid forums and include your diagnostics

 

 

123.png

Link to comment

Is there a way to revert to a previous update? I feel like the new GUI really needs some quality of life fixes.

 

Just a short list that I noticed when installed:

- You don't scroll back to top when going to the next page via pagination.

- There's no option to choose from on how many apps are shown on a page.

- The back button does NOT work and it's really annoying.

- No more menu links to random apps, new apps, top apps etc.

- The menu animations when collapsing are quite slow.

- Clicking on an app collaps a menu on the right. Perhaps make it scrollable too when not on the white, but also on the gray overlay (left side).

Link to comment

 

17 hours ago, yoyomama said:

this is my log and the app taking forever to refresh and most of the time I have to force it with plugin too

 

 

After the system actually loaded the page, it took 1 second to display the home page.  What is the delay?  Simply getting to the page?  (ie: was the spinner on Chrome's tab still spinning indicating the Chrome is still grabbing the information prior to CA actually loading?)

Link to comment
18 hours ago, Seven7527 said:

Thank You for the help with rolling back to 2021.08.31 because I am still on OS 6.8.3. My only question is nothing comes up for updates now. Is there something I can do to apply updates?

 

Link to comment
18 hours ago, Joopie said:

There's no option to choose from on how many apps are shown on a page

That hasn't been in CA since 2015, but is coming back soon

18 hours ago, Joopie said:

- The back button does NOT work and it's really annoying.

 

It's never been there.  Complete redesign from top down to implement and instead of showing a URL that is simply https://xxx.unraid.net/Apps would change to https://xx.unraid.net/Apps/AFewHundredCharactersHeres which I absolutely hate as I don't particularly trust that type of URL whenever I see it, and is also a big security risk with certain aspects of what CA is able to do.

 

18 hours ago, Joopie said:

- No more menu links to random apps, new apps, top apps etc.

 

All consolidated on the home page

 

18 hours ago, Joopie said:

Clicking on an app collaps a menu on the right. Perhaps make it scrollable too when not on the white, but also on the gray overlay (left side).

Why would you want to be able to scroll the main area when the side bar is open?  Half of the app icons are covered up by the sidebar to begin with...

Link to comment

Is there a way to get back the "old" view of CA?
The new GUI is designed great, ofc, but i love the old way where i can read the quickinfo what the app is for.
Now i only can see this for spotlighted apps and it needs "timewasting" additional clicks to find out what apps are out there.
This is what i want for every app:
JSQaNOM.png

Link to comment
9 hours ago, Squid said:

 

 

After the system actually loaded the page, it took 1 second to display the home page.  What is the delay?  Simply getting to the page?  (ie: was the spinner on Chrome's tab still spinning indicating the Chrome is still grabbing the information prior to CA actually loading?)

it's UnRaid App and Plugin loading it spinning forever or unable to install plugins. 

Link to comment
12 hours ago, yoyomama said:

it's UnRaid App and Plugin loading it spinning forever or unable to install plugins. 

Try setting static DNS addresses in Settings - Network settings (208.67.222.222 / 208.67.220.220) 

 

If no difference, then create a new thread in General Support and include your diagnostics

Link to comment
On 10/20/2021 at 6:22 PM, SplitHoirzon said:

Im having the problem with the spinner never going away and my CA never loads.  Here are my Debug logs.

CA-Logging-20211020-1120.zip 1.38 kB · 2 downloads

Is your "default font size" and "minimum font size" same in your browser settings? I have same problem if the values are same. But for example default 16 and minimum 14 and everything works fine. Only tried with Vivaldi.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.