[Plug-In] Community Applications


Recommended Posts

So I replicated this on 6.11 (still waiting on another update for 6.10)

 

It's not a CA issue per se, but rather a docker tab issue where it isn't picking up that the container was actually updated (and updated via its own update routine - CA is nothing but a front end for the existing code in the docker tab)

 

You can tell this because if you apply the update via docker, the total pull size will be zero and additionally a check for updates on docker will remove the Update being available.

 

I'll look into it. 

  • Thanks 3
Link to comment

What

12 hours ago, flyize said:

I've been trying to install the GPU Statistics plugin and it keeps getting stuck on 'pending'. I've even rebooted the server. Is this a CA problem or a GPU Statistics problem?

What version of the OS?

Link to comment
56 minutes ago, flyize said:

Oh duh. Sorry 6.11 RC2.

Reboot

 

Then try again.   Don't close the popup and then copy and paste the output of it.

 

(I can't replicate so need to see who's not doing their job: the OS or CA)

Link to comment
2 hours ago, Squid said:

Reboot

 

Then try again.   Don't close the popup and then copy and paste the output of it.

 

(I can't replicate so need to see who's not doing their job: the OS or CA)

I don't get a popup. Are there logs somewhere?

 

edit: FWIW, I am able to install other apps. Only GPU Statistics goes to 'pending'.

Edited by flyize
Link to comment

I have postgresql14 installed and it seems it got into a weird state, I can see both on the docker and apps page that it's got an update, on the apps page I get the Update and Edit choices but Edit pops up "XML file was missing" and Update gives "Configuration not found. Was this container created using this plugin?", what's the best way to fix it without losing settings?

 

image.png.1c09880582f52a79f4a2201e118acac1.png

 

image.png.774059b8f556cf813efa463da7465c3a.png

 

EDIT: Found the XML in my Jul 27th flash backup and restored it, but no idea why it disappeared...

EDIT2: I remember now, it showed up in "Previous Apps" and I deleted it from there since I thought it was another template I had installed before settling on that one, but no it was the live one. So now the question is why did it show up there...

Edited by Kilrah
Link to comment

Problem with installing Community Application on Unraid 6.9.2 and 6.10.3

 

Hello all nice people out here!

I have an unusual problem. 

I had to setup a new install of unraid and when I click on plugin tab (unraid 6.9.2) and paste the CA link I get a network failure problem. I get the same error message if I install in unraid 6.10.3.

I have checked my router and also used another router to see if the problem still is in the router. I have search on internet if anyone had the same problem. I also tried internal nic on the MB and my external.

Please see the attached picture.

I had installed unraid 6.10.3 from the beginning  but I decided to revert to 6.9.2 but the problem is the same. 

 

My specs:

MB: Asus Prime Z390-a

CPU: Intel Core i5 9400F 2.9 GHz 9MB

RAM: Corsair Vengeance RGB PRO 32GB (2x16GB) x2

GPU ASUS Geforce 1060 3GB

NIC: ASUS XG-C100C - Nätverkskort 10GBase-T x 1 / (PCIe)

PSU: EVGA Supernova G2 1300W

SDD NVME 1: Kingston A2000 1TB M.2 NVMe

SSD NVME 2: WD Blue SN550 NVMe SSD 1TB M.2 (WDS100T2B0C)

Parity HDD: Seagate ST14000NM001G Exos X16 14 TB

HDD 1: WD Gold 10TB 7200rpm 256MB

HDD 2-3: TOSHIBA N300 NASHDWG11A

I need help as I am stuck and run our of solutions. I hope I provided sufficient info.

community application plugin failed.png

Link to comment

Is this correct?

IPADDR[0]="100.27.27.245"
NETMASK[0]="255.255.255.0"
GATEWAY[0]="100.27.27.1"

Highly unusual to give the server a static IP address that's actually a internet address (and registered to amazon aws)

 

Also, 

DNS_SERVER1="82.209.169.7"

Never heard of this DNS server before... Doesn't mean anything in and by itself though.  Probably best to use 208.67.222.222 and 208.67.220.220

  • Thanks 1
Link to comment

Hello!

 

I have an isp adress but this is after on the LAN side that I gave my LAN this adress. The idea i got from watching lawrencestystems video of how to setup a pfsense router.  I have disconnected pfsense router to see if that helped but no.

Yes I agree with you that it says amazon but does this matter in any way? I had 192.168.1.245 before. But as many of gurus in network says you should give your LAN side a different LAN IP adress. So this is what I chose. 

What is your thought om this? I will try the ordinary adress now to see if it resolves my problem. I will get back in a minute.

Thanks for your help! This was something I didn´t think of. I let you know in a minute. 

Link to comment
1 hour ago, andreas79 said:

But as many of gurus in network says you should give your LAN side a different LAN IP adress. So this is what I chose. 

While I'm sure there may be many esoteric uses for assigning public IPs within a private LAN, I've never once seen an enterprise environment anywhere (ie: the network experts) who didn't use 10.x, 192.x, 172.x

Link to comment

I've had an issue viewing anything in the CA tab for the past two weeks. The rest of my network is fine as is all my dockers and unraid in general. When I visit the CA tab I get this:

 

Quote

 

Download of appfeed failed.

Community Applications requires your server to have internet access. The most common cause of this failure is a failure to resolve DNS addresses. You can try and reset your modem and router to fix this issue, or set static DNS addresses (Settings - Network Settings) of 208.67.222.222 and 208.67.220.220 and try again.

Alternatively, there is also a chance that the server handling the application feed is temporarily down. See also this post for more information

Last JSON error Recorded: Syntax error

 

Attached is log I got after visiting the page with Save CA debugging information enabled.

 

The log looks fine for downloading most json files but I think applicationFeed.json is giving it issues. It doesn't seem network related (judging by the json error reported). I can visit all the s3 links for json files in my browser reported in the log without an issue. As well as download them with wget from the unraid cli.

 

I have uninstalled and re-installed the CA app with no change in behavior. This is on Unraid 6.9.0

CA-Logging-20220808-1609.zip

Edited by FoxxMD
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.