Jump to content
Squid

[Plug-In] Community Applications

3208 posts in this topic Last Reply

Recommended Posts

Latest update broke this plug-in for me. It's been stuck on " Please wait... retrieving application information!" since the 23rd.

Internet explorer most likely.  I noticed it yesterday (it actually sneaked through on 2015.07.22)  Having been bouncing around fresh builds with sparklyballs since yesterday to fix it (and maintain compatibility with Safari).  Update will be released later on today, along with another viewmode.

 

Sorry for the inconvenience...

 

In the meantime, you can switch to Chrome.  Its also a lot faster at rendering the results.  (in my testing, IE is by far the slowest of all the browsers)

Share this post


Link to post

 

OK - I am sure I am being really dumb. But I have installed this and cannot figure out how to use it. It installed fine, and I see the icon in the settings area of the GUI. When I click on that, I can adjust the settings. But how do I get to the actual tool? I have tried on Chrome, Opera and Firefox...popup's are allowed. Liek I said, I am sure I am doing something silly...

 

Do I need to install anything else? Or enable anything else?

 

Thanks!

Share this post


Link to post

 

OK - I am sure I am being really dumb. But I have installed this and cannot figure out how to use it. It installed fine, and I see the icon in the settings area of the GUI. When I click on that, I can adjust the settings. But how do I get to the actual tool? I have tried on Chrome, Opera and Firefox...popup's are allowed. Liek I said, I am sure I am doing something silly...

 

Do I need to install anything else? Or enable anything else?

 

Thanks!

Go to the docker tab

 

Share this post


Link to post

don't forget to scroll down on the docker page as well, it gets lost for me under the running dockers

Share this post


Link to post

Updated to 2015.07.25c (if it wasn't for the IE issue, I would have held off for a few more days  ;) )

 

- Fixed issue with this plugin crashing Internet Explorer

- Added view mode Icon Details

- Revamped some of the default settings.

 

You MUST allow popups from your server to use this plugin

 

The app feed provided by Kode now seems to be stable, and as such it is now the default mode of using this plugin.  (If you have already installed this plugin and adjusted any of its settings, then you will have to go to the settings for CA, and enable Application Feed, and also enable automatic updates)

 

This feed downloads super quick (usually by the time you select the Community Applications tab or scroll down, the update will have finished.)  Using this feed also means that you no longer have to hit Update Applications.  The application feed is pretty much updated 1 per hour from Kode, and every time you enter this plugin, it will download the latest and greatest.

 

In addition, template maintainers can setup a "webhook" (http://lime-technology.com/forum/index.php?topic=41413.msg392752#msg392752) for their templates so that if / when they add a new application, the feed will recognize it immediately instead of waiting for the next full scan of templates (every hour).

 

However, in the event the maintainers do not utilize the webhook, and you KNOW that a new template is available, pressing Update Applications will manually download all the templates (same operation as before the application feed went into effect).  Note however, that the list returned by Update Applications is temporary if you are using the application feed.  The next time you exit and enter this plugin, any changes returned by Update Applications will have been lost if Kode's application feed scan has not yet run (hourly).

 

Also, if for whatever reason, the appfeed is unavailable, then the system will automatically revert to downloading the templates.

 

Share this post


Link to post

The "Apply" button in the settings is not enabled in Chrome or IE.

Works for me in IE, Chrome, Firefox, Safari (PC).  Have you actually made a change?  It's disabled until a change takes place  (The operation of Apply changed in 6.1rc-1)

 

Share this post


Link to post

The "Apply" button in the settings is not enabled in Chrome or IE.

Works for me in IE, Chrome, Firefox, Safari (PC).  Have you actually made a change?  It's disabled until a change takes place  (The operation of Apply changed in 6.1rc-1)

 

Yes made changes.  Changed all fields nothing enabled Apply.  I'm on 6.0.1, not 6.1rc1.

 

EDIT: Works on 6.1rc1 but not 6.0.1.

Share this post


Link to post

The "Apply" button in the settings is not enabled in Chrome or IE.

Works for me in IE, Chrome, Firefox, Safari (PC).  Have you actually made a change?  It's disabled until a change takes place  (The operation of Apply changed in 6.1rc-1)

 

Yes made changes.  Changed all fields nothing enabled Apply.  I'm on 6.0.1, not 6.1rc1.

 

EDIT: Works on 6.1rc1 but not 6.0.1.

My bad!.  The changes in 6.1 overwrote some settings that I had in PluginSettings to operate, but 6.01 never overwrote them.  Guess that I should leave one of my servers on the latest stable from here on it.

 

Anyways, updated to 25d.  (if anyone's curious, 2015.07.25->2015.07.25b were internal builds to fix compatibility with IE & Safari on a Mac)

Share this post


Link to post

Kode/Squid,

 

Thanks for the help. I appear to be getting ahead of myself as I am still setting up my unRAID server so do not have the docker tab (and understand why). Thanks for creating this utility - I look forward to using it when I get a bit further along. Thanks!

Share this post


Link to post

The "Apply" button in the settings is not enabled in Chrome or IE.

Works for me in IE, Chrome, Firefox, Safari (PC).  Have you actually made a change?  It's disabled until a change takes place  (The operation of Apply changed in 6.1rc-1)

 

Yes made changes.  Changed all fields nothing enabled Apply.  I'm on 6.0.1, not 6.1rc1.

 

EDIT: Works on 6.1rc1 but not 6.0.1.

My bad!.  The changes in 6.1 overwrote some settings that I had in PluginSettings to operate, but 6.01 never overwrote them.  Guess that I should leave one of my servers on the latest stable from here on it.

 

Anyways, updated to 25d.  (if anyone's curious, 2015.07.25->2015.07.25b were internal builds to fix compatibility with IE & Safari on a Mac)

 

Squid, the search function is no longer working for me on Chrome or Firefox.. Have tried rebooting the box after trying your internal builds.  Any ideas?

 

Share this post


Link to post

Any ideas?

Yeah....  I messed up    :o

 

Its fixed now, but looking at an issue with sonarr from needo (not picking up the overview properly).  Will pump out an update shortly.

 

I guess that eventually I was going to have a release that was buggy....

 

Share this post


Link to post

Fixed.  The issue that I found with needo's sonarr is actually a malformed xml file.  Issued a pull request on it.

 

As an aside, if anyone thinks that the QC on this latest version sucked, then they're probably right.  The changes in the underlying code to support on-the-fly changing of view modes had a number of compatibility issues with various browsers at various times in their evolution (eg.  Original code crashed IE.  The code that fixed IE worked on everything, but then crashed safari.)  Certain things like the settings not working on 6.01, and this search issue, however is just my poor final QC, as I was concentrating on the browser compatibility issues and didn't recheck very closely the coding the should have still worked (at least in my mind) -> namely search and Plugin settings.

 

My apologies to all...    :'(

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

 

That just sounds weird.

 

Good work on the fix. 

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

Think I may have eaten your cousin in a restaurant last night...

 

My bad

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

 

Squid%20Man%20on%20the%20Train.JPG

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

 

Squid%20Man%20on%20the%20Train.JPG

Hehe, where's that from?

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

 

Squid%20Man%20on%20the%20Train.JPG

Hehe, where's that from?

 

squid's journey to seaworld to visit the family.

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

 

Hehe, where's that from?

 

squid's journey to seaworld to visit the family.

I meant what movie...

 

EDIT: NVM found it "Squid Man"

Share this post


Link to post

No worries, everyone understands that Squid is errr.... human?

Now I'm tearing up.... :'( :'( That has to be the nicest thing that anyone has ever said to me  :'(

 

Hehe, where's that from?

 

squid's journey to seaworld to visit the family.

I meant what movie...

 

squidman2 , revenge of the calamari

Share this post


Link to post

Has to be a "b" flick.  I mean they went all out making a very realistic looking octopus hat...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.