unRAID Server Release 6.0.0-x86_64 Available


314 posts in this topic Last Reply

Recommended Posts

Is there a WARNING in the plugin that you're going to lose all of your plugin functionality and only have a basic NAS after it completes the upgrade?

 

+1

 

This is going to your best place to head off support issues for upgrading users who don't read all the instructions.

Link to post
  • Replies 313
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

... The unRaid-5-to-6 plugin is very simple.  It is going to create a folder on the flash called 'previous' and move all the unRaid-5 release files there in addition to ./extra, ./plugins, ./config/plugins directories.  Then download latest unRaid-6 and install.  When server reboots you will get 'stock' unRaid-6 with ability to "go back" if you want.

 

Is there a WARNING in the plugin that you're going to lose all of your plugin functionality and only have a basic NAS after it completes the upgrade?    This is what I was referring to earlier r.e. user's simply seeing an "upgrade plugin" and installing it; running it; and then wondering why their "stuff" doesn't work.    It sounds like this is basically doing what jonathanm suggested, except that instead of requiring the USER to remove his plugins before the upgrade, it's simply removing them all for him => hopefully WITH his knowledge (thus the warning).

 

Well Gary, there will be an Announcement post with a link to download the v5 plugin with a [glow=red,2,300]BIG FAT[/glow] warning: [glow=red,2,300]You're getting a vanilla install of v6 but you can go back if you hate it[/glow]".  Think that will be enough?  I suppose we can wrap it in a javascript alert - but if they don't read it in the Annoucement post, not likely they will read it anywhere else either right?

Link to post

i'm not getting an update, i'm running rc5, have restarted. checked again for updates, and it's status is up-to-date

 

still not getting offered the update through the normal update procedure, should i do it the old fashioned way, downloading and copying those 2 files to the usb?

Try a reboot of your server, then check for updates.  Does that work?

 

Tried that last night, I'll do it again though

Link to post

i'm not getting an update, i'm running rc5, have restarted. checked again for updates, and it's status is up-to-date

 

still not getting offered the update through the normal update procedure, should i do it the old fashioned way, downloading and copying those 2 files to the usb?

Try a reboot of your server, then check for updates.  Does that work?

 

Tried that last night, I'll do it again though

 

There are upgrade instructions beyond that massive change log.  All you have to do is download the zip,  unpack and copy these files to your usb flash:

bzimage

bzroot

license.txt

make_bootable.bat

make_bootable_mac

memtest

readme.txt

 

Then reboot.

Link to post

So there is a default limetech supported docker repo? I do not see the repo in my repo list. What is the url?

 

From within the docker tab make sure you click "update repositories" next to the search box.  I didn't see the new stuff until I did that.

 

I don't have a search box or "update repositories" anywhere on my Dockers or Docker Repositories page in advanced or basic view.

 

Added limetech repository manually. Thanks sadkisson

The update applications / update repositories / search for dockers only show up if you have installed the community applications plugin which makes adding docker containers much easier

Link to post

all good now, same thing after the 2nd restart, checked for updates and said was up to date, so just did it manually

 

i'm not getting an update, i'm running rc5, have restarted. checked again for updates, and it's status is up-to-date

 

still not getting offered the update through the normal update procedure, should i do it the old fashioned way, downloading and copying those 2 files to the usb?

Try a reboot of your server, then check for updates.  Does that work?

 

Tried that last night, I'll do it again though

 

There are upgrade instructions beyond that massive change log.  All you have to do is download the zip,  unpack and copy these files to your usb flash:

bzimage

bzroot

license.txt

make_bootable.bat

make_bootable_mac

memtest

readme.txt

 

Then reboot.

Link to post

Welcome to the forum Anthony, and thank you for your kind words. 

 

First off, great work team, there's a ton of great new functionality in this release.  I'm impressed and excited to upgrade.

 

I have an issue I'd appreciate some feedback on:

 

My default firewall configuration blocks outbound communication.

 

Can you please elaborate?  I'm assuming you mean you've configured your router to block outbound communication in some form, is that correct?  If so, is that specifically restricted for only your server, and not your other client devices (laptops/desktops/mobile/etc)?

 

Is there a proper way to install plugins without internet access? 

 

A plugin is essentially a script which typically executes commands to download packages of software from the internet to your server, then install them using the installpkg command.  If your firewall configuration prohibits the unRAID server from talking to the Internet, then your only recourse is to manually download all the software packages required through a proxy device, then copy them all to the appropriate places on the flash devices (/boot/config/plugins for .plg files and /boot/extra for packages, and manually repeat this process over and over anytime there is an update.  This will also hold true for downloading unRAID Server OS updates.  If your system cannot connect to the Internet directly, you will have to resort to manually copying files to your flash device each time through a proxy device.

 

On a side note, does unRAID 6 require internet access for anything other than checking for updates?  I have local NTP, SMTP.

 

Thanks!

 

unRAID requires Internet access to register a trial key for your system or to request an extension, but key files can be installed by downloading them through a proxy device and then copying to the flash device over the network.  Paid registration keys can be purchased from our website by simply providing the GUID from the webGui Registration page (under Tools).

 

It also requires Internet access if you do not have a local SMTP server and wish to utilize e-mail notifications.

Link to post

Well Gary, there will be an Announcement post with a link to download the v5 plugin with a [glow=red,2,300]BIG FAT[/glow] warning: [glow=red,2,300]You're getting a vanilla install of v6 but you can go back if you hate it[/glow]".  Think that will be enough?  I suppose we can wrap it in a javascript alert - but if they don't read it in the Annoucement post, not likely they will read it anywhere else either right?

 

You and I would certainly get the message ... but it's amazing what I've seen folks do in the face of very strong warnings.  That warning SHOULD be enough -- but it wouldn't surprise me at all if folks still overlook it.    Simple fact:  somebody is likely to read the warning and download the plugin anyway "just to have it."    At some later point, they'll remember they have an automatic upgrade plugin, and simply install it & run it.  Voila!!  They've just reverted to a plain vanilla NAS and lost all their apps !!

 

I think you'd be a LOT safer in terms of potential consequences if the plugin did something along these lines ...

 

(1)  Do EXACTLY what you said it was going to do at first ... i.e. "... create a folder on the flash called 'previous' and move all the unRaid-5 release files there in addition to ./extra, ./plugins, ./config/plugins directories."

 

(2)  Now, if there were ANY plugins or extras moved (i.e. "stuff" that won't be in the v6 install)  put up a [glow=red,2,300]BIG FAT WARNING[/glow] [glow=red,2,300][/glow]  telling the user these are going to require manual installation after the upgrade and asking if he wants to proceed.

 

(3)  As long as the answer is Yes, proceed with the download and install of v6.    Otherwise, simply "go back" to the original state.

 

 

There may still be folks who proceed all the way through this and don't realize what they've done ... but it should be far fewer than those who might have simply ignored the announcement post warning, since in this case they're responding to something that's going to happen NOW instead of just a warning about a download.

 

Link to post

Stoked that V6 has dropped!  Sadly I can't utilize all the goodness within as I cannot gain network connectivity.    http://lime-technology.com/forum/index.php?topic=40720.0

 

Did we lose support for the Realtek 8111E ?  http://www.newegg.com/Product/Product.aspx?Item=N82E16813131631

 

Swore I saw some similar issues posted by users in earlier betas of v6

 

- Scott

 

My Media server has an RealTek 8111E on it and the NIC works.  (There are some issues with slow processors but that is not your issue.)  Do you have a monitor and keyboard attached to your server.  If so, get a syslog and post it.. Instructions for doing so are in the first post in this thread:

 

    http://lime-technology.com/forum/index.php?topic=9880.0

Link to post

Trying to upgrade from v5 and for some strange reason not being able to generate the boot file "Idlinux.sys".

I run Win7, reformatted the flash and followed the instructions.

Right click on "make_bootable.bat" and ran as "Administrator".

It brings up the cmd window with a message "Press any key to continue".

 

Press Enter and I see:

 

K:\syslinux\syslinux.exe -maf K:

completed

Press any key to continue ...

 

So it seems like it ran, but I don't see the "Idlinux.sys" file generated at flash root and hence unable to boot.

I see this in my v5 backup.

 

what could be the reason here.. I even disabled the virus guard but still no luck..

 

Link to post

Trying to upgrade from v5 and for some strange reason not being able to generate the boot file "Idlinux.sys".

I run Win7, reformatted the flash and followed the instructions.

Right click on "make_bootable.bat" and ran as "Administrator".

It brings up the cmd window with a message "Press any key to continue".

 

Press Enter and I see:

 

K:\syslinux\syslinux.exe -maf K:

completed

Press any key to continue ...

 

So it seems like it ran, but I don't see the "Idlinux.sys" file generated at flash root and hence unable to boot.

I see this in my v5 backup.

 

what could be the reason here.. I even disabled the virus guard but still no luck..

 

That file has the 'system' attribute set so typically it's not visible.  I think it's under Folder Options you can select to view "hidden and system files" to see it.  If the script ran you're good to go, eject and boot your server.

Link to post

Sorry to be that guy, but how do I remove this surfing banner at the top?

 

Settings/Display Settings/Show Banner Image set to No for no San Diego banner  :(

 

Edit: one reason we have that banner is so that you can have different banners set for different unRaid servers on your network.  Why have more than one server?  Good question.........................

 

How do you use a custom banner? I searched the wiki for "banner" and "custom banner" but it contains nothing on the subject.

Link to post

Sorry to be that guy, but how do I remove this surfing banner at the top?

 

Settings/Display Settings/Show Banner Image set to No for no San Diego banner  :(

 

Edit: one reason we have that banner is so that you can have different banners set for different unRaid servers on your network.  Why have more than one server?  Good question.........................

 

How do you use a custom banner? I searched the wiki for "banner" and "custom banner" but it contains nothing on the subject.

 

Yeah we haven't added a control for that yet  :(

Link to post

Trying to upgrade from v5 and for some strange reason not being able to generate the boot file "Idlinux.sys".

I run Win7, reformatted the flash and followed the instructions.

Right click on "make_bootable.bat" and ran as "Administrator".

It brings up the cmd window with a message "Press any key to continue".

 

Press Enter and I see:

 

K:\syslinux\syslinux.exe -maf K:

completed

Press any key to continue ...

 

So it seems like it ran, but I don't see the "Idlinux.sys" file generated at flash root and hence unable to boot.

I see this in my v5 backup.

 

what could be the reason here.. I even disabled the virus guard but still no luck..

 

That file has the 'system' attribute set so typically it's not visible.  I think it's under Folder Options you can select to view "hidden and system files" to see it.  If the script ran you're good to go, eject and boot your server.

 

Thanks. Didn't realize that one is a hidden system file. I had setup to show hidden files but not hidden system files.

My system didn't boot first try so that was another reason I thought the stick was not bootable.

I tried again now and all seems to be well.  :)

 

Link to post

How do you use a custom banner? I searched the wiki for "banner" and "custom banner" but it contains nothing on the subject.

 

Yeah we haven't added a control for that yet  :(

 

That can be added in 6.1 .... due out in December ...... 2014 - if memory serves correctly?  :P  ;D

Link to post

Followed the wiki upgrade process - couple of unexpected results (all good in the end though! just fyi):

 

Coming from 5.0.5

 

I wanted to retain my config (disks, shares etc), so copied over config files from the backup v5 ./config. Says not to bring over any plugin data, and wasnt entirely sure what counted as plugin data, and what didnt, so just copied over the obvious config files (network, share, users etc (sorry going from memory))

 

I didnt copy over the go file, and didnt copy over one or two files without an extension ('core' being one of them) - didnt know what they were, so err'd on the side of caution..

 

Start up server, and it boots up ok, but none of my disks are assigned - 24 slots, with nothing showing (am only on a plus license, so a bit confused bout that.. still am a bit hah.. Presume the array just wont start if I try with more slots assigned then Im licensed for?)

 

Bit nervous at this stage.. no slots assigned.. but just assigned them from saved screenshots, and all seemed fine. Not sure why the disks werent detected? Maybe I missed a file from ./config?

 

Start array, checking box to trust the parity - array starts no problem, but parity check starts anyway..? Thought the check box would avoid that (?). I stopped it while I went over the changes, and its running one now - 0 parity corrections after 10hrs, last I looked, so all good

 

My main worry was dropping the plugins, mysql in particular.. installed a MariaDB docker, pointed its db directory to a backup of the mysql dir and it just works - 100%. Permissions, everything! Very pleased.. particularly as I'd no idea how I'd be able to interact with the sql command line inside the docker..  :P will need to though, as I want to configure scheduled backups

 

anyway, thanks again all, despite what the above wall of text would have you believe, it went very very smoothly  :)

Link to post

Followed the wiki upgrade process - couple of unexpected results (all good in the end though! just fyi):

 

Coming from 5.0.5

 

I wanted to retain my config (disks, shares etc), so copied over config files from the backup v5 ./config. Says not to bring over any plugin data, and wasnt entirely sure what counted as plugin data, and what didnt, so just copied over the obvious config files (network, share, users etc (sorry going from memory))

 

I didnt copy over the go file, and didnt copy over one or two files without an extension ('core' being one of them) - didnt know what they were, so err'd on the side of caution..

 

Start up server, and it boots up ok, but none of my disks are assigned - 24 slots, with nothing showing (am only on a plus license, so a bit confused bout that.. still am a bit hah.. Presume the array just wont start if I try with more slots assigned then Im licensed for?)

Bit nervous at this stage.. no slots assigned.. but just assigned them from saved screenshots, and all seemed fine. Not sure why the disks werent detected? Maybe I missed a file from ./config?

That information is in the super.dat file which explains why the disk configuration was not carried across

 

Assigning the disks is a valid way forward as unRAID recognises disks previously used as data disks and keeps their contents.  The only disk that is critical is knowing which is the parity disk as getting that wrong can lead to data loss.

 

Start array, checking box to trust the parity - array starts no problem, but parity check starts anyway..? Thought the check box would avoid that (?). I stopped it while I went over the changes, and its running one now - 0 parity corrections after 10hrs, last I looked, so all good
This is standard behaviour.  The check box stops it doing a parity build from scratch (which would then ideally be followed by a parity check) - not from doing the parity check the first time the array is brought online..

 

My main worry was dropping the plugins, mysql in particular.. installed a MariaDB docker, pointed its db directory to a backup of the mysql dir and it just works - 100%. Permissions, everything! Very pleased.. particularly as I'd no idea how I'd be able to interact with the sql command line inside the docker..  :P will need to though, as I want to configure scheduled backups

Glad to hear that it worked.  I think many users are initially reluctant to try Docker as it something new and they do not understand the benefits it brings.  However it is good to hear that it went OK for you.  Any suggestions on wording that would make this change seem less fearsome will always be welcomed.

 

anyway, thanks again all, despite what the above wall of text would have you believe, it went very very smoothly  :)

Initially I thought the 'wall of text' was referring to the update guide  :)

 

Feedback on how things went and anything that initially caught you out will help with gradually improving the update guide.  Suggestions for improvement on the guide will always be welcomed.

Link to post

... installed a MariaDB docker, pointed its db directory to a backup of the mysql dir and it just works - 100%. Permissions, everything! Very pleased.. particularly as I'd no idea how I'd be able to interact with the sql command line inside the docker..  :P will need to though, as I want to configure scheduled backups...

I think there is a docker that provides a gui for mysql. Install the Community Applications plugin.

 

Current count of dockers for the unRAID community: 189. 8)

Link to post

... installed a MariaDB docker, pointed its db directory to a backup of the mysql dir and it just works - 100%. Permissions, everything! Very pleased.. particularly as I'd no idea how I'd be able to interact with the sql command line inside the docker..  :P will need to though, as I want to configure scheduled backups...

I think there is a docker that provides a gui for mysql. Install the Community Applications plugin.

 

Current count of dockers for the unRAID community: 189. 8)

 

It's the Maria-WebSQL in the beta repo of yep, you've guessed it, Sparklyballs  ;D

I've been using it and it works well.

Link to post

Well I updated today from v5 to v6 following Joes wiki guide.  I went down the route of formatting the USB and copying back only needed files and the array started up fine.

 

I then installed sonaar and sabnzbd dockers (converting from using plugins previously) and after a bit of head scratching around paths managed to get both working.

 

Many thanks to all involved - new interface is really slick  :)

Link to post
Guest
This topic is now closed to further replies.