TVheadend plugin for unRaid 6

156 posts in this topic Last Reply

Recommended Posts

I did another update with tvheadend_4.1-2409 and a more intuitive way to wakeup for recordings. (No more workarounds) You may have to disable/enable the plugin to change the setting to yes (if you want the wakeup - its pretty neat :) )


The server will wake up 5 minutes before the recording. Make sure you don't record to the cache disk if you dont want the server to shut down in the middle of the recording. Once the recording is done, the disk will eventually spin down and the sleep plugin will power down the server. Works like a charm for me!


Let me know what you think.


Hey Mettbrot.

Thank you for this great plugin. I'm a little bit confused about the "wake up for recording" feature. Everything is working pretty good, except the wake up for scheduled recordings. My server is configured to enter sleep mode after some time. Wake on Lan is working...


The Wake up for Recording Settings on the tvHeadend Plugin Page is linked to this article:


Do I need to setup something or is the whole wake up dvr feature handled by your plugin ?


I'm using a HDHomerun Tuner.


Thank you



Link to post
  • Replies 155
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This plugin installs a stable version of tvheadend, a TV streaming backend, on your unRaid machine. It supports DVB-S, DVB-S2, DVB-C, DVB-T, ATSC, IPTV, SAT>IP and HDHomeRun as input sources.

Just a quick note of thanks for still updating the plugin! Not all of us are excited about Dockers

You can see the status of tvheadend if you go to your unraid settings > tvheadend. Is it running? Is everything detected ok on the left side (media tree, dvb adapter, password)?

Posted Images

Automatic Wakeup

The whole feature should be handled by the plugin. It calls the script you linked (well, a modified version of it) when tvheadend is stopped. You can see this briefly in the settings window when you click on stop it should tell you the status at the bottom left

executing wakeup script... ...OK

You may also call the script manually via the console (replace $DATADIR with your tvheadend data directory eg. /mnt/user/Apps/tvheadend leave the quotation marks):

/usr/local/emhttp/plugins/tvheadend/scripts/ "$DATADIR/dvr/log"

After that you can check manually weather a timer has been set by typing

cat /sys/class/rtc/rtc0/wakealarm

into the console. It should show the timestamp of the next wakeup (next recording -5 minutes).


If it shows but your server does not wake up its a bios setting you have to enable. Something like RTC wake, wake on ring or something, I have seen a dozen of those options from time to time :P

Edited by Mettbrot
Link to post

Hi everyone!


I just took some time to update tvh to the latest 4.2.1 STABLE.

You read correctly, they finally released a stable version :)


I also fixed some problems with the dependencies, so the plugin should install correctly now - even on new installations! Please let me know if it doesn't!


Have fun!

Edited by Mettbrot
Link to post
  • 2 months later...


Hi Mettbrot,


playing around with your great plugin for a view days now but as I'm completely new to Tvheadend I have a few questions:


When setting up the server for the first time I get asked for the superuser login credentials every time I try to access the webUI.

But after adding my users this does not happen anymore.

I'm using a wildcard user (*) for my local clients without admin rights which is allowed to access the server from my local network

and an admin user which of course has admin rights and is also allowed to access the server locally.

So when opening the webUI I don't get asked to login anymore but the webUI shows me an unauthorized login and I'm allowed to see the EPG.

Am I right that I get logged in to the wildcard account automatically here?

I can also login to the admin acount and am able to see the configurations tab afterwards.

But I'm just wondering if this is the normal behaviour. Does the superuser login isn't needed or asked for anymore after setting up other users? The superuser login credentials aren't  working aswell via the manual login which I'm using to login to my admin account.


I also got a question regarding your wakeup script.

When using the first command you posted above without having an actual timer already setup I don't have any log file inside my dvr folder

/usr/local/emhttp/plugins/tvheadend/scripts/ "$DATADIR/dvr/log"

So I'm assuming I can only use your command when having setup a scheduled recording already so that the the above command can write the timer to the file system right?

So when does the script gets executed normally? Is it when unraid powers off?


Hope this all makes sense to you and you can clear up my noob questions. Thank you :)


Edited by Marv
Link to post

Hi there!


its never wrong to ask ;)


as far as I know the rights management inside tvheadend is very granular.  You can select rights like EPG or DVR or live tv per user. If your wildcard user doesn't have a password and can access the epg i suppose you will be "logged in" without password with that user when you visit the web interface and can only see the epg. You may log out at the top right corner and use your super user or a user with admin rights to login like you said. For other questions you might want to check the help function inside the web interface or ask at the forum over at Most of the time I am overwhelmed by all the functionality too. :) You can access even more functionality if you set the settings level to expert in the top right corner. 


As far as the wake up function goes, you have to put your actual configuration path into the command, for me it's would be like this:


/usr/local/emhttp/plugins/tvheadend/scripts/ "/mnt/user/Apps/tvheadend/dvr/log"

The log files only exist if there is an actual timer scheduled, correct. The script gets executed when tvheadend is shut down. That would include a shutdown of the server :) 


I hope I could help you. Don't hesitate to ask again if something's unclear. I will probably update the tvheadend version to the latest stable in mid-July. 

Edited by Mettbrot
Link to post



thanks for clarifying. :) So wakeup works like I thought.

But for the login at the top right corner.. I can't login with the superuser credentials there. The admin user works but the superuser only works for me before adding the other accounts.

Are you able to login as the superuser from the tvh webUI?

Edited by Marv
Link to post

I can logout at the top right corner and login using any of the accounts specified as users in the webUI plus the super user. As far as I remember you can't logout when you  are using the superuser because to the system you are not a regular user. It's kind of hacked into the UI I guess. I don't know how it works with asterisk users though.. sorry

Link to post
  • 2 months later...



I have just installed and setup this docker and all appears to be well apart from connecting to a server to decode some channels. I have a cline but my question is do I need to install anything else or can I just input the information into TVHeadend? do I need to download the oscam docker?


Thanks in advance!

Link to post
16 hours ago, mbc0 said:


Is there good reason that I should use the plugin instead of the docker?






The reason to use our container instead of the plugin is that our container is waaaay better than the plugin xD


On a serious note. Don't remember what a c-line is, but if it's newcamd protocol, you can add it directly in the CA section of tvheadend. If it's cccam and you don't have your own subscription card, I'm not going to help you. 


Every container has its own support thread in the docker forum. There might be multiple containers for the same app, so pay attention to which you install. Support thread is also linked to in CA. 

Link to post

ok, I thought I would try this plugin over the docker as you say it is the best ;-)  however, I cannot connect to it?


I have tried




nothing? the plugin is installed but I cannot see the gui?

Link to post
54 minutes ago, Mettbrot said:

You can see the status of tvheadend if you go to your unraid settings > tvheadend. Is it running? Is everything detected ok on the left side (media tree, dvb adapter, password)?


Well that was embarrassing!


Thank you :-)

Link to post


12 hours ago, CHBMB said:

The issue with one tuner working is a linux kernel issue.


So hopefully a different build of unRAID DVB might fix it? I have a DVBSky S952 V3.0 any one got one of these cards working for both tuners?

Link to post
25 minutes ago, Mettbrot said:

On the settings page there is a button "advanced configuration" where you can put in your superuser credentials. You can then add additional users through the tvheadend interface.


Many Thanks but I cannot type in there? I have tried stopping the plugin as well but it's greyed out?



Link to post

I guess you can only change values there if you disable tvheadend at the top. Play with disable enable a bit. I know it can be a bit tricky ;)


While you're at it: Change the data directory to your cache drive. Something like: /mnt/cache/Apps/tvheadend

Edited by Mettbrot
mention data directory
Link to post

That's great! thank you, I can now loging after disabling. entering details, re-enabling, I just have the issue where I don't think my dual tuner card is going to work as I can only get one tuner working :-(



Link to post
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.