Jump to content
poopiepants

Unraid Drive Clearing Hard Drive Clicking

10 posts in this topic Last Reply

Recommended Posts

Hello,

 

I was wondering if someone has ran into this before.

I am using the regular Unraid clearing for a hard drive I just added.

It is a 1.5 Terrabyte Seagate.

 

During the clearing stage I get 2 loud clicks about every 3-4 minutes.

At first I thought the HD was bad, but it does it continuously and at certain intervals.

 

Can someone confirm if this is common?

 

Thank you

 

 

Share this post


Link to post

A bad cable can cause commands sent from the controller to the drive to arive garbled.  Garbled commands frequently look like seeks to disk locations that don't exist.  These command (from what I've seen) cause the drives to make bad noises.  These types of errors are relatively common here.

 

I have personally had it happen two or three times.  The smartctl logs show log entries of invalid commands, while unRAID is reporting disk errors.   Fixing the cabling had eliminated these and restored proper functioning for me.

 

I have never had a drive go bad and exhibit the "clicking" sound.  Maybe I just don't know what it sounds like.  But a bad cable definately can causes "bad sounds" from the disk that could easily be confused with clicking!  ;)

 

(I agree that testing the heck out of a suspect drive is a good idea.)

Share this post


Link to post

Clicking in this context USUALLY means the drive is doing a re-cal, USUALLY because it lost its servo position...

 

=BAD  :o

 

Share this post


Link to post

I was wondering if someone has ran into this before.

I am using the regular Unraid clearing for a hard drive I just added.

It is a 1.5 Terrabyte Seagate.

 

During the clearing stage I get 2 loud clicks about every 3-4 minutes.

At first I thought the HD was bad, but it does it continuously and at certain intervals.

 

As soon as possible, obtain a SMART report for the drive, and run the SMART long test.  Please see the Troubleshooting page, Obtaining a SMART report section.

Share this post


Link to post

I replaced the sata cable and power cable and no more clicking.

I've scanned my syslog and everything seems good and filled the drive with data.

 

Thanks for all the advice!

Share this post


Link to post

I replaced the sata cable and power cable and no more clicking.

I've scanned my syslog and everything seems good and filled the drive with data.

 

Thanks for all the advice!

 

Glad that worked for you.  I'd say 80%+ of reported drive problems here are cabling problem.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.