[support] MakeMKV-RDP container Deprecated


Recommended Posts

20 hours ago, saarg said:

 

That has nothing to do with the config and keys. 

If the disc isn't recognized, it's a drive issue. 

My guess is that you have the wrong drive since it doesn't read the disc. You need this version of the drive: NS50 (SVC NS50) for UHD to work. 

 

i do have the SVC NS50.

 

looks like you have to downgrade the fw -- http://www.makemkv.com/forum2/viewtopic.php?f=16&t=17058.

Link to comment
5 hours ago, jonathanm said:

 

How did you determine that? I'm not familiar with the drive in question, but your screen shot shows NS40, not 50.

 

The model and the svc is different. It's stated on a label on the back which version it is. 

Link to comment
  • 2 weeks later...
On 3/18/2018 at 1:43 AM, saarg said:

 

Did you also upgrade to 6.5?

There is a permission issue in the latest version and the host permissions doesn't apply in the container. You could try to do a chmod 777 /dev/sr0 and chmod 777 /dev/sg0 and see if that helps. 

Restart the container after. 

 

Just want to say that this worked for me too. Unraid 6.5.0. Thought I was going mad! 

Thanks saarg

Link to comment
On 3/17/2018 at 8:43 PM, saarg said:

 

Did you also upgrade to 6.5?

There is a permission issue in the latest version and the host permissions doesn't apply in the container. You could try to do a chmod 777 /dev/sr0 and chmod 777 /dev/sg0 and see if that helps. 

Restart the container after. 

Thank you!

Link to comment
  • 7 months later...

Good day @saarg

I have the "/Unraid" path (host path 2) set to "/mnt/user/Media/MakeMKV/"

however in the GUI when I go to convert a video it attempts to save to "/nobody/Videos/nameofvid" and gives no way to navigate to any useful looking location.  Anything ideas on this one?

Best

 

NM.... I was reading backwards through the forum... on the second page I found the answer...

One must browse from Nobody, up a directory to UnRaid folder in the web gui

 

Edited by landS
Link to comment
  • 4 weeks later...

Hello Everyone.  

 

I have installed the MakeMKV-RDP Docker everything shows up like it should but when i run the application and MakeMKV starts processing the Blu-Ray i get a Fatal Error Occurred, Program will now exit. I am wondering if any one has seen this issue or know to resolve it?  from the main screen looks like a Java issue. I am running Unraid 6.6.6.  

image.thumb.png.f8793adadaf97bead89cb3574262bb52.png

 

Thank you for all the help. 

Link to comment
11 hours ago, ok4ayl said:

Hello Everyone.  

 

I have installed the MakeMKV-RDP Docker everything shows up like it should but when i run the application and MakeMKV starts processing the Blu-Ray i get a Fatal Error Occurred, Program will now exit. I am wondering if any one has seen this issue or know to resolve it?  from the main screen looks like a Java issue. I am running Unraid 6.6.6.  

image.thumb.png.f8793adadaf97bead89cb3574262bb52.png

 

Thank you for all the help. 

 

I think there are some issues with specific disc's and Java. I think it's a makemkv issue. I know @Djoss did some work on his container and was in contact with the makemkv author about it, but don't remember if there was a solution.

Try his container and see if it works. 

Link to comment
  • 4 weeks later...

I'm not quite sure what I'm supposed to do. My USB DVD player was attached to a USB hub and to the motherboard, and not working, getting the the "The program can't find any usable optical drives." I'm on version 6.6.6.

 

1872233832_Screenshot2019-02-04at11_24_55.thumb.png.f4552b9a4e627506588de89c1c9e4ad9.png1895119397_Screenshot2019-02-04at11_25_32.thumb.png.4b1e211a5cea0773037e716a1ddcc780.png

I did try adding device and /dev/sg0 like mentioned before, and the container wouldn't start, giving error message.

 

Link to comment
3 hours ago, mdipinto said:

I'm not quite sure what I'm supposed to do. My USB DVD player was attached to a USB hub and to the motherboard, and not working, getting the the "The program can't find any usable optical drives." I'm on version 6.6.6.

 

1872233832_Screenshot2019-02-04at11_24_55.thumb.png.f4552b9a4e627506588de89c1c9e4ad9.png1895119397_Screenshot2019-02-04at11_25_32.thumb.png.4b1e211a5cea0773037e716a1ddcc780.png

I did try adding device and /dev/sg0 like mentioned before, and the container wouldn't start, giving error message.

 

 

Looks like you are using djoss's makemkv container, so wrong support thread. 

 

By the look of it, you have only added one of the device names. You need both the /dev/sgX and /dev/srX. 

Link to comment

@mdipinto I spent a great amount of time attempting to pass a USB Odd to the makemkv container and failed. 

 

 Installed this makemkv-rdp container and had it working with the USB ODD within 5 minutes.   

 

Note that when you select the output folder from within the program, each time you must select 'UNRAID' 

Link to comment
6 hours ago, landS said:

@mdipinto I spent a great amount of time attempting to pass a USB Odd to the makemkv container and failed. 

 

 Installed this makemkv-rdp container and had it working with the USB ODD within 5 minutes.   

 

Note that when you select the output folder from within the program, each time you must select 'UNRAID' 

 

You should be able to set /unraid as default path in settings. 

Link to comment

@saarg

I have the /UNRAID path set to mnt/user/ShareName/Folder & the program outputs videos wonderfully to thus location.   

 

The only 'minor' issue is that when the container is started, from within the container, for each new ODD the default output folder is within the container itself and I must change this to /UNRAID if I want access to the MKV (and not blow up my Docker image space). 

Link to comment
7 hours ago, landS said:

@saarg

I have the /UNRAID path set to mnt/user/ShareName/Folder & the program outputs videos wonderfully to thus location.   

 

The only 'minor' issue is that when the container is started, from within the container, for each new ODD the default output folder is within the container itself and I must change this to /UNRAID if I want access to the MKV (and not blow up my Docker image space). 

 

I'm talking about the settings in makemkv, not the container template. I have never set the path every start of the container as I set it to /unraid in the settings of makemkv. 

Link to comment
  • 4 weeks later...
14 hours ago, nikezzz said:

Its in the newest version of Makemkv

https://www.makemkv.com/forum/viewtopic.php?f=19&t=18856&p=70119&hilit=Libredrive#p70119

 

it seems to be ripping faster and helps with some Disney Movies that weren’t able to rip before. This also gets rid of the HashedKeys.txt

 

It looks like it's built into Makemkv, so it should be supported. Didn't get the info here on either Arch (non-docker) or the container on unraid (But drive doesn't really work). So have to check the build log if there are any errors regarding building the libredrive libs. Thanks to dockerhub, I don't have any build logs from previous builds as they upgraded their website and delete all logs!

Link to comment

hey saarg,

 

just revived your container to check the new LibreDrive support with my drive – and it seems to be supported, great!

it only has one option not enabled and that one is the unrestricted drive speed (or very similar called). but i guess this is feature might be coming in the future and needs to be implemented by the developers of MakeMKV.

 

now your container offers an RDP session. i only ask myself which credentials to use for the connection (using none for user/password doesn't work).

 

thx.

Link to comment
7 hours ago, s.Oliver said:

hey saarg,

 

just revived your container to check the new LibreDrive support with my drive – and it seems to be supported, great!

it only has one option not enabled and that one is the unrestricted drive speed (or very similar called). but i guess this is feature might be coming in the future and needs to be implemented by the developers of MakeMKV.

 

now your container offers an RDP session. i only ask myself which credentials to use for the connection (using none for user/password doesn't work).

 

thx.

There is nothing I can do about libredrive. It's the makemkv author that needs to enable the features. 

My drives doesn't even have any Libredrive I FO at all. 

 

I don't remember there being any username/password at all for rdp. Long time since I used it, so have to check tomorrow. 

Edited by saarg
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.