Jump to content
saarg

[Support] MKVToolNix-gui container

51 posts in this topic Last Reply

Recommended Posts

MKVToolNix-gui Container

 

Description

MKVToolNix is a set of tools to create, alter and inspect Matroska files under Linux, other Unices and Windows. https://www.bunkus.org/videotools/mkvtoolnix/

 

 

Configuration

 

Ports

Fill in the rdp and WEB interface ports you want in the Port section of the template. Remember to NOT change the containerport!

 

 

Resolution

You can change the resolution in the Environment section to whatever you want.

Add WIDTH and HEIGHT in the Environment Variables. Default is WIDTH 1600, HEIGHT 1050.

 

Volume mapping

/config is the folder where MKVToolNix-gui saves it's settings. Where you save this on unRaid is up to you, but it should be on a cache only share.

 

/UnRaid is where you map the folder you want to save you MKVs.

 

 

Adding the container

 

If you want to use this container you have to add the text below to the template repositories box on the Docker page or search for the container in Community Applications.

 

https://github.com/tobbenb/docker-containers/tree/templates

 

Using MKVToolNix-gui

I do nut use this program myself, so for help regarding the use of it, google is your friend.

Share this post


Link to post

Known Issues

    - The Tabs for Input, Output and Attachments does not show the text for some reason I can't find.

 

Changelog

 

26a.07.2015

    - Fixed permissions on written files

 

26.07.2015

    - Initial Release

 

Share this post


Link to post

does this container require the other mkv container for the actual program?

 

Also if yes, where do I configure my mkv key I own?

 

Thanks

Myk

 

Share this post


Link to post

does this container require the other mkv container for the actual program?

 

Also if yes, where do I configure my mkv key I own?

 

Thanks

Myk

They don't have anything to do with each other.

For configuring the key you should read the first post in the MakeMKV thread.

Share this post


Link to post

Thanks for the docker. I can't seem to input any text. Mouse works fine but any keyboard input is lost.

 

Share this post


Link to post

Thanks for the docker. I can't seem to input any text. Mouse works fine but any keyboard input is lost.

Have you tried different browsers?

Share this post


Link to post

Yes. Tried ie on win 8.1 and safari on Mac. Also tried direct rdp. All the same!

It's the same problem here. I thought I tested this, but apparently I couldn't have  ::)

I will fix it some time today when I get the time to fiddle with it.

Share this post


Link to post

Yes. Tried ie on win 8.1 and safari on Mac. Also tried direct rdp. All the same!

It's the same problem here. I thought I tested this, but apparently I couldn't have  ::)

I will fix it some time today when I get the time to fiddle with it.

Please delete the container and add it again. That should fix it I hope. It happens here also on a system update from 6.0.1 with the docker installed to 6.1.

Share this post


Link to post

very buggy, keyboard does not work,some tabs are small with ... instead of names and after using it for 5min i got a black screen not matter what i do i cant get the program to open again. Stopping and restarting the docker results again black screen after the xrdp login dialog

Share this post


Link to post

Exactly what i was looking for, thank you  :)

 

Although i have the keyboard problem too, both via RDP and browser. I deleted the container and re-added as suggested, but no luck.

 

Is there anything else i can try?

 

Thank you,

 

Rich

Share this post


Link to post

I think I had to delete container and image or whatever the option is when it pops up. Deleting the container only didn't quite fix it.

Share this post


Link to post

Removing the docker container and image fixed the keyboard input issue for me.  However, the arrow keys and the DEL key still don't work. Using Firefox browser.

Share this post


Link to post

It probably have to do with keyboard layout in Xrdp. I'll have a look at it when I have the time, but it might be some weeks.

Share this post


Link to post

I've removed both container and image twice now and still have the same problem. Any help would be appreciated saarg, no matter the lead time  :)

Share this post


Link to post

I've removed both container and image twice now and still have the same problem. Any help would be appreciated saarg, no matter the lead time  :)

I don't think I have any other recommendations than was already made others earlier. Maybe try to delete the appdata folder also?

Which version of Unraid do you run?

Which browser are you using?

 

Share this post


Link to post

Always the most up to date, so currently 6.1.3 and i've tried using safari, chrome, IE and also RDP directly. All have the same problem with no keyboard input.

Share this post


Link to post

Always the most up to date, so currently 6.1.3 and i've tried using safari, chrome, IE and also RDP directly. All have the same problem with no keyboard input.

Could you try again removing both container and image and also use a new config folder?

Share this post


Link to post

Just tried again; new container, image and config folder, but still no keyboard i'm afraid  :(

Share this post


Link to post

no matter what i do, i get a black screen with this app.. reinstalling didnt solve this

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.