[Support] Linuxserver.io - Plex Media Server


Recommended Posts

On 8/22/2019 at 3:22 AM, showstopper said:

This is a hotfix released that 'should' fix the issue for the buffering on Samsung TV's. Any chance this docker could be updated please?

Do you have a link to the hotfix info? Have had issues with 4K playback on my Samsung TV and wonder if they are finally getting around to fixing it.

 

Edit: Nevermind, I think I've found it. Looks to be a recent issue that cropped up in past few days in a server update. My issue is much older and this doesn't seem like it addresses it.

 

Edit2: Btw, it looks like the fix for the issue @showstopper is talking about has been pushed to Plex Pass users, so restart the container and it should pick it up - v1.16.5.1554-1e5ff713d.

Edited by deusxanime
  • Like 1
Link to comment

Is there a way to edit the libraries after setting them up? 

 

The way I had it before I had a single directory and made multiple libraries for each. One for 4k, one for anime, one for any movies not 4k, etc. If I use this version, will I still be able to set each library separately? 

 

I have elders using my plex and I tend to steer them towards specific libraries instead of making collections. 

 

Currently have been using https://registry.hub.docker.com/u/limetech/plex/ with gpu transcoding and have been happy with it. 

 

I'd like to know before I do any damage to my database trying to get this up and running. 

Edited by Chezro
Link to comment
34 minutes ago, Chezro said:

Is there a way to edit the libraries after setting them up? 

 

The way I had it before I had a single directory and made multiple libraries for each. One for 4k, one for anime, one for any movies not 4k, etc. If I use this version, will I still be able to set each library separately? 

 

I have elders using my plex and I tend to steer them towards specific libraries instead of making collections. 

 

Currently have been using https://registry.hub.docker.com/u/limetech/plex/ with gpu transcoding and have been happy with it. 

 

I'd like to know before I do any damage to my database trying to get this up and running. 

You can set separate host paths for each. IE /mnt/users/movies/4k, /mnt/users/movies/anime, etc.  Map each one to a custom container path (plex_4k, plex_anime, etc). I think this will let you set custom libraries within the app. Never tried it though.

Edited by wgstarks
  • Like 1
Link to comment
2 hours ago, wgstarks said:

You can set separate host paths for each. IE /mnt/users/movies/4k, /mnt/users/movies/anime, etc.  Map each one to a custom container path (plex_4k, plex_anime, etc). I think this will let you set custom libraries within the app. Never tried it though.

With this screenshot in mind, are you saying I would need to add host paths and remove the ones here or would that break this particular container?:

image.thumb.png.2f639a0e983f6ca36aeddd5905dae87b.png


Considering I have only one path as is...I'm not sure I'm going to be able to match as neatly as before. I had three separately shareable libraries, a pre-roll and plugins. Is there a plex option that's better for me? Re-scanning isn't that much of an issue since I rename everything with filebot but separating my libraries, gpu transcoding and.....if possible, having a preroll, is.  

This is my current setup: 

image.thumb.png.a1222af46231288d2a5920f66f31ab66.png

Edited by Chezro
Link to comment

Assuming you are using the same version of Plex in both dockers and the same mappings, the functionality should be the same. You will only be changing the container.

 

I have never used pre-roll before though. Wasn’t even aware of it before your post. I would suggest testing with the new docker. Shutdown the old docker but don’t delete it. Install the new docker with the same mappings and see what happens. Several people have posted that they were able to switch without any issues.

Link to comment
2 minutes ago, dnoyeb said:

Quick question, I am guessing that "latest" version is only pulling from beta.  Any way to get the docker to update into 1.16.7.1597 instead?  Curious to try out the new transcoder.

 

 

Yes. You can set a specific version as described in the docker hub and github links in the first post.

Link to comment
1 minute ago, wgstarks said:

Yes. You can set a specific version as described in the docker hub and github links in the first post.

sweet, thanks.  anyone tried out the new transcoder for hardware encoding / decoding yet?  

Edited by dnoyeb
Link to comment
10 hours ago, Xaero said:

This might not work since 1.16.7.1597 is a "forum only" preview.

Depends on if they made the file available at the same endpoint. It may work, worth a try, but you need to use the long version with all the extra digits after the dash

Edited by aptalca
Link to comment

Hi all,

 

I successfully setup my Plex docker and it has been working fine.

 

I created a new Plex account to take advantage of a discount in lifetime Plex which was for new users only.

 

I signed out of my Plex account on the unraid server and signed in with my new account.

 

I was expecting it to pick up the Plex server and allow the new account to claim it, however it is stuck at "looking for servers" 

 

Any ideas? I have a bunch of users I am sharing with so any way to clear this up without a complete reinstall would be great

 

Thanks

Link to comment
On 8/31/2019 at 2:53 AM, aptalca said:

Depends on if they made the file available at the same endpoint. It may work, worth a try, but you need to use the long version with all the extra digits after the dash

 

It does not use the regular endpoint. It uses: https://artifacts.plex.tv/plex-media-server-alpha/1.16.7.1597-a6e223f7f/debian/plexmediaserver_1.16.7.1597-a6e223f7f_amd64.deb

 

Unfortunately there is no way to get this container to update to this.

Link to comment
2 minutes ago, MowMdown said:

 

It does not use the regular endpoint. It uses: https://artifacts.plex.tv/plex-media-server-alpha/1.16.7.1597-a6e223f7f/debian/plexmediaserver_1.16.7.1597-a6e223f7f_amd64.deb

 

Unfortunately there is no way to get this container to update to this.

Looking over on the main plex page I see folks running it after doing a manual upgrade:

 

Go into the console for that docker and do the following:

wget <paste link to Ubuntu version of 1597 Plex>

Wait for it to download, then

dpkg -i

Restart your plex docker and you’re done.

 

I haven't had a chance to try it just yet.  

Link to comment

I already updated a new plexinc / pms-docker container to the latest 1.16.7-1597 version and had to move/delete the 50-plex-update script (https://github.com/plexinc/pms-docker/blob/master/root/etc/cont-init.d/50-plex-update) because it always overwrites the installed version after reboot and rebooting is required after install. So after removing this script, autoupdate is not available anymore.

 

The 1.16.7-1597 version is working pretty good. I have no issues so far and can see that nvidia hw-acceleration for nvdec and nvenc is working fine.

Edited by snorr
Link to comment
On 9/3/2019 at 3:59 AM, Hola said:

Hi all,

 

I successfully setup my Plex docker and it has been working fine.

 

I created a new Plex account to take advantage of a discount in lifetime Plex which was for new users only.

 

I signed out of my Plex account on the unraid server and signed in with my new account.

 

I was expecting it to pick up the Plex server and allow the new account to claim it, however it is stuck at "looking for servers" 

 

Any ideas? I have a bunch of users I am sharing with so any way to clear this up without a complete reinstall would be great

 

Thanks

The server is already claimed by an account, you can't expect to just claim it by another.

 

Try removing it from the old account first

Link to comment

I noticed something unusual in the last 2 builds. I keep getting notifications that there's an update but when I update, it shows 0 B pulled and it still shows update available. It doesn't matter whether I use docker, latest or public in VERSION, it still thinks there's an update avail. I also tried a couple of commands from a terminal but it looks like its running on the latest build.

 

Other than this, everything is running fine. Does anyone have any suggestions? 



image.png.2e552a18f817f69ee1568aaa99322073.png

Link to comment
18 hours ago, Gr1m_X said:

My plex docker is not connecting when i try and connect to the webgui, log isnt showing any errors that i can see. If there is something else i could be looking for to see if i can fix it let me know please 😃

We need more info than "not connecting"

 

Is this a new container or existing? What address are you going to? What is the docker run command?

Link to comment

all of a sudden my Plex server wouldn't update media , I restarted the docker and now I get this in the log 

 

any help ?

 

File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file storage.py, line 89
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file scheduler.py, line 132
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file storage.py, line 89
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file scheduler.py, line 137
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file storage.py, line 89
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file runtime.py, line 1128
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file storage.py, line 89
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file scheduler.py, line 132
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file storage.py, line 89
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file scheduler.py, line 137
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file storage.py, line 89
Traceback (most recent call last):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 76, in emit
if self.shouldRollover(record):
File "/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/logging/handlers.py", line 157, in shouldRollover
self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
IOError: [Errno 107] Transport endpoint is not connected
Logged from file runtime.py, line 1128

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.