[Support] Linuxserver.io - Plex Media Server


4997 posts in this topic Last Reply

Recommended Posts

12 minutes ago, mgutt said:

I'm using the official image and I like to know why Plex is writing constantly to the docker.img (its the only active container, so it must be plex):

2114039408_2020-09-2016_06_32.png.bb9026b88b2470add9c9652044d195c2.png

 

Logging is already disabled. I used the console of the container and this command to find the changed files:


find / -mmin -10 -ls > /config/recent_modified_files5.txt

And it contains... sorry... need to check later. Someone started a movie while writing this post ^^

 

If 6.8.3, probably this

 

https://forums.unraid.net/bug-reports/stable-releases/683-docker-image-huge-amount-of-unnecessary-writes-on-cache-r733/

 

TLDR; update to 6.9

 

Link to post
  • Replies 5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yep, seems like the problem.   Not to be outdone... google.  And what do I find.... Hoopster's post from over a year ago. I see your post here regarding the iGPU not being enabled corr

Go to the appdata share and look in Plex\Library\Application Support\Plex Media Server\Crash Reports You will find folders for your previous versions named as the release version.

Application Name: Plex Media Server Application Site: https://plex.tv/ Docker Hub: https://hub.docker.com/r/linuxserver/plex/ Github: https://github.com/linuxserver/docker-plex  

Posted Images

The Plex forums are utterly useless for support, so I am trying here:

 

Server Version#: 4.34.4
Player Version#: Latest Roku

 

On the Roku, and only on the Roku, Plex routinely (almost always) skips to the next episode within the last 3-5 minutes of the current episode.

 

The files are not corrupt, and it does not happen on iPad or Android.  It also does not happen on every show, but it does on many.

 

When we return to the episode whose last few minutes were skipped, and then fast forward to the skipped part, it plays fine.

 

This has been happening for many months, across numerous Roku and Plex software updates.

 

Any advice would be great.

Link to post
1 hour ago, tucansam said:

The Plex forums are utterly useless for support, so I am trying here:

 

Server Version#: 4.34.4
Player Version#: Latest Roku

 

On the Roku, and only on the Roku, Plex routinely (almost always) skips to the next episode within the last 3-5 minutes of the current episode.

 

The files are not corrupt, and it does not happen on iPad or Android.  It also does not happen on every show, but it does on many.

 

When we return to the episode whose last few minutes were skipped, and then fast forward to the skipped part, it plays fine.

 

This has been happening for many months, across numerous Roku and Plex software updates.

 

Any advice would be great.

Have you tried turning off auto play next episode?

Link to post

So, today I changed the mail and password for my server. Then lost access to it, via ip or app.

Tried renaming "Preferences.xml" to "Preferences.xml.old", no luck.

Then changed the appdata path, from "plex" to "plexNew" and still coulnd't find the server.

Removed image and downloaded again, with the same change on appdata path and no luck.

Tried plexinc docker image and worked.

Don't know what else to change to see if your image can work again...

Link to post

Hi all,

 

 

I'm getting transcode issue for the past few days with content off my gdrive..

 

anyone can help me.

 

I'm always getting transcode error.

 

Denying access to transcode of key /library/metadata/23967 due to terminated session

 

I tried to reinstall the docker.

Change the transcode folder

nothing is working

 

unraid-diagnostics-20200927-2005.zip

Edited by francrouge
Link to post

I have my server hooked up to a TV via hdmi and often view Unraid that way. Is there a way to play Plex movies directly? For instance, in Unraid, go to the Plex container, access the Plex webgui, select a movie and play it?  I cant seem to get it to work, actually for some reason often the webgui wont even let me log in when I am in Unraid directly it its Firefox browser.  But when I log into Unraid with my laptop using Chrome, then open the Plex webgui it works fine.  But I would like to do it from Unraid directly in its firefox browser.

Link to post

Hardware encoding seems to be broken in one of the newest container image updates. The Plex server believes the Nvidia driver is out of date and will not do hardware encoding.
 

Sep 28, 2020 06:59:19.216 [0x152ceebf5700] ERROR - [Transcode] [FFMPEG] - The minimum required Nvidia driver for nvenc is 418.30 or newer
Sep 28, 2020 06:59:19.217 [0x152cec7e3700] ERROR - [Transcode] [FFMPEG] - Driver does not support the required nvenc API version. Required: 10.0 Found: 9.1

I'm on Nvidia edition 6.8.3 with the 440.59 driver.

Link to post
33 minutes ago, SelfSD said:

Hardware encoding seems to be broken in one of the newest container image updates. The Plex server believes the Nvidia driver is out of date and will not do hardware encoding.
 


Sep 28, 2020 06:59:19.216 [0x152ceebf5700] ERROR - [Transcode] [FFMPEG] - The minimum required Nvidia driver for nvenc is 418.30 or newer
Sep 28, 2020 06:59:19.217 [0x152cec7e3700] ERROR - [Transcode] [FFMPEG] - Driver does not support the required nvenc API version. Required: 10.0 Found: 9.1

I'm on Nvidia edition 6.8.3 with the 440.59 driver.

Since we don't bundle any Nvidia drivers in the container, it's plex that is the cause of this I would think. You should report it to plex.

Link to post

I posted in the Plex forums and have gotten some replies so far. In 1.20.2 the required API version was updated. Public release is 1.20.1 at the moment and currently works.

 

I just got a reply from someone who ran driver version 440.100 and had the same issue running Ubuntu Server on bare metal. For them upgrading to 450.66 fixed the issue.

 

Should I post in the Unraid Nvidia topic too in case it requires a driver update to work? It would really suck if NVENC hardware encoding completely stops working when 1.20.2 is released to the public. ☹️

Link to post

When you open the Plex Webui (directly on the server) will it allow you to log into Plex and play movies right there in the Firefox browser?  It seems like it should since I can from other devices and browsers and Plex says it supports playback on Firefox....however, I cant seem to get it to work. Wondering if it works for others.

 

Thanks

Link to post

I just got another reply from another user who said the following:

 

Quote

 

Despite what the error message says, the Nvidia Video Codec SDK V10 has the following minimum driver requirements:

Windows: Driver version 445.87 or higher

Linux: Driver version 450.51 or higher

 

 

If this is true everyone who uses the Nvidia Unraid build is SOL once 1.20.2 of Plex drops for the public. ☹️

 

Edit: Just confirmed this on Nvidia's websites: https://developer.nvidia.com/nvidia-video-codec-sdk/download

Edited by SelfSD
Link to post

Is anyone doing this with Plex? He is transcoding his content totally off of RAM instead of a hdd/ssd. Is anyone else doing this?  Curious anyone elses results with this and how much ram its taking up....especially when transcoding a 4k blueray down to a 720p or 1080p.

 

Link to post
44 minutes ago, SPOautos said:

Is anyone doing this with Plex? He is transcoding his content totally off of RAM instead of a hdd/ssd.

Many people are doing this, me included:

https://forums.unraid.net/topic/35878-plex-guide-to-moving-transcoding-to-ram/page/12/?tab=comments#comment-894460

 

Plex cleans the Ramdisk by its owns l the most people use 4GB. The impact is there because even this tweak bypasses Unraid's SHFS overhead.

 

In addition you protect your SSD against wear out.

Edited by mgutt
Link to post
4 minutes ago, mgutt said:

Many people are doing this, me included:

https://forums.unraid.net/topic/35878-plex-guide-to-moving-transcoding-to-ram/page/12/?tab=comments#comment-894460

 

Plex cleans the Ramdisk by its owns l the most people use 4GB. The impact is there because even this tweak bypasses Unraid's SHFS overhead.

 

In addition you protect your SSD against wear out.

 

Can this along side the change you showed help with general playback of videos? I have 4K blueray videos that we like to play and while it plays them find, the CPU runs between 40% - 70% and I'd like to bring that down some. I'm wondering if these adaptations can have any impact on playback or if that will still be mostly using the CPU.

 

Is 4GB enough to transcode a 4K blueray?  

 

I guess I need to visit that other thread  lol

Link to post
1 hour ago, SPOautos said:

Can this along side the change you showed help with general playback of videos? I

I depends. If you are using hardware encoding your cpu cores have enough power left for Unraid's SHFS overhead. But if your videos are transcoded through CPU, than it should help to reduce the total load, especially if multiple movies are transcoded. But it depends on how fast your CPUs is, how many cores it has and which cores are used by Plex and Unraid.

 

Regarding the size: No problem. Plex transcodes only x MB parts of a movie even if it's 4K, while it's playing (open the transcode folder while a movie is transcoded and you can see these files). And if the transcode folder becomes out of space, Plex starts purging it.

Edited by mgutt
Link to post
2 hours ago, Bolagnaise said:

10 days since last plexpass docker update? Plexpass version 1.20.2.3402 has been waiting for update for a while now for me. Currently on Version 1.20.2.3370

Everything's up to date. It's explained in the readme

Link to post
1 hour ago, aptalca said:

Everything's up to date. It's explained in the readme

Sorry, i’m still a little confused. Are you saying that plexpass version 120.2.3402 is already available? I’m logged into my plex account with a plexpass and have ‘latest’ set in my version. 

Link to post
12 minutes ago, Bolagnaise said:

Sorry, i’m still a little confused. Are you saying that plexpass version 120.2.3402 is already available? I’m logged into my plex account with a plexpass and have ‘latest’ set in my version. 

Restart your container and watch the logs

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.