[Support] Linuxserver.io - Plex Media Server


Recommended Posts

Hi,

After updating to 1.22.1.4228-724c56e62 I appear to be unable to play files in firefox or edge.  I am able to navigate plex, and click into the info screens for items, but I cannot play an item. I click play and nothing happens. It looks like the browser registers the click but nothing changes.

 

Chrome works just fine with no issues.

 

I have tested on multiple computers.

 

Any ideas, I have removed all ad blockers, and cleared my cookies, etc.

Edited by guyonphone
Link to comment
9 hours ago, guyonphone said:

Chrome works just fine with no issues.

That suggests there is no problem with this docker or the way you are using it, but instead a problem with plex and/or your browsers. Have you checked on the plex forums for help with this?

Link to comment
3 hours ago, trurl said:

That suggests there is no problem with this docker or the way you are using it, but instead a problem with plex and/or your browsers. Have you checked on the plex forums for help with this?

 

Thank You, I ended up rolling back to a previous version and its working now. Must be an issue with the release.

Link to comment
1 hour ago, guyonphone said:

 

Thank You, I ended up rolling back to a previous version and its working now. Must be an issue with the release.

 

This might be related to a recent Plex release that is upgrading the secure portion to using Let's Encrypt that might not be playing nicely with some browsers.  I just tried and it's working for me in Firefox, Edge (Chromium) and Chrome.  Not sure if that is fully implemented in the latest docker release and if Plex is forcing a change in the secure connections settings on certain installs.

 

https://support.plex.tv/articles/206225077-how-to-use-secure-server-connections/?utm_source=Plex&utm_medium=email&utm_content=network_security_button&utm_campaign=Newsletter_Mar_24_2021_RoW_PP

 

I do clear my cache/cookies once a month or so in all my browsers (CTRL + SHIFT + DELETE) in most to bring up the dialog.  Maybe that might clear some things up for you as well if you are using the secure access mode.

Edited by axipher
Added link to Plex Article
Link to comment
/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/difflib.py:437: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal

a[besti+bestsize] == b[bestj+bestsize]:
/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/difflib.py:433: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal

a[besti-1] == b[bestj-1]:

 

 

running 1.22.1.4228

 

I'm getting the warning above usually during scans 

I see one other person with the issue below and of course no help from plex forum.

has anyone else seen this?

@luigi408 did you ever fix this?

 

https://forums.plex.tv/t/unicodewarning-errors-while-updating-library-metadata/545011/4

Link to comment

Quick and maybe a stupid question.

I just migrated from Binhex-Plex to Linuxserver.io, because of hardware transcoding. I know Binhex has one for plexpass, for HW-transcoding, as far as I know. But that just confuses me & SpaceinvaderOne made a video using linuxservers docker, so for me, is was a good place to start.

 

But my question is, does the hardware transcode option only visible if you have a PlexPass? I can se my options for transcoding is different from the one he(SpaceinvaderOne) has in his video, using the same docker. Or have I made a mistake when I migrated?

Edit: Nvm, it all looks fine, except the settings. But when I press play nothing happens. It's seems a mistake have been made :E

Edited by Michelle Bausager
Link to comment
30 minutes ago, ConnerVT said:

The Plex application requires a PlexPass to enable HW transcoding, regardless of what platform you are using.

Yes, but I would like to see the grayed-option before I buy.

 

My question boils down to; is it greyed-out or not visible before the purchase? 

Edit: It's not visible. Now to figure out why the migration didn't work :E

Edited by Michelle Bausager
New Info
Link to comment

Hrm, anyone else having issues HW transcoding 4k HEVC HDR content? My 4K HEVC content is hardware transcoding perfectly on my intel 10400, but throw HDR into the mix and it just reverts back to software. I have the HDR tone mapping option enabled of course.

Link to comment
26 minutes ago, coblck said:

Fine with my i5 7400 

Yeah suspecting it may be an issue with 10000 series?  I dunno, have to spend some time getting logs for it I guess. Could have sworn I was watching a video file with it transcoding perfectly fine just the other day though, wonder if I can downgrade easily from latest version to test that theory...

Link to comment
12 minutes ago, coblck said:

Did notice there is an update on my docker waiting but not updated yet maybe be worth rolling back see if OK 

Hrm thought this would be easy, but can't find a place anywhere in the linuxserver.io package to enter the tag so guessing I need to manually add it as a new variable, anyone more knowledgeable than myself mind sharing how to set the specific tag to use please?

Link to comment

Nevermind figured it out! And indeed, everything is working perfectly again on the older image. I swapped back to 'version-1.22.0.4163-d8c4875dd' with linuxserver.io image and that did the trick for me. Unsure if it's just me, but might be worth mentioning to save some people headaches should it be an actual issue.

Link to comment

Hello all, posting here if anyone else runs into this issue.

 

Saw there was an update to Unraid 6.9.1 this morning. Update installed with no issue and restarted my server. On reboot, my Plex container was not started (should be auto-start). When I went to start it, it just gave me the "execution error: bad parameter" error. I tried editing the docker settings, and when I went back to the Docker tab, Plex was gone. This was odd as it was working perfectly last night.

 

I tried to add the container again from my previous image but kept getting this error:image.thumb.png.303b37a9fa9d09b902ff61d50ad42df6.png

 

I searched for "nvidia driver" and installed this one as it seemed like the previous "Unraid Nvidia" plugin that I had downloaded before wasn't there anymore (see screenshot). 

 

Once that finished installing, I re-added the container from my previous image and it fired up no problem. Hope this helps.

image.png

Link to comment

I updated to the latest version today after I was notified by Plex that a new "everyone" version was available. Now when I go to settings I get the error "server settings are unavailable". I followed the instructions and deleted the login information from my Preferences.xml file. But then it wouldn't let me claim my server. Rather than going to the login it just says "server settings are unavailable". I was finally able to log my server back in by using the PLEX_CLAIM Docker variable. It still won't let me get to my settings though. Any ideas?

Link to comment
29 minutes ago, Taddeusz said:

I updated to the latest version today after I was notified by Plex that a new "everyone" version was available. Now when I go to settings I get the error "server settings are unavailable". I followed the instructions and deleted the login information from my Preferences.xml file. But then it wouldn't let me claim my server. Rather than going to the login it just says "server settings are unavailable". I was finally able to log my server back in by using the PLEX_CLAIM Docker variable. It still won't let me get to my settings though. Any ideas?

I am having the same problem

 

Checking the logs, I get:

 

Plex Plug-in [com.plexapp.system]: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

Plex Plug-in [com.plexapp.system]: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

/usr/lib/plexmediaserver/Plex Relay: error while loading shared libraries: libcurl.so: cannot open shared object file: No such file or directory

 

Link to comment
29 minutes ago, resuarez said:

I am having the same problem

 

Checking the logs, I get:

 


Plex Plug-in [com.plexapp.system]: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

Plex Plug-in [com.plexapp.system]: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

/usr/lib/plexmediaserver/Plex Relay: error while loading shared libraries: libcurl.so: cannot open shared object file: No such file or directory

 

Exactly the same issue here :(

Link to comment
42 minutes ago, resuarez said:

I am having the same problem

 

Checking the logs, I get:

 


Plex Plug-in [com.plexapp.system]: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

Plex Plug-in [com.plexapp.system]: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

/usr/lib/plexmediaserver/Plex Relay: error while loading shared libraries: libcurl.so: cannot open shared object file: No such file or directory

 

Same issue here, running latest version of UnRaid and Plex. Same exact errors in the logs, cannot access Plex remotely or access the server settings. Only local network users are able to play files from Plex. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.