[Support] Linuxserver.io - Plex Media Server


Recommended Posts

1 hour ago, tucansam said:

Thrown into an i7-2600 unraid/plex server

 

if you talk about using the igpu from the i7 instead, its a pretty old cpu when i see correctly, sandy bridge, it can decode/encode AVC (x264) only, so when your source media is AVC only, yes, should be ok, hevc will not work in hardware on this igpu.

 

same for your GTX750ti ...

 

https://en.wikipedia.org/wiki/Intel_Quick_Sync_Video

 

https://developer.nvidia.com/video-encode-and-decode-gpu-support-matrix-new

Link to comment
1 hour ago, tucansam said:

Not sure what all of that means.

 

me neither ;)

 

14 hours ago, tucansam said:

I have a GTX750ti that is about to be replaced.

GPU replaced with .. ?

 

14 hours ago, tucansam said:

Thrown into an i7-2600 unraid/plex server,

this is now a CPU with integrated iGPU

 

in terms you mean this (take the GPU out, use the iGPU from this CPU instead), see my above post.

 

only you know in which format your media's are at home, if they are AVC (x264, h264, ..) then yes, both of your pointed devices (GTX750ti and you iGPU from sandy bridge) would be capable todo this ... while the Nvidia Card (NVENC) is limited to 3 simultan streams (been 2 before, but meanwhile its 3)

 

Nvidia Matrix ...

 

here the encodings for your card

image.thumb.png.095919853780644335badb7121b86984.png

 

while HEVC (modern Format) is not even decode supported (hardware accel reading ...) so lets say all 4k's will be a pain ...

image.thumb.png.3948dd478c1d95f33c8b71045e8b263e.png

Link to comment
Posted (edited)

Latest Linuxserver Plex container release introduces permission errors in unRAID (maybe related to 6.10?).

 

Upgraded to 6.10.1 a few days ago with no major issues, Plex was working fine last night, and this morning Plex from Linuxserver stopped working with permission errors:

 

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.26.2.5797-5bd057d2b/PLEX MEDIA SERVER/48e796f0-ca99-405e-6d6b99b6-b191e5f8.dmp
Starting Plex Media Server.
libc++abi: terminating with uncaught exception of type std::runtime_error: Codecs: Initialize: 'boost::filesystem::create_directory: Permission denied: "/config/Library/Application Support/Plex Media Server/Codecs/994f4ee-4302-linux-x86_64"'

 

I have containers on auto-update, and the Plex container updated during the night, so I rolled back to version 1.26.1 (edited repository to linuxserver/plex:1.26.1) and no more errors.

 

Question is if this is an issue on Linuxserver's Plex latest release, or if 6.10 introduced something which breaks new releases?

 

EDIT: Reddit made me aware that the error was local, ran the following as a user script and it solved the permission issue, will check back if it reappears:

 

#!/bin/sh

 

for dir in "/mnt/user/appdata/plex/"

do

`echo $dir` `chmod -R ug+rw,ug+X,o-rwx $dir`

chown -R nobody:users $dir

done

Edited by goodyear
Link to comment

Has anyone else been having problems with Plex over the last couple of weeks where it crashes overnight, and the docker can't be stopped or killed?  I'm having to reboot every couple of days because of this. 

 

Or, are there other commands I can use instead of docker stop plex and docker kill plex?

Link to comment

I updated this docker today, and now I can no longer access media.

Note: This issue probably has nothing to do with this docker, but I'd just appreciate a heads up as to where to start looking!

 

Plex starts as normal, and is accessible via the web ui on both local and remote devices. However, my media (one called tv, the other called movies) doesn't show anything. Instead I see

"Something went wrong

An unexpected error occurred."

on both. This is when clicking "library" or "recommended" on each source.

This was working fine until I checked it today, and I haven't updated anything else other than the community applications and unassigned devices plugins on unraid aside from that. I tried rebooting the server and restarting plex too.

Any advice appreciated! I'm sure this is something simple. Thank you!

Link to comment

Hello,

 

Recently updated the container and hardware transcoding no longer works.  Nothing shows on the dashboard or when using smi in the console.  No settings were changed in the docker itself, still has runtime enabled as well as the gpuid.  In plex itself the hardware acceleration box has been checked.

 

Any idea what might be causing this?  Kind of kicking myself as I didn't even mean to update the plex docker.

Link to comment
15 minutes ago, NserUame said:

Hello,

 

Recently updated the container and hardware transcoding no longer works.  Nothing shows on the dashboard or when using smi in the console.  No settings were changed in the docker itself, still has runtime enabled as well as the gpuid.  In plex itself the hardware acceleration box has been checked.

 

Any idea what might be causing this?  Kind of kicking myself as I didn't even mean to update the plex docker.

Which version of unRAID? I haven't been able to get it to work on anything after 6.9.2

Link to comment

Got the latest update and the now getting: Got exception from request handler: std::bad_cast

 

Anyone else seeing this?  After all the streaming they have added and now this, I am ready to leave Plex for good.

Link to comment
On 5/29/2022 at 7:05 AM, ctexy said:

I updated this docker today, and now I can no longer access media.

Note: This issue probably has nothing to do with this docker, but I'd just appreciate a heads up as to where to start looking!

 

Plex starts as normal, and is accessible via the web ui on both local and remote devices. However, my media (one called tv, the other called movies) doesn't show anything. Instead I see

"Something went wrong

An unexpected error occurred."

on both. This is when clicking "library" or "recommended" on each source.

This was working fine until I checked it today, and I haven't updated anything else other than the community applications and unassigned devices plugins on unraid aside from that. I tried rebooting the server and restarting plex too.

Any advice appreciated! I'm sure this is something simple. Thank you!

 

just updated the docker this morning and ran into the same issue.. "Something went wrong"

 

I have been running 6.10.1 since it came out without issues so something must have gone wrong with the docker update.

Link to comment
1 hour ago, DisposableHero said:

 

just updated the docker this morning and ran into the same issue.. "Something went wrong"

 

I have been running 6.10.1 since it came out without issues so something must have gone wrong with the docker update.

 

fixed it by repairing the database

 

 

Link to comment

Is it possible to stop the plex media server service within this container while it is running? My db is corrupt and I'd like to repair it using the built in SQLite binary, but need the service to be stopped first.

Link to comment
26 minutes ago, knalbone said:

Is it possible to stop the plex media server service within this container while it is running? My db is corrupt and I'd like to repair it using the built in SQLite binary, but need the service to be stopped first.

The two posts above yours describe how to stop the container, and scan/repair the database.

Link to comment
  • 2 weeks later...

Gang,

 

I am going to be upgrading from an i7-2600 to an i7-9700F.  

 

I'm upgrading a couple of other systems too, and will have a GTX 1050ti laying around unused.

 

From the standpoint of Plex transcoding, 1080p and possibly 4k, will the 1050ti have an appreciable impact in helping, or is the 9700F sufficient enough on its own? 

 

I have several family members who stream 1080p content and often share my 10mbps upstream connection, so I have streams limited to 3-4mbps.  As such, as soon as I get three or more transcoding, my i7-2600 pegs.  I know the 9700F is a huge upgrade, I'm just wondering if the 1050ti is worth hanging onto and putting in my unraid server for Plex.

 

If so, I'm not sure how to enable its use in the docker container.

 

Thanks.

Edited by tucansam
Link to comment
2 hours ago, tucansam said:

From the standpoint of Plex transcoding, 1080p and possibly 4k, will the 1050ti have an appreciable impact in helping, or is the 9700F sufficient enough on its own? 

you know the "F" versions dont have a igpu included ? so you loose the igpu hardware transcoding then ...

 

a 9700 would be better therefore then a 1050ti (which is limited to 3 transcodes max afaik)

Link to comment
6 hours ago, alturismo said:

you know the "F" versions dont have a igpu included ? so you loose the igpu hardware transcoding then ...

 

a 9700 would be better therefore then a 1050ti (which is limited to 3 transcodes max afaik)

 

Thank you.  Yes, I have an old pcie-1x NVS200 to use as a video card in that server, unless the 1050ti would be the better option.  Was just trying to figure out if the 9700 would be better served by giving it a higher-end video card.

Link to comment

Let's not overthink this one.  A i7-9700F + GTX1050ti > i7-2600 + iGPU.  By a significant amount.  Especially if you have the hardware in hand.

 

For all hardware transcoding, Plex Pass is required.  Install the NVidia plugin.  Follow the excellent directions in the plugin's support thread.  Enjoy videos.

 

As for 4K to 1080 transcoding, it is always a bad idea, no matter what hardware you are using.  I've yet to come across anyone who does so without issues.

Link to comment

Hi All, 

 

So, I've just noticed sort of a weird problem, and, since I'm not sure how to search for the answer, I figured I'd raise it here. Went to access Plex today, and my libraries weren't available under my main, admin account, but I was still connected to the server. Updated the docker and Unraid to the latest versions, no luck.

For science, I made a new managed account while logged in as the admin. I then accessed Plex via the new managed account. The managed account has full access to all my libraries. I'm assuming this is some sort of permissions problem with the docker update last night (6/14/2022), but I'm really at a loss. Has anyone else experienced this? Has anyone got any idea of how I can get my regular account to work properly again? I can get logs if you need them, but I wasn't sure which ones might be helpful. Thanks in advance for your help! 

Link to comment

I hope that someone can help I just rollback my unraid server to 6.9 to get someone else to work, but in doing so, my plex server is now showing my the following error when I try to start it

image.png.ce0559bbe1f3da491a67cced84a5f96c.png

 

my question is: if I create a new Plex container and copied in my old Plex container files and folders then would this resolve the issue ? or is there a easier way to resolve this ?

 

I also attached my log file from the container

 

PlexLog.txt

Link to comment

Hey Chris, 

 

That should work, yeah. What I would recommend, however (and what worked for me), was to move from the Linux Server repository to the Binhex-Plex repository. I just used the same mappings and settings on both dockers, deleted the Linux docker, and was back up and running within a half an hour. I hope this helps. 

Link to comment

This has probably been asked before, but upon searching it seems that the situation keeps changing.

Using my Ryzen 2400G, I'm trying to get hw transcoding working with the container, and in theory it should really work.

ich777's Jellyfin container utilises the iGPU, and mauimauer has a working container on dockerhub.

Is there any way for this function to be merged into lsio?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.