[Support] Linuxserver.io - Plex Media Server


5050 posts in this topic Last Reply

Recommended Posts

Just noticed this too. Didn't have as solution on how to update to the latest public version...

 

Just tried deleting the "PUBLIC" variable from the docker settings, resorted the docker, and the Plex Server settings are still telling me to install manually...

 

Looks like the server file isn't posted as per my server logs..

 

Atempting to upgrade to:
https://downloads.plex.tv/plex-media-server/%20/plexmediaserver_%20_amd64.deb:
2017-02-02 08:41:07 ERROR 404: Not Found.

 

I'm getting the same message in my logs. Is this Plex or container related?

From my quick glance at the logs looks like the plex version number seems to be missing - instead it's been replaced with %20 in the file name.

 

Strange, I don’t see this behavior in my logs.

Atempting to upgrade to: 1.3.4.3285-b46e0ea
2017-02-02 16:21:43 URL:https://downloads.plex.tv/plex-media-server/1.3.4.3285-b46e0ea/plexmediaserver_1.3.4.3285-b46e0ea_amd64.deb [101364400/101364400] -> "/tmp/plexmediaserver_1.3.4.3285-b46e0ea_amd64.deb" [1]
(Reading database ... 10918 files and directories currently installed.)
Preparing to unpack .../plexmediaserver_1.3.4.3285-b46e0ea_amd64.deb ...
/var/lib/dpkg/info/plexmediaserver.prerm: 13: /var/lib/dpkg/info/plexmediaserver.prerm: stop: not found
Unpacking plexmediaserver (1.3.4.3285-b46e0ea) over (1.3.3.3148-b38628e) ...
Setting up plexmediaserver (1.3.4.3285-b46e0ea) ...
Processing triggers for systemd (229-4ubuntu13) ...
[cont-init.d] 50-plex-update: exited 0.
[cont-init.d] done.
[services.d] starting services
Starting Plex Media Server.

 

What unRAID version are you running?

 

Scrap that, just seen your signature and you're on the same version as me ?

Link to post
  • Replies 5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Go to the appdata share and look in Plex\Library\Application Support\Plex Media Server\Crash Reports You will find folders for your previous versions named as the release version.

Yep, seems like the problem.   Not to be outdone... google.  And what do I find.... Hoopster's post from over a year ago. I see your post here regarding the iGPU not being enabled corr

Application Name: Plex Media Server Application Site: https://plex.tv/ Docker Hub: https://hub.docker.com/r/linuxserver/plex/ Github: https://github.com/linuxserver/docker-plex  

Posted Images

Just noticed this too. Didn't have as solution on how to update to the latest public version...

 

Just tried deleting the "PUBLIC" variable from the docker settings, resorted the docker, and the Plex Server settings are still telling me to install manually...

 

Looks like the server file isn't posted as per my server logs..

 

Atempting to upgrade to:
https://downloads.plex.tv/plex-media-server/%20/plexmediaserver_%20_amd64.deb:
2017-02-02 08:41:07 ERROR 404: Not Found.

 

I'm getting the same message in my logs. Is this Plex or container related?

From my quick glance at the logs looks like the plex version number seems to be missing - instead it's been replaced with %20 in the file name.

 

Strange, I don’t see this behavior in my logs.

Atempting to upgrade to: 1.3.4.3285-b46e0ea
2017-02-02 16:21:43 URL:https://downloads.plex.tv/plex-media-server/1.3.4.3285-b46e0ea/plexmediaserver_1.3.4.3285-b46e0ea_amd64.deb [101364400/101364400] -> "/tmp/plexmediaserver_1.3.4.3285-b46e0ea_amd64.deb" [1]
(Reading database ... 10918 files and directories currently installed.)
Preparing to unpack .../plexmediaserver_1.3.4.3285-b46e0ea_amd64.deb ...
/var/lib/dpkg/info/plexmediaserver.prerm: 13: /var/lib/dpkg/info/plexmediaserver.prerm: stop: not found
Unpacking plexmediaserver (1.3.4.3285-b46e0ea) over (1.3.3.3148-b38628e) ...
Setting up plexmediaserver (1.3.4.3285-b46e0ea) ...
Processing triggers for systemd (229-4ubuntu13) ...
[cont-init.d] 50-plex-update: exited 0.
[cont-init.d] done.
[services.d] starting services
Starting Plex Media Server.

 

What unRAID version are you running?

I am on 6.3.0-rc9

Link to post

There appears to be an issue with plex downloads site related to the ubuntu downloads.

 

manually downloading any of the linux packages other than ubuntu and the links work, the two ubuntu (32 and 64 bit) links do not work.

 

the release is dated today, so it looks like a propagation issue to their mirrors for downloads

Link to post

All's well. Restarted the container and it found the newest update.

 

Wonder why it uses the ubuntu version and not the official unRAID copy Plex puts out...

 

Because the docker container is based on Ubuntu Xenial.

Link to post

Is there a guide to setting up a Plex docker in unRaid with the Plex data and transcoding on separate SSDs outside the array?

No guide, but just point the volume mappings for the appdata and transcode folders to the appropriate folder (presumably you're using Unassigned Devices to mount the drive, so it'll be /mnt/disks/whatever - when doing this set the access mode to be Read/Write,Slave
Link to post

Is there a guide to setting up a Plex docker in unRaid with the Plex data and transcoding on separate SSDs outside the array?

 

Is it possible to use /tmp for transcoding? 

 

Thanks in advance.

 

I mount a ram disk (tmpfs) in my /boot/config/go file and point plex to the mount.  Seems to work well for me.

 

 

Is is possible to run the transcoding preview release on this docker?  (v#.#.#.####)

Just download the .deb and update the image manually?

 

Link to post

Is is possible to run the transcoding preview release on this docker?  (v#.#.#.####)

Just download the .deb and update the image manually?

 

This is covered in the readme linked in the first post of this thread.

Link to post

Is is possible to run the transcoding preview release on this docker?  (v#.#.#.####)

Just download the .deb and update the image manually?

 

This is covered in the readme linked in the first post of this thread.

 

My apologies - it is possible I'm a complete moron.  I explored the links on the first post, but I still don't see it...

Link to post

Is is possible to run the transcoding preview release on this docker?  (v#.#.#.####)

Just download the .deb and update the image manually?

 

This is covered in the readme linked in the first post of this thread.

 

My apologies - it is possible I'm a complete moron.  I explored the links on the first post, but I still don't see it...

The github link explains how to use the VERSION environment variable.
Link to post

The github link explains how to use the VERSION environment variable.

Got it working - thanks!  The latest preview version I wanted to run wasn't pulling.  I found a previous preview build that has the same features, and that pulls just fine.

 

Cheers!

J

Link to post

Hoping someone can help with an artwork issue that I am not able find a solution to with a search.

 

This is a new install with the trial key. About half of my TV Shows are not displaying their artwork like posters and backgrounds. The show descriptions show correctly though.

 

So half of the shows work and the Movies all work.

 

I have reinstalled the docker twice now with the same behavior and the same shows not getting their artwork. My windows VM that I am looking at moving to this unRAID docker is pulling all shows artwork fine.

 

Thanks

Link to post

Hoping someone can help with an artwork issue that I am not able find a solution to with a search.

 

This is a new install with the trial key. About half of my TV Shows are not displaying their artwork like posters and backgrounds. The show descriptions show correctly though.

 

So half of the shows work and the Movies all work.

 

I have reinstalled the docker twice now with the same behavior and the same shows not getting their artwork. My windows VM that I am looking at moving to this unRAID docker is pulling all shows artwork fine.

 

Thanks

This really sounds like a question for plex instead of for this specific docker implementation of plex. Are you sure you have your plex settings the same in both places? I know you can tell plex where to look to try to match movies and tv shows.
Link to post

I have just added this to my new unraid server and I too have no artwork or details for my media, as a site note, the container path variable for media is missing from the docker configuration, it has to be added manually.

 

The artwork is nothing to do with the container.  That's a Plex issue,  there's not a /media path as everyone sets it up differently.  For instance I use /music /tv and /movies

Link to post

So I'm not sure if this is a Plex Docker issue, or if Plex is just displaying a symptom.  It seems though that randomly the media I'm watching will pause for upwards of 30 seconds, and then usually resume without issue.

 

I'm using Rasplex running on a Pi2, with everything hardwired across a gigabit network.  My unraid box is a dual 2670 with 128gb of ram, with the transcode directory sitting in memory (though this is for direct play items, so moot point).  I've examined the logs, and do not see anything that stands out.

 

Has anybody else had this issue, or can offer some advice?

 

Thanks in advance!

 

~Spritz

Link to post

I noticed today there was an update for Plex so I went to apply the update and got this error:

 

oot@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="plex" --net="host" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -e "VERSION"="latest" -v "/mnt/user/Movies/":"/movies":rw -v "/mnt/user/TV/":"/tv":rw -v "/mnt/user/appdata/plex":"/config":rw --cpuset-cpus=3,11,4,12 linuxserver/plex

 

/usr/bin/docker: Error response from daemon: Conflict. The name "/plex" is already in use by container daefe599cfefd11d827ae303e5a52e66e1234775d3cef737ef3875b0d51c9335. You have to remove (or rename) that container to be able to reuse that name..

See '/usr/bin/docker run --help'.

 

 

Not sure why there is a conflict, I haven't changed anything and this has now broken plex. Should I just delete the image and reinstall it?

Link to post

I noticed today there was an update for Plex so I went to apply the update and got this error:

 

oot@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="plex" --net="host" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -e "VERSION"="latest" -v "/mnt/user/Movies/":"/movies":rw -v "/mnt/user/TV/":"/tv":rw -v "/mnt/user/appdata/plex":"/config":rw --cpuset-cpus=3,11,4,12 linuxserver/plex

 

/usr/bin/docker: Error response from daemon: Conflict. The name "/plex" is already in use by container daefe599cfefd11d827ae303e5a52e66e1234775d3cef737ef3875b0d51c9335. You have to remove (or rename) that container to be able to reuse that name..

See '/usr/bin/docker run --help'.

 

 

Not sure why there is a conflict, I haven't changed anything and this has now broken plex. Should I just delete the image and reinstall it?

How did you try to apply the update? Normally all you need to do is restart the existing docker and it will update itself. It sounds like you tried to install an additional instance.
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.