[Support] Linuxserver.io - CouchPotato


Recommended Posts

But... But... I wrote:

please don't tell me to wait for the update because it might take quite a bit of time before it is done

 

:-\

 

Fine I'll wait... Thanks y'all.

 

Nothing we can do about it, our container will get the code as it floats downstream. 

 

PR Merged => Development Branch => Main Branch => Docker

 

Only the last step we have any control over.  Once the code is in the Main branch the following Friday our container will get updated to reflect the change.

Link to comment

But... But... I wrote:

please don't tell me to wait for the update because it might take quite a bit of time before it is done

 

:-\

 

Fine I'll wait... Thanks y'all.

 

Nothing we can do about it, our container will get the code as it floats downstream. 

 

PR Merged => Development Branch => Main Branch => Docker

 

Only the last step we have any control over.  Once the code is in the Main branch the following Friday our container will get updated to reflect the change.

 

i really dislike the fact that they cant be arsed to do a release any more, so your stuck with either a VERY old release or taking your chances with master branch, hmmmm.

Link to comment

But... But... I wrote:

please don't tell me to wait for the update because it might take quite a bit of time before it is done

 

:-\

 

Fine I'll wait... Thanks y'all.

 

Nothing we can do about it, our container will get the code as it floats downstream. 

 

PR Merged => Development Branch => Main Branch => Docker

 

Only the last step we have any control over.  Once the code is in the Main branch the following Friday our container will get updated to reflect the change.

 

i really dislike the fact that they cant be arsed to do a release any more, so your stuck with either a VERY old release or taking your chances with master branch, hmmmm.

 

I'm not offended by the git clone required.  Whether they package it up as a release or not I don't mind.  Even if they packaged it up today as 3.0.2 it's still just a git clone at the end of the day.  ???

Link to comment

In CouchPotato, there is a setting to wait for release before searching.  Recently, movies are getting released 2-3 weeks early on Digital before DVD or Bluray.  Is there a way or could a feature be added to have CouchPotato search on the Digital release date instead of the DVD/Bluray?

Link to comment

In CouchPotato, there is a setting to wait for release before searching.  Recently, movies are getting released 2-3 weeks early on Digital before DVD or Bluray.  Is there a way or could a feature be added to have CouchPotato search on the Digital release date instead of the DVD/Bluray?

 

I dunno, we just package the app in a container....  :-\

Link to comment

In CouchPotato, there is a setting to wait for release before searching.  Recently, movies are getting released 2-3 weeks early on Digital before DVD or Bluray.  Is there a way or could a feature be added to have CouchPotato search on the Digital release date instead of the DVD/Bluray?

 

I dunno, we just package the app in a container....  :-\

You can turn on the option to search prior to the release dates, but you will get more fakes.

 

This really would be a feature req for the CP forums

Link to comment

Hello Forum :)

 

Hey...is anyone else finding that CP is no longer displaying queued media on the "Snatched & Available" dashboard after the most recent update?  Funny thing is; when selecting the "Wanted" tab under the "Movies" section, I see the results from my Searchers, the results that should be on the dashboard.  See the attached screenshots if I'm not making sense.

 

EDIT:  Running v40577904 (11/15/2016)

 

I'm getting exactly the same.

Link to comment

Hello Forum :)

 

Hey...is anyone else finding that CP is no longer displaying queued media on the "Snatched & Available" dashboard after the most recent update?  Funny thing is; when selecting the "Wanted" tab under the "Movies" section, I see the results from my Searchers, the results that should be on the dashboard.  See the attached screenshots if I'm not making sense.

 

EDIT:  Running v40577904 (11/15/2016)

 

I'm getting exactly the same.

 

Glad it's not just me!  Been going on since my last post.  Kinda just been dealing with it!

Link to comment

Hey y'all. Is there any way to modify the couchpotato/core/media/_base/providers/torrent/passthepopcorn.py file in the docker.

PTP migrated to HTTPS and now CP can't login to search that site.

 

I found the fix https://github.com/CouchPotato/CouchPotatoServer/pull/7138/commits/78a474995251264bc6203c2bb374346a059b0d06 but I don't know how to go about implementing it.

 

Also, please don't tell me to wait for the update because it might take quite a bit of time before it is done.

 

Found a temporary workaround for the PTP issue. Set up Jackett with PTP and add it to CP.

I wish they'd push that update, but since it is an "easy fix" when not using a docker container they probably aren't in any hurry...

Link to comment

I seem to have misplaced my username and password for CouchPotato, the one I have in my KeePass manager isn't working.

 

Is there any way to change or rest my username/password?

I cannot find the config.ini under /appdata/Couchpotato, I seem to be looking for a /var/ directory according to Google, but I cannot find it.

 

Thanks in advance and happy holidays!

 

Cheers,

Arndroid

Link to comment

I seem to have misplaced my username and password for CouchPotato, the one I have in my KeePass manager isn't working.

 

Is there any way to change or rest my username/password?

I cannot find the config.ini under /appdata/Couchpotato, I seem to be looking for a /var/ directory according to Google, but I cannot find it.

 

Thanks in advance and happy holidays!

 

Cheers,

Arndroid

 

stop the container, backup your ini file, try changing the entries for username and password to just `=` after the relevant values in the core section.

Link to comment

I seem to have misplaced my username and password for CouchPotato, the one I have in my KeePass manager isn't working.

 

Is there any way to change or rest my username/password?

I cannot find the config.ini under /appdata/Couchpotato, I seem to be looking for a /var/ directory according to Google, but I cannot find it.

 

Thanks in advance and happy holidays!

 

Cheers,

Arndroid

 

stop the container, backup your ini file, try changing the entries for username and password to just `=` after the relevant values in the core section.

 

Heya,

 

Where can I find the .ini file (config.ini)?

I would change the username and password in it, but I cannot find it under:

/mnt/user/appdata/CouchPotato/

 

Where is it located? :)

 

Thanks!

Link to comment

I seem to have misplaced my username and password for CouchPotato, the one I have in my KeePass manager isn't working.

 

Is there any way to change or rest my username/password?

I cannot find the config.ini under /appdata/Couchpotato, I seem to be looking for a /var/ directory according to Google, but I cannot find it.

 

Thanks in advance and happy holidays!

 

Cheers,

Arndroid

 

stop the container, backup your ini file, try changing the entries for username and password to just `=` after the relevant values in the core section.

 

Heya,

 

Where can I find the .ini file (config.ini)?

I would change the username and password in it, but I cannot find it under:

/mnt/user/appdata/CouchPotato/

 

Where is it located? :)

 

Thanks!

 

That's where it should be....  wherever you mapped /config to be on your array.

Link to comment

 

Heya,

 

Where can I find the .ini file (config.ini)?

I would change the username and password in it, but I cannot find it under:

/mnt/user/appdata/CouchPotato/

 

Where is it located? :)

 

Thanks!

 

That's where it should be....  wherever you mapped /config to be on your array.

 

Hmm indeed, it seem to have disappeared out of the blue.

As I started the docker again, it appeared, but had forced me to go through the wizard.

 

I only had to set up API's and stuff, other than that everything is fine.

 

Strange, but I guess it it solved now. :P

Link to comment

 

Heya,

 

Where can I find the .ini file (config.ini)?

I would change the username and password in it, but I cannot find it under:

/mnt/user/appdata/CouchPotato/

 

Where is it located? :)

 

Thanks!

 

That's where it should be....  wherever you mapped /config to be on your array.

 

Hmm indeed, it seem to have disappeared out of the blue.

As I started the docker again, it appeared, but had forced me to go through the wizard.

 

I only had to set up API's and stuff, other than that everything is fine.

 

Strange, but I guess it it solved now. :P

 

Unless you've got it mapped as /mnt/cache/ instead of /mnt/user/ and it's been moved to the array.  Take a look at Squid's latest post in the docker FAQ

Link to comment

I'm having an issue where my config file is being overwritten.

 

When I enable my downloaders such as Deluge and NZBGet, after about 5 mins, CouchPotato says that it can't connect to the downloader because the password is incorrect. I noticed in the config file that the password has changed from plain text to *****. If I update the password in the GUI, it changes the config file but it changes back again after 5 mins.

 

Has anyone else experienced this/know of a cure?

Link to comment
  • 2 weeks later...

Recently my CouchPotato docker decided to crap out and I'm not sure why.  I'm trying to fix it without having to rebuild it from scratch if it's at all possible.  I don't know exactly when it crapped out as I don't check it all that often, it just does its thing and I leave it alone, but I went to add a movie today and found it wasn't behaving correctly.

 

My Docker run command

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="CouchPotato" --net="bridge" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 5050:5050/tcp -v "/mnt/user/Storage/Videos/Temp/CompletedMovies/":"/downloads":rw -v "/mnt/user/Storage/Videos/Movies/":"/movies":rw -v "/mnt/user/Storage/":"/storage":rw -v "/mnt/user/appdata/CouchPotato":"/config":rw linuxserver/couchpotato
f6a5fd43b7796d4bec5f13579dc5c82aa3b14c987075bd516d580b835d943e32

 

My CP docker log file

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-install: executing...
Cloning into '/app/couchpotato'...
[cont-init.d] 30-install: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

 

Before I tried restarting it several times I was getting a Errno 98, address in use error in both Docker and on my CP logs.  I tried switching the port CP ran on at least through the docker but that didn't have any effect.  I can get to my Web UI in CP and view my logs which is filled with 3 pages of errors every time I restart.  A sample can be found in the attachment.  One other thing I did notice, when I go to the edit screen of the docker the port is red which I imagine is an error of some sorts, maybe that the port is in use but no other docker is using this port.  I even shut down docker and brought it back up with only CP running and it's still red.  I ran a netstat -l on my unraid server to look and I see no mention of anything using port 5050.  The most recent thing I did to my server prior to noticing this was to setup PlexPy but I think it was happening before then even, I just didn't notice it.    Any suggestions?

CP_Logs.PNG.96c9fb8c504d4050ad270c82f5ba9210.PNG

Link to comment

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="couchpotato" --net="bridge" -e TZ="Europe/London" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 5050:5050/tcp -v "/mnt/cache/app/couchpotato/":"/config":rw -v "/mnt/cache/app/sabnzbd/Downloads/complete/":"/downloads":rw -v "/mnt/user/":"/movies":rw linuxserver/couchpotato

01e9905128509e39749d4f268ecb3458160d05395c290c5acd849bf5373ca520

The command finished successfully!

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-install: executing...
Cloning into '/app/couchpotato'...
[cont-init.d] 30-install: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

 

that's the information you requested

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.