Jump to content
linuxserver.io

[Support] Linuxserver.io - CouchPotato

430 posts in this topic Last Reply

Recommended Posts

I am getting this error " ERROR[tato.core.plugins.renamer] The from folder "" doesn't exist. Please create it. " But when I try to see what the folder is for renaming a blank box comes up and I can't see anything.  It won't let me do anything in the box.  This has happened since the last update.  I have tried using firefox and explorer but both the same.  When I look in the config file it seems that my setting for /Downloads is there but I am getting this error an the movies aren't being renamed and moved.

Share this post


Link to post

How do you have your your settings setup for Renamer in couchpotato?  Looks like it can't seem to find the movies to move them.

Share this post


Link to post

That is the strange part, this only happens to maybe 30% of the movies, the rest is moved properly.

 

 

Skjermbilde 2018-04-05 kl. 13.56.08.png

Skjermbilde 2018-04-05 kl. 13.56.23.png

Share this post


Link to post
On 20/03/2018 at 2:38 PM, Halvliter said:

Unfortunately it does not seem to work.

https://imgur.com/a/Tu3GW

Should be set to copy or link, move will break your torrents.

 

If you want to move your finished downloads to a different directory, manage this in you torrent program (or in CP on downloader config IF not using blackhole method) and set the finished directory as the "From" "Folder where CP searches for movies." path in Renamer settings.

Share this post


Link to post
24 minutes ago, tjb_altf4 said:

What are you CHMOD settings under General in settings?

Looks like permission errors to me.

 

 

16 minutes ago, tjb_altf4 said:

Should be set to copy or link, move will break your torrents.

 

If you want to move your finished downloads to a different directory, manage this in you torrent program (or in CP on downloader config IF not using blackhole method) and set the finished directory as the "From" "Folder where CP searches for movies." path in Renamer settings.

 

I've recently changed the way I download torrents, to the blackhole method, but thank you anyway :)

Skjermbilde 2018-04-05 kl. 14.27.55.png

Share this post


Link to post

What I find odd about all this is that it only affects some movies. Almost all movies are extracted from rar's and copied properly, except a few.

Share this post


Link to post

Try clearing the Unrar path variable, the docker won't have access to this path.

Blank will unpack in rar's current directory.

Share this post


Link to post
On 5.4.2018 at 3:45 PM, tjb_altf4 said:

Try clearing the Unrar path variable, the docker won't have access to this path.

Blank will unpack in rar's current directory.

Did you mean like this?

The problem is not extracting files, because the movies are being extracted, but once the movies are extracted nothing happens.

 

EDIT: I tried that, but to no effect.

Skjermbilde 2018-04-05 kl. 17.33.44.png

Share this post


Link to post

I think I'm going to loose my mind over something so so so simple. 

 

No matter what I do CouchPotato will NOT let me chance my transmission host IP to "192.168.1.200:9091"

 

The local IP of my unRaid server is "192.168.1.200" but localhost:9091 fails when tested. Changing it to "192.168.1.200:9091" and testing works just fine, but if I refresh the page or go to a different settings section is just reverts back to local host!

 

Someone please point out whatever it is I'm overlooking before I go insane. Thanks!

Capture.PNG

Share this post


Link to post
25 minutes ago, trackstarjc2003 said:

if I refresh the page or go to a different settings section is just reverts back to local host!

Wild guess, but what happens if you tab to a different field after you make the change? Not click with the mouse, hit the tab key.

Share this post


Link to post
22 hours ago, jonathanm said:

Wild guess, but what happens if you tab to a different field after you make the change? Not click with the mouse, hit the tab key.

No effect. Same issue.

Share this post


Link to post

Today I tried editing the config.ini via the unraid terminal. 

 

Stopped the docker image. 

Opened terminal.

cd /mnt/user/appdata/couchpotato

nano config.ini

 

Scrolled down and changed the host line to:

"host = http://192.168.1.200:9091"

Saved and closed the terminal. 

Started the docker image and took a look at the settings, and wouldn't you know it reverted back to localhost. 

 

 

I then said screw it and tried to edit the config file with the docker still running. No effect. Instantly reverts to localhost. 

 

Share this post


Link to post

Editing the config file via CA Config Editor has no effect.

 

Changing download clients has no effect. The issue is seems to be limited to the CouchPotato docker. Something is simply overwriting changes to the host IP.  

Share this post


Link to post

Welp. Going into the docker settings and changing the network type to HOST fixed the issue. 

 

Setting the IP manually still reverts back to localhost, but now that works just fine. 

 

It's always something stupid...

Share this post


Link to post

Hello 

Can anyone tell me where i find CouchPotatoServer? 

 

I need to change some lines in it

Share this post


Link to post

Thank you for the reply, but i am such a noob i am i struggling to get my torrentsites to work with radarr

Share this post


Link to post

Not exactly helpful considering this is a couchpotato thread. I am still waiting for nest folder support in the library before radar is useful for me.

  1.  Ditch CouchPotato
  2. Install Radarr
  3. Happy times :-)


Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Was only a joke, I just find Radarr to be better. Couch Potato would continually downloads different copies of the same movies and fill my drives up, got annoyed and moved to Radarr. 

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.