[Support] Linuxserver.io - CouchPotato


Recommended Posts

  • 4 weeks later...

Hi.  I recently downloaded this.  I am also using linuxserver's Deluge.  linuxserver's sonarr connects to linuxserver's deluge properly.  but linuxserver's couchpotato cannot "see" deluge.  

 

Deluge's network type is set to Host, is that right?  My Unraid's IP is 192.168.1.104, using port 8112.  Instead of using localhost:588xx, I'm using 192.168.1.104:8112 for my Deluge setting.  Username I used is admin, password, I have since changed to blank.  I've also added label to couchpotato movies.  Same goes in Deluge.  Any ideas?

Link to comment
17 hours ago, jang430 said:

Hi.  I recently downloaded this.  I am also using linuxserver's Deluge.  linuxserver's sonarr connects to linuxserver's deluge properly.  but linuxserver's couchpotato cannot "see" deluge.  

 

Deluge's network type is set to Host, is that right?  My Unraid's IP is 192.168.1.104, using port 8112.  Instead of using localhost:588xx, I'm using 192.168.1.104:8112 for my Deluge setting.  Username I used is admin, password, I have since changed to blank.  I've also added label to couchpotato movies.  Same goes in Deluge.  Any ideas?

 

 

make a user for deluge as per the 

 

Add User to the authentication file

 

section here https://dev.deluge-torrent.org/wiki/UserGuide/ThinClient#AddUsertotheauthenticationfile the file being in /config/auth

 

set remote connections on in deluge via the webui then restart the deluge docker (screenie shows it off which is wrong, lol)

 

 1702064924_ScreenShot2018-06-18at22_06_39.png.b34115d209f4720bc083804615e30dd8.png

 

 

then in couch use 58846 and the credentials to match the deluge user 

 

1820319180_ScreenShot2018-06-18at22_12_28.thumb.png.33496b80044daba0fac8e0cb26682905.png

 

Edited by sparklyballs
Link to comment

hi @sparklyballs, I think this is the command I should be running?  

echo "alice:MyC0mpL3xPass:10" >> ~/.config/deluge/auth
How do I run it inside the docker app?  

 

Edit:  I found this-

 

docker exec -it deluge echo "alice:MyC0mpL3xPass:10" >> ~/.config/deluge/auth

 

Is this correct?

 

Thanks

Edited by jang430
Link to comment
1 hour ago, jang430 said:

hi @sparklyballs, I think this is the command I should be running?  


echo "alice:MyC0mpL3xPass:10" >> ~/.config/deluge/auth

How do I run it inside the docker app?  

 

Edit:  I found this-

 

docker exec -it deluge echo "alice:MyC0mpL3xPass:10" >> ~/.config/deluge/auth

 

Is this correct?

 

Thanks

 

 

 

Link to comment

Sorry, I'm lost with @sparklyballsinstructions as to how to add a deluge user, with the deluge app being in a docker container.  Kindly point out.  I'd also like to let you know that deluge with Sonarr is working fine, and can communicate, and send torrents to deluge properly.  CP can't see deluge.  

 

@CHBMB, sorry I totally didn't understand what you're pointing out with the link above.

Link to comment
6 hours ago, jang430 said:

Sorry, I'm lost with @sparklyballsinstructions as to how to add a deluge user, with the deluge app being in a docker container.  Kindly point out.  I'd also like to let you know that deluge with Sonarr is working fine, and can communicate, and send torrents to deluge properly.  CP can't see deluge.  

 

@CHBMB, sorry I totally didn't understand what you're pointing out with the link above.

 

Did you click on the bit in the red box.  Step by step instructions to do what you want.

 

 

screenshot.png

Link to comment

@jonathanm, thanks, I indeed overthinked it :D

 

@CHBMB, sorry, I didn't.  Instead, I clicked on 1329764278_ScreenShot2018-06-20at08_03_25.png.c857d9a870e11c18b31b5f75c1223e5a.png ? . Your instructions did the trick.  

 

Do I need to change write permissions if downloaded with the new username and password that I created?  I used xxxxx:xxxxxx:10.  Will I have problems moving files here and there?  Permission issues?

 

Last question, Sonarr currently connecting to Deluge with default admin as username, and password.  Do I have to change it?  Although I confirmed it's connecting as it is.  

 

 

 

 

Link to comment

I have my Sabnzbd download to /downloads/, which, in my case, is /mnt/user/appdata/downloads/.  So when Sonarr finds NZBs, it sends to Sab, and downloads to that folder.  After which, Sonarr picks it up during post process.  

 

In Deluge, I transfer completed downloads to /downloads/ as well, using the same folder.  It's still being picked up by Sonarr.

 

I read that we have to be consistent, hence, in CP, I also use /downloads/, so it can be picked up during post process.  Won't there be any chance wherein Sonarr and CP both see the same files, and there might be an occassion that it's the same title?  E.g. Suits TV show, and just in case, there is another Suits The Movie.  What's the best practice?

 

Will it be possible to have CP monitor /downloads/Couchpotato?  And have Deluge download all shows labelled Movies to /downloads/ Couchpotato?

Link to comment

Hi.  Don't know where exactly to post, so I'll ask here.  

 

I'm using CP/ Deluge.  I have CP searching for movies via magnetdl, and rarbg.  When it finds one, it sends it to Deluge for download.  In my Deluge, I have files downloading at /downloads/deluge/temp, and CP label of movies get moved to /downloads/couchpotato/complete upon completion.  I have in my CP renamer settings to rename movies from /downloads/couchpotato/complete/ to /movies (a share on my array).  The movie gets downloaded, and Movie appears in /downloads/couchpotato/complete/, CP sees it, ang moves it to /movies (share), but on an occasion or two, the main movie isn't there.  All the other nfo files, that come with the folder is there, but the main movie is neither in /movies (share) nor /downloads/couchpotato/complete/.  But I did see it finish download.  

 

Don't know where to start troubleshooting.  Hope you can shed some light.

 

Deluge settings:

 

Stop seeding when ratio reaches: 0

 

CP Downloader settings:

 

Deluge is checked

Lablel: movies

Directory: left blank

Completed Directory: left blank

Remove Torrent: unticked

Remove Files: unticked

 

Link to comment
  • 2 months later...

for  while now, whenever I launch couchpotato, i just get the left navbar and the right side is just blank white.  If I try to add a movie, it says "movie didn't add properly, check logs"  when i look in the logs, its chock full of errors.  below is a small sample.  any idea how to troubleshoot this?

 

09-10 20:11:01 ERROR [31m[tato.core.plugins.renamer] Failed checking snatched: Traceback (most recent call last):
  File "/app/couchpotato/couchpotato/core/plugins/renamer.py", line 956, in checkSnatched
    rels = list(fireEvent('release.with_status', ['snatched', 'seeding', 'missing'], single = True))
  File "/app/couchpotato/couchpotato/core/plugins/release/main.py", line 536, in withStatus
    for ms in db.get_many('release_status', s):
  File "/app/couchpotato/libs/CodernityDB/database.py", line 991, in get_many
    "Index `%s` doesn't exists" % index_name)
IndexNotFoundException: Index `release_status` doesn't exists
[0m
09-10 20:12:01 ERROR [31m[tato.core.plugins.renamer] Failed checking snatched: Traceback (most recent call last):
  File "/app/couchpotato/couchpotato/core/plugins/renamer.py", line 956, in checkSnatched
    rels = list(fireEvent('release.with_status', ['snatched', 'seeding', 'missing'], single = True))
  File "/app/couchpotato/couchpotato/core/plugins/release/main.py", line 536, in withStatus
    for ms in db.get_many('release_status', s):
  File "/app/couchpotato/libs/CodernityDB/database.py", line 991, in get_many
    "Index `%s` doesn't exists" % index_name)
IndexNotFoundException: Index `release_status` doesn't exists
[0m
09-10 20:13:01 ERROR [31m[tato.core.plugins.renamer] Failed checking snatched: Traceback (most recent call last):
  File "/app/couchpotato/couchpotato/core/plugins/renamer.py", line 956, in checkSnatched
    rels = list(fireEvent('release.with_status', ['snatched', 'seeding', 'missing'], single = True))
  File "/app/couchpotato/couchpotato/core/plugins/release/main.py", line 536, in withStatus
    for ms in db.get_many('release_status', s):
  File "/app/couchpotato/libs/CodernityDB/database.py", line 991, in get_many
    "Index `%s` doesn't exists" % index_name)
IndexNotFoundException: Index `release_status` doesn't exists

 

Edited by bdee1
found log files.
Link to comment
  • 3 months later...
  • 3 weeks later...
2 minutes ago, trackstarjc2003 said:

CouchPotato just completely stopped working for me today. The app launches in docker, but I can not get the webpage to come up.

 

Restart, reinstall, reboot, nothing has any effect.....

Tools - Diagnostics, attach complete diagnostics zip file to your next post.

Link to comment

We have a new build of couchpotato and we are looking for testers. This is a multi-arch build, meaning x86_64, arm and aarch64 builds are all hosted in the same repo and when you pull latest, your system should automatically get the correct arch. They also use our new build system. 

 

If you're willing to test, please first back up your existing config folder, then replace the image linuxserver/couchpotato in container settings with lspipepr/couchpotato and save. Then let us know here if it all goes well. 

 

Following successful tests, these builds will be published in the original repo. 

 

Thanks

Link to comment
10 hours ago, trackstarjc2003 said:

You have a ridiculously large (80G) docker image. This is usually a sign that someone has been filling up their docker image and to solve the problem they increase its size. It will not solve the problem, it just makes it take longer to fill. If you have your applications correctly configured it is very unlikely you would ever need even 20G. See the "Docker Image Filling Up" section of the Docker FAQ:

 

https://forums.unraid.net/topic/57181-real-docker-faq/

 

Link to comment
1 hour ago, trurl said:

You have a ridiculously large (80G) docker image. This is usually a sign that someone has been filling up their docker image and to solve the problem they increase its size. It will not solve the problem, it just makes it take longer to fill. If you have your applications correctly configured it is very unlikely you would ever need even 20G. See the "Docker Image Filling Up" section of the Docker FAQ:

 

https://forums.unraid.net/topic/57181-real-docker-faq/

 

Yes, it a large docker file. But I don't see how that would prevent CouchPotato from running. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.