[Support] Linuxserver.io - CouchPotato

Recommended Posts

11-04 11:11:55 ERROR[o.core.downloaders.deluge] Config properties are not filled in correctly, port is missing.

11-04 11:13:12 ERROR[o.core.downloaders.deluge] Config properties are not filled in correctly, port is missing.


I get this error when trying to connect couchpotato to deluge.

I have added myusername:mypassword:10 in deluge auth file.

I have tried with several ports, etc in my couchpotato settings. 58846 being the default one.


My container is set to


What port is missing?

Edited by SkyHead
Link to comment
  • 3 months later...
7 hours ago, Ockingshay said:

the developer has started top update this again, from various pull requests.


Will these get picked up on the weekly linuxserver update?


EDIT* as if by magic the update was already there for it...thanks! seems to be working a lot better now as well 

Yup, it's all automated

Link to comment
  • 2 weeks later...

02-17 10:27:38 ERROR
[to.core.media._base.media] Media with id "d1376eebc87a43039184d2a22a329cf8" not found

[ couchpotato.api] Failed doing api request "dashboard.soon": Traceback (most recent call last): File "/app/couchpotato/couchpotato/api.py", line 36, in run_handler res = api[route](**kwargs) File "/app/couchpotato/couchpotato/core/plugins/dashboard.py", line 34, in getSoonView for profile in profiles: TypeError: 'NoneType' object is not iterable




Been running this docker for years however I noticed last night when using gui webpage the wanted/managed page is not loading completely


Only black screen with wanted/manage at top


Any thoughts  

Edited by snuffy47
add log
Link to comment
  • 2 weeks later...

I get this over and over.


Traceback (most recent call last):
File "/app/couchpotato/CouchPotato.py", line 135, in <module>
File "/app/couchpotato/CouchPotato.py", line 89, in run
runCouchPotato(self.options, base_path, sys.argv[1:], data_dir = self.data_dir, log_dir = self.log_dir, Env = Env)
File "/app/couchpotato/couchpotato/runner.py", line 142, in runCouchPotato
File "/app/couchpotato/libs/CodernityDB/database_super_thread_safe.py", line 43, in _inner
res = f(*args, **kwargs)
File "/app/couchpotato/libs/CodernityDB/database_super_thread_safe.py", line 93, in open
res = super(SuperThreadSafeDatabase, self).open(*args, **kwargs)
File "/app/couchpotato/libs/CodernityDB/database.py", line 571, in open
File "/app/couchpotato/libs/CodernityDB/tree_index.py", line 156, in open_index
raise IndexException("Doesn't exists")
CodernityDB.index.IndexException: Doesn't exists


Was working fine until I updated yesterday.


Anyone seen this???

Link to comment
  • 2 months later...
5-13 03:33:43 ERROR[edia._base.providers.base] Failed getting release from TorrentPotato: Traceback (most recent call last): File "/opt/couchpotato/couchpotato/core/media/_base/providers/base.py", line 207, in download return self.urlopen(url, headers = {'User-Agent': Env.getIdentifier()}, show_error = False) File "/opt/couchpotato/couchpotato/core/plugins/base.py", line 221, in urlopen response = r.request(method, url, **kwargs) File "/opt/couchpotato/libs/requests/sessions.py", line 469, in request resp = self.send(prep, **send_kwargs) File "/opt/couchpotato/libs/requests/sessions.py", line 598, in send history = [resp for resp in gen] if allow_redirects else [] File "/opt/couchpotato/libs/requests/sessions.py", line 194, in resolve_redirects **adapter_kwargs File "/opt/couchpotato/libs/requests/sessions.py", line 571, in send adapter = self.get_adapter(url=request.url) File "/opt/couchpotato/libs/requests/sessions.py", line 645, in get_adapter raise InvalidSchema("No connection adapters were found for '%s'" % url) InvalidSchema: No connection adapters were found for 'magnet:?xt=urn:btih:5E3106B309D0C186D6B63899BB91E650A51A5AA5&dn=The+Chronicles+of+Riddick+2004+BluRay+720p+DTS+dxva-LoNeWolf+mkv&tr=udp://tracker.coppersurfer.tk:6969/announce&tr=udp://tracker.leechers-paradise.org:6969/announce&tr=udp://9.rarbg.to:2710/announce&tr=udp://tracker.pirateparty.gr:6969/announce&tr=udp://tracker.internetwarriors.net:1337/announce&tr=udp://p4p.arenabg.com:1337/announce&tr=udp://denis.stalker.upeer.me:6969/announce&tr=udp://tracker.opentrackr.org:1337/announce&tr=udp://open.demonii.si:1337/announce&tr=udp://bt1.archive.org:6969/announce' 

I keep getting this error in couch potato from torrentpotato searchers. Is this a couchpotato issue or Jackett?

Link to comment
  • 4 weeks later...
  • 3 months later...
  • 3 weeks later...
  • 2 weeks later...
  • 7 months later...

Hi Team,


it looks like CP has not been updated for a while. I use Kodi Leía.

CP no longer sends notifications to Kodi to update its library. It connect properly. But I suspect CP is sending outdated command to Kodi.


On the setup page it’s clearly listed as Isengard and Helix compatible. Nothing beyond that.

Does anyone experience the same issue? Is there a command in the code where this can be updated?


thank you!





Link to comment
  • 3 weeks later...

the docker just stopped working for me. when I try to download a movie I get:

07-15 10:32:20 ERROR
[chpotato.core.plugins.log] API log: {'file': u'http://HOST/couchpotato/static/scripts/combined.plugins.min.js?1580803031', 'message': u"chrome 91: \nUncaught TypeError: Cannot read property 'length' of undefined", 'line': u'1288', 'page': u'http://HOST/couchpotato/movies/', '_request': <couchpotato.api.ApiHandler object at 0x14fda2805d90>}


and it no longer issues the search to the indexers.


It worked a couple weeks ago, but I have updated since then.  I'm currently up to date.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.