Jump to content
linuxserver.io

[Support] Linuxserver.io - MariaDB

284 posts in this topic Last Reply

Recommended Posts

Try changing /mnt/user/Configs/ to /mnt/cache/Configs

 

Shouldn't that be /mnt/cache/appdata/Configs?

Share this post


Link to post

My configs for mariadb are in /mnt/cache/Configs/mariadb-nextcloud

 

Yes but that's not have you have it mapped,

Share this post


Link to post

My configs for mariadb are in /mnt/cache/Configs/mariadb-nextcloud

 

In the Docker setup, the Docker config path/config should be: /mnt/cache/appdata/mariadb/config.  Change it to this and see if the problem is not solved.

Share this post


Link to post

Yes it is, /mnt/user/Configs is a cache only share, that maps to /mnt/cache/Configs

 

I know that, but at the same time the way the FUSE filesystem is handled by docker means that specifying /mnt/cache/ (ie a direct disk share) can fix problems caused by using /mnt/user/ even though they are exactly the same place.

 

Also if you take dlandon's advice as well it would be sensible, as a standard has evolved through Unraid that /config is normally mapped to /mnt/cache/appdata/application.

Share this post


Link to post

Yes it is, /mnt/user/Configs is a cache only share, that maps to /mnt/cache/Configs

 

You are writing the mariadb config files directly to a share.  If the "Config" share is used by other Dockers, you have a mess on your hands.  The idea is Docker files go to /mnt/cache/appdata with a unique folder for each Docker.  In this case it should be: /mnt/cache/appdata/mariadb/ and the config folder is created there for mariadb.

 

Try to stay with the standard nomenclature so we can offer you help.  Your non-standard configuration is very confusing and hard for us to support.

Share this post


Link to post

Yes it is, /mnt/user/Configs is a cache only share, that maps to /mnt/cache/Configs

 

You are writing the mariadb config files directly to a share.  If the "Config" share is used by other Dockers, you have a mess on your hands.  The idea is Docker files go to /mnt/cache/appdata with a unique folder for each Docker.  In this case it should be: /mnt/cache/appdata/mariadb/ and the config folder is created there for mariadb.

 

Try to stay with the standard nomenclature so we can offer you help.  Your non-standard configuration is very confusing and hard for us to support.

 

This ^^^^

 

Like I wrote in my guide.  Generally until you're really familiar with the workings of stuff best to stick to the standard way of doing things,

Share this post


Link to post

Absolutely, I'll move my dockers over there from now on. I've been doing it like this (wrong) for a while now apparently! :)

 

It is now in /mnt/cache/appdata/mariadb/config but even with the config file set to MIXED mariadb loads up with STATEMENT

Share this post


Link to post

Ah I see, my apologies. However, changing it doesn't fix the issue. It still shows up as STATEMENT :/

 

I have no idea what you're doing, or how things are setup, but I'm very confident it's a problem with how you're doing things.  I suspect the way forward will be to hose your config and start afresh.

 

1.  Create a USE CACHE ONLY share called appdata.

2.  Delete mariadb & delete any config folders you've already got

3.  Reinstall mariadb and be sure to enter the correct path for the appdata...

/mnt/cache/appdata/mariadb-nextcloud/

Share this post


Link to post

Right, I purged all configs, reinstalled mariadb and pointed to the cache only appdata folder. When I attach to the docker, and cat the custom.cnf it DOES show the mixed binlog_format, its just mariadb seems to ignore this config file.

Share this post


Link to post

I just setup a brand new config on my virtual unRAID test box and it's working fine, so I don't know what's happening your end, but the container isn't the problem.

Share this post


Link to post

Right, I think I fixed it. Entirely deleting the image and the container, instead of just removing the container, and reinstalling, it now keeps the mixed setting! I have no idea why or how, but thank you for your assistance.

Share this post


Link to post

Ah I see, my apologies. However, changing it doesn't fix the issue. It still shows up as STATEMENT :/

 

I have no idea what you're doing, or how things are setup, but I'm very confident it's a problem with how you're doing things.  I suspect the way forward will be to hose your config and start afresh.

 

1.  Create a USE CACHE ONLY share called appdata.

2.  Delete mariadb & delete any config folders you've already got

3.  Reinstall mariadb and be sure to enter the correct path for the appdata...

/mnt/cache/appdata/mariadb-nextcloud/

Right, I think I fixed it. Entirely deleting the image and the container, instead of just removing the container, and reinstalling, it now keeps the mixed setting! I have no idea why or how, but thank you for your assistance.

 

I did try and tell you to do that a while ago....  ;)

Share this post


Link to post

Oh no not the config folders, actually choosing "delete container and image" instead of just "delete container" from the docker menu on deleting :P Unless that is what you meant by configs xD

Share this post


Link to post

Oh no not the config folders, actually choosing "delete container and image" instead of just "delete container" from the docker menu on deleting :P Unless that is what you meant by configs xD

 

Well if you don't delete the image then it'll just be reused when you install the container again.....

Share this post


Link to post

just did the upgrade from 6.1.9 to 6.2 when i try to do the update i get this error

 

Error: layers from manifest don't match image configuration

 

how do i fix that

Share this post


Link to post

Check the docker FAQ, or post #2 in the 6.2 announcement

Share this post


Link to post

-rw-r----- 1 abc abc 998K Nov 15 02:24 Docker-Server.err

-rw-rw---- 1 abc abc  16K Nov 15 02:15 aria_log.00000001

-rw-rw---- 1 abc abc  52 Nov 15 02:15 aria_log_control

-rw-rw---- 1 abc abc  48M Nov 15 02:24 ib_logfile0

-rw-rw---- 1 abc abc  48M Nov 15 02:14 ib_logfile1

-rw-rw---- 1 abc abc  12M Nov 15 02:15 ibdata1

-rw-rw---- 1 abc abc    0 Nov 15 02:14 multi-master.info

drwx------ 2 abc abc 4.0K Nov 15 02:14 mysql

drwx------ 2 abc abc 4.0K Nov 14 20:16 performance_schema

 

 

your mysql folder has different ownership to mine.

 

I seem to have the same ownership as ridge. Do I need to perform the same fix he did?

At this point, I'm not having any issues at all as I've just installed (within the last 30 minutes) for the very first time the LS.io mariaDB docker. I'd just like to get this squared away before doing anything else.

 

Here's mine:

 

drwxr-xr-x 1 abc users      344 Sep 26 19:23 .
drwxrwxrwx 1 abc users      136 Sep 26 19:23 ..
-rw-r----- 1 abc users     2121 Sep 26 19:23 46aa7177f8fa.err
-rw-rw---- 1 abc users    16384 Sep 26 19:23 aria_log.00000001
-rw-rw---- 1 abc users       52 Sep 26 19:23 aria_log_control
-rw-rw---- 1 abc users 50331648 Sep 26 19:23 ib_logfile0
-rw-rw---- 1 abc users 50331648 Sep 26 19:23 ib_logfile1
-rw-rw---- 1 abc users 12582912 Sep 26 19:23 ibdata1
-rw-rw---- 1 abc users        0 Sep 26 19:23 multi-master.info
drwx------ 1 abc users     2976 Sep 26 19:23 mysql
drwx------ 1 abc users       72 Sep 26 19:23 performance_schema

 

Here's the fix I'm referring to: http://lime-technology.com/forum/index.php?topic=42422.msg420112#msg420112

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.