Jump to content
linuxserver.io

[Support] Linuxserver.io - Kodi-Headless

584 posts in this topic Last Reply

Recommended Posts

Decided to load alpha 3 (which is stated as the last alpha), normally OE was so far distant I wouldn't dare (2 Pi's in house, thanks LE!).

Now realizing this is still stuck at 16, any chance an update is happening prior to beta releases?

 

Normally we wait for the beta cycle.  And with the rebase of our images at the moment, things are kinda busy.  Sorry.

Share this post


Link to post

Thanks for the reply, I get it..

I've switched these duties to the Pi for now, should suffice in the mean time. Keep up the great work, "go team" etc..  :)

Share this post


Link to post

Hey all. Great work on this docker. I've been using it for quite a while with two raspberry pi 2s. Keeping everything in sync and updated. Everything was working fine and I decided to do another pi project. Since then the pi3 had come out and I decided to upgrade my HTPCs to pi3s and repurpose the pi2s. I use OSMC on the pis and their release for the pi3s is v16. So I changed the VERSION variable in the docker to 16, (it wasn't set before) and installed the pis and everything almost just worked.

 

My problem is some of my media is missing from the library. I.e. I have all episodes of a show. They showed up in the TV Shows category on Isengard, but in Jarvis, some of the episodes are missing. I can browse to them in files. The files are there, just not in the library. I tried library update but it didn't do anything. Any suggestions?

Share this post


Link to post

ok I must be missing something obvious, but dammed if i can find it.. just installed this through the Community Applications plugin. Go to docker tab. click on the one thats port 8080 and it's asking for a username and password, and I'll be dammed if i can work it out or find it. If i click on the on that has a port of 9777 I get nothing, site can't be reached.

 

Share this post


Link to post

ok I must be missing something obvious, but dammed if i can find it.. just installed this through the Community Applications plugin. Go to docker tab. click on the one thats port 8080 and it's asking for a username and password, and I'll be dammed if i can work it out or find it. If i click on the on that has a port of 9777 I get nothing, site can't be reached.

 

xbmc/xbmc

Share this post


Link to post

ok I need help, is there a guide on setting this up?

 

Maybe it didn't download correctly i donno. But I open it, and if i click on movies/tv shows or music, just get a circle beside profiles spinning forever.. If i click on profiles, than click master user, I get a red box appear above that connection to server lost

 

 

Share this post


Link to post

ok I need help, is there a guide on setting this up?

 

Maybe it didn't download correctly i donno. But I open it, and if i click on movies/tv shows or music, just get a circle beside profiles spinning forever.. If i click on profiles, than click master user, I get a red box appear above that connection to server lost

Akin to how the name is (headless), there is zero need to ever hit the webUI on this container.  (and the webUI doesn't even work properly since this is basically a hack of Kodi designed specifically just to update the library)

 

Rough directions on how to set up

Setting up the application

 

Set the optional VERSION variable to use an earlier release than what is current from kodi (use only the main version number, 14 , 15 or 16 etc, not point releases). Not setting or removing the VERSION variable will cause the container to update only releases within the same main version number you have installed.

 

Mysql/mariadb settings are entered by editing the file advancedsettings.xml which is found in the userdata folder of your /config/.kodi mapping. Many other settings are within this file also.

 

The default user/password for the web interface and for apps like couchpotato etc to send updates is xbmc/xbmc.

 

If you intend to use this kodi instance to perform library tasks other than merely updating, eg. library cleaning etc, it is important to copy over the sources.xml from the host machine that you performed the initial library scan on to the userdata folder of this instance, otherwise database loss can and most likely will occur.

 

You need to have an already working kodi so that you can do the initial scan and then copy over the sources.xml  (may also require passwords.xml ->can't remember) And you then point your download clients to point to this app to automatically update the library instead of pointing it at a HTPC.

 

 

Share this post


Link to post

Howdy

 

Has anyone installed Pseudo TV Live http://pseudotvlive.com/ to allow it to run as a master to make channel updating less of a chore?

 

This may not be the right place for this question but I am running the kodi headless docker for my libary sync.

Share this post


Link to post

Having a real hard time here. I noticed the docker keeps on restarting on its own. Mariadb is fine, dbs were empty and I noticed that the docker created the schemas for both videos/music. Added the VERSION = 16 variable was the only change I made to the docker plus the /config/.kodi path.

 

The server keeps on restarting but the docker remains up, can't telnet into 8080 and I noticed the kodi.log keeps on updating with the same info. Tried to delete container and image and restarted and same.

 

Thoughts please.

 

Noticed this now:

 

12:49:28 T:47541202773760   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
12:49:28 T:47541202773760   ERROR: CRepository: Failed to parse addons.xml. Malformated.
12:49:28 T:47541202773760   ERROR: CRepositoryUpdateJob[repository.xbmc.org] failed to read or parse directory 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz'
12:50:51 T:47540441307392  NOTICE: Samba is idle. Closing the remaining connections

 

I guessed it timeout on some download or something...

 

Also seeing this:

 

Fetched 22.5 MB in 25s (877 kB/s)
Reading package lists...
Checksum Failed, falling back to original version , try again by restarting the container
Aug 25 13:29:20 0c30efe98b04 syslog-ng[78]: syslog-ng starting up; version='3.5.3'

 

I am going out through a VPN and it could be the the VPN's ip is blacklisted or something preventing me to access the internet during docker start.

kodi.old.log.zip

Share this post


Link to post

It looks like it's tripping up on http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz

 

I just managed to download that file without issues so the mirror is up.

 

Can you try

 

wget http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz

 

from a telnet prompt and post the log...

Share this post


Link to post

addons.xml.gz seem to download all right.

 

2016-08-25 14:01:09 (939 KB/s) - ‘addons.xml.gz’ saved [550529/550529]

 

the headless server refuses to start, docker remains up, telnet 8080 refuses, i see this in docker log

 

Checksum Failed, falling back to original version , try again by restarting the container

 

kodi.log does not show any errors, i then notice kodi.bin topping my cpu, so i know it's bugging somewhere....

 

anyway to increase the log level in advancesettings?

Share this post


Link to post

addons.xml.gz seem to download all right.

 

2016-08-25 14:01:09 (939 KB/s) - ‘addons.xml.gz’ saved [550529/550529]

 

the headless server refuses to start, docker remains up, telnet 8080 refuses, i see this in docker log

 

Checksum Failed, falling back to original version , try again by restarting the container

 

kodi.log does not show any errors, i then notice kodi.bin topping my cpu, so i know it's bugging somewhere....

 

anyway to increase the log level in advancesettings?

 

Can you post a copy of your docker run command or a screenshot of your setup please?

 

Share this post


Link to post

Can you post a copy of your docker run command or a screenshot of your setup please?

 

Thanks for the help, I'm going bonkers here. Up until today I was using sparklyballs docker on ver 14 with no issues.

 

How do I get at the run command from within the interface or shell?

 

Is this what you want to see?

 

 

I also removed my advancesettings.xml and it still continues to restart itself with the default supplied xml. I see the kodi.log continuously recreate itself with the same data...

 

I increased the log level and attached a log. The stuff in the log file keeps on repeating once it rotates the log over to kodi.old.log

 

kodi.old.log.zip

Share this post


Link to post

Did you start with an empty appdata or are you using your previous one from Sparklyballs' older container?

Share this post


Link to post

Did you start with an empty appdata or are you using your previous one from Sparklyballs' older container?

 

Started from an empty appdata, I also tried a new mariadb container as well, with empty databases.

 

The log stops at the following for some reason and then the server restarts...

 

CRepository 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz' is gzip. decompressing

Share this post


Link to post

Nuke the container, nuke the appdata and post the logs, shoud look something like this.

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/05_set_the_time.sh...

Current default time zone: 'Europe/London'
Local time is now: Thu Aug 25 19:37:00 BST 2016.
Universal Time is now: Thu Aug 25 18:37:00 UTC 2016.

*** Running /etc/my_init.d/10_add_user_abc.sh...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

*** Running /etc/my_init.d/20_apt_update.sh...
finding fastest mirror
Getting list of mirrors...done.
Testing latency to mirror(s)
Getting list of launchpad URLs...done.
Looking up 3 status(es)
1. mirror.mythic-beasts.com
Latency: 12.14 ms
Org: Mythic Beasts Ltd
Status: Up to date
Speed: 1 Gbps
2. repo.bigstepcloud.com
Latency: 12.42 ms
Org: Bigstep Cloud LTD
Status: Up to date
Speed: 1 Gbps
3. mirror.vorboss.net
Latency: 13.80 ms
Org: Vorboss Ltd
Status: Up to date
Speed: 10 Gbps
New config file saved to /defaults/sources.list
We are now refreshing packages from apt repositories, this *may* take a while
Ign http://mirror.mythic-beasts.com trusty InRelease
Get:1 http://mirror.mythic-beasts.com trusty-updates InRelease [65.9 kB]
Get:2 http://mirror.mythic-beasts.com trusty-security InRelease [65.9 kB]
Get:3 http://mirror.mythic-beasts.com trusty Release.gpg [933 B]
Get:4 http://mirror.mythic-beasts.com trusty-updates/main Sources [472 kB]
Get:5 http://ppa.launchpad.net trusty InRelease [15.5 kB]
Get:6 http://ppa.launchpad.net trusty InRelease [15.4 kB]
Get:7 http://ppa.launchpad.net trusty/main amd64 Packages [2,941 B]
Get:8 http://mirror.mythic-beasts.com trusty-updates/restricted Sources [5,247 B]
Get:9 http://mirror.mythic-beasts.com trusty-updates/universe Sources [204 kB]
Get:10 http://ppa.launchpad.net trusty/main amd64 Packages [29.5 kB]
Get:11 http://mirror.mythic-beasts.com trusty-updates/multiverse Sources [6,927 B]
Get:12 http://mirror.mythic-beasts.com trusty-updates/main amd64 Packages [1,106 kB]
Get:13 http://mirror.mythic-beasts.com trusty-updates/restricted amd64 Packages [23.5 kB]
Get:14 http://mirror.mythic-beasts.com trusty-updates/universe amd64 Packages [478 kB]
Get:15 http://mirror.mythic-beasts.com trusty-updates/multiverse amd64 Packages [16.1 kB]
Get:16 http://mirror.mythic-beasts.com trusty-security/main Sources [151 kB]
Get:17 http://mirror.mythic-beasts.com trusty-security/restricted Sources [3,944 B]
Get:18 http://mirror.mythic-beasts.com trusty-security/universe Sources [46.4 kB]
Get:19 http://mirror.mythic-beasts.com trusty-security/multiverse Sources [2,550 B]
Get:20 http://mirror.mythic-beasts.com trusty-security/main amd64 Packages [647 kB]
Get:21 http://mirror.mythic-beasts.com trusty-security/restricted amd64 Packages [20.2 kB]
Get:22 http://mirror.mythic-beasts.com trusty-security/universe amd64 Packages [174 kB]
Get:23 http://mirror.mythic-beasts.com trusty-security/multiverse amd64 Packages [4,850 B]
Get:24 http://mirror.mythic-beasts.com trusty Release [58.5 kB]
Get:25 http://mirror.mythic-beasts.com trusty/main Sources [1,335 kB]
Get:26 http://mirror.mythic-beasts.com trusty/restricted Sources [5,335 B]
Get:27 http://mirror.mythic-beasts.com trusty/universe Sources [7,926 kB]
Get:26 http://mirror.mythic-beasts.com trusty/restricted Sources [5,335 B]
Get:27 http://mirror.mythic-beasts.com trusty/universe Sources [7,926 kB]
Get:28 http://mirror.mythic-beasts.com trusty/multiverse Sources [211 kB]
Get:29 http://mirror.mythic-beasts.com trusty/main amd64 Packages [1,743 kB]
Get:30 http://mirror.mythic-beasts.com trusty/restricted amd64 Packages [16.0 kB]
Get:31 http://mirror.mythic-beasts.com trusty/universe amd64 Packages [7,589 kB]
Get:32 http://mirror.mythic-beasts.com trusty/multiverse amd64 Packages [169 kB]
Fetched 22.6 MB in 6s (3,282 kB/s)
Fetched 22.6 MB in 6s (3,282 kB/s)
Reading package lists...
(Reading database ... 27276 files and directories currently installed.)
Preparing to unpack .../python2.7-dev_2.7.12-1~trusty1_amd64.deb ...
Unpacking python2.7-dev (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7-dev_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7-dev:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../python2.7_2.7.12-1~trusty1_amd64.deb ...
Unpacking python2.7 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../python2.7-minimal_2.7.12-1~trusty1_amd64.deb ...
Unpacking python2.7-minimal (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7-minimal_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7-minimal:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Unpacking libpython2.7-minimal:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7-stdlib_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7-stdlib:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Unpacking libpython2.7-stdlib:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../wget_1.15-1ubuntu1.14.04.2_amd64.deb ...
Unpacking wget (1.15-1ubuntu1.14.04.2) over (1.15-1ubuntu1.14.04.1) ...
Preparing to unpack .../python-pip_1.5.4-1ubuntu4_all.deb ...
Unpacking python-pip (1.5.4-1ubuntu4) over (1.5.4-1ubuntu3) ...
Preparing to unpack .../python-pip-whl_1.5.4-1ubuntu4_all.deb ...
Preparing to unpack .../python-pip-whl_1.5.4-1ubuntu4_all.deb ...
Unpacking python-pip-whl (1.5.4-1ubuntu4) over (1.5.4-1ubuntu3) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Setting up libpython2.7-minimal:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7-minimal (2.7.12-1~trusty1) ...
Setting up libpython2.7-stdlib:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7 (2.7.12-1~trusty1) ...
Setting up libpython2.7-stdlib:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7 (2.7.12-1~trusty1) ...
Setting up libpython2.7:amd64 (2.7.12-1~trusty1) ...
Setting up libpython2.7-dev:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7-dev (2.7.12-1~trusty1) ...
Setting up wget (1.15-1ubuntu1.14.04.2) ...
Setting up python-pip-whl (1.5.4-1ubuntu4) ...
Setting up python-pip (1.5.4-1ubuntu4) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...
Setting up wget (1.15-1ubuntu1.14.04.2) ...
Setting up python-pip-whl (1.5.4-1ubuntu4) ...
Setting up python-pip (1.5.4-1ubuntu4) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...
*** Running /etc/my_init.d/30_set_the_config.sh...
*** Running /etc/my_init.d/40_update.sh...
--2016-08-25 19:37:43-- https://files.linuxserver.io/kodi/LATEST16
Resolving files.linuxserver.io (files.linuxserver.io)... 104.18.60.43, 104.18.61.43
Connecting to files.linuxserver.io (files.linuxserver.io)|104.18.60.43|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 36
Saving to: ‘/tmp/LATEST’

0K 100% 6.12M=0s

2016-08-25 19:37:44 (6.12 MB/s) - ‘/tmp/LATEST’ saved [36/36]

No Update Required
*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 290
Aug 25 19:37:44 825b3c2add8d syslog-ng[297]: syslog-ng starting up; version='3.5.3'

 

Just wondering if it's tripped up somewhere in the original docker pull and that's causing an issue.  The log above is from mine, completely new install on a test server.  Never installed kodi before on it.

Share this post


Link to post

Clean install, nuked everything. Default advancesettings.xml, Still restarts.

 

 

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \ 
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

finding fastest mirror
1. ubuntu.mirror.iweb.ca
Latency: 8.51 ms
Org: iWeb Technologies Inc.
Status: Up to date
Speed: 4 Gbps
2. mirror.cedille.club
Latency: 19.00 ms
Org: Club CEDILLE
Status: Up to date
Speed: 100 Mbps
3. archive.ubuntu.mirror.rafal.ca
Latency: 20.22 ms
Org: Rafa? Rzeczkowski
Status: Up to date
Speed: 1 Gbps
New config file saved to /defaults/sources.list
We are now refreshing packages from apt repositories, this *may* take a while
Get:1 http://ppa.launchpad.net trusty InRelease [15.5 kB]
Get:2 http://ppa.launchpad.net trusty InRelease [15.4 kB]
Get:3 http://ppa.launchpad.net trusty/main amd64 Packages [2,941 B]
Get:4 http://ppa.launchpad.net trusty/main amd64 Packages [29.5 kB]

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \ 
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

finding fastest mirror
1. ubuntu.mirror.iweb.ca
Latency: 8.51 ms
Org: iWeb Technologies Inc.
Status: Up to date
Speed: 4 Gbps
2. mirror.cedille.club
Latency: 19.00 ms
Org: Club CEDILLE
Status: Up to date
Speed: 100 Mbps
3. archive.ubuntu.mirror.rafal.ca
Latency: 20.22 ms
Org: Rafa? Rzeczkowski
Status: Up to date
Speed: 1 Gbps
New config file saved to /defaults/sources.list
We are now refreshing packages from apt repositories, this *may* take a while
Get:1 http://ppa.launchpad.net trusty InRelease [15.5 kB]
Get:2 http://ppa.launchpad.net trusty InRelease [15.4 kB]
Get:3 http://ppa.launchpad.net trusty/main amd64 Packages [2,941 B]
Get:4 http://ppa.launchpad.net trusty/main amd64 Packages [29.5 kB]
Ign http://ubuntu.mirror.iweb.ca trusty InRelease
Get:5 http://ubuntu.mirror.iweb.ca trusty-updates InRelease [65.9 kB]
Get:6 http://ubuntu.mirror.iweb.ca trusty-security InRelease [65.9 kB]
Get:7 http://ubuntu.mirror.iweb.ca trusty Release.gpg [933 B]
Get:8 http://ubuntu.mirror.iweb.ca trusty-updates/main Sources [470 kB]
Get:9 http://ubuntu.mirror.iweb.ca trusty-updates/restricted Sources [5,217 B]
Get:10 http://ubuntu.mirror.iweb.ca trusty-updates/universe Sources [201 kB]
Get:11 http://ubuntu.mirror.iweb.ca trusty-updates/multiverse Sources [5,946 B]
Get:12 http://ubuntu.mirror.iweb.ca trusty-updates/main amd64 Packages [1,097 kB]
Get:13 http://ubuntu.mirror.iweb.ca trusty-updates/restricted amd64 Packages [23.5 kB]
Get:14 http://ubuntu.mirror.iweb.ca trusty-updates/universe amd64 Packages [474 kB]
Get:15 http://ubuntu.mirror.iweb.ca trusty-updates/multiverse amd64 Packages [14.3 kB]
Get:16 http://ubuntu.mirror.iweb.ca trusty-security/main Sources [150 kB]
Get:17 http://ubuntu.mirror.iweb.ca trusty-security/restricted Sources [3,920 B]
Get:18 http://ubuntu.mirror.iweb.ca trusty-security/universe Sources [44.1 kB]
Get:19 http://ubuntu.mirror.iweb.ca trusty-security/multiverse Sources [2,550 B]
Get:20 http://ubuntu.mirror.iweb.ca trusty-security/main amd64 Packages [638 kB]
Get:21 http://ubuntu.mirror.iweb.ca trusty-security/restricted amd64 Packages [20.2 kB]
Get:22 http://ubuntu.mirror.iweb.ca trusty-security/universe amd64 Packages [170 kB]
Get:23 http://ubuntu.mirror.iweb.ca trusty-security/multiverse amd64 Packages [4,850 B]
Get:24 http://ubuntu.mirror.iweb.ca trusty Release [58.5 kB]
Get:25 http://ubuntu.mirror.iweb.ca trusty/main Sources [1,335 kB]
Get:26 http://ubuntu.mirror.iweb.ca trusty/restricted Sources [5,335 B]
Get:27 http://ubuntu.mirror.iweb.ca trusty/universe Sources [7,926 kB]
Get:28 http://ubuntu.mirror.iweb.ca trusty/multiverse Sources [211 kB]
Get:29 http://ubuntu.mirror.iweb.ca trusty/main amd64 Packages [1,743 kB]
Get:30 http://ubuntu.mirror.iweb.ca trusty/restricted amd64 Packages [16.0 kB]
Get:31 http://ubuntu.mirror.iweb.ca trusty/universe amd64 Packages [7,589 kB]
Get:32 http://ubuntu.mirror.iweb.ca trusty/multiverse amd64 Packages [169 kB]
Fetched 22.6 MB in 17s (1,311 kB/s)
Reading package lists...
(Reading database ... 27276 files and directories currently installed.)
Preparing to unpack .../python2.7-dev_2.7.12-1~trusty1_amd64.deb ...
Unpacking python2.7-dev (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7-dev_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7-dev:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../python2.7_2.7.12-1~trusty1_amd64.deb ...
Unpacking python2.7 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../python2.7-minimal_2.7.12-1~trusty1_amd64.deb ...
Unpacking python2.7-minimal (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7-minimal_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7-minimal:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../libpython2.7-stdlib_2.7.12-1~trusty1_amd64.deb ...
Unpacking libpython2.7-stdlib:amd64 (2.7.12-1~trusty1) over (2.7.11-0+trusty1) ...
Preparing to unpack .../wget_1.15-1ubuntu1.14.04.2_amd64.deb ...
Unpacking wget (1.15-1ubuntu1.14.04.2) over (1.15-1ubuntu1.14.04.1) ...
Preparing to unpack .../python-pip_1.5.4-1ubuntu4_all.deb ...
Unpacking python-pip (1.5.4-1ubuntu4) over (1.5.4-1ubuntu3) ...
Preparing to unpack .../python-pip-whl_1.5.4-1ubuntu4_all.deb ...
Unpacking python-pip-whl (1.5.4-1ubuntu4) over (1.5.4-1ubuntu3) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Setting up libpython2.7-minimal:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7-minimal (2.7.12-1~trusty1) ...
Setting up libpython2.7-stdlib:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7 (2.7.12-1~trusty1) ...
Setting up libpython2.7:amd64 (2.7.12-1~trusty1) ...
Setting up libpython2.7-dev:amd64 (2.7.12-1~trusty1) ...
Setting up python2.7-dev (2.7.12-1~trusty1) ...
Setting up wget (1.15-1ubuntu1.14.04.2) ...
Setting up python-pip-whl (1.5.4-1ubuntu4) ...
Setting up python-pip (1.5.4-1ubuntu4) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...
No Update Required
Aug 25 14:53:16 de6ce92bb863 syslog-ng[292]: syslog-ng starting up; version='3.5.3'

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="kodi-headless" --net="bridge" -e PUID="99" -e PGID="100" -e VERSION="16" -e TZ="America/New_York" -p 8080:8080/tcp -p 9777:9777/udp -v "/mnt/cache/appdata/docker/kodi-headless":"/config/.kodi":rw linuxserver/kodi-headless

kodi.old.log.zip

Share this post


Link to post

running docker logs container gives me segmentation faults...which is probably what's causing the restarts, as to why...btw running unraid in esxi, not like that should matter

 

*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 285
./run: line 2:   296 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   321 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   344 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   366 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   388 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   410 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   432 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   454 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   476 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   498 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   520 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   542 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:   564 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
*** Shutting down runit daemon (PID 285)...
*** Killing all processes...
*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/05_set_the_time.sh...
*** Running /etc/my_init.d/10_add_user_abc.sh...
*** Running /etc/my_init.d/20_apt_update.sh...
Getting list of mirrors...done.
Testing latency to mirror(s)
[13/13] 100%
Getting list of launchpad URLs...done.
Looking up 3 status(es)
[3/3] 100%
ubuntu.mirror.iweb.ca (current) is the currently used mirror.
Skipping file generation
*** Running /etc/my_init.d/30_set_the_config.sh...
*** Running /etc/my_init.d/40_update.sh...
--2016-08-25 14:59:09--  https://files.linuxserver.io/kodi/LATEST16
Resolving files.linuxserver.io (files.linuxserver.io)... 104.18.61.43, 104.18.60.43
Connecting to files.linuxserver.io (files.linuxserver.io)|104.18.61.43|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 36
Saving to: ‘/tmp/LATEST’

     0K                                                       100% 10.5M=0s

2016-08-25 14:59:10 (10.5 MB/s) - ‘/tmp/LATEST’ saved [36/36]

*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 80
./run: line 2:    92 Killed                  /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:    95 Killed                  /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless
./run: line 2:    97 Killed                  /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless

 

I also put my advancesettings.xml file in userdata, not sure if it's related. Now it's topping my cpu. What on earth is happening  :'(

 

I also nuked another container which I assume was also using the same base image(s). will try again with default advancesettings.xml

 

EDIT: still getting

 

./run: line 2:   296 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless

 

syslog

 

Aug 25 15:25:23 tower kernel: JobWorker[4812]: segfault at 4c0 ip 00000000009c0cc7 sp 00002af96bc50730 error 4 in kodi.bin[400000+1da6000]

 

I'm going wipe the docker.img at this point, I guess my user templates will stay intact...

kodi.old.log.zip

Share this post


Link to post

OK, I've done a bit of investigating. 

 

I can reproduce the segfault here, but not sure why it's happening.  Sparkly is the kodi whizz and the author of this container.  I'll chat with him and see if we can get to the bottom of it.

 

Thanks for all the logs.  ;)

Share this post


Link to post

OK, I've done a bit of investigating. 

 

I can reproduce the segfault here, but not sure why it's happening.  Sparkly is the kodi whizz and the author of this container.  I'll chat with him and see if we can get to the bottom of it.

 

Thanks for all the logs.  ;)

 

Glad it not isolated to me, I was going to leap out of the nearest window...

Share this post


Link to post

I've not tested that as a possible solution, so I'd be grateful if you try it if you could post the results here...

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

I've not tested that as a possible solution, so I'd be grateful if you try it if you could post the results here...

 

Sent from my LG-H815 using Tapatalk

 

Just to clarify you mean for me to try to delete the docker.img or leap out of the nearest window as a possible solution? lol, will report back.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.