[Support] Linuxserver.io - Headphones


141 posts in this topic Last Reply

Recommended Posts

6 minutes ago, saarg said:

 

You have changed the port in the webgui of headphones to 9191 at one point and this makes it not work. You either find the port option in your config file or change the port mapping to say 9191 for both host and container port. 

 

The reason why it happened is that we changed how headphones is started.  We removed the forced port 8181 and this activated the port in the webgui. 

 

I changed the port back to 8181 in the config file and that's fixed it. Thanks heaps saarg.

Link to post
  • 2 weeks later...
  • Replies 140
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Headphones Application Site: https://github.com/rembo10/headphones Docker Hub: https://hub.docker.com/r/linuxserver/headphones/ Github: https://github.com/linuxserv

Thanks, changing the localhost to 0.0.0.0 worked fine.  Looking at me logs, up until dec 31 2017, my container was using 0.0.0.0  From Jan 1st 2018 onwards it was loading with localhost.   I

REQ: New icon that works in both LIGHT and DARK themes

Posted Images

On 06/04/2018 at 3:16 AM, saarg said:

 

Go to your Headphones appdata folder and edit config.ini and change http_host to the below.

 


http_host = 0.0.0.0

 

 

That got me up and running again, cheers!

 

I was previously using 8181, so not sure where the issue has arisen form, but sorted now :)

Edited by tjb_altf4
Link to post

Thanks, changing the localhost to 0.0.0.0 worked fine.  Looking at me logs, up until dec 31 2017, my container was using 0.0.0.0  From Jan 1st 2018 onwards it was loading with localhost.

 

I can only assume it was a change in the docker update

Link to post
  • 1 month later...
  • 1 month later...
  • 3 weeks later...

I recently installed this container and came to this support thread for more info on setting it up. I noticed some people were having problems with some settings too. For those having problems with post processing and encoding, ffmpeg is installed at /usr/bin/ffmpeg, so under "Advanced Settings" tab in the "Settings" menu, look under the heading "Advanced Encoding Options", and set "Path to Encoder" to /usr/bin/ffmpeg

 

My files are now being re-encoded and moved properly. Thanks for providing this docker. Great work!

Link to post
  • 3 months later...

Hi,

 

Happy New Year Everyone!

 

My Headphones docker seems to have broken around 4am on 01/01/19 and I can no longer access the GUI  I have rebooted the unRAID server, removed & reinstalled the docker image but still no dice! 

 

Can someone please help at all? My Log is below 🙂

 

Many Thanks

headphones.rar

Edited by mbc0
Link to post
17 hours ago, mbc0 said:

Hi,

 

Happy New Year Everyone!

 

My Headphones docker seems to have broken around 4am on 01/01/19 and I can no longer access the GUI  I have rebooted the unRAID server, removed & reinstalled the docker image but still no dice! 

 

Can someone please help at all? My Log is below 🙂

 

Many Thanks

headphones.rar

I had same problem - doing this mentioned above by some other helpful person fixes it:

 

Go to your Headphones appdata folder and edit config.ini and change http_host to the below.

 

http_host = 0.0.0.0

Link to post
4 hours ago, 10meghalfduplex said:

I had same problem - doing this mentioned above by some other helpful person fixes it:

 

Go to your Headphones appdata folder and edit config.ini and change http_host to the below.

 

http_host = 0.0.0.0

Thank you very much matey! All working now 🙂

Link to post
  • 6 months later...

How do you guys have your music organized?

 

I have a music share, and in it, I have directories for artist name, and under that, directories for albums, with songs inside those.

 

ie g:\abc\album1, g:\abc\album2, etc

 

Problem is, headphones is downloading multiple copies of the same albums, because it seems that it can't see into those subdirectories.

 

If I instead do g:\abc_album1, g:\abc_album2, etc., then headphones appears to understand that the album already exists and does not download it.

 

Is anyone else having this issue?

Link to post
  • 2 months later...

Trying to setup an NGINX reverse proxy. All i get is 404. I have tried changing http_root and http_proxy in the config ini. Both get reverted after a reboot.

 

location /music {
    include /config/nginx/includes/proxy;
    proxy_pass http://xxx.xxx.xxx.xxx:8181/;
}

 

My proxy conf:

 

client_body_buffer_size 128k;

#Timeout if the real server is dead
proxy_next_upstream error timeout invalid_header http_500 http_502 http_503;

# Advanced Proxy Config
send_timeout 5m;
proxy_read_timeout 240;
proxy_send_timeout 240;
proxy_connect_timeout 240;

# Basic Proxy Config
proxy_set_header Host $host:$server_port;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto https;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Ssl on;
proxy_redirect http:// $scheme://;
proxy_http_version 1.1;
proxy_set_header Connection "";
proxy_cache_bypass $cookie_session;
proxy_no_cache $cookie_session;
proxy_buffers 32 4k;

Link to post

Im having some trouble adding my existing library. I have /downloads (/mnt/user/downloads/) and /music (/mnt/user/media/library/music). Within headphones ive tried setting 'path to directory' as /music/media/library/music and /media/library/music but neither way seems to find my existing library. 

Link to post
3 hours ago, 2Piececombo said:

I have /downloads (/mnt/user/downloads/) and /music (/mnt/user/media/library/music). Within headphones ive tried setting 'path to directory' as /music/media/library/music and /media/library/music but neither way seems to find my existing library. 

You told it to be just /music, so why not try that?

Link to post
  • 1 year later...

Is there a way to make headphones smarter about scanning folders for existing music?

 

I have a share called "music," and in that there are 36 folders: 0-9 and A-Z.  I have all of my artists arranged alphabetically and numerically, for the sake of ease of organization.

 

Of course when I point headphones to "/music," it thinks there is no music present and I get everything downloaded in duplicate.

 

Aside from having every artist in the /music folder, is there a better way?

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.