[Support] Linuxserver.io - Piwigo


Recommended Posts

Hi All

 

Trying to find alternatives to the "DS Photo" page on my Synology using Unraid and dockers

Looking here there are only 3 pages for this docker, is most people using something else? or does this just work great!?

 

I have Nextcloud installed with MariaDB and it okay but not really a solution for a large TB photo/Video collection 😞

So if this is the solution, would it be okay to create a secound DB in my existing MarisDB docker for the needed DB to be used with Piwigo?

Or better to install a separate Mariadb docker to only be used for this?

 

I haven't really found any videos about the installation or usage of this, so please share your experiences

Thanks

 

Link to comment

Ok did a separate install and so far so good... pretty fast on my cache drive

One thing I think there need to be some seperate setup og write access to the config file?

 

Warning: mkdir(): Read-only file system in /config/www/gallery/plugins/piwigo-videojs/include/function_sync2.php on line 157

Any input on how to solve this?

Link to comment
  • 3 weeks later...
On 7/13/2020 at 3:57 PM, dee2 said:

Since there doesn't seem to be an all-in-one  tutorial on the web.

 

Linking shares to container

 

Step 1 - permitted characters:

Piwigo doesn't like spaces and non-englisch characters. Your filenames are probably filled with them. If not, skip.

Start Piwigo and go to plugins and install "Local files editor".

Open this editor and in "local configuration" find

$conf['sync_chars_regex'] = '/^[a-zA-Z0-9-_.]+$/';

You can add or remove chracter to fit your needs. As long as you mind the UTF-8 encoding.

 

Latin languages $conf['sync_chars_regex'] = '/^[(a-zA-Z0-9-_.+&áéíóúàãõ@ )]+$/';

Germans $conf['sync_chars_regex'] ='/^[(a-zA-Z0-9-_.ÄäÖöÜüß@ )]+$/';

Etc

 

Keep your filenames civil and don't anger the html guys. & # ' " can be troublesome.

Special characters are also dependant on your os.

You'll find out in step 3.

 

Step 2 - make the link in unraid:

Add a path in the docker config.

image.png.b82a578115f5a58f8adf25ba0f2db386.png

 

Step 3 - sync the files/folders inside Piwigo:

Go to admin > tools > synchronize

This part is self explanatory. Don't forget to turn of simulation.

Hi, I can't find the Plugin: 'Linking shares to container' within Piwigo, any suggestion? THX

Link to comment
  • 4 weeks later...
  • 2 weeks later...
On 11/8/2020 at 10:09 AM, casperse said:

Ok did a separate install and so far so good... pretty fast on my cache drive

One thing I think there need to be some seperate setup og write access to the config file?

 

Warning: mkdir(): Read-only file system in /config/www/gallery/plugins/piwigo-videojs/include/function_sync2.php on line 157

Any input on how to solve this?

@casperse I was wondering this too. Did you just install a separate MariaDB container in Docker? Did you get your errors worked out? Everything working OK? 

Link to comment
  • 4 weeks later...

Hi There,

 

I cannot get Piwigo 2.10.2 working at all. I have tried a MySQL docker DB, and now a mariadb, it will not connect to the database. i've tried different IPs, Ports, created databases, users, tested a telnet to the db, no problems. but i am met with "Cannot connect to server" on every attempt. i am assuming that cannot connect to server means it cannot connect to the database.

 

tried  192.168.0.70:3306 or 192.168.0.70

 

 

 

 

image.png.8cd0e02dcdfa73fd39a24dd4e050d14c.png

image.thumb.png.a75881f829ee972b7d5f97f33c252d43.png

 

Edit: Fixed it, it was a permission issue. I used the root user and pass and was able to install piwigo

Edited by matda59
solved
Link to comment

Hello, I am trying to get piwigo to run through my SWAG reverse proxy.

 

Here is how I have the conf file set up;

 

## Version 2020/12/09
# make sure that your dns has a cname set for piwigo

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name photos.*; my cname on my domain is in fact photos

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;
    # enable for Authelia
    #include /config/nginx/authelia-server.conf;

    location / {
            #enable the next two lines for http auth
            #auth_basic "Restricted";
            #auth_basic_user_file /config/nginx/.htpasswd;
            #enable the next two lines for ldap auth
            #auth_request /auth;
            #error_page 401 =200 /ldaplogin;
            # enable for Authelia
            #include /config/nginx/authelia-location.conf;
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app piwigo;
        set $upstream_port 65;
my piwigo runs on port 65
        set $upstream_proto https; I changed this to https because http wasn't working
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    }
}

 

Ok, so I've compared this to other .conf files i have that are working properly and I can not find a fault with this (other than to say that I can not access my piwigo from outside the network. I either get 502 bad gateway, or when I've tried to  enable http auth, I get Forbidden after typing in the correct user/pass for piwigo.

 

I'm sure there is a glaring error on this conf file, but I for the life of me can not seem to find it.

 

In my SWAG docker, I do have photos in there and a subdomain. All of my other subdomains work.

 

Any advice?

 

Thank you,

 

EDIT, forgot to mention that I do have Piwigo set up on proxtNet vs bridge as with he other dockers I have using the reverse proxy.

Edited by ppompili
added info
Link to comment
35 minutes ago, ppompili said:

Hello, I am trying to get piwigo to run through my SWAG reverse proxy.

 

Here is how I have the conf file set up;

 

## Version 2020/12/09
# make sure that your dns has a cname set for piwigo

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name photos.*; my cname on my domain is in fact photos

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;
    # enable for Authelia
    #include /config/nginx/authelia-server.conf;

    location / {
            #enable the next two lines for http auth
            #auth_basic "Restricted";
            #auth_basic_user_file /config/nginx/.htpasswd;
            #enable the next two lines for ldap auth
            #auth_request /auth;
            #error_page 401 =200 /ldaplogin;
            # enable for Authelia
            #include /config/nginx/authelia-location.conf;
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app piwigo;
        set $upstream_port 65;
my piwigo runs on port 65
        set $upstream_proto https; I changed this to https because http wasn't working
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    }
}

 

Ok, so I've compared this to other .conf files i have that are working properly and I can not find a fault with this (other than to say that I can not access my piwigo from outside the network. I either get 502 bad gateway, or when I've tried to  enable http auth, I get Forbidden after typing in the correct user/pass for piwigo.

 

I'm sure there is a glaring error on this conf file, but I for the life of me can not seem to find it.

 

In my SWAG docker, I do have photos in there and a subdomain. All of my other subdomains work.

 

Any advice?

 

Thank you,

 

EDIT, forgot to mention that I do have Piwigo set up on proxtNet vs bridge as with he other dockers I have using the reverse proxy.

You have to use the port inside the container, not the host port. So change it to the correct port and probably change it back to http also.

 

Enabling http Auth in swag has nothing to do with user/password set in piwigo.

Link to comment
35 minutes ago, saarg said:

You have to use the port inside the container, not the host port. So change it to the correct port and probably change it back to http also.

 

Enabling http Auth in swag has nothing to do with user/password set in piwigo.

That worked. Thank you!

Link to comment

Ok, second and hopefully last Pïwigo question.

 

I am trying to share albums with people outside my network using a link. I googled it and I see that there is a Piwigo plugin that can be installed to do this. When I go to the plugin section on my Piwigo install, that plugin isn't there. I don't see a way to add plugins that aren't on the list. None of the other plugins (with the exception of one called private share) seems to do what I am looking for.

 

How are others sharing albums?

 

Edit: I found this plugin, but not sure that I can just drop it into Piwigo. It is not listed on the version of Piwigo I am using within unRaid (the most current version I imagine)

Edited by ppompili
Link to comment
  • 4 weeks later...

Worked great for a year but suddenly get these messages on top of my gallery pages:

 

Deprecated: Array and string offset access syntax with curly braces is deprecated in /config/www/gallery/include/functions_cookie.inc.php on line 72

Notice: Trying to access array offset on value of type null in /config/www/gallery/include/functions_category.inc.php on line 140

Notice: Trying to access array offset on value of type null in /config/www/gallery/include/functions_category.inc.php on line 141

 

 

UPDATE :

 

To remove the depreciation message (that prevented logins from my IOS piwigo client app) I modified the following line in <config>/www/gallery/local/config/config.inc.php 

 

from :

$conf['show_php_errors'] = E_ALL;

new:

$conf['show_php_errors'] = E_ALL & ~E_DEPRECATED;

 

 

The other messages , no idea but they do not harm my ios app so ignoring for now. Only show up on main landing page of gallery when using web browser. 

 

 

UPDATE 2 : Upgraded to 11.3.0 from within piwigo admin page and resolved he remaining errors .

 

So closed.

 

Edited by glennv
issue solved
Link to comment
  • 1 month later...
  • 3 weeks later...
Posted (edited)

having issues with a new install. I setup a data base in mariadb using 

 

https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/ 

 

as a guide for the db setup, then installed piwigo. I'm getting "Connection to server successful, but the connection to the database was not possible." I think this means my setup is nearly right, in that by using a wrong password or wrong username instead registers as "cannot connect to server", so I'm thinking I might have some form of port connection not quite right?

 

the piwigo config screen is setup with the host as SERVERIP:PORTID (192.168.0.10:8011)...am I missing something when I setup the docker itself? Installed both from community apps.

 

 

edit: closed. It said it had created the database, but when checking the existance of the database it wasn't there, so I recreated it. Odd. Up and running now!

Edited by griphon31
Link to comment
  • 2 months later...

I am somewhat at a loss.

I did a plain install of piwigo from the app in unraid. I used my own custom network type and port 8087.

I created a data base and installed the program with no other changes.

The program installed and started.

I created a few albums and uploaded a 1000 plus pictures as a test.

This is what displays.

 

I tried to sync the files no luck. 

I went looking for the gallery and could not find it in any folder in unraid.

This is what the appdata piwigo folder looks like.

What am I doing wrong and where do I find the gallery.

Thanks

Screenshot from 2021-07-06 12-07-57.jpg

Screenshot from 2021-07-06 12-11-19.jpg

Link to comment
  • 1 month later...

Hi to everyone who's still using piwigo for photos, it was a little hard to install container but installed /gallery to mnt/user/appdata/piwigo/www/

but how to link gallery to outside container? 

Is piwigo good for store a lot of photos? 

Or maybe is PhotoPrism is better or other self hosted photo server? 

Thanks

Link to comment

Do you have a gallery directory in the /mnt/user/appdata/piwigo? Because I don't have it. There's a symbolic link in piwigo/www to /gallery but that doesn't of course work outside the container.

 

If I use the LocalFiles Editor plugin and save the edits, I can find the edited file under /gallery path, if I look for it inside the container. Aren't those files and edits lost when the container is restarted, because they exist only inside the container? What's the deal? Or are the edits also in the database?

 

Edit: Docker hub document instructs to expose /galley. I wonder why it's not included in the template. Pretty major thing to miss.

Edited by lsaranto
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.