Jump to content
dmacias

[Plugin] Command Line Tools (Shell in a Box) for 6.1+

97 posts in this topic Last Reply

Recommended Posts

I'll try compiling latest release instead of the latest commits. I'll look at the source also maybe I can find the bug in the vt100.js. What browser were you guys using and did you try others also.

Share this post


Link to post

using latest FF, just tried chrome and it does the same

 

Thanks

Myk

 

Just realized, it should be forward slashes (/) to indicate a linux path ... try: cd /boot/scripts/vlog

 

This is working on Chrome, Edge and FF!

 

Share this post


Link to post

 

 

using latest FF, just tried chrome and it does the same

 

Thanks

Myk

 

Just realized, it should be forward slashes (/) to indicate a linux path ... try: cd /boot/scripts/vlog

 

This is working on Chrome, Edge and FF!

 

Oh ok good. I only tested the characters that weren't working and the css.

Share this post


Link to post

Completely broken for me as of today. Updated to 9.20 release.

 

I see a frame error.

 

Latest version of Chrome.

Share this post


Link to post

You probably need to add the cert again. From the settings page when the service is running click on the version and add an exception. Or connect to the default port 4200 or the port you set up on your server from a separate browser tab. And add an exception for the self signed cert.

 

Share this post


Link to post

get the following 2 errors in my syslog upon bootup or array start

 

Sep 29 00:34:27 Tower shellinaboxd: /usr/sbin/shellinaboxd: /lib64/libcrypto.so.1.0.0: no version information available (required by /usr/sbin/shellinaboxd)

Sep 29 00:34:27 Tower shellinaboxd: /usr/sbin/shellinaboxd: /lib64/libssl.so.1.0.0: no version information available (required by /usr/sbin/shellinaboxd)

 

Thanks

Myk

 

Share this post


Link to post

get the following 2 errors in my syslog upon bootup or array start

 

Sep 29 00:34:27 Tower shellinaboxd: /usr/sbin/shellinaboxd: /lib64/libcrypto.so.1.0.0: no version information available (required by /usr/sbin/shellinaboxd)

Sep 29 00:34:27 Tower shellinaboxd: /usr/sbin/shellinaboxd: /lib64/libssl.so.1.0.0: no version information available (required by /usr/sbin/shellinaboxd)

 

Thanks

Myk

Does it work otherwise? Running shellinaboxd --version will give those errors too. It shouldn't need to call those libs for that. They are safe to ignore. I'll see if I can suppress them in the mean time and contact developer to fix.

Share this post


Link to post

Using Chrome

6.1.6

2015.12.30

 

I get the following error message

 

Unable to resolve the server's DNS address.

Share this post


Link to post

How were you trying to access it? I did make a couple mistakes when I changed the plugin name. On the Tools/Command Line page I didn't change the cfg name to to shellinabox-plugin so it can't find the cfg file and uses a default port. The other mistake was I set the default port on that page to 8088. So basically it will only work with port 8088.  I'll fix this when I get home.

 

You still should be able to connect to http://tower:4200 or what ever port you chose and the name or ip of your server.

Share this post


Link to post

Honestly I just enabled the plugin via the plugin settings and then went to tools and clicked on Command line icon. I didn't change any settings.

Share this post


Link to post

Honestly I just enabled the plugin via the plugin settings and then went to tools and clicked on Command line icon. I didn't change any settings.

If you update the plugin, go to the settings page and enable. Then after it's running click on the green running link or connect to port 4200 manually. You have to add an exception in your browser for the self signed certificate that shell in a box uses.  Then the command line page will work.

Share this post


Link to post

Well... despite hoping to no longer need the command line I find myself in the middle of a file migration for an RFS to XFS swap on all disks and unBalance is not cooperating...

 

First - Great plugin!

 

Second - how the heck to we resume screen after closing the browse window?... I believe the old command, now not working, was;  screen -r

 

Thanks!

Share this post


Link to post

This plugin is awesome!  Is there a way to configure it to use my server IP address versus hostname?  i looked in the shellinabox-plugin.cfg file and did not see a hostname entry.

 

TIA

al

Share this post


Link to post

Install screen from the nerd tools plugin

 

Facepalm --- thank you!

 

Good thing the following command resumes :)

rsync -avPX /mnt/disk1/ /mnt/disk4/

Share this post


Link to post

This plugin is awesome!  Is there a way to configure it to use my server IP address versus hostname?  i looked in the shellinabox-plugin.cfg file and did not see a hostname entry.

 

I assume you too are using linux rather than windows?  just type https://YOUR.IP.ADDRESS.###:4200 into a browser

Share this post


Link to post

True, i can definitely do that.  Was thinking about modifying the link, but in reality, all i really have to do is hit the web page that way.  Good point.

Share this post


Link to post

FYI, works on an android phone from the same network just like it does on linux :)

 

Share this post


Link to post

I will add a setting to use ip address instead of hostname for those that wish to. Also a link on the settings page for importing the certificate.pem.

Share this post


Link to post

Minor upgrade suggestion:  check box for use HTTPS TowerName vs use Internal_I.P. when clicking on green link?    Easy enough to type both into a web browser I suppose ;)

 

Edit, you beat me to it!

Share this post


Link to post

I will add a setting to use ip address instead of hostname for those that wish to. Also a link on the settings page for importing the certificate.pem.

 

Thanks. Ip fix works great

Share this post


Link to post

After I installed/enabled the plugin, I tried to open it and both Chrome and Edge give me a frowny face.  At least Edge tells me:

 

Content was blocked because it was not signed by a valid security certificate.

 

So I figured I need to install the cert.  When I click on that button, it navigates to http://192.168.1.10/boot/config/plugins/shellinabox-plugin/certificate-server.pem

 

and I get

 

404 File not found

 

What am I doing wrong?

Share this post


Link to post

After I installed/enabled the plugin, I tried to open it and both Chrome and Edge give me a frowny face.  At least Edge tells me:

 

Content was blocked because it was not signed by a valid security certificate.

 

So I figured I need to install the cert.  When I click on that button, it navigates to http://192.168.1.10/boot/config/plugins/shellinabox-plugin/certificate-server.pem

 

and I get

 

404 File not found

 

What am I doing wrong?

I used the wrong cert name. That was one I was playing with. It should be just certificate.pem. I'll fix in a minute.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now