Unraid becomes unresponsive periodically


Fatal_Flaw

12 posts in this topic Last Reply

Recommended Posts

Over the past couple of weeks, my unraid machine has become unresponsive every 2 to 3 days.

 

It starts by being unable to access the unraid shares. Then shortly after that, the unraid web interface and SSH sessions becomes unresponsive. The odd thing is that the VM running on the cache discs still functions when this happens. When the web interface and SSH are unresponsive, the only way to restart is a hard shutdown. If I get to the web interface before it becomes unresponsive, I can shut down the VM properly. However, trying to stop the array causes it to hang when it says "Sync filesystems". I then have to do a hard shutdown.

 

In the couple of times when I caught it after the shares became inaccessible but before the web interface does, I was able to download a syslog. I've attached them to this post. When I don't get there in time and the web interface is unresponsive, I am unable to get a syslog file because it's cleared on reboot. If anyone knows how to preserve the syslog when this happens, please let me know.

filebox-syslog-20150908-1918.zip

filebox-syslog-20150910-1944.zip

Link to post
  • 3 weeks later...

I've still been unable to solve this issue. I'm having to hard reboot it every 24-48 hours. I've moved the one virtual hard disk file from my VM off of the data array and onto the cache drive. That didn't change anything. I ran extended SMART tests on all of my drives and they all came back without errors.

 

Does anyone have any ideas what else I could try? At this point I don't know what else to check.

Link to post

i've had this once since moving to an HP Gen8 - of course the causes of your and my problem are just as likely to be different - but i was wondering if anyone had a way to capture the syslog if the system is unresponsive? In my case, i can see via the ILO that the whole OS has stopped responding, so i can't even log in to the console.

Link to post

I was having a similar issue with unraid becoming unreachable randomly also. So far it's been stable without running any virtual machines. Sorry I can't offer anything about your issue, besides maybe leaving the vms shut down for a couple days to see what happens.

Link to post

I've still been unable to solve this issue. I'm having to hard reboot it every 24-48 hours. I've moved the one virtual hard disk file from my VM off of the data array and onto the cache drive. That didn't change anything. I ran extended SMART tests on all of my drives and they all came back without errors.

 

Does anyone have any ideas what else I could try? At this point I don't know what else to check.

You are thinking it's a hardware issue, but it's most likely a software problem.  It *could* be hardware, memory or heat, I would run a very long Memtest, and make sure the CPU and bridge chipsets on the motherboard aren't getting too hot.  I don't think there's any way the drives could be involved with a hard crash, no matter what went wrong with them.

 

But it's more likely a software issue, especially if you are running VM's or plugins.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.