Jump to content
Vaseer

Notification - SMTP Settings

19 posts in this topic Last Reply

Recommended Posts

I have some problems setting up notifications via Gmail. What ever I try, I get error "Test result: Authorization failed".

Config:

Preset service: Gmail

Sending email address: mynotificationmail@gmail.com

Mail server: smtp.gmail.com

Mail server port: 465

Use SSL/TLS: Yes

Use STARTTLS: No

Define a TLS certificate: No

Authentication method: Login

Username: mynotificationmail@gmail.com

Password: 64 characters (no # in password) - Tried with shorter password and no luck.

 

Gmail account settings:

Allow less secure apps: On

POP3 and IMAP enabled.

 

I tried with different e-mail provider and it worked, but I want to use gmail address since I use it in other apps for notifications (in CouchPotato the same mail and same settings works).

 

Any ideas what am I doing wrong?

Share this post


Link to post

my settings:

gmail with TLS

sending email: myname@gmail.com

email recipient: myname@gmail.com

Priority in Header: yes

Email subject: unraid status

mail server: smtp.gmail.com

mail server port: 587

User SSL/TLS: Yes

Define TLS Cert: No

TLS Cert: blank

Auth Method: Login

username: myname

password: mypassword

 

the username field does not have @gmail.com in it.

 

 

Share this post


Link to post

In Logs I get 2 errors:

Sep 26 20:50:56 Alfheimr sSMTP[14849]: Creating SSL connection to host

Sep 26 20:50:56 Alfheimr sSMTP[14849]: SSL connection using ECDHE-RSA-AES128-GCM-SHA256

Sep 26 20:50:56 Alfheimr sSMTP[14849]: Authorization failed (535 5.7.8 https://support.google.com/mail/answer/14257 ft3sm9487967wib.17 - gsmtp)

and

Sep 26 20:43:18 Alfheimr sSMTP[12839]: Creating SSL connection to host

Sep 26 20:43:18 Alfheimr sSMTP[12839]: SSL connection using ECDHE-RSA-AES128-GCM-SHA256

Sep 26 20:43:19 Alfheimr sSMTP[12839]: Authorization failed (534 5.7.14 https://support.google.com/mail/answer/78754 p20sm9484949wie.5 - gsmtp)

 

Tried everything in suggested links and no luck.

If I enter wrong password, I get the same error and Log entry is the same.

 

unRAID version: 6.1.2.

Share this post


Link to post

Just to be clear ... did you change the port to 587 ??

 

... one other thing:  I don't think anything changed that would impact this, but nevertheless I'd upgrade to 6.1.3 just so you're on the current version.

 

Share this post


Link to post

unRAID upgraded to 6.1.3.

 

SMTP Settings that I tried:

- 465 + SSL/TLS

- 587 + STARTTLS

- TLS certificate always "No"

- Mail server: always "smtp.gmail.com"

- Authentication method: Login (Username: mynotificationmail@gmail.com (tried with mynotificationmail (without @gmail.com)) + Password: mypassword)

- Authentication method: tried with None (Test result: 530 5.5.1 https://support.google.com/mail/answer/14257 fz1sm12624287wic.8 - gsmtp) and CRAM-MD5 (Test result: Authorization failed)

 

Gmail settings:

- Allow less secure apps: On

- POP3 and IMAP: enabled

- 2-Step verification: Off

- unlock Captcha: done

 

I always get same error: "Test result: Authorization failed"

 

I created new Gmail account. It works. Same settings as previous account...?  :o

 

Edit:

It seems, that there is problem with some characters in password (don't know which). Old password contained characters: (within "") " , + : $ = ' ` . * ? ". New password contain just letters (lower and upper case), numbers and brackets " [ ] { } ( ) < > " and it works.

Share this post


Link to post

I cannot get Gmail notification working with anything I try.

 

My password are plain letters and numbers. No funny characters. I am on v. 6.1.9 of unRAID.

 

I do not have 2 step authentication. When I click the link above, Google tells me "The setting you are looking for is not available for your account"

 

Here are two of the many combinations I have tried:

 

Rj36JEy.png

 

Gs4W3oT.png

 

Any help is greatly appreciated.

 

Thanks,

 

H.

Share this post


Link to post

I cannot get Gmail notification working with anything I try.

 

maybe this:

 

Found the culprit. I had to change a setting allowing less secure access to my account. While logged into your Gmail account use this link.

 

https://www.google.com/settings/security/lesssecureapps

 

I'm going to personally setup a unRAID email account that forwards to my primary account and use it for notifications.

Share this post


Link to post

Odd when I set this up and do a test I get

 

HPTower kernel: blk_update_request: I/O error, dev loop0, sector 39504

 

Why would that pop up?

Share this post


Link to post

Odd when I set this up and do a test I get

 

HPTower kernel: blk_update_request: I/O error, dev loop0, sector 39504

 

Why would that pop up?

That's an issue with your docker.img file (loop0)

Share this post


Link to post
On 2016-03-10 at 4:51 PM, johnnie.black said:

 

maybe this:

 

 

No help here. Try Google with 2 factor and account without. Test Yahoo mail, no luck. Try same settings the abow member has:

https://forums.lime-technology.com/applications/core/interface/imageproxy/imageproxy.php?img=http://i.imgur.com/Rj36JEy.png&key=1047afc403d3d37508c696b60debb0343e11912fd0ded00b1738c18fa0142040

 

Hm, i succes when I change the settings in IE Explorer instead of Google Chrome. In Chrome the new settings with the app password don't have effect.

Edited by stormense

Share this post


Link to post

I have got it to work with "less secure apps" ENABLED
However, when that option is enabled, I get signed out of my google accounts every 5-10 minutes automatically.

What is the best way to get this notification working without editing "Less Secure Apps" on google?

Share this post


Link to post
On 01/10/2017 at 8:40 PM, bombz said:

I have got it to work with "less secure apps" ENABLED
However, when that option is enabled, I get signed out of my google accounts every 5-10 minutes automatically.

What is the best way to get this notification working without editing "Less Secure Apps" on google?

 

Share this post


Link to post

hmm... maybe there's still a problem with wrong authentication method used by unRAID.

 

before i recognized that, my setup looked like:

email-server was not using SSL/TLS and allowed a bunch of authentication methods, like CRAM-MD5, LOGIN, Kerberos…

 

after i saw these errors, the setup had changed to this:

email-server was setup to accept TLS, but also non-TLS connections, but i disabled the LOGIN authentication.

nothing else changed (same account, same passwords).

 

but, because of the now disabled LOGIN authentication method, unRAID server yells "Server didn't like our AUTH LOGIN (504 Authentication method not enabled)" – yeah, right, because i configured you to use CRAM-MD5.

 

so it was using all the time the "LOGIN" authentication method, despite me setting it to use CRAM-MD5. i've used the "Custom" preset, because i run my own email-server (postfix).

i run this server for years and it cares about quite alot of domains/users. everthing works for everybody, only unRAID seems to misbehave here – it simply doesn't use the choosen authentication method.

 

the email-server log, when unRAID tries to send email (or me hitting the "Test"-button).

 

Creating SSL connection to host

SSL connection using DHE-RSA-AES256-SHA
Server didn't like our AUTH LOGIN (504 Authentication method not enabled)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now