Unable to browse \\UnRaid in win explorer


Recommended Posts



I have tried to resolve this issue by searching the forum etc but i just cannot get to the bottom of it and so now need to ask for help !


My setup was working perfectly  until i changed my motherboard and upgraded to windows 10 - although the motherboard change seemed to be the start of the problems.


I have a number of programs and different things which work with my backup server at \\backupsvr (in addition to my main storage which is on \\Tower). I can access them at and 160 at and time in explorer but none of the mapped folders which are used will work and i get the "network path not found" message and cannot browse \\backupsvr or \\tower in windows. I have rebooted everything, i have unset and reset the backupsvr as the network master in SMB setting several times (this did work one time but it seemd to "drop off" after a couple of hours and now changing the setting seems to do nothing anymore. This has become a real pain and i cannot find a resolution which will make it so i can resolve names instead of IP addresses. I have attached the syslog where i am sure you will see me setting the network mater off and back on again a few times, in between with some windows reboots, router reboots .....


I have no idea why a new motherboard would cause such an issue but i need to find a way to get my mapped drives to work again so all of my backups work without needing to redo everything only using IP addresses as it should work like it did before and be able to hold onto those settings ...... frustrating !!


As soon as i get time i am going to upgrade to 6 and combine my 2 servers together but for now i need the current setup working like it was before.


All help is much appreciated


Link to comment

I am really hoping there is a key to fixing this. The first time I changed the local master by switching it off they all came back but only for a few hours, switched it back so this server is the local master it was OK .... And now that does not work either. You would think there was one thing that would control this and resolve an IP to a name. For a couple of years this has been no issue and I have files which back up to \\ backupsvr\something and then these are then backed up by crashplan to the cloud. It all worked so well and now it's all failing.


Can someone see something in the syslog or say what's up as I really don't want to change everything - after all it should work with a name !!


Edit: is this just a "5" issue or should it be moved to another area of the forum where it might get some technical feedback or more visability?

Link to comment

A motherboard change should not have affected anything at all, EXCEPT for the MAC change on the new network card.  You really don't want to change anything therefore on the unRAID server, just wait for the other machines to recognize the change, and as you know Windows machines can be ridiculous about that.  Rebooting the router should have helped.  I suppose if I was doing it, I'd shut them ALL down, then bring up the router first, then unRAID, then the other stations.


It's possible that messing with local master and other network reconfigurations just slowed down the whole process.  Windows takes its time.  It may have slowly been getting used to one change, then here came another, then another (obviously a simplistic view of it but ...).

Link to comment

Thanks RobJ - the motherboard change was a number of weeks ago and its not been right since. I was almost at the point of buying a separate network card just to see if one off the motherboard would somehow function differently (i had an add in board before as the old motherboard did not have a gig capability, the one on the new board does).


Maybe i need to try what you suggest and shut everything down and every device (tablets, phones on wifi etc) and then start up in the suggested order and then leave for a day or two to see what happens. I have tried lots of the forum suggestions but maybe i am expecting a faster responce in the modern computing world than hours to sort something which seems quite simple and basic - and something which should remain in placve for more than a few hours before falling over again. I hope i can get a resolution so i do not have to resort to IP addresses to get all my backups functioning again.


Could you just confirm should either of the unraid servers be set as the network master or is it best to leave that to the windows 10 PC (my main PC) to handle? when i set my backup server to "no" and checked my PC was the netwrok master - and then i read a post to say the server should be the master so turned it back on again ......

Link to comment

Could you just confirm should either of the unraid servers be set as the network master or is it best to leave that to the windows 10 PC (my main PC) to handle? when i set my backup server to "no" and checked my PC was the netwrok master - and then i read a post to say the server should be the master so turned it back on again ......


I'm not a networking expert, but the simple answer is keep it on the station that's always on, whether that be your unRAID server or your Windows station or some other.  But I don't know the reasoning behind preferring it on a particular station.  Seems perfect for the router actually, don't know why it generally isn't.

Link to comment
  • 4 weeks later...

Sorry to go back to this but also sorry i dont seem to be able to fix it !!


Tried to power down everything, including phones, tables .... everything. starter router, then server then pc, phones etc and for an hour or so everything fine - and then the mapped drives drop out again and are not accesable by name only by IP.

After some checking i made another device the net master and tried again - and for a few hours .......

Went into the netwrok settings of my main win 10 PC and set netbios to enabled and for a few hours ......

I have even upgraded one of my 2 servers to 6.1.3 to see if unraid can do something new here, but no improvement


While i could do everything using IP why should i, this always used to work, and for brief periods of time i can make it work again. i have backup software which is backing up to \\tower\backups and other software which wants to see a network drive and an IP adress cannot be used.


Any more help from anyone - this is driving me crazy - it should not be this hard to get a set of machines all on the same netwrok, all in the same workgroup, all from the same router, all from the same switch in most cases from being able to see each other in a way that stick.


Pleaseeeeeeeeeee  ;D ;D ;D ;D

Link to comment

I'm still hoping someone with more experience with networking issues will jump in, but it's probably fewer and fewer users checking the v5 boards.  Your syslog showed an error message usually caused by Windows 10 stations, looks like you have 2 of them.  Somewhere, there are a few reports of issues on Windows 10 stations recognizing unRAID, and I think the solution involved Win10 registry changes, don't know how to find those reports though.  But you have indicated things worked fine for short periods, which would seem to indicate the configuration is fine, and it's something different.  Almost sounds like a conflict somewhere...  I wonder if the router is having problems, and rebooting periodically...


That's all the ideas I have.

Link to comment

Thanks for the input RobJ - as i have now upgraded one of my servers to 6.1.3 and still have the same problem with that one do you think a new post there would get more views and possible solutions or can you move this post there with a comment as to why?


Just a couple of other notes after reading almost every post i can find about network issues ....


I have my DHCP reservation pool set to "xxx.100 to xxx.149" and then i have a static IP for my main \\tower as xxx.150, me second \\backupsvr as xxx.160 set in UnRaid (not in the router) and i have an IP camra set up as xxx.170 - Is it ok to have static IP outside of the DHCP pool - i think i did it like that based upon stuff i had read when it was all set up years ago so there was no overlap. All of this started with a change of motherboard in my main PC and upgraded to windows 10 !!


All devices are in the same workgroup, netBios set to enable .....


After setting NetBios to enable everything came back, i started to run my backup software to do all of the backups which fail as it backs up different folders at different frequencies to \\backupsvr\whatever - and after about an hour the backups failed as the destination had dropped off again and could not be found by \\backupsvr - by IP address it always works .....


Frustrating for something which should be so simple !!!!



Link to comment

Viaduct - I am sure i am not the only person with this issue, but it should be solvable, computers dont "just forget" and not when in the middle of backups or something. I also have backup links to names as there is not the option to backup to an IP. I would really like to know what this is and more importantly how to fix the darn thing !!


Link to comment

this is a generic issue with Windows systems and the way they handle networking at the NetBIOS (SMB) level, in particular the name<->IP mapping.


To maximise the chance of it operating trouble free it is recommended that:

  • Have an IP address reserved in your router for the unRAID server.
  • The unRAID server is set to be the Local master at the SMB level.

You also tend to not have any issues if you have a domain and a WINS server, but these would not exist in a typical home environment.

Link to comment

OK, so i set the resrved IP addresses in my router and i set the server as netmaster and the mapped drives all appeared - very good. i then started up my failed backups from my pc to the mapped drives and all was working. A few hours l;ater they were gone again before the backup completed !! This morning i have double checked the IP reservations, all good, i have checked netmaster is checked, fine, i have rebooted the router and i now do not have the mapped drives accesable and i can not access them or the server. As always if i use the IP address the server immediatly is there, it appears in my network places with its IP address but anything name related does not function again. I am sure i could alter something and it might come back but its only for a few hours, minutes or until the next reboot and its all gone again. For year this has worked perfectly, and now its a nightmare.


This is sooooo frustrating now. What else can i do / try as i really am running out of things to even try - and why will a solution work for a short whiole and then in the middle of a backup or something just not be there anymore?


EDIT: I remember i had to do the map a drive work around to get crashplan to backup to a network drive - would i need to redo this process with the IP to get the new connection in place ??


EDIT 2: maybe a little early to celibrate ..... servers do not appear in netowrk places until the address is entered into the search although then they do appear based on name. Still got issues with crashplan seeing backupsvr from PC and Archonis is not playing nicely. Think i will do what i plan in terms of consolidating to one server and then set things up from scratch and fix the prblems as they present themselves. Never though something as simple as seeing a few computers all on the same network, all in the same workgroup etc causing so much pain !!

Link to comment

You will need to do some investigation as to which machine is being seen as the "Local Master" at the SMB level as this is what is used to do the name->IP mapping.    The vagaries of Windows networking mean that this can change, or even worse different clients do not agree.


This is why it is recommended that you try and select a machine that is 'always on' to be the Local Master.  If your unRAID server is always on then this is a good choice.  A good alternative if your router allows it is to let the router take on this role.  However when you reboot your unRAID server this can mean that it loses its Local master role for the time being.


However whatever machine is selected as the Local master if any client machines lose contact with it they can negotiate with each other for another to take over the role, and if only some machines do this you end up with more than one Local master on your network which is when machines start losing the ability to find each other by name.


Is there any good reason why you should not connect by IP all the time?  It will tend to be far more reliable.

Link to comment

how does one set a router as local master? I couldnt find the option for my AC68u

There seems to be no standard way of doing this (if you can) at the router level.  If you have a router that supports a USB hard disk, then you may find that going into the settings for that disk and setting the workgroup to the one your clients use has the effect of setting this.


I thought unraid sets itself as the local master by default? That's the way its set during my first install anyway and I appear to have a similar problem as OP

The setting in unRAID only "allows" it to be a candidate for the local master (you can set/check the unRAID setting under Settings->SMB->workgroup).  If another machine is already the local master when unRAID boots then unRAID should not become the Local Master.    That is why one common solution to this issue is to switch off all clients and reboot unRAID (so it DOES become the local master) and then reset the network and switch on the other clients.  However this can be very inconvenient :( .  I tend to create shortcuts on all my clients using the IP address, and then rename the shortcuts to a friendly name as this by-passes this issue.


There is a Dynamix Local Master plugin that can help you determine what unRAID thinks is the Local Master at the moment.  It is intended to help with debugging this sort of issue which seems to be very frequent.

Link to comment

ah I see. Looking at the problem a different way then - is it possible to check on windows machines whether they are the local master, and force them not to be?

I would suggest googling for this, although this article looks like what you may be looking for in terms of stopping the Windows clients becoming a Local Master.


One point that may not be obvious is you want to make sure all your clients and servers are in the same workgroup/domain as there can be a different local master for each workgroup.

Link to comment

Thank you for all the input and suggestions, i have tried them all and seem to still have this problem. I am going to remove all of my currently mapped drives/folders and start again mapping by IP address as this always seems to work (although does not show up in my network places unless i go to the location and then it appears). I am then going to change all of the destinations to these new folders in my backup software (Archonis) and give it a try to see if i can keep a constant connection.


I am consolidating from 2 servers down to 1 and will use cloud (crashplan) as a backup for my unraid folders which are in turn the backup for my PC's and files which are backed up onto the unraid server. When i consolidate i will also map only using IP.


How do i change crashplan on my desktop PC to see the IP adress, currently it points to \\backupsvr\crashplan\PC but it cannot connect to that location as it does not appear, it needs to connect to \\IP\crashplan\PC ??


Seems crazy there is no easy fix to this but the frustration has won and so its IP from now on, a backward step but unreliable connections are just not going to work for me

Link to comment

If you're changing all your references to IP's, you should first (a) Set static addresses in your servers, so the IP's never change; and (b) set your router so it doesn't assign addresses that conflict.


Be sure, of course, that the addresses you use are in the same subnet as what your router assigns.


Link to comment

Hi garycase - my servers have always had fixed IP addresses outside of the router DHCP pool and i now have them reserved also in the router as a possible solution to my disapearing drive issue - but that and setting the sever as netmaster did not fix the problem. Very frustrating !!


As part of my consolidation i am going to reset all of my backups so my PC does a backup to a spare internal HDD AND to my unraid server and then my server will backup to crashplan cloud the folders which hold my pictures, documents etc. I also intend to do a regular scheduled backup of my complete C drive to Unraid as well. As far as i can tell (will double check) if i use Archonis to do the local backups crashplan will back these up to the cloud as well as the "normal" files. I want to end up with everything i would need in 3 places, one of which is not a home. As part of the consolidation i think i will be left with a couple of smaller drives which i might make a snapshot of everything on and store them away somewhere ! I have had this kind of thing running for a good while with no issue until this network issue made things unreliable (i changed my PC motheboard and upgraded to Win 10 ..... i guess you get what you deserve)


I need to think it through so i dont end up over or under doing the whole thing - and will re-read you sticky on the subject :-)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.