[Support] Linuxserver.io - HTPC-Manager (Hellowlol)


84 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: HTPC-Manager (Hellowlol)

Application Site: https://github.com/Hellowlol/HTPC-Manager

Docker Hub: https://hub.docker.com/r/linuxserver/htpcmanager/

Github: https://github.com/linuxserver/docker-htpcmanager

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io
Link to post
  • Replies 83
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It won't show any unless you map /mnt iirc

Posted Images

Is pyopenssl included in the base image? If not htpc manager will not be able to create ssl cert and key for the user.

 

baseimage here hellowlol.

 

https://github.com/linuxserver/docker-baseimage-python27

 

and yes it is in the baseimage, using the pip package because it's more up to date and updating the underlying ssl stuff with updating ndg-httpsclient as well.

 

 

Link to post

Hi Hellow,

 

Got HTPC-Manager setup here but it's not talking properly with TVHeadend, any ideas?

 

Info:

HTS Tvheadend 4.1-555~g0a0681b

 

I've also experienced this, never been able to get TVHeadend working with HTPC Manager..

Link to post

Hi Hellow,

 

Got HTPC-Manager setup here but it's not talking properly with TVHeadend, any ideas?

 

Info:

HTS Tvheadend 4.1-555~g0a0681b

 

It's broken after they changed there api.

 

I don't have access to a tvheadend so I doubt it will be fixed anytime soon. I tried to ping the original author of that module but he didn't respond.

 

I had access to some other users tvheadend and tried to fix it but I lost my motivation when the access came and went. (His dad turned off the router at night)

 

I probably should have disabled that module but your the second one asking, I think has been broken for over a year year

 

I have a unpushed working branch where all the channels are listed correctly, to bad nothing else works :D

Link to post

Hi Hellow,

 

Got HTPC-Manager setup here but it's not talking properly with TVHeadend, any ideas?

 

Info:

HTS Tvheadend 4.1-555~g0a0681b

 

It's broken after they changed there api.

 

I don't have access to a tvheadend so I doubt it will be fixed anytime soon. I tried to ping the original author of that module but he didn't respond.

 

I had access to some other users tvheadend and tried to fix it but I lost my motivation when the access came and went. (His dad turned off the router at night)

 

I probably should have disabled that module but your the second one asking, I think has been broken for over a year year

 

I have a unpushed working branch where all the channels are listed correctly, to bad nothing else works :D

 

Thanks for letting us know.  Appreciated, everything else rocks though..  :D

Link to post
  • 3 weeks later...
  • 4 weeks later...

i installed this and it seems mostly to work. Weird thing, when i use the WebUI button, it redirects right away to 127.0.0.1:(internal port) instead of the server IP and exposed port that was configured.  Any ideas why that would happen? **Issue was having "use rev proxy headers" set to on***

 

Also, SMART feature doesn't work due to smartmontools not being included. Are you able to add that? 

 

And also... great job!

Link to post
  • 4 weeks later...

Mine's working, just set it up to test... (Only really use Plex for mobile devices so never bothered to add it to HTPC Manager)

 

Server was auto-discovered....

 

Works with both my pms account name and my local home user name...

 

p0M0m7t.jpg

Link to post

One thought though, it does pull my Plex ip from the WAN rather than the LAN IP address...

 

It won't work pulling it from the LAN as the docker container will not have an IP address in the same subnet as Plex.

 

Changing the HTPC Manager docker to run on host networking rather than bridge enables LAN IP to be used.

 

Just tested this and it works.

 

Been chatting to Sparklyballs about this.  Changing to host does seem to work enabling LAN IP to be used, however my logic leading me there doesn't....  :-[

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.