Request: Homebridge


165 posts in this topic Last Reply

Recommended Posts

  • 4 weeks later...
  • Replies 164
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I've turned nfarina's home bridge docker image into a more unRAID friendly one if anyone wants to try it out.   https://github.com/ckuburlis/docker-templates   Just copy the example config files

Just adding my 2 cents for what it took to get smart things working with homebridge.  This is the general guide I used but what I have below will help with our docker.    https://github.com/pdlove/hom

1. You have to login into your UNRAID system over SSH. 2. Now execute  docker ps 3. Search the line for your Homebridge instance CONTAINER ID IMAGE COMMAND

Posted Images

This is working well for the most part. However, I can't get a few platforms working correctly. I'm currently focusing on HomeAssistant and the plugin crashes when it tries to load. I have quadruple checked everything and my json file validates.

 

I did notice that this docker (https://github.com/ckuburlis/homebridge-docker) is a few commits behind. Would that have something to do with this?

 

Best

Link to post
  • 5 months later...

Hey guys, I made a new docker template that has been updated to the latest release of homebridge. https://github.com/lukeadair/docker-templates

It has also been reworked to use the phusion base image. Many thanks to @ckuburlis for his original docker!

 

Hey thank you! Do I just copy the config files into the appdata/homebridge/ folder and install plugins like ckuburlis had with his plugininstallfile?

Link to post

This is working well for the most part. However, I can't get a few platforms working correctly. I'm currently focusing on HomeAssistant and the plugin crashes when it tries to load. I have quadruple checked everything and my json file validates.

 

I did notice that this docker (https://github.com/ckuburlis/homebridge-docker) is a few commits behind. Would that have something to do with this?

 

Best

 

Figured out the plugins installing. However I am having the same issue where it crashes when I load it with Home Assistant. Did you get it sorted out?

Link to post

This is working well for the most part. However, I can't get a few platforms working correctly. I'm currently focusing on HomeAssistant and the plugin crashes when it tries to load. I have quadruple checked everything and my json file validates.

 

I did notice that this docker (https://github.com/ckuburlis/homebridge-docker) is a few commits behind. Would that have something to do with this?

 

Best

 

Figured out the plugins installing. However I am having the same issue where it crashes when I load it with Home Assistant. Did you get it sorted out?

 

Sorry, I'm not using the Home Assistant plugin. Have you tried contacting the developer of the homebridge-homeassistant plugin? https://github.com/home-assistant/homebridge-homeassistant

Link to post

Hey guys, I made a new docker template that has been updated to the latest release of homebridge. https://github.com/lukeadair/docker-templates

It has also been reworked to use the phusion base image. Many thanks to @ckuburlis for his original docker!

Thank you for this! First time installing it on unRAID and it works great! Now have my Haiku fan and Chamberlain garage door opener homekit-enabled!

Link to post

Hey guys, I'm having a bit of trouble adding the following repositories.

 

https://github.com/lukeadair/docker-templates

https://github.com/ckuburlis/homebridge-docker

 

I was able to put them in the Template Repositories list on the Docker main page but when I go into the Add Container I don't see them in the Template drop down.  :-\ Has anyone experienced this? I verified my unRAID box has internet connectivity and valid DNS entries.

Link to post

Thanks for the work on this. I'm getting an error that I haven't seen on any of my other docker instances.

Error: layers from manifest don't match image configuration

 

Any ideas what might be causing it? (This is, of course, on the brand new Unraid 6.2)

Link to post

Thanks for the work on this. I'm getting an error that I haven't seen on any of my other docker instances.

Error: layers from manifest don't match image configuration

 

Any ideas what might be causing it? (This is, of course, on the brand new Unraid 6.2)

Have you tried the Docker FAQ?    ;)

Link to post

Sure.

 

Get your running Docker container names with:

docker ps

Then enter the Docker shell:

docker exec -it homebridge /bin/bash

Then uninstall your plugin(s) with:

sudo npm uninstall -g <plugin name like hombridge-whatever>

Doing this from memory so my commands may be off slightly.

Link to post

Hey guys, I made a new docker template that has been updated to the latest release of homebridge. https://github.com/lukeadair/docker-templates

It has also been reworked to use the phusion base image. Many thanks to @ckuburlis for his original docker!

Thanks again, Adair!  Do you plan on regularly updating the template to keep up-to-date with homebridge, by chance?  I ask because there seems to have been quite a bit of development lately on the github.  Appreciate your efforts!

Link to post

Thanks again, Adair!  Do you plan on regularly updating the template to keep up-to-date with homebridge, by chance?  I ask because there seems to have been quite a bit of development lately on the github.  Appreciate your efforts!

 

I mainly made this for my personal use and figured I'd share it with the community. I will try to keep it up-to-date with homebridge as I need the updates for my setup.

Link to post

I mainly made this for my personal use and figured I'd share it with the community. I will try to keep it up-to-date with homebridge as I need the updates for my setup.

I appreciate your sharing the container with the community.  I am getting great use out of it.

Link to post
  • 3 weeks later...

I'm using Adair's homebridge docker and it seems to only work only once until I restart it.

 

I've got mine loaded with Nest and Chamberlain MyQ. If I issue a command to Siri to close the garage door, it will close. But if I try another command, like change the temperature to 75 degrees, Siri doesn't get a response and therefore doesn't carry out the command.

 

It will work after restarting the homebridge docker, but only one command works and then I have to restart it again. Shame as this could be very nifty!

 

Any ideas?

Link to post

I'm using Adair's homebridge docker and it seems to only work only once until I restart it.

 

I've got mine loaded with Nest and Chamberlain MyQ. If I issue a command to Siri to close the garage door, it will close. But if I try another command, like change the temperature to 75 degrees, Siri doesn't get a response and therefore doesn't carry out the command.

 

It will work after restarting the homebridge docker, but only one command works and then I have to restart it again. Shame as this could be very nifty!

 

Any ideas?

Perhaps it's the Nest plugin.  I use the liftmaster2 plugin with my Chamberlain garage opener, as well as the BigAssFans module.  It definitely can get a little wonky after a week or two of running, but I can absolutely issue multiple commands or use the iOS 10 home app no problem.

Link to post

What's weird is that it'll take only one command, from either Nest OR MyQ. Any subsequent command goes to deaf ears.

 

I'll have to try the liftmaster2 module rather than the MyQ. I do recall homebridge saying the MyQ module was deprecated but it installed anyway.

Link to post
  • 2 weeks later...

Trying to use this with SmartThings, I managed to get this running. From the logs I can see that it loads my SmartThings accessories and says it's running on port 51826, however on my iOS device it doesn't find any accessories from homebridge. Is there a step I'm missing so that devices can be discovered properly (port/variables/path, etc)?

Link to post
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.